Klokpuls werkt niet 4017 IC


1. Snap je hoe de schakeling moet werken? Dus welke signalen doen wat?
2. Als het antwoord op 1 "Ja" is, dan kun je gaan meten met een voltmeter. Waar klopt het niet meer met je theorie?

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

Ja flip, heb dit voor de zekerheid nog eens getest, als ik op de switch van de clock druk, komt er 12.5V (batterijspanning) op de clock, zelfde voor de reset, de inhibit en de 5-10 staan op de 0 dus die zijn hier niet van belang, de spanning over de IC zelf is ook 12.5V, dus nu vraag ik me echt af of ze me echt niet gewoon een slechte batch gegeven hebben, maar 10 ineens is wel heel veel lijkt me.

Heb je misschien de aansluitingen in spiegelbeeld door onder en bovenaanzicht te verwisselen.

Hensz

Golden Member

Toch nog maar eens kijken naar de pinout van het ding. Weet je ZEKER dat alles op de juiste plek zit? Voor het geval het niet duidelijk was in de datasheet staat de pinout en het IC is van bovenaf getekend. Precies zoals je er, gemonteerd op een print, ook tegenaan zou kijken.
Zit je wel op de goed knop de drukken, en dus niet per ongeluk op de reset? Doen die knoppen het wel? Is er voedingsspanning (meten) en meet ook een op de uitgangen met een multimeter i.p.v. leds. Die leds dan wel ff loshalen.

Don't Panic!

Als ik je schakeling bekijk gok ik zo snel dat je weerstanden verkeerd staan. Je schakelt met je schakelaar net hetzelfde signaal als je weerstand. Dus, je weerstand zit aan Vdd, dan schakel je naar Vss en omgekeerd.
Je weerstand zit aan de 0V, dan moet je schakelaar aan de +12. En omgekeerd voor de andere.

Let daar eerst eens even op.

Dus, volgens mij, gewoon een fout in je schema. Zo zal het nu ook wel zijn waarom dit keer niks het nog doet. Ik ben even te lui om het schema erbij te pakken, dan kan je beter zelf effe doen, ter lering...

[Bericht gewijzigd door Appel op 17 april 2015 19:33:42 (24%)]

Hensz

Golden Member

Reset moet bij een 4017 laag zijn om klokpulsen door te laten komen, dat is dus goed, met hoog reset je 't ding.
Klokpuls zelf maakt niet zoveel uit of je die in rust omlaag of omhoog trekt. Ik zou kiezen voor omhoog en dat is hier ook gedaan. Niks mis mee.

Don't Panic!

en wat meet je op Q0, Q1, Q2 tm/ Qveel ? Leds verkeerd om ?

Hoei, een breadboard, maakt alles wel contact ? draadjes en weerstanden zal wel gaan, maar halen die switches de contactveren wel ? en de IC's kunnen wel eens zeer twijfelachtig contact maken.
Alle pinnen op het IC zelf nagemeten ?

Zie ik nou goed dat Carry Out aan een van de voedinglijnen hangt ?

[Bericht gewijzigd door Henry S. op 20 april 2015 20:46:11 (72%)]

stop het overmatig spatiegebruik !

@JvdBe: Gebruik de edit toets i.p.v. al die nutteloze posts... (vinden de mods niet leuk)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

en bedankt voor het waarde-oordeel ...

stop het overmatig spatiegebruik !

Op 17 april 2015 20:21:16 schreef JvdBe:
en de IC's kunnen wel eens zeer twijfelachtig contact maken.

@TS, nogmaals, al deze dingen kun je meten. Die clk pulsen op de pennen vh IC zijn te meten. Voedingen ook. Reset puls ook.

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

@JvdBe: Ik bedoel het aantal posts, niet de inhoud. Om de paar minuten een nieuwe post is wat veel van het goede...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Ik mis de ontkoppel-C. Ofwel ik zie hem over het hoofd, of hij is er niet.

Verder: Zitten je schakelaars goed om? Als je ze in je breadbord een kwartslag verkeerd gedraaid hebt, maken ze altijd verbinding.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

@Arco: we moeten om een delete knop vragen, dan is het zo opgeruimd :)

stop het overmatig spatiegebruik !

Het is gewoon een kwestie van op het IC meten of je overal de juiste spanning hebt.
Dus: zit het IC wel goedom in het breadboard?
hangt de Vdd inderdaad aan de plus?
hangt de Vss inderdaad aan de min?
zit clock inhibit wel aan de min?
Zit reset wel aan de min?
Gaat clock input omhoog en omlaag bij indrukken en loslaten van de schakelaar?

@Rew, een ontkoppelcondensator is toch eentje die je parallel over je voeding en nulleider van je IC aansluit toch? Nog eens nagemeten, blijkt dat er tussen de voeding (voedingspin) en elke andere pin 12V staat, dat klopt niet echt lijkt me?

[Bericht gewijzigd door Jesseee op 17 april 2015 21:38:16 (57%)]

Bijna alle pinnen zijn laag in rust (op carry na), dus dat je 12v meet klopt wel...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Op 17 april 2015 21:22:39 schreef JvdBe:
@Arco: we moeten om een delete knop vragen, dan is het zo opgeruimd :)

What has been said, cannot be unsaid.

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

Op 17 april 2015 21:09:28 schreef rew:
Verder: Zitten je schakelaars goed om? Als je ze in je breadbord een kwartslag verkeerd gedraaid hebt, maken ze altijd verbinding.

Ik denk dat dit de eerste kanshebber is: Allereerst is ook mijn ervaring dat dit soort schakelaartjes absoluut onbetrouwbaar werken in een breadboard. Ik soldeerde er altijd afknipte pootjes van onderdelen aan, dan waren ze tenminste betrouwbaar in een breadboard te steken.

Die schakelaartjes heb je echter ook in verschillende varianten: sommige hebben alleen een verbinding die diagonaal loopt (met 2 pootjes onder maakt alleen het linkercontact verbinding bij indrukken met het rechtsboven-contact maar er zijn nog meer varianten, waaronder beide pinnetjes aan onderkant die contact maken met de beide contacten aan de bovenkant.
Het zou dus kunnen dat als het schakelaartje wel contact maakt, dat dus altijd staat te doen, in plaats van alleen bij indrukken.

http://www.m-voorloop.nl --- Ik? Welnee! Ik zit nog lang niet achter de germaniums.

Nog eens bedankt voor alle antwoorden, heel wat frustraties verder denk ik gewoon dat het toch aan de IC zelf ligt, had er nog heel wat liggen dus had vandaag een astabiele multivibrator gebouwd, had nog wat 555jes liggen ook, aangesloten op mijn klok, nu werkte dit voor welgeteld een seconde, ze lichten in volgorde op, en dan stopte het, spanning over de vcc en gnd gemeten, niks, dus ik gok kapot, ik snap gewoon helemaal niet hoe, ik rook niks verbrand, ik heb alles 5x gecheckt volgens het schema online, zou iemand een verantwoorde gok kunnen wagen waarom mijn IC het begeeft?

(Heb de 555 nog eens snel doorgemeten en deze werkt nog perfect dus dat was het alvast niet)

Heb ook nog eens een andere 4017 erbij gehaald die zou moeten werken, voeding, gnd aangesloten, en dan enkel de eerste uitgang, dit gaf niks, dan alle uitgangen aangesloten ook niks, wat ik raar vind aangezien er toch altijd 1 uitgang hoog moet zijn in deze IC?

[Bericht gewijzigd door Jesseee op 20 april 2015 15:58:54 (16%)]

als je nog steedsd de carry out aan massa hebt hangen snap ik wel dat je precies 1 cycle kunt maken ...

stop het overmatig spatiegebruik !

Ah djuu daar had ik eerlijk gezegd niet meer naar gekeken, maar heb hierna wel een onaangetaste 4017 gepakt, enkel Vcc en GND aangesloten en dan uitgang 0 aangesloten, en dit werkte ook niet.

Dan heb je dus een heleboel zwevende ingangen. Dat vindt een CMOS IC niet fijn.

Op 20 april 2015 15:50:44 schreef Jesseee:
spanning over de vcc en gnd gemeten, niks, dus ik gok kapot

Huh? Dan heeft het IC geen spanning, doet ie niks, nada noppes. Maar misschien fout gemeten?
Een IC kan overigens prima stuk gaan zonder rook hoor. Bv een uitgang aan de gnd vinden er veel niet fijn.

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

Van IC's

Altijd een 100nF condensator direct in de buurt over de voedingspaaning.
Nooit ingangen los laten hangen de ingang zweeft dan.
Uitgangen nooit direct aan gnd of VCC hangen dit is een kortsluitingen en kan die uitgang kapot maken.

Op 20 april 2015 16:25:18 schreef Jesseee:
Ah djuu daar had ik eerlijk gezegd niet meer naar gekeken, maar heb hierna wel een onaangetaste 4017 gepakt, enkel Vcc en GND aangesloten en dan uitgang 0 aangesloten, en dit werkte ook niet.

als je 'm niet reset is de uitgang niet gedefinieerd ...

stop het overmatig spatiegebruik !