PM5160 Oscillator Reparatie


Dat is het resultaat van de aanvraag van de TS. Eenmaal aangevraagd is het schema voor iedereen.

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."
RAAF12

Golden Member

Lastig om een 285MΩ weerstand door te meten met een gewone meter.

[Bericht gewijzigd door RAAF12 op 10 juli 2015 18:35:18 (19%)]

Een aantal bench-DMM's kan 285M meten, o.a. Keysight, Tektronix en Philips.
Met een gewone multimeter gaat dit inderdaad niet.
De onderste drie bereiken werken niet. De derde range is wat werstand betreft wel goed te meten, zou dus daar beginnen.
Ben ook benieuwd wat dan de impedantie op de gate van TS20 is.

blackdog

Honourable Member

Hi fertinator,

Ik heb het schema en de specificaties even bekeken.
Bij blok zal de TT spanning ongeveer 1/3 zijn van de TT bij de sinus.

De uitgang van de generator is AC gekoppeld zie het schema links omderaan.
De transistoren TS63, 64 en TS65 zijn het uitgangstrapje.
Het signaal komt vanaf de emittor van TS65 dit signaal gaat door twee dikke elco's van 2x 2200uF.
Deze elco's kennen in rust als er niets is aangeloten op de generator alleen geladen worden door R167 van 10K.
De 10K en de 4400uF geeft een RC tijd van 44seconden...
Als je de uitgang even kortsluit, dan is R168 van 47 Ohm de dominante weerstand en zijn de elcos sneller vol.

Loopt de DC spanning op de uitgang snel weer op als je hem b.v. even hebt kortgesloten, dan verdenk ik C68 en C69.

Ik hoop dat je hier iets mee kan.

Gegroet,
Blackdog

1e, Do No Harm! 2e, Leave Things Better Than You Found Them.

De service manual staat ondertussen op de freeservicemanual site:
http://freeservicemanuals.info/nl/servicemanuals/viewmanual/Philips/PM…

Op 8 juli 2015 00:20:30 schreef markce:
In de onderste drie standen is dit extreem hoog-ohmig (tot 285Mohm per weerstand). Dit zijn waarschijnlijk bruin/oranje koolweerstanden op de draaischakelaar. Op leeftijd verlopen deze soms.
...
Zit de originele BFX63 er nog in (TS20)?

De originele BFX63 zit er nog in. Deze is overigens niet gesoldeerd maar zit in een speciaal voetje.
Ik heb voor zover mogelijk de hoog-ohmige weerstanden doorgemeten tot 20 MOhm, verder komt de DMM niet. De gemeten weerstanden zijn qua waarde nog goed en binnen tolerantie.

Op 6 juli 2015 19:50:04 schreef blackdog:

Wat de DC shift betreft, kan het zijn dat de condensator die naar de uitgangs bus gaat misschien lekt?
Belast de generator eens met 10K en kijk of met Blok of Sinus het DC niveau nu wel in het midden zit.

Gegroet,
Blackdog

Belasting met 10k levert geen verschil op. Het signaal begint met een offset en verschuift daarna naar de 0V middenlijn (duurt ±30sec)

Op 10 juli 2015 20:22:56 schreef markce:
Ben ook benieuwd wat dan de impedantie op de gate van TS20 is.

Hoe kan ik dit meten?

Op 10 juli 2015 21:35:09 schreef blackdog:
...De 10K en de 4400uF geeft een RC tijd van 44seconden...
Als je de uitgang even kortsluit, dan is R168 van 47 Ohm de dominante weerstand en zijn de elcos sneller vol.

Loopt de DC spanning op de uitgang snel weer op als je hem b.v. even hebt kortgesloten, dan verdenk ik C68 en C69.

Als ik dit doe bij de sinusgolf dan blijft deze, nadat ik de kortsluiting weg haal, gewoon rond de 0V. Doe ik dit daarentegen voor de blokgolf dan krijgt deze elke keer een offset van ongeveer -2 Volt.

Hi fertinator,

Ik verwacht dat je problemen nog de zelfde zijn.

Meet eens op D hier moet je sinus staan zonder de eindversterker.

Gr Henk.

Everything should be as simple as possible, but not simpler.

Ik zie op de laagste drie standen niks verschijnen op meetpunt D. Alleen bij de hoogste drie standen is er een sinus aanwezig.
Ik heb het schema van het sinus-bordje wat verder bekeken en zag wat spanningen staan rond een aantal transistoren. Ik heb deze gemeten bij elke stand en in de volgende tabel gezet.

Ik had overigens eerst de voedingsspanning op 'precies' 24,0 volt gezet. Hij stond namelijk op 24,1 V (niet dat het veel uitmaakt denk ik)

Op een aantal punten is dus in de laagste drie standen de spanning wel degelijk verschillend dan de manual zegt. Vooral de spanningen rond de schakelaar zijn verschillend. Misschien toch verlopen weerstanden daar die ik niet kan meten? (>20 MOhm)

Ben benieuwd of de BFX63 nog heel is. Je kunt bv via een serieweerstand van 10M extra spanning op de gate zetten en met een DVM (ook 10M in) meten of de verwachte waarde (halve verhoging) ook echt op de gate staat.

RAAF12

Golden Member

Op 18 juli 2015 20:18:24 schreef fertinator:
Misschien toch verlopen weerstanden daar die ik niet kan meten? (>20 MOhm)

De schakeling oscilleeert in de hoge bereiken. De drie laagste niet, dan ligt het voor de hand dat die weerstanden aan de bereikenschakelaar kapot zijn. Nieuwe eventueel samenstellen uit meerdere weerstanden in serie want R's boven de 20 MΩ heeft niet iedereen liggen.

@ fertinator,

Kan je het draadje op pin 21 los nemen en dan daar met de scope meten.

Gr Henk.

Everything should be as simple as possible, but not simpler.

Op 18 juli 2015 20:39:53 schreef markce:
Ben benieuwd of de BFX63 nog heel is. Je kunt bv via een serieweerstand van 10M extra spanning op de gate zetten en met een DVM (ook 10M in) meten of de verwachte waarde (halve verhoging) ook echt op de gate staat.

Ik heb dit geprobeerd en het werkt! Wanneer de extra spanning hoog genoeg is zie is een sinus signaal verschijnen op meetpunt D.
Het probleem lijkt dus toch rond de weerstanden en de FET te zitten, maar wat is het nu?

electron920: pin 21 is hetzelfde als meetpunt D. Ik heb hem losgehaald en gemeten, maar op de laagste drie verschijnt er niks.

Hi fertinator,

Ik den nog steeds dat je probleem in de positieve terugkoppeling zit dus niet in de negatieve.

Dit wil zeggen dat de amplitude niet goed of in het geheel niet geregeld wordt met name in de lage frequenties.

Als je de generator op een goede stand zet dan moet je op testpunt C 20mV rms meten kun je dit controleren.

Gr Henk.

Everything should be as simple as possible, but not simpler.
blackdog

Honourable Member

Hi fertinator,

ik ben het in grote lijnen met Henk eens.
Omdat hij het wel doet op de hogere frequenties, denk ik dat er te weinig gain is op de lagere frequenties.
En dat is bijna altijd een condensator probleem, elco's in deze schakeling, zoals c22 en c24.

als deze condensatoren slecht zijn, wordt de gain in de onderste bereiken te laag.
Het regel circuit met de Thermistor kan het dan niet bijbenen.

Het regelbereik wordt meestal zo gekozen dat de regeling van de uitgangsspanning zo mooi mogelijk is met zo min mogelijk vervorming.

De dc spanning veranderd ook als de schakeling niet werkt.
Als de dc spanningen kloppen in de hoogste bereiken dan is de schakeling wat dc betreft in mijn ogen goed.

gegroet
Bram

1e, Do No Harm! 2e, Leave Things Better Than You Found Them.
RAAF12

Golden Member

Ik zou toch ook even de RC tijd van de oscillator testen in de drie laagste bereiken. De kans dat die hoogohmige weerstanden oneindig hoog zijn is zeer groot. Die kunnen de tand des tijds maar moeilijk aan. Bij gebrek aan geschikte meetapparatuur gewoon verwisselen cq. samenstellen uit courante waardes.

Hi RAAF12,

Ik denk toch meer aan c26 en c27en de componenten er na deze voert het signaal voor de positieve feedback naar de verschil versterker.

In het frequentie net werk moeten dan 3 weerstanden verlopen zijn het kan zeker alles is immers net zo oud.

Het blijft moeilijk als je niet kan meten door gebrek aan apparatuur
ik dacht dat fertinator wel weerstanden kon meten dan kan hij toch het pad van de amplitude feedback meten hier zit ook een 100k potmeter in en het kan echt geen gevaar om er eens aan te draaien.

Gr Henk

Everything should be as simple as possible, but not simpler.

Vrijwel alle belangrijke elco's zijn al vervangen. Overigens mis ik C23 op de 2e foto.

Nog een puntje:
Controleer ook de als trimmer misbruikte Philips potmeters die er al sinds 1970 inzitten.

[Bericht gewijzigd door Henry S. op 21 augustus 2015 00:17:23 (39%)]

Heren, bedankt voor de informatie. Ik was even op vakantie en school is weer begonnen, dus het lag even stil.

C23 zit niet op de printplaat, maar extern gemonteerd, zie onderstaande foto.

Ik heb deze ook maar vervangen voor een nieuwe (schema zegt 400µF, maar zat 470 in. Toen kwam ik erachter dat deze condensator niet goed aangesloten zat. Met één zijde was deze aan de ground bevestigd. Heb hem dus aan de 24 Volt gehangen.

Ik zie nu bij de derde stand (10²) dat bij maximale frequentie wel een sinusgolf eruit komt, maar snel verdwijnt als de frequentie verandert wordt. Ik weet niet zeker of dit door bovenstaande komt of niet.

De 20 mVrms kan ik niet goed meten (geen RMS meter) en de scoop zit dan ook in zijn laagste spanning/div stand en ik heb alleen een 1:10 probe. Maar ik lees een topwaarde van ongeveer 35 mV, wat op een RMS van ongeveer 25 mV uitkomt.
Als ik dan potmeter R36 iets verander zie ik wel direct dat het systeem bijregelt.

Voor de zekerheid heb ik C26 en C27 vervangen, maar geen verandering. De trimmers heb ik ook gecontroleerd en zijn nog goed.

Shiptronic

Overleden

Onder de "USB" aansluiting zit een brakke soldering.

Wie de vraag stelt, zal met het antwoord moeten leren leven.

<shameless plug>

In V&A bied ik deze PM5160 met ongeveer dezelfde kwaaltjes aan voor de liefhebber... dit geheel ter zijde

</shameless plug>

Opmerkelijk, ik heb een functiegenerator (PM5162) van dezelfde generatie meetapparatuur. Ook extreem slecht gedrag bij veroudering, bijzonder temperatuur gevoelig en bijna niet werkend te krijgen. Na vervanging van alle schakelaars, veel potmeters en vervangen van heel veel torren-paartjes door dual's en circuit mod's werkt het.

RAAF12

Golden Member

In de drie laagste bereiken zitten hier hoogohmige R's, samen met vervuiling en verloop is dat een probleem. In de andere bereiken oscilleert die wel soepel.

edit

Ow ja, je kan die bereiken niet testen met open kast. Vangt teveel storing op wegens de hoge impedanties.

@ fertinator,

Komt het signaal in deze band wel terug als je een andere frequentie heb gekozen?
Het regel circuit van dit principe is nog al traag dus in de lage frequenties zal het signaal even verdwijnen pas als de amplitude is gestabiliseerd is je signaal weer terug.

@ Shiptronic,

Wat bedoel je met onder de USB???

@ markce,

Dan heb je bijna een nieuwe gebouwd ;)

Het nadeel van oude apparaten welke op ebay of marktplaats verkocht worden is dat het nog werkt :*

Maar als je de spec's meet kom je van een koude kermis thuis |:(
Het is dus niet defect maar versleten verouderd ga daar maar aan staan.

Als je kan ontwerpen en er zin en tijd voor heb kan je dit vaak beter doen je bouwt een nieuw apparaat met componenten welke vaak veel beter zijn dan die van 30 jaar geleden en je weet precies hoe een en ander werkt.

Ik zal nog een op het schema kijken of ik een zinvolle opmerking kan plaatsen.

Om nu net als markce gedaan heeft alle componenten te vervangen is ook wat overdreven :+

Gr Henk.

Everything should be as simple as possible, but not simpler.

Nog een idee: je hebt de var-C (frequentieregeling) al schoongespoten met perslucht?

In mijn geval, des te meer tijd je investeert, de te moeilijker het is om het apparaat af te schrijven. En dat kan nogal uit de hand lopen. Achteraf was ik met nieuwbouw sneller klaar geweest.

[Bericht gewijzigd door markce op 2 september 2015 23:31:15 (19%)]

Hopelijk is de fout ondertussen verholpen maar het lijkt me toch zinvol als ik mijn ervaring met de PM5160 toevoeg. Net zoals festinator kreeg ik de oscillator met een gebrek; er kwam alleen signaal uit korte tijd na aanzetten en daarna bleef het weg op alle standen van de frequentie keuzeschakelaar.
Om een of andere reden werd dus niet aan de oscillatie voorwaarde voldaan; dat de rondgaande versterking groter of gelijk is aan 1, behalve net na het aanzetten. Bij de PM5160 van deze link is dat het geval bij drie bereiken en het is mogelijk dat het dubbel T-netwerk bij de andere bereiken een net iets verkeerde verzwakking geeft. Er is dan niets kapot, alleen wat verlopen. Electron 920 zegt het al; de positieve regellus is dus verdacht.
Ik heb er (te) lang naar moeten zoeken, TS20 BFX63 vervangen wat niets uitmaakte en de thermistor nagemeten die heel bleek (gelukkig maar want de thermistor is een zeldzaam artikel en duur op het net). De oorzaak bleek lekkende ingangs-transistors: TS22 en TS23 BSX20, waardoor de versterking van de gehele opamp TS20-TS25 te laag was geworden en vervangen door nieuwe BSX20's loste alles in een klap op.
De verklaring ligt in de betrekkelijk lage doorslag spanning van de basis emittor diode van de BSX20 (4,5V wordt opgegeven als maximum toegelaten spanning) en die spanning kan bij aan- en uitzetten overschreden worden. In bedrijf staan de emittors op ong. +6V en als bij uitzetten de ene kant van het tweetal langer stroom voert ziet de ander 0V op de basis terwijl de emittor nog op 6V staat. Bij mijn PM5160 waren deze twee BSX20's al een keer vervangen! Als beveiliging zijn er nu diodes tussen de basis en emittor gezet.
De oscillator doet het nu al jaren goed en de prestaties zijn indrukwekkend; het apparaat is mooi en met zorg gemaakt. Doordat de kast hermetisch is komt er ook geen stof is en schoonspuiten met perslucht is zeker af te raden. Met de handen aanraken van de hoog-ohmige delen van de schakeling ook maar het boekje is daar duidelijk in.
Dat de schakeling de amplitude traag stabiliseert is alleen maar gunstig want je wil niet dat de schakeling tijdens het veranderen van de spanning, de sinus, al reageert want dat zou vervorming kunnen geven.
Hopelijk is de fout allang gevonden en anders succes,

Donald