Grootte van bijv. een schema op CO.

Lambiek

Special Member

Het is me al een paar maal opgevallen dat bijv. een schema die een aantal jaren geleden op een goede manier is geplaatst, (gaf toen geen fout aan dat het te groot was) nu ineens veel te groot zou zijn als je hem in een topic plaatst. Is dat alleen bij mij zo, of hebben meerdere daar last van.

Als je haar maar goed zit, GROETEN LAMBIEK.
flash2b

Golden Member

Ben van mening dat de restrictie op pixel grootte aan de krappe kant is vooral bij schema's. Dat er dan een melding wordt gemaakt dat je thumbnails moet gebruiken vind ik voor schema's niet handig. Dan is namelijk het hele overzicht weg.

Jeroen

Moderator

De limiet dat een afbeelding een balkje krijgt omdat ie te groot is is al jaren hetzelfde, namelijk 900 pixels. Heb je een voorbeeld waar/met welke afbeelding het fout gaat?

Op 24 april 2017 10:58:07 schreef flash2b:
Ben van mening dat de restrictie op pixel grootte aan de krappe kant is vooral bij schema's. Dat er dan een melding wordt gemaakt dat je thumbnails moet gebruiken vind ik voor schema's niet handig. Dan is namelijk het hele overzicht weg.

Het gaat om de bestandsgrootte, als het bestand te groot is moet er een melding komen. Echter is het in Javascript niet (cross-browser) mogelijk om de bestandsgrootte van een afbeelding uit te lezen, daarom wordt er gekeken naar de breedte in pixels.

Als je het schema via upload toevoegt, heb je dat probleem toch niet? (alleen via externe links)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

het ligt dus aan de foto invoeger via externe links en niet via de bijlage uploader ;-)

als je een externe foto wil invoegen van 600pixels, lukt dit, je krijgt de foto op 600pixels te zien.
voorbeeld:
http://fcapri.homelinux.com/off/pics/eo/arduinodash/640/P_20...142307.jpg
http://fcapri.homelinux.com/off/pics/eo/arduinodash/640/P_20150318_142307.jpg

als je een foto invoegt van meer dan 900pixels, kwam die vroeger resized eruit. echter als je dat nu doet, krijg je een melding dat je moet verkleinen
voorbeeld: dezelfde als 1000pixels:
http://fcapri.homelinux.com/off/pics/P_20150318_142307.jpg
http://fcapri.homelinux.com/off/pics/P_20150318_142307.jpg
maar bij het invoegen via de kader kreeg ik wel deze fout en kan je niet invoegen. (met gefoefel lukt het wel)
http://fcapri.homelinux.com/off/pics/fout.jpg

als bijlage doet die dat zo (foto van 1000pixels). is dan ook ineens klikbaar:

eigenlijk is het quasi onmogelijk om nu nog dat ding te maken met die rode kader errond, dit is een restant van vroeger.
net wel gezien dat in chrome alle fotos klein worden weergegeven en klikbaar zijn. op mijn werk pc met internet explorer wordt alles realsize weergegevens en zijn de eerste 3 niet klikbaar (enkel die via de uploader is verkleind en klikbaar)

[Bericht gewijzigd door fcapri op 24 april 2017 11:47:21 (10%)]

ik hou van werken ..., ik kan er uren naar kijken
Lambiek

Special Member

Op 24 april 2017 11:19:57 schreef Jeroen:
Heb je een voorbeeld waar/met welke afbeelding het fout gaat?

Hier bijv., en ik heb het vaker gezien ook bij andere schema's.

https://www.circuitsonline.net/forum/view/136691

En bij het plaatsen gebruik ik altijd thumbnails, omdat je anders direct de melding krijgt dat het te groot is. Dus dat werkt wel, maar dat het dan na jaren in eens de melding krijgt dat het te groot is snap ik niet. En het maakt mij verder niet uit, maar het viel me gewoon op. :)

Hier is de thumpnail/resized dus van weg.
https://www.uploadarchief.net/files/download/eind%20-%20trap.jpg

Op 24 april 2017 11:28:37 schreef Arco:
Als je het schema via upload toevoegt, heb je dat probleem toch niet? (alleen via externe links)

Ik gebruik altijd de upload van CO.

Als je haar maar goed zit, GROETEN LAMBIEK.

Ik heb nog nooit die melding gehad met CO upload. (behalve als het te groot is...)
Wordt altijd automatisch geresized, en is dan clickable (1017x905):

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
Jeroen

Moderator

Op 24 april 2017 11:32:08 schreef fcapri:
als je een foto invoegt van meer dan 900pixels, kwam die vroeger resized eruit. echter als je dat nu doet, krijg je een melding dat je moet verkleinen

Die rode stippelrand krijg je als de afbeelding kleiner is gemaakt om in de pagina te passen. Dan kun je erop klikken om de oorspronkelijke afbeelding weer te geven. De reden dat je die nu minder krijgt zal zijn omdat je tegenwoordig hogere schermresoluties hebt. Dit staat los van de melding dat je thumbnails moet maken.

Op 24 april 2017 11:37:12 schreef Lambiek:
En bij het plaatsen gebruik ik altijd thumbnails, omdat je anders direct de melding krijgt dat het te groot is. Dus dat werkt wel, maar dat het dan na jaren in eens de melding krijgt dat het te groot is snap ik niet. En het maakt mij verder niet uit, maar het viel me gewoon op. :)

Jouw afbeelding in dat topic is 1760 pixels breed. Jaren geleden had dat ook een melding opgeleverd omdat de grens (> 900 pixels breed) hetzelfde is gebleven.

Hier is de thumpnail/resized dus van weg.
https://www.uploadarchief.net/files/download/eind%20-%20trap.jpg

[...]
Ik gebruik altijd de upload van CO.

In deze post heb je het Upload Archief gebruikt en niet de upload functie van Circuits Online. Of is er iets geweest met het Upload Archief waardoor thumbnails weg zijn o.i.d.?

Lambiek

Special Member

Op 24 april 2017 13:19:09 schreef Jeroen:
Jouw afbeelding in dat topic is 1760 pixels breed. Jaren geleden had dat ook een melding opgeleverd omdat de grens (> 900 pixels breed) hetzelfde is gebleven.

En toen is dat dus niet gebeurt, anders had ik het wel aangepast. Toen het net geplaatst was (2008) en ik gebruikte het in een topic kreeg ik de melding niet, hoe kan dat dan? En nu na een aantal jaren krijg je wel te zien dat het te groot is.

In deze post heb je het Upload Archief gebruikt en niet de upload functie van Circuits Online.

Uuh, nu ontgaat mij iets. Het Upload Archief is toch van CO? Of bedoel je de Upload onder aan een nieuw Topic, die gebruik ik zelden.

Of is er iets geweest met het Upload Archief waardoor thumbnails weg zijn o.i.d.?

Nou, niet dat ik weet.

Als je haar maar goed zit, GROETEN LAMBIEK.

Uuh, nu ontgaat mij iets. Het Upload Archief is toch van CO?

Lijkt me toch niet... :)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
Lambiek

Special Member

Dat is dus niet van CO? Als dat zo is, dat heb ik dus nooit geweten ging er altijd van uit dat het bij CO hoorde. Dus alleen de Upload onder aan een nieuw topic is van CO?

Als je haar maar goed zit, GROETEN LAMBIEK.
flash2b

Golden Member

Het is toch helemaal niet handig/wenselijk om plaatjes ipv linken te downloaden en dan via de upload van het forum in te voegen?

Juist door een link te gebruiken leidt zoekmachines tot de CO site, met kopieren heb je dat niet.

Op 24 april 2017 13:19:09 schreef Jeroen:
Die rode stippelrand krijg je als de afbeelding kleiner is gemaakt om in de pagina te passen. Dan kun je erop klikken om de oorspronkelijke afbeelding weer te geven. De reden dat je die nu minder krijgt zal zijn omdat je tegenwoordig hogere schermresoluties hebt. Dit staat los van de melding dat je thumbnails moet maken.

mijn schermresolutie op het wekr is 1920x1080. de fotos worden NIET resized op mijn beeld (kan er ook niet op klikken). nogthans heeft die ene nog altijd een rode rand errond. als de foto dus meer dan 900pixels is, heb je altijd die rode rand.

het plaatsen van fotos in een topic die te groot zijn, lukt nog altijd niet dan. dat wordt altijd geweigerd, hoe groot je schermresolutie ook is

ik hou van werken ..., ik kan er uren naar kijken

Op 24 april 2017 13:44:13 schreef Lambiek:
Dat is dus niet van CO? Als dat zo is, dat heb ik dus nooit geweten ging er altijd van uit dat het bij CO hoorde. Dus alleen de Upload onder aan een nieuw topic is van CO?

Klopt...

"Het Upload Archief is voornamelijk bekend onder de gebruikers van de site circuitsonline.net, maar mag door iedereen gebruikt worden."

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
Lambiek

Special Member

Nou, dat weten we dan ook weer. :) Maar er zijn toch nog problemen lees ik, misschien toch niet voor niets aangehaald.

Als je haar maar goed zit, GROETEN LAMBIEK.
Jeroen

Moderator

Op 24 april 2017 14:10:48 schreef fcapri:
[...]

mijn schermresolutie op het wekr is 1920x1080. de fotos worden NIET resized op mijn beeld (kan er ook niet op klikken). nogthans heeft die ene nog altijd een rode rand errond. als de foto dus meer dan 900pixels is, heb je altijd die rode rand.

het plaatsen van fotos in een topic die te groot zijn, lukt nog altijd niet dan. dat wordt altijd geweigerd, hoe groot je schermresolutie ook is

Dat is ook logisch. De rode stippelrand verschijnt als de foto te groot is voor jouw beeldscherm. Dan wordt ie verkleind weergegeven en kun je er op klikken. Zou dat niet gebeuren dan past het niet in de site.

De rode balk echter geeft aan dat de foto te groot is voor het downloaden voor alle bezoekers. Het idee hierachter was bezoekers met een datalimiet, die je niet tientallen MB's wil laten downloaden als ze een topic openen. Daarom komt die melding altijd als de foto > 900 pixels is, ongeacht je beeldscherm.