arduino loopt vast bij uploaden

Beste allen,

Ik heb een kloon arduino nano. Wanneer ik een sketch probeer te uploaden blijft de IDE software hangen in het uploaden en start de sketch niet.

Heb verschillende USB kabels geprobeerd, de drivers ge-update en ook verschillende COM poorten geprobeerd. De nano wordt wel herkend bij het verbinden. Weet iemand een oplossing of is ie misschien kapot?

KGE

Golden Member

Je hebt wel het juiste board gekozen in de IDE ?

Zoja, proberen met een andere Nano..

ja heb het goede board gekozen. Mijn UNO werkt wel, heb helaas geen andere nano.....

pe1bia

Golden Member

Hallo
Voordat je op upload drukt de reset aansluiting aan aarde leggen. (ik heb hiervoor even een schakelaar gebruikt). Dan op upload in de balk drukken en wachten tot onder in het beeld de tekst verschijnt uploaden. Dan schakelaar loslaten. Ik heb daar ook dagen op gezocht.

Joop PE1BIA

Dat zou op een Nano automatisch moeten gaan, de rst hangt nl aan de DTR pin van de USB/ser converter.
http://playground.arduino.cc/Main/DisablingAutoResetOnSerialConnection

(maar goed, proberen kan altijd natuurlijk)

[edit] Wel de goede USB driver gebruikt? Andere PC geprobeerd?

[Bericht gewijzigd door flipflop op 7 mei 2017 19:33:09 (13%)]

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

Zonder de sketch te zien is er natuurlijk weinig over te zeggen.
Ook kun je eerst proberen zonder board aangesloten op controleren te drukken.
Toont de IDE dan geen fouten?

De sketch compileert zonder fouten. Maar we zijn er inmiddels achter. Na kortsluiten van de reset aan ground begon de chip te roken. Ik vermoed dat ie wel kapot was of in elk geval nu dan zeker ....
Dank jullie voor de reacties

Da's wel een heel unieke manier om een uC op te blazen. Sterk verhaal. Hoe is ie stuk gegaan dan?

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein