Automatisch licht met laag stroomverbruik

Thevel

Golden Member

Op 12 januari 2018 20:55:31 schreef jerome:
Heb dergelijke timers al vaak gemaakt maar zie het nut niet van de 8 diodes op de uitgangen. Ik schakel het relais met een pnp tor, zodat het relais sluit als 3 laag is.
Ik had een aantal posts terug dezelfde gedachte maar gaat gaat toch niet werken:
Op 8 januari 2018 11:16:12 schreef tysie:
Maar dan brand de led dus zolang pen3 laag is. Overdag zal de schakeling in reset staan waarbij de pen laag is en de led de hele dag brand.
Thevel

Golden Member

Op 12 januari 2018 20:21:06 schreef tysie:
heb uitgevonden dat de schakeling wel werkt zonder D1.
Wat kan het probleem zijn met deze diode:
http://nl.farnell.com/on-semiconductor/nsr0530ht1g/schottky-...s%2Fsearch
Het is een Schottky diode en heeft een lek van een paar µA.
Omdat er door R2 (1MΩ) maar weinig stroom loopt kan pen 11 onbedoeld laag worden.
Als je R1 en R2 verlaagt naar 100kΩ en C1 verhoogt dan zal het wel werken denk ik.

Maar beter is om de diode te vervangen door een 1N4148 welke een veel lagere lekstroom heeft.
Thevel

Golden Member

.

[Bericht gewijzigd door Thevel op 12 januari 2018 21:25:10 (99%)]

Heb een andere diode erop gezet en dat werkt. In ieder geval de led gaat aan, moet nog even testen of hij zo na een uurtje uit gaat.

Nu het verbruik:
Als het gaat schemeren(ik dim de verlichting) gaat het verbruik naar 1-3mA zonder dat de leds nog aangaan. Dit vind ik wel vreemd.
De potmeter staat op 500kohm ingesteld. Dus mocht de LDR naar 0 ohm gaan zou de maximum stroom daar 0.000024ampere= 0.024mA.
Waardoor kan dat nog komen? Het wordt niet energiezuinig zo
Op 12 januari 2018 21:32:51 schreef tysie:
Nu het verbruik:
Als het gaat schemeren(ik dim de verlichting) gaat het verbruik naar 1-3mA zonder dat de leds nog aangaan. Dit vind ik wel vreemd.
De potmeter staat op 500kohm ingesteld. Dus mocht de LDR naar 0 ohm gaan zou de maximum stroom daar 0.000024ampere= 0.024mA.
Waardoor kan dat nog komen? Het wordt niet energiezuinig zo

Een LDR wordt nooit 0Ω en die stroom is toch al erg laag!
Ik kom trouwens op 9volt/500k= 18µA maar dat kan door de spanningsval over R4 (waarde?) nog wat lager worden, dan is het geen 9 volt meer.
Doorgaans schrijf ik duidelijk wat ik bedoel, en toch wordt het wel eens anders begrepen.
Thevel

Golden Member

Als het gaat schemeren(ik dim de verlichting) gaat het verbruik naar 1-3mA zonder dat de leds nog aangaan. Dit vind ik wel vreemd.
Dat gebeurt als de reset ingang zich tussen hoog en laag bevind in het "verboden gebied".
Een CMOS poort kan dan een beetje beetje stroom trekken, daar kun je niets aan doen, de stroom zal per merk ic kunnen verschillen.
Als de LDR goed belicht is dan is de ingang echt hoog en zal het IC nog nauwelijks stroom trekken.
Op 12 januari 2018 21:45:53 schreef Thevel:
[...]Dat gebeurt als de reset ingang zich tussen hoog en laag bevind in het "verboden gebied".
Een CMOS poort kan dan een beetje beetje stroom trekken, daar kun je niets aan doen, de stroom zal per merk ic kunnen verschillen.
Als de LDR goed belicht is dan is de ingang echt hoog en zal het IC nog nauwelijks stroom trekken.


Dat klopt. Als het goed licht is loopt er minder dan een mA. Dus het zal alleen veel gebruiken tijdens schemering dan. Ik moet alleen nog meten wat hij doet nadat de timer de leds heeft uitgezet

Of er moet een comparator voor die poort. Ik weet niet hoe laag ik het stroomverbruik van een opamp kan krijgen
Thevel

Golden Member

Het verbruik zal een stuk minder kunnen zijn als je het IC op 3V of 5V laat draaien, dat zal je kunnen proberen.
Als dat acceptabel is kun je er een low-current regelaar tussen zetten.
Je kunt er een schmitt-trigger tussen zetten (bijv 2 stuks 40106 poorten)
Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
Ik weet niet hoe laag ik het stroomverbruik van een opamp kan krijgen

Voorbeeld, heb even gezocht, ik was ook benieuwd.
http://www.linear.com/product/LT6003
overzicht van LT, bij andere merken heb ik niet gezocht.
http://www.linear.com/parametric/low_bias_current_amplifiers
Thevel

Golden Member

Ik heb de schakeling even op een breadboard gezet en gemeten, in het "verboden gebied" is de stroom max. 2,8mA daarbuiten is de stroom nagenoeg nul als de reset hoog is.
Bij 5V voeding neemt de stroom in het "verboden gebied" drastisch af tot slechts 0,2mA.
Het merk IC dat ik gebruik is onbekend, bij een ander merk kunnen de stromen misschien wel anders zijn.

Ik heb ook gemerkt dat de schakeling toch niet helemaal lekker werkt, er is een klein gebied tussen aan en uit van de reset waardoor de oscillator staat te "klapperen" en heel onregelmatige pulsen geeft, of dat invloed heeft op de tijdsduur heb ik niet getest.


Op 12 januari 2018 22:31:20 schreef Arco:
Je kunt er een schmitt-trigger tussen zetten (bijv 2 stuks 40106 poorten)
Ook dat heb ik getest maar dan met een CD4093 schmitt-trigger.
Ook een C4093 heeft een hoger verbruik in het "verboden gebied" maar dat is een stuk lager, zo rond de 0,3mA
Een 40106 zal ook een iets hogere stroom hebben in het "verboden gebied" maar dat heb ik niet getest.
Met de schmitt-trigger heb je geen last van het eerder genoemde "klapperen".
Om die timer met ldr overdag en s'nachts aan de gang te houden ben je maar een heel klein zonnepaneeltje en kleine oplaadbare batterij nodig als je naar bv 5V wilt.
Thevel

Golden Member

Dat zal ook nog kunnen maar een paar mA uit een bootaccu stelt ook weinig voor.
Het is geinstalleerd en na wat afstellen tijdens schemeren ging het licht keurig aan.
Ik heb een 3M9 weerstand en een 0.22uf condensator gebruikt dus ik zou verwachten dat hij op zn minst 4 uur bleef branden, maar na 2 uur schakelde hij uit.
Met de schakeling is verder niks mis want even een zaklamp op de sensor en weer weg, en de verlichting ging weer aan.

De berekening is toch als volgt?:

1/(2.5*3.9e6*0.22e-6)=0.466....
en dan 8192/0.466....=17571 seconden=4.88 uur?