Nicd-Nimh lader

Ik heb een lader van sigma 7V 900mA

Nu meet ik tijdens het laden van een nipack (staat op het accupack) een pulserende spanning van ca 2V

Heb de lader open gemaakt en er zit een trafo in die een sec spanning geeft van 14Vac
Spanning na gelijkrichtcel 18V
dan zit er een b857 transistor daar staat op de collector een pulserende spanning 18V
Vandaar een diode en die gaat via een condensator naar de uitgang +
Condensator lijkt een beetje op een tantaal exemplaar.

Op de uitgang zit verder alleen een 20KΩ die weer aansluit op een LM393P

Verder zitten er nog een IC waar geen codering vanaf te lezen valt maar deze lijkt om de multicolor LED aan te sturen.

Het verbruik in rust is ca 2Watt

Elco's gemeten waarde voldoen.
Mijn vraag is dit een soort van puls lader en hoe controleer ik of de lader werkt?

Mvg
Harrie

Er zijn vele wegen die naar Rome leiden (en ook laadmethoden... ;) )
Pulse of Burp-charge is er ook een, er wordt dan met pulsen geladen/ontladen.

https://www.mpoweruk.com/images/burp.gif

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

dit is geen puls, maar de spanning van een ongestabiliseerde gelijkrichting, de lader klinkt erg simpel van opbouw.

waar rook was, werkt nu iets niet meer

Hier een paar foto's

Foto condensator?

Kan dat met die condensator?

Da's geen condensator, maar een zekering... (multifuse)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
maartenbakker

Golden Member

Dat is een zekering.

Ik zou als eerste de elco's verdenken. Meten zonder ESR-meting geeft geen betrouwbare indicatie. Je zou de boel ook eens lekker warm kunnen stoken met de haardroger. Doet hij het dan beter, dan zijn er elco's rot. Maakt het niets uit dan weet je eigenlijk nog niet zoveel meer.

Verder zie ik prut op de print, dat kan eventueel bruin geworden lijm (bisonkitachtig) zijn, die is corrosief en geleidend en moet je dan wegschrapen.

"The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

vanwaar de verdenking dat deze lader niet goed meer is? als de nicd cellen niet meer willen kan dat ook zijn omdat ze gewoon rot zijn. als de led van de lader groen blijft, kan dat komen door te lage klemspanning van de cellen. met de hand op 1V per cel brengen wil weleens helpen. als de interne weerstand erg slecht is kappen dergelijke laders ook wel af, eindspanning is al bereikt.

waar rook was, werkt nu iets niet meer

die 2 4,7µF hebben een ESR van ca 1Ω
De grote elco van 470µF 0,01Ω

edit
Als ik de lader aansluit gaat de LED even aan en gelijk weer uit
Geen rood of groen
Ook niet als het accupack wordt opgeladen

[Bericht gewijzigd door ZeHa op 7 augustus 2018 15:28:05 (43%)]

de led zit in een stel houders, vaak een hol blikken buisje. soms maakt dat slecht contact.

ik zou zeggen, meet de hulpspanning van het ic eens, kan zijn dat die al niet klopt.

waar rook was, werkt nu iets niet meer

Op 7 augustus 2018 15:33:51 schreef testman:
de led zit in een stel houders, vaak een hol blikken buisje. soms maakt dat slecht contact.

ik zou zeggen, meet de hulpspanning van het ic eens, kan zijn dat die al niet klopt.

Jij bedoeld de LM393?

[Bericht gewijzigd door ZeHa op 7 augustus 2018 15:44:57 (45%)]

Ik denk van het grote laad ic (zal wel iets als een BQ2xxx van TI zijn)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Op 7 augustus 2018 15:48:49 schreef Arco:
Ik denk van het grote laad ic (zal wel iets als een BQ2xxx van TI zijn)

Dat 16 polig IC daar kan ik niks op lezen helaas
Heb je een link naar een vergelijkbaar laad ic?

maartenbakker

Golden Member

ESR klinkt goed. Het gaat duidelijk om een schakelende voeding, IC kan een algemeen PWM type zoals SG3524, TL494 o.i.d. zijn of een dedicated type voor laders zoals hierboven al genoemd. Ik heb helaas niet direct linkjes maar met een datasheet is de pinout snel te verifiëren.

Pulsen geven, "hikken", doen schakelende voedingen vooral bij overbelasting of bij een defecte diode, elco, senseweerstand. De elco's lijken goed. Als de prut op de print inderdaad hard en donker geworden bruine prut is met onderliggende onderdelen eventueel wat geoxideerd dan is dat ook nog steeds een mogelijkheid.

"The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Op 7 augustus 2018 16:15:11 schreef maartenbakker:
Als de prut op de print inderdaad hard en donker geworden bruine prut is met onderliggende onderdelen eventueel wat geoxideerd dan is dat ook nog steeds een mogelijkheid.

Ga morgen die print maar eens schoonmaken

Kan ook dat de accu defect is. Meet je 2 Volt op het accupack?

Dat vroeg ik me ook al af. En: Wat voor accu is het precies, spanning, aantal cellen, etc. foto(!)

Don't Panic!
HenkR

Golden Member

Als ik de foto van de onderkant van de print bekijk lijkt het er op dat de middelste poot van de LED los zit. Dit verklaard het niet branden van de led.
@ Maartenbakker: schakelende voeding lijkt me stug met die grote gewikkelde trafo.

Groet, Henk

De leds zitten zo te zien aan pin 10/11 van het ic, zou kloppen met de Benchmarq/TI bq2004: http://www.ti.com/product/BQ2004

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
HenkR

Golden Member

Op 7 augustus 2018 18:56:18 schreef Arco:
De leds zitten zo te zien aan pin 10/11 van het ic, zou kloppen met de Benchmarq/TI bq2004: http://www.ti.com/product/BQ2004

Een schakelende voeding achter een gewikkelde voedingstrafo? wat is de reden om een schakelende voeding achter een voedingstrafo te zetten?

Groet, Henk

Minder warmte?... Efficiency?...
Het zal het ic worst zijn waar of hoe de spanning gemaakt wordt zolang die klopt...

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

het kan ook de afgaande draad zijn die niet aanraakveilig is, stekker met open contacten bijv. een smps geeft een 100-130V aan lading door de c tussen primair en secundair. deze constructie van een smps achter een trafo zie ik vaker bij oa intercom voedingen, geen koppeling met de 230V..

waar rook was, werkt nu iets niet meer

't Is een switcher (non-isolated), er is geen primair en secundair. (daar is de gewone grote trafo voor).

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
maartenbakker

Golden Member

@HenkR: vrij duidelijk een switcher, zie de mooie grote spoel naast de gekoelde tor of IC, 2 diodes, elco's.

Als ik de foto nog eens goed bekijk is er inderdaad sprake van het soort lijm dat ik dacht. Na verwijdering (zou relatief makkelijk moeten zijn) even alle weerstanden die eronder of ertegenaan zaten, doormeten. Door de oxidatie zijn dat goede kandidaten voor onderbrekingen of hoogohmigheid.

"The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Als 't een BQ2004 is, zal het wel vergelijkbaar zijn met het datasheet schema:

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com
maartenbakker

Golden Member

Dat is een mooi uitgangspunt om zelf een schema uit te tekenen inderdaad. Voor zover nodig om het mankement te verhelpen natuurlijk, of gewoon als oefening.

"The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."