Arduino aansturen met 24V 5A


Waarom niet gewoon de emittor van de opto aan massa, en de collector via de weerstand aan de ingang van de PLC?
Zo in de tekening blijft de ingang zweven.
(ik ben niet zo'n voorstander van emmittorvolgers, vraag me niet waarom )

[Bericht gewijzigd door mel op 27 maart 2019 12:48:39 (19%)]

u=ir betekent niet :U bent ingenieur..

Op 27 maart 2019 12:47:05 schreef mel:
Waarom niet gewoon de emittor van de opto aan massa, en de collector via de weerstand aan de ingang van de PLC?
Zo in de tekening blijft de ingang zweven.
(ik ben niet zo'n voorstander van emmittorvolgers, vraag me niet waarom )

Zou je misschien een tekening kunnen maken want ik volg je niet helemaal.
Want zoals jij het zegt lijkt het bij mij dus dat de poort aan is wanneer de Arduino de pin laag trekt.

edit:
ik kan me wel herinneren dat ik een relais module had die je schakelde door gnd te verbinden.
misschien is het wat om naar dat schema te kijken.

of bedoel je dit ?

Ik heb ook nog even de handleiding van de logo doorgespit en dit gevonden:

We gebruiken op school de 12/24 variant.

Zelf weet ik niet of mijn opto coupler er voor geschikt is kan iemand dat voor mij checken of me tips geven waar ik naar moet kijken.
ik gebruik een til 117.

altijd druk met de verkeerde dingen
Lambiek

Special Member

Op 27 maart 2019 13:08:43 schreef remco_blom:
Zelf weet ik niet of mijn opto coupler er voor geschikt is kan iemand dat voor mij checken of me tips geven waar ik naar moet kijken.

Je kunt toch meten hoeveel stroom je PLC ingang trekt als je de ingang hoog maakt. En misschien staat dat ook wel in de datasheet van de PLC. Op die manier kun je controleren of je optocoupler goed is voor dit klusje.

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 27 maart 2019 13:45:57 schreef Lambiek:
[...]
Je kunt toch meten hoeveel stroom je PLC ingang trekt als je de ingang hoog maakt. En misschien staat dat ook wel in de datasheet van de PLC. Op die manier kun je controleren of je optocoupler goed is voor dit klusje.

In de datasheet staat het niet vermeld(of ik kijk in de verkeerde).
Ik zal morgen de ampère meter er aan leggen en de gegevens door spelen.

De Arduino Mega die ik gebruik heeft een Output current van 40mA dan is de vraag nog of de optocoupler niet te veel trekt anders zit ik daar ook weer mee.

al met al morgen is het test dag.

altijd druk met de verkeerde dingen
Lambiek

Special Member

Op 27 maart 2019 14:14:59 schreef remco_blom:
Ik zal morgen de ampère meter er aan leggen en de gegevens door spelen.

Kun je gewoon met je multimeter doen op de 200mA stand.

De Arduino Mega die ik gebruik heeft een Output current van 40mA dan is de vraag nog of de optocoupler niet te veel trekt anders zit ik daar ook weer mee.

Het enige wat de Arduino hoeft te doen is de interne led van je optocoupler aansturen, dat kost niet meer dan +/- 10mA. En vergeet je voorschakelweerstand niet.

Je kunt je logo op twee manieren aansturen, zie voorbeeld.

het type optocoupler moet je zelf maar opzoeken, ik zou er een zonder basis nemen. De weerstanden moet je ook zelf uitrekenen, kun je doen met de wet van Ohm.

Als je haar maar goed zit, GROETEN LAMBIEK.

Bedankt lambiek voor het advies maar die voorschakelweerstand heb ik al uitgerekend (Schema 1).
De berekeningen staan er bij misschien kun je kijken of ik nog iets fout heb gedaan.

Ik hoor net van mijn leraar dat de logo een zodanig kleine weerstand heeft de amperage die hij zal trekken is minimaal dus ik zou het zo moeten redden.

Bedankt voor het advies ik zal als het project klaar is foto's maken.
En natuurlijk van het bouwproces.

Met vriendelijke groet,

[Bericht gewijzigd door remco_blom op 27 maart 2019 14:40:11 (10%)]

altijd druk met de verkeerde dingen
Lambiek

Special Member

Had nog iets toegevoegd, zie post hierboven.

EDIT:
Ik zie dat je nog iets gevonden hebt over de logo, er staat bij de ingangsstroom < 1.0mA. Dus daar moet je de weerstand op uitrekenen voor de kant van je transistor. Aan de led kant teken je twee weerstanden, waarom? Is niet nodig.

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 27 maart 2019 14:42:02 schreef Lambiek:
Had nog iets toegevoegd, zie post hierboven.

EDIT:
Ik zie dat je nog iets gevonden hebt over de logo, er staat bij de ingangsstroom < 1.0mA. Dus daar moet je de weerstand op uitrekenen voor de kant van je transistor. Aan de led kant teken je twee weerstanden, waarom? Is niet nodig.

kijk daar heb ik iets aan had net bijna die til 117 besteld maar die is dus met basis.

bedankt lambiek

maar die <1mA klopt niet want dat is voor schakelstand 0 wat dat ook mag betekenen bij schakelstand 1 staat een andere waarde dus die moet ik nog verder opzoeken.

[Bericht gewijzigd door remco_blom op 27 maart 2019 14:50:41 (14%)]

altijd druk met de verkeerde dingen
Lambiek

Special Member

Op 27 maart 2019 14:48:48 schreef remco_blom:
maar die <1mA klopt niet want dat is voor schakelstand 0 wat dat ook mag betekenen bij schakelstand 1 staat een andere waarde dus die moet ik nog verder opzoeken.

Daar staat voor een één > 1.5mA, dus als je bijv. 5 tot 10mA aanhoud heb je meer dan voldoende stroom om je ingang hoog te maken. Meet het maar gewoon op morgen.

Kijk eens bij PC817.

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 27 maart 2019 14:21:45 schreef Lambiek:

het type optocoupler moet je zelf maar opzoeken, ik zou er een zonder basis nemen. De weerstanden moet je ook zelf uitrekenen, kun je doen met de wet van Ohm.

Heb er 1 uitgezocht ik denk dat de CNX 82A Optocoupler wel wat is.

altijd druk met de verkeerde dingen
Lambiek

Special Member

Op 27 maart 2019 15:06:32 schreef remco_blom:
Heb er 1 uitgezocht ik denk dat de CNX 82A Optocoupler wel wat is.

Die zou kunnen voldoen.

Zelf gebruik ik deze vaak.
http://www.google.nl/url?sa=t&rct=j&q=&esrc=s&&...cyDUXxWbT4

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 27 maart 2019 15:19:05 schreef Lambiek:
[...]
Die zou kunnen voldoen.

Zelf gebruik ik deze vaak.
http://www.google.nl/url?sa=t&rct=j&q=&esrc=s&&...cyDUXxWbT4

Heb hem gevonden op reichelt in een 4 channel pakket (pc847x) dat vind ik een mooie en is goedkoper als 1 til 117 dus dat wordt hem dan.

altijd druk met de verkeerde dingen
Lambiek

Special Member

Op 27 maart 2019 14:39:12 schreef remco_blom:
Bedankt lambiek voor het advies maar die voorschakelweerstand heb ik al uitgerekend (Schema 1).
De berekeningen staan er bij misschien kun je kijken of ik nog iets fout heb gedaan.

De stroom door de led van je optocoupler is veel te hoog, daar gaat nu +/- 100mA doorheen met een weerstand van 38Ohm. Dat moet je dus even opnieuw doen. Sorry, ik zie net dat er nog een schema staat met een extra weerstand van 1K, dus welke is het nu?

Hou de stroom door je led op max 20mA, minder is ook goed.

Bedankt voor het advies ik zal als het project klaar is foto's maken. En natuurlijk van het bouwproces.

Dat zou leuk zijn, dat gebeurd namelijk veel te weinig. :)

Als je haar maar goed zit, GROETEN LAMBIEK.

Lambiek ik heb je schema nog even bekeken en zie dat je bij de bovenste een pull down weerstand gebruik deze is echter overbodig.
Volgens sine zit er namelijk een pull down weerstand ingebouwd in de Logo.

Nu heb ik het volgende schema:

(vergeet die weerstand aan de rechter kant bij beide schema's)

Zo zou het goed moeten werken nietwaar ?

En alle uitgangen bij elkaar:

altijd druk met de verkeerde dingen
Lambiek

Special Member

Op 28 maart 2019 10:49:45 schreef remco_blom:
Lambiek ik heb je schema nog even bekeken en zie dat je bij de bovenste een pull down weerstand gebruik deze is echter overbodig.
Volgens sine zit er namelijk een pull down weerstand ingebouwd in de Logo.

Als dat zo is hoeft het inderdaad niet.

Nu heb ik het volgende schema: Zo zou het goed moeten werken nietwaar ?

Alleen dat stukje bij het noodstop relais klopt niet, hoe groot is dat relais?, als dat relais te groot is heb je kans dat je optocoupler de stroom niet kan leveren. En het is een spoel, dus daar hoort een blusdiode over heen. Ook kun je de relaisspoel beter naar de gnd trekken in plaats van in de plus te schakelen.

Voorbeeld: Dat wordt dus iets in deze trend.

Als je haar maar goed zit, GROETEN LAMBIEK.

laat het relais maar zitten dat ga ik in de software verwerken.
Tenminste ik moet even bekijken welke ik heb liggen.

[Bericht gewijzigd door remco_blom op 28 maart 2019 15:55:34 (30%)]

altijd druk met de verkeerde dingen

ik loop wel ergens tegen aan met mijn c# programma in visual studio kan ik dat ook hier plaatsen of moet ik dit even onder een ander kopje in het forum plaatsen.

De signalen van pc naar arduino werken goed, alleen als ik van arduino naa r pc wil begint mijn programma te mekkeren over cross threads.

als er iemand toch nog verstand van heeft: https://www.dropbox.com/sh/kx24myxjq5t7awu/AACqqFWBQ8O0Xdw0h...eEDva?dl=0

[Bericht gewijzigd door remco_blom op 28 maart 2019 21:20:04 (17%)]

altijd druk met de verkeerde dingen
Lambiek

Special Member

Je mag het programma gewoon hier plaatsen.

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 28 maart 2019 21:28:43 schreef Lambiek:
Je mag het programma gewoon hier plaatsen.

komt er aan

c code:

private void serialPort1_DataReceived(object sender, SerialDataReceivedEventArgs e)
        {
            textBox1.Text = serialPort1.ReadExisting();

            
           
        }

het gaat over dit stuk, om het hele programma er in te zetten lijkt me onhandig (400 lijnen).

de foutmelding is:
System.InvalidOperationException: 'Het is niet toegestaan een bewerking uit te voeren via verschillende threads: er werd vanaf een andere thread toegang gekregen tot het besturingselement textBox1 dan de thread waarop het element is gemaakt.'

Zou het komen doordat ik hem in een private void heb staan of wat is er mis.
Als ik de error opzoek komen de termem me om de oren vliegen en dan ook nog in het engels al met al daar wordt ik niet zijzer op.

[Bericht gewijzigd door remco_blom op 28 maart 2019 22:28:29 (51%)]

altijd druk met de verkeerde dingen

Je schrijft dat de Arduino met de Logo communiceert via serial. Is dat in 2 richtingen? Zowel heb ik een uitstekend schema voor jou.

Nihil est verum, quod non probatur primo.

Op 28 maart 2019 23:04:16 schreef Evarist:
Je schrijft dat de Arduino met de Logo communiceert via serial. Is dat in 2 richtingen? Zowel heb ik een uitstekend schema voor jou.

2 richtingen en dat zou op wezen.
Ik zie ook dat mensen readtimeout gebruiken en dat doe ik echter niet.

Zal dit ook een deel zijn van het probleem.

[Bericht gewijzigd door remco_blom op 29 maart 2019 08:00:13 (18%)]

altijd druk met de verkeerde dingen

Sorry voor de late reactie. Gepensioneerden hebben het vaak heel druk. :-)

Hier vind je de schakeling met optocouplers als je een beetje naar beneden scrolt.

2x maken voor RX rn TX van je serial poort.

http://www.esacademy.com/en/library/technical-articles-and-d...c-faq.html

Nihil est verum, quod non probatur primo.
Lambiek

Special Member

Ik heb ooit dit gemaakt om met een pic 16F887 "of een ander type" te communiceren met de PC, is een beetje vergelijkbaar met wat Evarist laat zien.

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 22 maart 2019 17:31:41 schreef Lucky Luke:
[...]
Paar 100 kiloOhm. 240k geeft 20mA door de tor als 'ie die ingang laag trekt. Met minder stroom kun je waarschijnlijk ook wel toe.

Met 240k wordt het wel al behoorlijk minder :-)

24V / 240k = 100 uA

hmmz. Ergens een bitje omgevallen in een neuron... Dank voor correctie!

Eluke.nl // Backwards Lightspeed Bus: i*i=-1, so iic=-c.