P1 Poort Data...wat gaat er mis?

Mensen een vraagje. Ik heb een rs485 module waarmee ik verbinding leg naar de P1 poort van mijn Sagemcom T210-D 3 Fase slimme meter.

Nu heb ik deze module ingesteld op, zoals beschreven, 115200 8N1 en ik krijg ook continu een stroom data binnen maar ik kan er geen kaas van maken. Herkend iemand deze output en heeft iemand op die diagnose ook een recept gevonden?

Hier een foto en een link naar een stukje video van de continu datastroom.

Hier de videolink

Zeer hartelijk bedankt voor het meedenken. Ik loop even dood met verdere config van sensoren en actuatoren tot ik het signaal probleem heb opgelost.

Volgens http://domoticx.com/p1-poort-slimme-meter-hardware/ levert dat ding een geinverteerd signaal.

Verder lijkt onder jouw gegevens tabel dat ie nu elke byte als HEX eruit gooit, voor debuggen is t makkelijker als je 't in ASCII weergeeft

Stap 1 zou zijn om 'm op een normale seriele poort te hangen en te kijken of je data correct is (dmv een MAX232 en een normale RS232 poort) en dan pas het hele RS485 verhaal op te pakken. (Dan weet je iig dat je bron goed is)

Ja daar heb je volkomen een punt. Eerst de baseline checken en dan pas verder. Ik ga sleutelen. Bedankt voor de repliek

?? RS485 is een gebalanceerde receiver, die heeft normaal 2 tegengestelde datalijnen terwijl de P1 maar 1 lijn uitstuurt.

Dus volgens mij kun je het beste een inverter toevoegen.

Op 19 augustus 2019 16:13:33 schreef DJSmiley:
Verder lijkt onder jouw gegevens tabel dat ie nu elke byte als HEX eruit gooit, voor debuggen is t makkelijker als je 't in ASCII weergeeft

Maar de hex waardes zijn "0xFE" en "0xFF" zeven of 8 eenen. Dan heeft het geen zin om naar de ascii waardes te kijken. Dan krijg je hoogstens "~?~~~???" te zien of iets dergelijks: minder duidelijk dan nu.

Er lijkt iets met baud rate aan de hand. Of inderdaad signaal geinverteerd. Zoiets.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Die slimme meters hebben toch geen 485 uitgang? Die van mij heeft gewoon een "rs232" poort, enkel tx lijntje op 5V (is geen rs232 dus, maar hoe noem je het anders? uart, serieel).

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

Dat is geen RS232. Maar wel een asynchroon UART signaal op 115200 baud.
Alles in ASCII dus goed te verwerken.

Data request moet hoog zijn. Dan komt de data vanzelf, elke seconde een volledig verslag.

Data is een open collector. Om dat te gebruiken heb je een pull-up weerstand nodig en een inverter. Daarna kan het naar een Seriele poort (TTL niveau). Ik heb de mijne gekoppeld aan een HC-06 Bluetooth module om de data op afstand te kunnen lezen.

Volledige specifikatie:
https://www.netbeheernederland.nl/_upload/Files/Slimme_meter...fce1f1.pdf

[Bericht gewijzigd door deKees op 19 augustus 2019 21:31:06 (10%)]

Ik gebruik "snelle" optocouplers als de HCPL0600. Die heeft een 5V nodig aan de ontvangende kant. Die heeft dus een soort van digitalisatie stap aan de uitgang.

Ik had de indruk dat die 5V "RTS" dus gebruikt werd om die optocoupler te voeden.

Anderzijds, het officiele verhaal zal wel zijn zoals jij het tekent.

Dat er geen "een beetje 5V" beschikbaar is, blijkt voor veel projecten een beetje tricky. Vandaar dat een nieuwe versie van de standaard ook 5V aanbied op de P1 connector.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
Sine

Moderator

De P1 is al galvanisch gescheiden, dus nog een opto mag .. maar is een beetje dubbelop.

Angaben sind wie immer ohne Gewähr.

De P1 poort geeft een buffer met asci karakters uit op 115200 (nieuwe versie) of 9600 baud (oorspronkelijke standaard).
Zou een wereldstandaard worden maar binnen de kortste keren werd 9600 opgewaardeerd naar 115200.
Op het moment dat DataRequest hoog wordt gemaakt begint de meter zijn databuffer te zenden en doet dat voortdurend met tussen de buffers in een seconde stilte. Uitzending stopt als je DR weer laag maakt.
Buffer kan er uit zien zoals hieronder (mijn slimme meter). 15200 Baud 8 bit no parity

1-3:0.2.8(42)
0-0:1.0.0(171123162121W)
0-0:96.1.1(4530303236303030303130373532353134)
1-0:1.8.1(002816.198*kWh)
1-0:1.8.2(003759.680*kWh)
1-0:2.8.1(000005.564*kWh)
1-0:2.8.2(000007.806*kWh)
0-0:96.14.0(0002)
1-0:1.7.0(00.476*kW)
1-0:2.7.0(00.000*kW)
0-0:96.7.21(00010)
0-0:96.7.9(00004)
1-0:99.97.0(1)(0-0:96.7.19)(000101000022W)(2147483647*s)
1-0:32.32.0(00000)
1-0:52.32.0(00000)
1-0:72.32.0(00000)
1-0:32.36.0(00000)
1-0:52.36.0(00000)
1-0:72.36.0(00000)
0-0:96.13.1()
0-0:96.13.0()
1-0:31.7.0(000*A)
1-0:51.7.0(000*A)
1-0:71.7.0(002*A)
1-0:21.7.0(00.000*kW)
1-0:22.7.0(00.000*kW)
1-0:41.7.0(00.001*kW)
1-0:42.7.0(00.000*kW)
1-0:61.7.0(00.470*kW)
1-0:62.7.0(00.000*kW)
0-1:24.1.0(003)
0-1:96.1.0(4730303332353631323631383932313136)
0-1:24.2.1(171123160000W)(02458.473*m3)
!4251

Vonkenpromotor

Golden Member

Heb voor met een Arduino al jaren een programmaatje lopen op een Mega.
In de bijlage een onderdeel hieruit voor het decoderen van het "Telegram" uit mijn Kaifa slimme meter.

Als je het heel netjes wilt doen zou je ook nog de sumcheck moeten controleren. Dat zijn de 4 karakters die nog op het uitroepteken volgen.
Ik doe dat ook niet maar er gaat een enkele keer wat mis. Hoogst waarschijnlijk door timing perikelen in mijn processortje die de 115200 baud soms niet kan bijbenen.
Aan de datastroom die jij hebt vertoond denk ik dat je of op de verkeerde baudrate zit of idd inverse data laat zien.
Ik ga er nu maar even van uit dat je inderdaad de nieuwere versie (4.0?) van het protocol gebruikt.

Vonkenpromotor

Golden Member

Volgens mij is het signaal inverted.

Op 21 augustus 2019 09:59:23 schreef Leo-Bolier:
Als je het heel netjes wilt doen zou je ook nog de sumcheck moeten controleren. Dat zijn de 4 karakters die nog op het uitroepteken volgen.
Ik doe dat ook niet maar er gaat een enkele keer wat mis. Hoogst waarschijnlijk door timing perikelen in mijn processortje die de 115200 baud soms niet kan bijbenen.
Aan de datastroom die jij hebt vertoond denk ik dat je of op de verkeerde baudrate zit of idd inverse data laat zien.
Ik ga er nu maar even van uit dat je inderdaad de nieuwere versie (4.0?) van het protocol gebruikt.

Volgens de Domoticx site http://domoticx.com/p1-poort-slimme-meter-hardware/ zou de meter van TS ESMR 5.0 zijn.

Op 21 augustus 2019 10:11:12 schreef Vonkenpromotor:
Volgens mij is het signaal inverted.

Ja. rs 232 signalen zijn ALTIJD inverted..

u=ir betekent niet :U bent ingenieur..