probleem softclose hekopener

Beste forumleden,

ik ben bezig met het automatiseren van dubbel hek. De poort bestaan dus uit 2 delen welke door 2 lineaire motoren geopend worden.

De eerste automatisering die ik had, had geen softclose/softopen mechanisme waardoor de poortdelen redelijk had tegen elkaar kwamen (bij sluiten) en redelijk hard tegen de eindstop (bij openen). Daarom heb ik de firma gecontacteerd en zij vertelde dat ze een 'beter' model hadden met dus de optie softclose/soft open waardoor de poort op het einde trager, en dus rustiger, sluiten.

Echter zit ik nu met het volgende probleem: bij opening gaat het 1ste deel van de poort voor 80% open en schakelt vervolgens over naar zijn softopen (het 2de deel komt later en zit bv op 70% open). Van het moment dat het 1ste deel tegen de eindstop komt blokkeer je eigenlijk de motor (hij vraagt dus meer stroom dan gewoon tijdens openen). Het probleem komt nu: het 2de poort gedeelte stopt nu met draaien voor 1 seconde. Het 1ste poortdeel is nu volledig open en staat mooi vast tegen de stop en vervolgens zal het 2de deel ook volledig openen.

Hij lijkt er dus op dat door poortdeel 1 zich tegen de eindstop 'trekt' deze de spanning doet inzakken waardoor poortdeel 2 even niet genoeg/zonder spanning komt te zitten.

Nu was ik zelf voor een oplossing aan het denken: ik zet dicht bij de motor een grote elco. Gelukkig kwam ik er optijd achter dat de sturing de + & - omkeert om de motor in de andere richting te doen bewegen. Dit zal de elco dus niet graag hebben...

Foto's/werking van de PCB kan je hier vinden: https://www.superjackpro.nl/wp-content/uploads/2019/05/Handl...k-Plus.pdf

Ziet iemand een mogelijkheid om dit probleem te kunnen oplossen?...

Alvast bedankt

als de motor gewoon vermogen blijft duwen omdat de poort tegen een eindstop loopt, dan vraag ik me af of er wel een einde is ingesteld? ofwel met een eindschakelaar ofwel met een instelling op de motor.

waar rook was, werkt nu iets niet meer

Is de voeding niet te licht? (motor trekt behoorlijk wat stroom bij blokkeren, schiet voeding misschien in beveiliging?)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

het einde is inderdaad ingesteld. De tijd dat de motor op vol vermogen tegen de eindstop aandruk is ook maar 1 seconde. Maar da is wel een seconde dat het 2de hek (dat nog niet dicht is) stopt met draaien waarna het verder open gaat. (tot aan de eindstop)

Ik had de sturing eerst in de kelder staan en vermoede dat de kabellengte te lang was. Daarom heb ik de sturing al bij de poort gezet. Ik vermoed ook dat de voeding te licht is. Maar wat kan ik hier aan veranderen? Andere transfo? en de rest dat er achter zit?...

Heb je de firma al gecontacteerd over dit probleem?

Dat kump er noe van....

als de poort tegen de eindstop aandrukt is het einde dus te ruim ingesteld. die stop zou niet strak tegen de poort moeten drukken, motor, laswerk en scharnieren gaan daar van lijden.

waar rook was, werkt nu iets niet meer

Een eindschakelaar op het hek zelf? En dan natuurlijk op beide hekken..
Maar het idd een moeilijk probleem..Zoiets hebben we ook eens gehad met sluisdeuren, duurde 3 maanden eer het goed werkte..

u=ir betekent niet :U bent ingenieur..

Het probleem is dat de poort zichzelf aanleert bij het 1ste maal programmeren. De poort moet ook tegen gedrukt worden omdat anders de wind de poort zou doen bewegen.
De firma beweert dat dit normaal is. Maar volgens mij komt het door een deel onder gedimensioneerde onderdelen op de print.

Iemand nog een idée voor een oplossing?

GJ_

Moderator

Wat is het probleem eigenlijk?

Op 12 september 2019 11:43:39 schreef GJ_:
Wat is het probleem eigenlijk?

Als poortdeel 1 opent en tegen de aanslag komt. Stopt poort 2 voor een seconde en gaat erna verder. Soms gebeurt het ook dat tijdens deze seconde de poort in beveiliging gaat. En poortdeel 2 dus niet volledig opent.

Die soft stop is door een lagere stroom/spanning door de motor te sturen. Hierdoor krijg je dat.
Is idd door bezuinigen op onderdelen, sturing voor beide motoren 1x uitgevoerd. Als motor 1 stopt/blokkeert trekt die de voeding plat waardoor motor 2 ook (even) stopt.
Is niet de voeding die te licht is, wel omdat de soft-stop ingrijpt en de stroom begrenst.
Weinig tegen te beginnen dan een compleet dubbel uitgevoerde sturing te bouwen (of 2x soft-stop, 1 voor elke motor apart)

Daar vreesde ik al voor. Zou de softstop Werken door de 2 witte vermogenweerstanden (zie print handleiding) in serie te zetten met de motor?

Heb je al eens 'gespeeld' met de dipswitches 4...8?

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Op 12 september 2019 12:46:59 schreef Arco:
Heb je al eens 'gespeeld' met de dipswitches 4...8?

Yep. Van max strôom tot minimale strôom. Geen verschil. Of toch zeer weinig.

Je kan de kracht instellen met dipswitches 4 tot 8. 4 aan is het 'zwakste' alles uit het sterkste. Probeer die eens wat slapper te zetten.

Wat je ook kan doen is het bij inleren een plankje tussen de aanslag te houden. Het hek leert dan iets eerder in dan in de uiteindelijke situatie.

Op 12 september 2019 14:29:41 schreef K7Jz:
Je kan de kracht instellen met dipswitches 4 tot 8. 4 aan is het 'zwakste' alles uit het sterkste. Probeer die eens wat slapper te zetten.

Wat je ook kan doen is het bij inleren een plankje tussen de aanslag te houden. Het hek leert dan iets eerder in dan in de uiteindelijke situatie.

Alle krachtinstellingen reeds gedaan. Lost het probleem niet op.

Iets tussen steken bij openen zou kunnen. Maar dat lost het probleem met sluiten niet op...

maar wat maakt het eigenlijk uit dat het 2e deel even hikt als het 1e deel tegen de eindstop loopt? dat 2e deel loopt erna toch verder weer?

waar rook was, werkt nu iets niet meer

Probleem is dat soms bij het 'hikken' van de ene motor het systeem in fout melding gaat. En de flikkerlamp afgaat

Stroombegrenzer tussen beide motoren...

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

ik heb eens wat metingen gedaan op de print. Er zijn 2 relais bij iedere poort om de draairichting te wijzigen. Deze gaan vervolgens naar een ULN2803 en vervolgens naar een microcontroller die alles aanstuurt. Na meten blijkt dat van het moment dat de ene poort zijn aanslag bereikt, de andere poort zijn relais uitschakelt (en na 1 seconde dus terug aan). De spoelspanning valt op deze relais weg(voor 1 seconde). Ook bij de ULN valt deze weg en ook de uitgang van de microcontroller valt weg. De voedingsspanning van de microcontroller blijft wel stabiel.

De plus van de motoren wordt rechtstreeks geschakeld. Tussen de - van de motoren staat een mosfet in serie met hierin een grote vermogensweerstand. Bij gewone sluiting krijgt deze mosfet 12volt, bij softclose een 8volt.

2 vragen: Waarom staan de vermogenweerstden in serie met de motor? (zowel in gewoon openen als met soft)?
2devraag: Iemand die hier iets mee is om mijn probleem op te lossen?

mvg

een fet met vermogensweerstand, dat zal een toerenregeling zijn met een stroomshunt, te veel motorstroom en de besturing kapt af.

waar rook was, werkt nu iets niet meer

Je hebt de hekken wel 'ingeleerd' zoals in de beschrijving? (anders begrijpt de microcontroller 't ook allemaal niet meer)
Je kunt eens proberen of het met een lamp in serie beter gaat. (bijv een autokoplamp met beide gloeidraden parallel, heb je 110W.)
(heel lage weerstand, behalve bij een vastloper van de motor)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Op 12 september 2019 16:00:57 schreef Jeffreyy:
[...]

Alle krachtinstellingen reeds gedaan. Lost het probleem niet op.

Iets tussen steken bij openen zou kunnen. Maar dat lost het probleem met sluiten niet op...

Welk probleem met sluiten?

Ik zie het zo:

De microcontroleer leert in de leer fase hoelang het ongeveer duurt voordat het hek open is. Krijg hij eerder weerstand dan ziet hij het als een blokkering en dan krijg je storing. Als je nu met inleren iets ertussen houdt (baksteen / plankje, even proberen) dan zal hij mogelijk iets minder hard tegen de eindstop gaan duwen als dat plankje weg is.

Met sluiten kan je hetzelfde truukje natuurlijk doen.

Op 12 september 2019 11:08:46 schreef Jeffreyy:
De firma beweert dat dit normaal is.

Als ze hun product een beetje kennen zal dat oordeel wel kloppen, ik vind het eigenlijk ook niet gek klinken.

Maargoed. Je zou kunnen nameten of de voedingsspanning inderdaad inzakt, op moment dat het ene deel van het hek de eindstop raakt en het andere deel nog verder moet bewegen. En zo ja, hoe ver dan wel? En of dat het stoppen van het andere deel veroorzaakt. Het zou ook zomaar eens zo ontworpen kunnen zijn, dat als gedetecteerd wordt dat de ene motor aan het "aanduwen" is, de andere even stopt. Als ze allebei gaan "aanduwen" terwijl je er tussen zit is niet prettig. Maar ik weet niet of dat de reden is, of gewoon een lichte voeding en niet 2 tegelijk laten "aanduwen" op die voeding. Maar als de voeding niet (fiks) inzakt, is het waarschijnlijk gewoon volgens ontwerp en normaal.

Desondanks zou je natuurlijk een hek kunnen willen dat in 1x door dichtgaat, ook als de andere helft vaststaat.

Dat wordt dan dus ofwel de huidige firma vragen of ze dat ook kunnnen, of een andere firma zoeken, of zelf knutselen. En dan goed nadenken "wat als ik er tussen zit", want dan moet ' ie wel stoppen met "aanduwen".

Blog // Backwards Lightspeed Bus: i*i=-1, so iic=-c.