Eagle zoom all is de kluts kwijt?


fatbeard

Honourable Member

Nope, geen hidden layers (was het eerste wat ik checkte).
En ook geen achtergebleven objecten, daar heb ik ULPs voor...

Er zal een bitje zijn omgevallen ergens, maar in de .eagle.rc en de design.epf heb ik het nog niet kunnen ontdekken...
Het design is proprietary, en kan ik dus niet posten.

De opbouw van de nieuwe borders en frames library verloopt redelijk voorspoedig, nog geen gekkigheid gezien.

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.

Gaat het ook fout als je een ander al ouder ontwerp met oudere library dat altijd goed geweest is.

Misschien is het onzichtbare bitje bij de laatste aanpassingen omgevallen? Dan kun je beginnen met de oudere library waar je alleen de nieuwste wijzingen opnieuw doet. Spaart een hoop tijd.

[Bericht gewijzigd door Ex-fietser op 18 september 2019 15:10:24 (48%)]

fatbeard

Honourable Member

Maandag werkte het nog gewoon, vandaag niet meer. Geen wijzigingen geweest in libraries of design.
Trouwens, Eagle slaat kopieën van de gebruikte componenten op ín het schema, zodat wijzigingen in de libraries het schema niet overhoop halen (zoals de oudere versies van OrCad dat deden).
Vervangingslibrary is trouwens bijna klaar...

Mogelijk is het een issue met de GUI, ik meen me te herinneren dat Eagle QT gebruikt.

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.

Zou het een component kunnen zijn dat iets 'onzichtbaars' heeft? Ik zou een kopietje maken en componenten (stuk voor stuk) weghalen. Daarmee moet een eventuel boosdoener snel te vinden zijn.

buckfast_beekeeper

Golden Member

Als het frame de schuldige is moet het dit ook doen zonder componenten. Als dat zo is kan je dat zo plaatsen. Aan een frame is niks geheim te houden.

Een versie 5 frames librarie toegevoegd.

Honing kan je importeren, bestuiving niet.

Op 18 september 2019 11:34:17 schreef fatbeard:
Maar daar stáát helemaal nix...

Niet waar. D'r staat WEL wat, maar in een layer die je uit hebt staan.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
fatbeard

Honourable Member

Checked, and double checked: d'r staat nix, zelfs niet op een niet gedefiniëerde layer.

Zal -omwille van de vingeroefeningen- een ulp maken die botweg alles uithoest wat er in dat schema staat, en die ook posten.

Stand by.

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.
EricP

mét CE

Ben ik nou de enige die onder de -6150 een verticale lijn in het plaatje ziet staat? Wat is dat en wat doet het daar?

Een ULP die alles in het schema uitspuugt, gaat je probleem niet oplossen. Als je een component op (0, 0) hebt staat en ergens in de component definitie staat 1 stipje op (-1000, -1000), dan zal je ULP - naar mijn verwachting - een component op (0, 0) uitspugen waarbij iedereen denkt 'dat kan het probleem niet zijn'.

Je zegt dat wanneer je het frame wegmikt, het spul zich weer normaal lijkt te gedragen. Dat impliceert dat het probleem in het frame zit (right?).

2 testjes: maak een nieuw schema, zet er alleen dat frame op en kijk of de 'zoom all' het goed doet (ik verwacht van wel).
2de testje (indien eerste succesvol): mik het frame weg. Doe een save. Stop eagle. Start eagle. Zet het frame weer neer.
Testjes zijn gebaseerd op het feit dat het frame feitelijk een component is, component definities in het schema worden opgeslagen en dat daar ergens wat 'stuk' is. Ik kan me zo voorstellen als je dat frame alleen wegmikt en gelijk weer terug zet, eagle denkt 'hey, die heb ik nog' en de 'oude' definitie gebruikt - en de ellende ook meteen weer introduceert.
Alternatief zou zijn om in de library van het frame dit frame te wijzigen, 'update in schematic' te doen, undo in de lib, weer een update in schematic. Daarmee forceer je ook een nieuwe definitie vanaf de lib.

Op 19 september 2019 09:43:47 schreef EricP:
Ben ik nou de enige die onder de -6150 een verticale lijn in het plaatje ziet staat? Wat is dat en wat doet het daar?

Het zou kunnen dat dit een "hier-is-je-muis" indicatie is. In veel ontwerppaketten kan je dat aanzetten. Ik kan dat feature niet (meer?) vinden in mijn versie van eagle.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
EricP

mét CE

Daar zat ik ook aan te denken, rew. Maar dan zou je verwachten (ik in elk geval...) dat er ook een horizontale lijn zou zijn...

fatbeard

Honourable Member

Op 19 september 2019 09:43:47 schreef EricP:
Ben ik nou de enige die onder de -6150 een verticale lijn in het plaatje ziet staat? Wat is dat en wat doet het daar?

Dat is een overblijfsel van de cursor. Ik heb altijd een grote cursor, dat maakt uitlijnen over een heel schema een stuk makkelijker.

Een ULP die alles in het schema uitspuugt, gaat je probleem niet oplossen. Als je een component op (0, 0) hebt staat en ergens in de component definitie staat 1 stipje op (-1000, -1000), dan zal je ULP - naar mijn verwachting - een component op (0, 0) uitspugen waarbij iedereen denkt 'dat kan het probleem niet zijn'.

Als ik zeg alles bedoel ik ook alles. Dus ook de onderdelen van de onderdelen, en de onderdelen dáárvan.
Gewoon een kwestie van het recursief volgen van alle loop members...

Die testjes die jij voorstelt had ik voor een deel al uitgevoerd, ik zal de overige voorstellen ook doen. Gelukkig zijn bijna alle attributen global...

EDIT
Gek genoeg is het gewraakte frame in z'n uppie geen reden voor Eagle om de zoom all te verprutsen...
Ook een aangepast frame herladen na een verse start heeft geen effect...

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.
EricP

mét CE

Het is dus het frame in combinatie met 'iets'. Tsja, prettige wedstrijd inderdaad. Ik ben benieuwd of je 'recursieve ULP' wat op gaat leveren.
Hoe zit dat met fonts? Waar is de basis daarvan gedefinieerd? (ofwel: als het een letter is waar iets 'stuk' is, dan 'staat' er wellicht ook opeens ergens 'iets'. Dat hangt aan je frame, maar is het niet helemaal zeg maar.

In je frame worden een aantal attributes gebruikt neem ik aan. Staat daar ergens wat 'raars' in waardoor het frame de boel lijkt te verzieken, maar het een combinatie-van is? (waarbij 'raar' dan ook weer een rekbaar begrip is... ik bedoel dus meer iets wat Linux mogelijk wel snapt en de parser van Eagle niet, waardoor er een 'random' stukje data als 'character' gebruikt wordt.)

Ander idee: verschuif de hele zooi eens een stukje. Zodat je nulpunt ergens anders komt te liggen.

fatbeard

Honourable Member

Goed idee: als ik alles verschuif naar de uiterste linkerrand krijg ik een min-of-meer correcte zoom.
Als ik daarentegen alles naar de uiterste rechterrand verschuif is de 'foute' zoom weer terug, maar wel in dezelfde factor (het is niet opeens veel kleiner).
Dat geeft dus een indicatie dat "frame+iets anders" wel "iets" oplevert wat op <minimumXcoordinate> t.o.v. het frame nulpunt ligt...
Mijn ulp-in-aanbouw geeft ook o.a. de volgende output:

code:

Schematic BLE-jig.sch has 1 sheet(s).
  grid 50mil (lines,on) at interval 2
  cross reference string "%F%N (%S-%C%R)"

Global attribute ART_DATE with value "20190823"
Global attribute ART_NAME with value "L. Potjewijd"
<snipped attributes>

Net class 0(default), clearance 0mm, drill size 0mm, trace width 0mm

Layer 91(Nets), used, visible, color 2, fillstyle Solid
Layer 92(Busses), unused, visible, color 1, fillstyle Solid
Layer 93(Pins), used, invisible, color 2, fillstyle Solid
Layer 94(Symbols), used, visible, color 4, fillstyle Solid
<snipped layers>

Library Borders&frames
Library C
Library LED
Library R
Library common
Library comparator
Library conn
Library diode
Library regulators

Net !RESET, class default
Net +5V, class default
Net GND, class default
Net N$1, class default
Net N$2, class default
Net N$3, class default
Net N$9, class default
Net N$12, class default
Net SWCLK, class default
Net SWDIO, class default
Net UART-TX, class default
Net VTARGET, class default

Sheet 1, 842.982 by 191.334mm

en dat is voor een A4-tje in landscape oriëntatie best wel breed.
We zoeken en programmeren verder.

edit: lijst getrimd.

[Bericht gewijzigd door fatbeard op 19 september 2019 16:44:33 (48%)]

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.
EricP

mét CE

Het is dus niet puur de zoom die de mist in gaat. Om de een of andere reden denkt eagle echt dat er wat staat...

Je zou nog eens in een leeg schema een kader neer kunnen zetten en dat eens een eind weg schuiven. Het lijkt erop (als ik je verhaal goed interpreteer) dat zowel 'kader weg' als 'boel naar nulpunt schuiven' je probleem oplossen.

Heb je geprobeerd om alles naast je frame te selecteren met de "group" knop en daarna de selectie weg te gooien.
Ik heb net geprobeerd om tekst toe te voegen en slechts een spatie in te typen, maar dan krijg ik toch en kruisje te zien. Ik kan me zo niets voorstellen wat helemaal onzichtbaar is maar als er zoiets bestaat dan moet je dat als group kunnen verwijderen.

fatbeard

Honourable Member

Normaal gesproken staat in al mijn designs de linker onderhoek van het kader op absolute coordinaat (0 0).
Als ik de hele boel verschuif tot tegen de linkerrand van het ontwerpveld (-33 inch) werkt de 'zoom all' zoals verwacht. Alleen zijn de coordinaten dan wat, euh, curieus voor anderen...

@hennep: toen ik zag dat de schaal niet veranderde toen alles aan de rechterrand van het ontwerpveld stond heb ik alle lagen aangezet en een group proberen te selecteren van het ontwerp tot de linkerrand: er werd niets geselecteerd (te zien aan het feit dat het group-commando niet wordt beëindigd).

The plot thickens: op mijn Windows machine treed het verschijnsel niet op. Zelfs de (gedownloade, dus identieke) ulp geeft nu een normale maat weer voor het A4tje (280.294x191.334mm)...

De designfile heb ik gedownload van het werk en is dus identiek, en ik draai dezelfde versie Eagle (5.12).
Zoals een oude vriend van mij placht te zeggen: "schiet mij maar in het rubber"...

Voorlopige conclusie is dat het aan de combinatie Linux-Eagle-frame-nogietsanders ligt. Ik bouw nog wel even door aan die ulp, die heeft vast nog wel andere toepassingen.

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.
EricP

mét CE

Rechts onder in je frame staat het nodige aan text. Ik heb hoe langer hoe meer het idee dat dat er iets mee te maken heeft.

Ter experiment: gooi in de lib al die texten (die van attributes af komen) eens weg, save, update je frame-in-schema en kijk eens of het beter wordt. Ik kan me zo voorstellen dat er iets met een filename / unicode / font de mist in gaat.

Ik ben zelf een tijd geleden met een commandline tool van mezelf aan het stoeien geweest. Het fijne kan ik me er niet meer van herinneren, maar iets met 'unicode / extended ASCII' was veranderd in Ubuntu waardoor er opeens de meest uiteenlopende 'rommel' te zien was.

Ik kan het probleem reproduceren door gewoon iets te tekenen in een laag die ik daarna gewoon uitzet.

Click op "layers" en dan op "all". Ga door de lijst-met-layers heen om te kijken of er niet 1 is die "slecht zichtbaar" is, zodat je hem mogelijk over het hoofd ziet, zelfs als ie aanstaat.

Haal dingen die je wel kan zien "een voor een" weg totdat het probleem weg gaat. Je kan een binaire zoek strategie volgen. Eerst de helft weghalen, kijken of het effect verdwijnt, dan met undo terughalen en verder gaan met de helft waar je weet dat het probleem moet zitten.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
fatbeard

Honourable Member

_/-\o_ DANK voor alle suggesties en methodieken _/-\o_

Je raadt het al: ik ben er uit, ik heb de schuldige gevonden.
Het is een uiterst vreemde combinatie van tekst, grootte en font.

De titel van de tekening (attribute TITLE, "ATE-BLE needle adapter") staat in font 'proportional' met grootte 200, de ratio stond op 15% (overblijfsel van eerdere versies).

  • als ik het attribute TITLE leeg maak is het probleem weg, net als de titel
  • als ik de fontgrootte op 150 zet is het probleem weg (198 werkte niet, niet verder gezocht naar het kantelpunt)
  • als ik het font op 'vector' zet is het probleem weg, maar is de tekst te lang voor het vakje
  • als ik de eerste letter (hoofdletter 'A') vervang door iets anders is het probleem weg
  • als ik iets vóór die A zet is het probleem weg

Conclusie:
Een attribuut in proportional font met een grootte van meer dan 150 (kan ook meer zijn, niet onderzocht) met een waarde die met "AT" begint zorgt voor een foute zoom factor. 8)7
Toevallig (?) is AT de unieke identificatie van het keyword ATTRIBUTE, maar andere lettercombinaties lijken het probleem niet te veroorzaken (ben bij BU opgehouden).

Dit is iets wat die ulp waarschijnlijk niet onthuld zou hebben (wat me er overigens niet van weerhoudt om hem tòch te maken), dus EricP had het (om de verkeerde reden) bij het rechte eind toen hij stelde

Een ULP die alles in het schema uitspuugt, gaat je probleem niet oplossen. Als je een component op (0, 0) hebt staat en ergens in de component definitie staat 1 stipje op (-1000, -1000), dan zal je ULP - naar mijn verwachting - een component op (0, 0) uitspugen waarbij iedereen denkt 'dat kan het probleem niet zijn'.

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.
EricP

mét CE

Fijn dat het werkt. Ook om de verkeerde reden zat ik er blijkbaar ook niet zover naast dat er ergens met een font wat de mist in gaat. Jammer dat niet achterhaald is wat (snap ik ook hoor... het is een tool, geen doel op zich).

Succes verder!

fatbeard

Honourable Member

Oops...
Het is klaarblijkelijk niet zó simpel, het verschijnsel was net weer terug en geen van de truuks werkte... Te vroeg gejuicht?

Opnieuw opstarten van Eagle bracht de boel gelukkig wel weer terug, wat me het kantelpunt in de grootte liet bepalen: 182. Groter = feest.

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.

Ik heb eenzelfde probleem bij het maken van een afbeelding voor het maken van een print. Als ik een potmeter plaats in een ontwerp dan wordt de ruimte daarvoor overgenomen door de cam2image.ulp
Zie afbeeldingen:

wat we eigenlijk nodig hebben is een layer die wel wordt getoond maar niet in de berekeningen voor grootte wordt meegenomen. Dan zou jij de tekst in die layer kunnen schrijven. De as van de potmeter in mijn design is leuk om te zien, maar heeft niets met de grootte van de print te maken. Als er zo'n layer zou zijn dan kun je de libraries aanpassen zodat voor de pcb niet relevante info in die layer wordt getekend.
Ik ben al even met een aantal layers bezig geweest maar alles wat ik tot nu toe probeerde beinvloedt de grootte van de pcb

fatbeard

Honourable Member

Je kunt inzoomen tot datgene wat je wilt zien en dan bij de export opgeven dat je niet alles wilt hebben.

Beetje een klutz, maar toch.
Als je echt alleen de PCB wilt hebben moet je Gerbers maken...

[edit]
Ik zie nu dat je het met een ulp doet, wellicht kun je die aanpassen?

[Bericht gewijzigd door fatbeard op 20 september 2019 12:32:26 (17%)]

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.

Tja, er staat een kader in de dimension (layer 20) in het ontwerp. Daarmee zou eigenlijk de export en ook de zoomfunctie moeten werken. Meer hoef je toch niet te zien.
Ik zal eens kijken of ik de ulp kan aanpassen zodat het dimension kader maatgevend is.

[Bericht gewijzigd door hennep op 20 september 2019 12:43:35 (21%)]

fatbeard

Honourable Member

Beter nog: maak het selecteerbaar.
Misschien wil je in sommige gevallen wèl alles zien...

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.