Mosfet met TC427 probleem

Ik heb het volgende schema gebruikt, maar de mosfet blijft alleen maar geleiden, ik stuur de TC427 aan met een ATMEGA328P.
Ik stuur op de ingang een puls:

digitalWrite(FAN, HIGH);
delay(1000);
digitalWrite(FAN, LOW);
delay(1000);

Op de uitgang van de TC427 gaat het goed, er komt een nette puls uit van 12 Volt, R1 is een autolampje, wat is er mis met de mosfet ?

https://static.circuitsonline.net/camo/5f73daa0db52c3d4842c26062869eb3a35db9f97/687474703a2f2f70726f736a652e62652f50726f6a656374732f4472697665725374757572547261702e706e67

Het signaal gaat toch netjes aan/uit op het scoopbeeld? (blauwe lijn)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Nee, dit plaatje is wat ik na gebouwd heb, het scoop plaatje is niet van mij...

Sine

Moderator

Als de uitgang van je driver goed is dan is je fet frut, of verkeerd om aangesloten (S/D verwisseld)

Angaben sind wie immer ohne Gewähr.

Source en drain zijn niet verwisseld, ik heb het diverse keren nagekeken.

In de datasheet staat dat VGS(TH) max 4 volt mag zijn, klopt dit schema dan wel ?

Vgs max = +/- 20V, dus er is niks aan de hand.

Vgs(th) is de treshold waarde, dat is de gate-spanning waarbij de FET volledig open staat, dus in verzadiging. Deze waarde ligt tussen de 2.1 en 4 volt.

Zolang het probleem niet duidelijk is, is het zinloos om naar een oplossing te zoeken.

Op 21 oktober 2019 16:57:15 schreef Hunter: Vgs(th) is de treshold waarde, dat is de gate-spanning waarbij de FET volledig open staat, dus in verzadiging. Deze waarde ligt tussen de 2.1 en 4 volt.

Nee, dat is de spanning waarbij de MOSFET een heel klein beetje in geleiding gaat; vaak wordt die spanning gespecificeerd met een drain stroom van 1mA.

Om de MOSFET echt volledig open te sturen, moet je sowieso voorbij het Miller plateau zijn, en dan eigenlijk nog een stukje verder, want in het gebied boven het Miller plateau neemt de Rds(on) nog wat verder af.

Maar dat maakt voor de TS niet uit, als hij de driver voedt met 10.5V, is hij daar al ruimschoots voorbij.

MOSFET verkeerd om of gewoon stuk zijn de meest voor de hand liggende mogelijkheden.

Als je met de voeding uit en de lamp uit het circuit met een multimeter in diode stand van de source naar de drain meet, en dan nog een keer met de meetpennen andersom, wat meet je dan?

Met de rode pen op de drain en de zwarte op de source zou je meter OL moeten aangeven, en met de rode pen op de source en de zwarte op de drain ergens in de buurt van 0.3-0.5V.

[Bericht gewijzigd door SparkyGSX op 21 oktober 2019 17:05:57 (24%)]

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Haal de gate los en hang die direct aan de min en je weet of je mosfet nog heel is.

Al is een spreekwoord nog zo raar, als het rijmt dan is 't waar

GND M328 verbonden met min TC427? Een extra afvlak Ctje (10uF) aan Vcc TC427 en een diode over lampje.

RES

Ik denk ook dat D-S zijn omgewisseld (of de fet is gewoon kapot)
Of hij zit ongeisoleerd op een geaard koelblok?

[Bericht gewijzigd door Arco op 21 oktober 2019 17:13:48 (28%)]

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Je kunt het volgende testen:

Verbindt met de ingang van de TC4427 een weerstand van 10....100k ohm, naar de massa of GND en haal de Arduino los van de TC4427.
Je mosfet moet dan niet geleiden, de lamp blijft uit.
Vervogens zet je spanning op de TC4427 ingang en nu moet de mosfet volledig in geleiding gaan.

"tijd is relatief"

Als je met de voeding uit en de lamp uit het circuit met een multimeter in diode stand van de source naar de drain meet, en dan nog een keer met de meetpennen andersom, wat meet je dan?

Ik meet dan 600 en andersom niets.

Met de rode pen op de drain en de zwarte op de source zou je meter OL moeten aangeven, en met de rode pen op de source en de zwarte op de drain ergens in de buurt van 0.3-0.5V.

Daar meet ik niets.

GND M328 verbonden met min TC427? Een extra afvlak Ctje (10uF) aan Vcc TC427 en een diode over lampje.

Dat is allemaal gebeurd.

Of hij zit ongeisoleerd op een geaard koelblok?

Is niet geaard op koelblok.

@SparkyGSX Sorry, ik had wat dingen door elkaar gehaald.

Zolang het probleem niet duidelijk is, is het zinloos om naar een oplossing te zoeken.
Lambiek

Special Member

@TS,

Heb je dit aangehouden?

Als je haar maar goed zit, GROETEN LAMBIEK.

Als ik tegen de voorkant kijk van jouw plaatje, dan wel...

Ondertussen mijn laatste BUZ11 erin gesoldeerd, maar weer geen resultaat...

Een 12 volt ventilator erop aangesloten, deze gaat aan, maar niet uit.

Als je de gate loshaalt van de TC427 en deze verbindt met de massa moet de ventilator uit gaan.

"tijd is relatief"
Sine

Moderator

En anders kan een foto van het geheel wel eens helpen.

Angaben sind wie immer ohne Gewähr.
Henry S.

Moderator

Op 21 oktober 2019 18:24:57 schreef ireric:
Als je met de voeding uit en de lamp uit het circuit met een multimeter in diode stand van de source naar de drain meet, en dan nog een keer met de meetpennen andersom, wat meet je dan?

Ik meet dan 600 en andersom niets.

Met de rode pen op de drain en de zwarte op de source zou je meter OL moeten aangeven, en met de rode pen op de source en de zwarte op de drain ergens in de buurt van 0.3-0.5V.

Daar meet ik niets.

Dat is een tegenstrijdig antwoord. Eerst geef je aan dat je 0.6V meet, en vervolgens weer niet...

73's de PA2HS - ik ben een radiohead, De 2019 CO labvoeding.

Op 21 oktober 2019 19:06:32 schreef ireric:
Een 12 volt ventilator erop aangesloten, deze gaat aan, maar niet uit.

Ondanks dat "niets meten" niet kan, denk ik dat je metingen aangeven: De mosfet is prima!

Over de metingen: de meter heeft een "out-of-range" indicatie. In diode of weerstandmode is dat als er niets is aangesloten. Maar als je een kortsluiting zou meten dan zou het display iets van "000" moeten aangeven en ook dat kan "niets" genoemd worden.

Als je de mosfet meet en de meter geeft "out-of-range", dan heb je niet "niets" gemeten. Wat je gemeten hebt is dat de mosfet dan niet geleidt.

Als de mosfet in orde is dan is de volgende verdachte: dat TC427 ding. Meet met de multimeter in volt-stand de uitgang van de TC427.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Op 21 oktober 2019 19:06:32 schreef ireric:
Ondertussen mijn laatste BUZ11 erin gesoldeerd, maar weer geen resultaat...

Hoe doet je ventilator het zonder BUZ11? Volgens mij heb je de BUZ11 niet nodig om je ventilator te laten draaien. Er is gewoon kortsluiting op je print tussen de Drain-aansluiting en Source-aansluiting.

Bezoek mijn neefjes' site: www.tinuselectronics.nl

Simpelste is de 427 eruit en de Gate en Source doorverbinden. Is de lamp dan wel uit?

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

1

[Bericht gewijzigd door ireric op 22 oktober 2019 01:55:14 (99%)]

Ik en de andere hebben intussen al zoveel goede tips gegeven, maar daar zien we niks van terug.

Nogmaals als je de gate los haalt en verbindt met de source dan moet de mosfet uit geleiding zijn.
Probeer dat nou maar eerst eens.

"tijd is relatief"

Zoekplaatje??

Op de print heeft de Fan gewoon vaste voeding van 12V. Die gaat dus altijd draaien. De mosfet schakelt de Pump, niet de FAN.

En ik zie op de print nergens een autolampje.

En dan is er geheel geen overeenkomst tussen het schema in de startpost en de hier getoonde printplaat.

En wij moeten ook maar raden welke pin je met je code probeert aan te sturen?

Dus wel een erg slecht zoekplaatje. De helft van de benodigde info ontbreekt, en wat we wel weten is fout.

Nogmaals als je de gate los haalt en verbindt met de source dan moet de mosfet uit geleiding zijn.

Dit heb gedaan, de fan (als test op de pump connector gedaan) ging uit,
daarna heeft de schakeling helemaal niets meer gedaan, de voeding werkte wel nog, de puls kwam nog uit de Atmega328p, en de TC427 gaf op de uitgang nog de puls door.

Nu weer de mosfet vervangen, door de 30N06, nog steeds doet hij niets meer.

Sorry voor de vaagheid, de fan connector op het board is voor de koeling van de mosfet, en op de pomp heb ik voor de test een fan aangesloten, en voordien een auto lampje.
Om alles uit te sluiten heb ik van allles geprobeerd en daardoor komt het wat rommelig over.