TouchFormer TF105B lamp (met aan/uit/dimfunctie) defect


Thevel

Golden Member

De metingen op de trafo's zijn heel normaal behalve de 0,3Ω op trafo A.
0,3Ω is veel te laag, mogelijk zijn de BUF644 transistors defect, dat zal ook verklaren waarom 0.22Ω veiligheidsweerstand defect gegaan is.
Meet de BUF644 transistors eens na op sluiting.

Trafo' s lijken me niet stuk. Spoeltje zal inderdaad als kortsluiting meten op DC. (Die 187k is eerder ongeloofwaardig. Heb je toevallig je vingers op de pennen gehouden?)

...

Ah, en nu valt bij mij ook een kwartje. Het is een halogeenlampvoeding. Dus geen gelijkrichting of afvlakking. Dus dat de secundaire korgesloten meet is ook niet gek, het is gewoon de secundaire trafowikkeling die je dan meet... :+ oeps.

Alsnog is er een 5V DC voor de PIC die er op zit. Die heeft dus wel gelijkrichting en afvlakking, meet die kortgesloten of niet?

Maar waarschijnlijk zit het probleem gewoon primair:

Op 21 december 2019 14:45:11 schreef Arco:
Lijkt een 0.22Ω/1W veiligheidsweerstand. Als die oneindig meet is 'ie kapot...
(let wel: die gaan doorgaans niet zonder reden kapot, er kan/zal wel meer kapot zijn)

Dan zijn waarschijnlijk de transistors die de primaire schakelen ook stuk, dat kun je ook met je meter op diodestand uitmeten. (BE (Basis-emitor) en CB (collector-basis) diodes moeten in 1 richting geleiden, CE moet open zijn, anders is ' ie stuk.)

Op 19 december 2019 22:37:41 schreef Arco:
Ik heb geen idee of daar een condensatorvoeding in zit, of dat de micro uit de hoofdvoeding komt...
De twee BUF644 vormen zo te zien een oscillator. Bij dit soort voedingen is het bij afslaan van de oscillator meteen einde oefening voor de transistoren.
Vreemd is dan wel dat er geen schade te zien is. (meestal ploft de boel dan nogal gewelddadig uit elkaar...)

Ik denk dat de veiligheidsweerstand ervoor gezorgt heeft dat er niet meer schade is. Die heeft zijn werk dan dus goed gedaan.

Als je die vervangt moet daar dus ook weer een flameproof type terug in. Dat heeft een veiligheidsfunctie.

(flameproof resistor / safety resistor / fusible resistor zijn wat zoektermen - ze kunnen wat lastig te vinden zijn. Reichelt noemt ze op hun nederlandstalige site "Rezystory przewodu bezpiecznikowego" wat mij toch niet zo Nederlands lijkt... Ik denk dat het Pools is te vinden onder "loodweerstanden" wat dan weer een slechte vertaling is van "leaded" waarmee "bedraad" wordt bedoeld, en niet "gelood". Waarmee je toevallig wel de poolse zoekterm weet mocht je bij TME willen kijken. Maar farnell heeft dergelijke weerstanden uiteraard ook, en via Sinuss kun je daar met enige opslag ook bestellen als particulier, of probeer het een bedrijf / je werkgever)

Als je ze niet kunt vinden, zoek dan op metaaloxideweerstand, en bekijk het datablad. Vaak zijn die ook non-flamable: voorbeeld, is deze, toevallig gelijk 1W/0.22 Ohm.

Eluke.nl // Backwards Lightspeed Bus: i*i=-1, so iic=-c.

Kan ik de 2 stuks BUF644 transistors zo op de printplaat doormeten of moeten ze er uit gesoldeerd worden?
En moet de BUX87 ook gecontroleerd worden?

What the hell i'm doing?...
Thevel

Golden Member

Waarschijnlijk zul je de transistor(s) in sluiting meten als hij nog op de print zit.
Als dat idd zo is kun je de transistor(s) van de print halen en nogmaals meten, grote kans dat de transistor(s) stuk zijn.

Ehh... waar zitten de Basis,Emitor en Collector?
Hebben alle transistors de zelfde volgorde?

What the hell i'm doing?...
Thevel

Golden Member

Pootjes naar beneden, tekst naar je toe, het is dan van links naar rechts: B-C-E

Hebben alle transistors de zelfde volgorde?

Nee, was dat maar zo. :)

Pootjes naar beneden, tekst naar je toe, het is dan van links naar rechts: B-C-E

Bij de BUF644, maar niet bij de BUX87, daar is het van rechts naar links... ;)

[Bericht gewijzigd door Arco op 26 december 2019 17:58:21 (38%)]

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Heb wat metingen gedaan op de printplaat,want er uit solderen is een crime omdat de pootjes van de componenten tijdens het productieproces zijn "gezet" zodat ze mooi blijven zitten tijdens het soldeerbad.
Erg leuk maar dan zitten ze ook hardnekkig vast,ondanks diverse de-soldeer middelen.
Ook zitten er SMD componenten heel dicht bij de soldeerpunten,dus "even loshalen om te testen" gaat hier wat moeilijk.

Alles op diode-stand gemeten.

BUF644 (1e)

BE = 004 (in display) (+/- pen verwisselen maakt geen verschil)
CB = 614 (+ op B en andersom cijfer 1 in display)
CE = 610 (+ op E en andersom cijfer 1 in display)

BUF644 (2e)

BE = 004 (+/- pen verwisselen maakt geen verschil)
CB = 590 (+ op B en andersom cijfer 1 in display)
CE = 586 (+ op E en andersom cijfer 1 in display)

BUX87

BE = 788 (+ op B en 784 bij + op E)
CB = 766 (+ op B en andersom cijfer 1 in display)
CE = 1894 (+ op E en andersom cijfer 1 in display)

What the hell i'm doing?...

Er zit een spoel overheen, dus de gemeten waardes heb je niet veel aan...

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Sorry voor de late reactie,kerstdagen en zo.
Transistors met fysieke dwang en bout erop los gekregen,het desoldeerdraad werkt niet goed op deze printplaat lijkt wel.
Tweede ronde:

Alles op diode-stand gemeten.

BUF644 (1e)

BE = 756 ((+ op B en andersom cijfer 1 in display)
CB = 709 (+ op B en andersom cijfer 1 in display)
CE = (+/- pen verwisselen geen enkele reactie)

BUF644 (2e)

BE = 758 (+ op B en andersom cijfer 1 in display)
CB = 700 (+ op B en andersom cijfer 1 in display)
CE = (+/- pen verwisselen geen enkele reactie)

BUX87

BE = 788 (+ op B en andersom cijfer 1 in display)
CB = 767 (+ op B en andersom cijfer 1 in display)
CE = (+/- pen verwisselen geen enkele reactie)

What the hell i'm doing?...

Ehh.. heb ik de metingen goed gedaan?
Zijn de transistors goed?

What the hell i'm doing?...
Thevel

Golden Member

Zo te zien zijn de transistors goed.

Thevel

Golden Member

Meet je zonder transistors nog steeds 0,3Ω bij "A"?

Dat klopt, het is nog steeds 0,3Ω bij meetpunt A.
(De multimeter zelf is wel een goedkoop hobbydingetje van de bouwmarkt)

What the hell i'm doing?...
Thevel

Golden Member

A lijkt me de primaire kant van de trafo, 0,3Ω is wel erg laag.
Mogelijk is de trafo stuk of zit er nog iets mee verbonden wat de lage weerstand verklaard.
Je zal dan de spoortjes moeten volgen en kijken wat er nog meer mee verbonden is.

Je kan ook de trafo los solderen ven de print en direct meten op de trafo al zal dat lastig zijn zonder goede de-soldeer middelen.

Na los solderen is het nog steeds 0,3Ω bij meetpunt A...

What the hell i'm doing?...

Is de trafo goed of slecht?

What the hell i'm doing?...

Die 0.3 Ohm lijkt me niet verkeerd voor 12 windingen dik draad... ;)
(ik denk dat een deel nog uit de meetsnoertjes zelf komt...)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

De draadjes bij de primaire aansluiting A zijn juist niet dik.
En de multimeter zelf krijg ik niet lager dan 0,3Ω als ik de snoertjes tegen elkaar houd.
Ik meet dus bij A 0,6Ω,trek hier de 0,3Ω afwijking multimeter van af en dan hou je 0,3Ω over lijkt mij.

What the hell i'm doing?...

Iemand nog suggesties?
Of zou de safety resistor zo maar stuk gegaan zijn?

What the hell i'm doing?...

De draadjes bij de primaire aansluiting A zijn juist niet dik.

Ik zie toch alleen maar dik draad op die kern zitten...
Zo'n veiligheidsweerstand kan wel eens spontaan kapot gaan. Had er onlangs een waar niets mee gebeurd was en niets aan te zien, en toch kapot. (fabrieksfoutje)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Wat is dik?
Gemeten 0,53 mm draaddikte bij primaire wikkeling.
Secundair is 1,25mm draaddikte.

Zou ik de onderdelen er gewoon weer in zetten en een weerstand van gelijke waarde (heb zo geen safety resistor liggen) plaatsen om te proberen?

What the hell i'm doing?...
Thevel

Golden Member

Trafo lijkt toch wel goed, transistors zijn goed en verder zijn er geen verbrande of bijzondere dingen te zien.
Zoals eerder aangegeven kun je de safety weerstand vervangen, misschien dat het dan weer werkt..

Zou ik de onderdelen er gewoon weer in zetten en een weerstand van gelijke waarde (heb zo geen safety resistor liggen) plaatsen om te proberen?

Om te proberen kun je tijdelijk een 0,25W weerstandje gebruiken, houd de draden zo lang mogelijk en als hij direct begint te roken trek je de stekker eruit.

Op 9 januari 2020 21:55:04 schreef Thevel:
Trafo lijkt toch wel goed, transistors zijn goed en verder zijn er geen verbrande of bijzondere dingen te zien.
Zoals eerder aangegeven kun je de safety weerstand vervangen, misschien dat het dan weer werkt..
[...]Om te proberen kun je tijdelijk een 0,25W weerstandje gebruiken, houd de draden zo lang mogelijk en als hij direct begint te roken trek je de stekker eruit.

Ben ik weer...sorry voor de late reactie steeds,het is gierend druk op het werk.
Heb even gekeken in mijn rommeldoos,ik heb geen weerstandje van 0,22Ω ,het laagste wat ik zo heb liggen is 1Ω.
Hier kan ik natuurlijk deze schakeling niet even snel mee testen toch? :/

Hebben safety resistors altijd lage waarden?,of zijn ze zelfs allemaal standaard 0,22Ω?

What the hell i'm doing?...
Lambiek

Special Member

Is die varistor niet gewoon stuk?

En je zit nu aan de 230VAC kant te meten en te kijken, maar voor het zelfde geld zit het aan de andere kant.

Als je haar maar goed zit, GROETEN LAMBIEK.