16f628 en 2 x tr5v

Goededag wat doe ik fout.

ik had eerste deze print gemaakt, 1 relais werkte goed
wilde ik 2 gebruiken begon hij te klapperen.

dus ik denk ik maak de print opnieuw. begint het meteen te klapperen.
als ik het test zonder de pic, werkt het allemaal.

Wel zie ik af en toe een piek op mijn voeding van de voltage???

niet afgebeeld er zit een d4148 op elk relais.

Vervolgens was bij de 2de print daarna ook mijn pic stuk.

pic 16f628
Relais tr5v mini
ipv de bc546 ook de bc337 geprobeerd.

bedankt

De 7805 staat ongetwijfeld te oscilleren
Waarom D1 en D2 bij de 7805?
Waarom geen ontkoppel c's bij de 7805?
Waarom de 10k weerstanden aan de ingangen van de controller?

Er is spanning zonder stroom maar geen stroom zonder spanning

D1 moet weg, er missen condensatoren rondom de 7805. Er missen blusdiodes over de relais. De condensator zit aan de verkerde kant van D2. Nog een vraag, staat de ontkoppel condensator dicht bij de pic?

Kijk eens in de datasheet van de 7805. Daar staat vast en zeker een voorbeeld in over de ontkoppeling die nodig is.

[Bericht gewijzigd door hardbass op 27 mei 2020 23:25:38 (23%)]

Blus diodes , daar zijn de d4148 toch voor?

De diodes ervoor had ik gedaan om kortsluiting te voorkomen maar zitten er momenteel niet op.

ct-tronic je hebt gelijk heb het schema even aangepast, zoals het is.

ontkoppel c op de 7805 zal ik naar kijken, maar dat kan toch niet het probleem zijn dat hij zo raar doet en mijn ic molt.

heb ik de transistors aan de goede kant zitten? dat ik daar de fout in ga.

zie boven heb even wat aangepast

@hardbass

ja die voor de ic, soldeer ik er altijd onder direct op de plus en de min.

De ontkoppel ic's op de 7805 zitten er niet voor de lol: zonder wordt de boel onstabiel en kan er van alles gebeuren.
Als de kabel naar de 12v vanaf de 7805 langer als 15cm is, moet er een grotere bufferelco op (47uF is dan niet genoeg), en zo dicht mogelijk bij de 7805.

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

@arco begrijp ik en zal ik zeker doen.

alleen is het lastige , zonder de ic werkt het goed, en als ik de ic er op zet, knalt die er uit, dus ik wil proberen zoveel mogelijk uit te sluiten voor ik er weer 1 naar de prullenbak blaas hihi.

ps momenteel is de kabel 3 cm zowel de plus als de min.

Kan iemand mij melden of ik het relais aan de goede kant van de transistor heb zitten, want als die verkeerd zit, is het logisch dat de boel klapt.

bedankt

[Bericht gewijzigd door spacegremlin op 27 mei 2020 23:40:05 (21%)]

Handig om het originele schema in je openingspost te vervangen, dat maakt de eerste reactie al niet meer te volgen. Je kan beter het aangepaste schema in een nieuwe post plaatsen.

De zinloosheid des levens is nog geen rechtvaardiging voor sisyphusarbeid.

Op 27 mei 2020 23:38:42 schreef spacegremlin:

alleen is het lastige , zonder de ic werkt het goed, en als ik de ic er op zet, knalt die er uit, dus ik wil proberen zoveel mogelijk uit te sluiten voor ik er weer 1 naar de prullenbak blaas hihi.

Klopt de voedingspanning op de pinnen van het IC wel? Of is die misschien omgedraaid? En heb je al in de datasheet gekeken van de 7805?

Ik neem aan dat het een onderaanzicht is van de transistor? (wel handig als ze dat erbij zouden zetten :( , maar het relais is ook onderaanzicht)
Dan klopt de pin-out niet, die is net andersom.

https://robotechshop.com/wp-content/uploads/2016/02/546_547_548.gif

[Bericht gewijzigd door Arco op 28 mei 2020 10:14:16 (19%)]

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Ik zal het erbij zetten.

Ik heb mijn transistor getekend van boven af.

Bedenk mij net alleen

Ik ging er van uit dat op het relais. Toch niet uitmaakt waar de plus en min zit op de coil?

pull-up weerstand en 100nF condensator aan de reset pin van de PIC zetten, naast alle aanpassingen die hierboven al genoemd zijn.

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Toch niet uitmaakt waar de plus en min zit op de coil?

Bij een 'normaal' relais niet, maar er zijn types waar dat wel verschil maakt.
(bistabiele, voorgemagnetiseerde, met ingebouwde diode,...)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

@arco ja thxs.

@sparky maar klopt dat dan dat doordat
Ik de gemelde aanpassingen niet heb
Dat hij meteen de uc opblaast

Bij mijn eerste print had ik dat niet
En klapperde hij alleen maar. En daar
Is dan jouw optie mogelijk voor.

Ga nog even het 1 en ander aanpassen.
Het is lastig te testen want als hij elke keer een pic er uit knalt.

Is het een optie om een optocoupler
Te gebruiken ipv een relais.
Of een optocoupler tussen de ic en relais.

Zodat ik in iedergeval mijn pic behoud.

Heb je nou de voedingspanning van de pic al gemeten? Zoals het schema eerst was, met die diode naar de gnd wordt de 5v geen 5v maar eerder 5.7v ik weet niet precies hoe gevoelig die pics zijn maar het is zeker niet goed. Zoals je relais zitten kunnen deze je pic niet slopen. Er zit een transistor tussen en een blusdiode. Ook heb je netjes een basis weerstand toegepast. Zelfs als de transistor sluiting zou maken moet de pic het overleven.

Als de pic kapot gaat is er wat grondig mis in de schakeling.
Aangenomen dat de ontkoppel c's, elco, en blusdiodes (over relais en buzzer) nu aanwezig zijn, anders is 't wel verklaarbaar.
Een optocoupler gaat dat niet oplossen: je moet kijken wat/waar het verkeerd zit...

Worden de relais uit de 5v of 12v gevoed?

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Hoe zit het met Pin 4? MCLR, is die in je code ingang of reset ?
Hang anders een 10k pull-up eraan

Guus@Sint-Michielsgestel

Het werkt.

Had nu alleen even de 7805 aangepast

wat ik ook vreemd vond. ik had een condensator 104 gepakt.
deze had ik nu nodig voor de 7805 dus ik pak het zelfde zakje
pak er een 104 uit, wat mij meteen opviel was dat de 104 die
ik op mijn pic had, groter is?? maar stond wel 104 op
uit voorzorg had ik die toch maar vervangen, ivm mijn probleem.

Ik moet nog wel zoals je op de print kan zien de S1 en S2 plaatsen.
Maar daar zie ik geen problemen.
Ook heb ik op de pic andere poorten gepakt, maar was meer om het wat
mooier te kunnen plaatsen op de pcb.

ieder bedankt.

@walter, ik doe niks met die in, uitgang. standaard houd ik die al apart om in circuit te kunnen programmeren, als ik dat wil toepassen.

Ik wil nog de mclr toepassen, alleen de vraag:
Moet ik die in de PIC op OFF laten staan, of moet die
met deze aanpassen op ON.

Config INTRC_OSC_NOCLKOUT, WDT_OFF, PWRTE_ON, LVP_OFF, MCLRE_OFF