Arduino IDE start niet met windows 10

Hallo;

Aljarenlang ben ik zeer intensief bezig met electronica ...van buizentechniek tot.... Meestal wel "analoog"
Dus ...mijn goede voornemen tijdens de corona-lockdown was dan ook om eindelijk ééns te beginnen werken met een microcontroller.
Dus heb ik een startpakket aangekocht met een arduino Leonardo en een heleboel sensoren enz.
Ik volg nu via het internet op youtube de cursus " arduino voor beginners " en zet zo mijn eerste stappen in deze wereld....leuk he!

Het ging allemaal goed , tot bij mijn 5 de projectje....IDE wou niet meer starten. ...Bij het starten krijg ik het beginlogo , en dan zegt deze " Loading Packages "...en dan stopt de boel.

Ik heb alles al terug opnieuw geinstalleerd..geen resultaat.

Ter info : ik werk hier op deze laptop met windows 10 laatste versie, de IDE komt vers van de pers versie 1.8.12.

Het rare is wel dat het hier wel gewerkt heeft ...
Wie kan er mij wat tips geven?

Hartelijk dank van deze Noob!

Grtz....Dirk

zal wel een probleem zijn op je pc. ik draai hier ook arduino ide op windows 10, alsook op mijn werk, en op mijn vorige laptop. draaide gewoon altijd.

wat ik wel doe, eens ik een werkende map met libraries heb, kopieer ik die op een usb stick, en het is altijd dezelfde map die gebruikt wordt. 1x IDE starten en in preferences de lokatie van de broncodes instellen.

dat wordt blijkbaar ergens in een config file geschreven dat NIET die installatie folder is. dus misschien is die file ergens corrupt bij u?

ik vond alvast een map bij (mijn arduinomap staat op de D schijf)
C:\Users\fcapri\Documents\Arduino\libraries

EN

C:\Users\fcapri\AppData\Roaming\Arduino15
die laatste heeft blijkbaar een preferences file.

board=nano
build.verbose=false
build.warn_data_percentage=75
console=true
console.auto_clear=true
console.error.file=stderr.txt
console.length=500
console.lines=4
console.output.file=stdout.txt
custom_cpu=nano_atmega328
editor.antialias=true
editor.caret.blink=true
editor.divider.size=2
editor.external=false
editor.font=Monospaced,plain,12
editor.indent=true
editor.invalid=false
editor.keys.alternative_cut_copy_paste=true
editor.keys.home_and_end_travel_far=false
editor.keys.shift_backspace_is_delete=true
editor.languages.current=
editor.linenumbers=true
editor.save_on_verify=true
editor.tabs.expand=true
editor.tabs.size=2
editor.update_extension=true
editor.window.height.default=600
editor.window.height.min=290
editor.window.width.default=500
editor.window.width.min=400
export.applet.separate_jar_files=false
export.application.fullscreen=false
export.application.platform=true
export.application.stop=true
export.delete_target_folder=true
last.ide.1.6.0.daterun=1586870001
last.ide.1.6.0.hardwarepath=D:\arduino\Arduino1.6\hardware
last.screen.height=1080
last.screen.width=1920
last.serial.location=0,0,663,379
last.sketch.count=0
last.sketch0.location=-7,0,974,1047,858
last.sketch0.path=D:\arduino\PROGS\gamechild2d\gamechild2d.ino
last.sketch1.location=953,0,974,1047,858
last.sketch1.path=D:\arduino\PROGS\ArduinoTetrisV2.1\ArduinoTetrisV2.1.ino
last.sketch2.location=59,11,981,997,808
last.sketch2.path=D:\arduino\PROGS\gamechild1\gamechild1.ino
platform.auto_file_type_associations=false
preproc.color_datatype=true
preproc.enhanced_casting=true
preproc.imports.list=java.applet.*,java.awt.Dimension,java.awt.Frame,java.awt.event.MouseEvent,java.awt.event.KeyEvent,java.awt.event.FocusEvent,java.awt.Image,java.io.*,java.net.*,java.text.*,java.util.*,java.util.zip.*,java.util.regex.*
preproc.output_parse_tree=false
preproc.save_build_files=false
preproc.substitute_floats=true
preproc.substitute_unicode=true
preproc.web_colors=true
programmer=arduino:avrispmkii
run.display=1
run.options=
run.options.memory=false
run.options.memory.initial=64
run.options.memory.maximum=256
run.present.bgcolor=#666666
run.present.exclusive=false
run.present.stop.color=#cccccc
serial.databits=8
serial.debug_rate=9600
serial.parity=N
serial.port=COM4
serial.port.file=COM4
serial.stopbits=1
sketchbook.path=D:\arduino\PROGS
software=ARDUINO
target_package=arduino
target_platform=avr
update.check=true
update.id=6742540694815992235
update.last=1586870005932
upload.using=bootloader
upload.verbose=false
upload.verify=true

[Bericht gewijzigd door fcapri op 10 juni 2020 19:26:49 (64%)]

ik hou van werken ..., ik kan er uren naar kijken

en de IDE ontwikkelaars hebben een voorlopige oplossing:

https://forum.arduino.cc/index.php?topic=661342.msg4636956#msg4636956

[Bericht gewijzigd door Pertinax op 10 juni 2020 20:34:08 (11%)]

Mijn thuis is waar mijn Weller staat

Even feedback...Heb toch nog een allerlaatste update van Windows 10 gedaan en...nu werkt alles terug normaal.
Thnx!