LOGO raakt in de war?

Hi,

Weer een LOGO vraag...

Op m'n werk hebben wij onder andere een gesloten koelsysteem wat altijd op druk blijft. De voordruk, of zuigdruk voor de pomp hoort 1,5 bar te zijn. De persdruk moet 3 bar zijn dus de pompen zijn ingesteld op een verschildruk van 1,5 bar.

Omdat er aan het gesloten systeem vele afsluiters/kleppen geplaatst zijn hebben we nogal last van drukschommelingen. Dit hebben we opgevangen dmv expansievaten die de waterslag opvangen. Op zich werkt dit prima.

Maar soms verschilt de zuigdruk toch nog wel eens, vooral bij opstart en afsluiten van de fabriek. Als de zuigdruk te laag word, gaan de motoren erg hard draaien, tot max 100 Hz en als de zuigdruk bijvoorbeeld 3 bar word, gaat het veiligheidsventiel open die aftapt naar een open buffervat.

Nu heb ik dit opgelost dmv een LOGO met druksensor.https://www.circuitsonline.net/forum/view/146739

Dit werkt prima, ik vul automatisch bij en tap automatisch af en de zuigdruk blijft binnen de gewenste toleranties.

Wat er niet ingebouwd was, is tankniveau controle. Hierdoor kon de LOGO dus de hele tank leegpompen in geval van lekkage. Dit is nu opgelost door een maximale vultijd en aftaptijd in de LOGO te zetten. Als de LOGO nu langer dan 40 seconden bij staat te vullen, valt ie in storing en schakelt de klep uit en de vulpomp. De zuigdrukregeling staat dan uit en kan alleen met een harde reset weer teruggezet worden.
Maar...

Gisteren had een monteur per ongeluk een kraan open gezet waardoor er dus een x aantal liters koelwater over de vloer ging. Resultaat: de LOGO gaat dat bijpompen. Maar kennelijk niet snel genoeg want bij aankomst stond de LOGO in storing, zoals geprogrammeerd...

De druk was gezakt tot 0,2 bar en de vulpomp kan dit niet binnen 40 seconden bijpompen.

Ik kan dan handmatig de regeling overrulen en toch bijvullen tot 1,5 bar en vervolgens heb ik de LOGO uitgezet en weer aan. Maar de LOGO is helemaal in de war. Hij meet 1,50 bar en gaat toch bijvullen terwijl dat niet zou mogen. Ook kleurt het scherm willekeurig rood en amber en dan ff wit die bij de te hoge, te lage en ingestelde druk horen. Om dit te fixen moet ik met de laptop het programma opnieuw inschieten om het weer werkend te krijgen. '

Heeft iemand een idee hoe dit kan? Het programma werkt d.m.v. 2 PI regelaars, 1 meet hoge druk en de ander lage druk. Deze sturen hun waarde naar een Differential Trigger die de uitgangen schakelt op bepaalde setpoints.

Ik moet zeggen dat ik niet echt thuis ben in het analoge deel van LOGO maar het werkt zo op zich prima. Alleen wanneer de LOGO dus lang "in storing"staat, blijft ie daar in hangen na een reset.

Bijgevoegd het programma.
Op zich niet heel spannend denk ik, 2 regelingen die uitgangen schakelen. Het vertraagd in- en uitschakelen van de perslucht ivm het "vasthangen" van de membraampomp.
Een paar tellers, die op dit moment trouwens niet weergegeven worden.

De ingestelde waarde 355 komt overeen met de 1,5 bar zuigdruk. De hoge en lage schakelpunten zijn 1,3 en 1,7 bar. De tijdvertragingen voor het inschakelen van de uitgangen zijn om te zorgen dat de LOGO niet reageert op snelle pieken. Die wilde ik filteren met de Analoge filters maar dat werkt niet zoals gewenst.

Bij voorbaat dank voor het meedenken.

Mvg, R-Tronic

Ik kan je programma niet openen, maar ik vraag me af waarom je daar 2 PI regelaars hebt gebruikt, waarvan je vervolgens (als ik je uitleg goed begrijp) de uitgangen vergelijkt met een grenswaarde om een ventiel of pomp aan of uit te zetten? Bij elke kleine afwijking van de referentiewaarde zal een PI regelaar eindeloos weglopen (sneller naarmate de afwijking groter is).

Ik neem aan dat het uit- en weer aanzetten van de LOGO de integrators leeg maakt, maar het klinkt eigenlijk alsof dat niet gebeurd. Hij kan dan wel een actuele waarde van 1.5 bar meten, maar als die integrators zonder beperking vol gelopen zijn, door een hele grote afwijking, duurt het wel even voordat die weer normaal hun werk doen. Het is gebruikelijk om de maximale integratorwaarde te beperken, juist om dit te voorkomen.

Waarom niet gewoon je analoge ingang filteren, vergelijken met de waardes voor 1.3 en 1.7 bar, en daarmee de pomp en het ventiel schakelen?

[Bericht gewijzigd door SparkyGSX op 5 juli 2020 13:37:52 (30%)]

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Hi Sparky,

Zoals gezegd is mijn kennis van Analoog niet geweldig. Vandaar dat ik het op deze manier heb gedaan. De PI regelaar kan alleen maar omhoog óf omlaag werken.

Als ik het goed begrijp kan ik de PI eruit laten en direct de triggers naar de input laten kijken?

Het is meestal lastig een programma dat door een ander gemaakt is helemaal uit te pluizen.

Mogelijk is het zoals SparskyGSX al aangeeft dat je ingerator 'volloopt'.
Als je een PI regelaar heel lang een te lage (of te hoge) input geeft tov de gewenste waarde (druk is heel lang veel te laag) dan gaat de regelaar raar reageren als de druk dan hoger wordt (en omgekeerd). Ondanks dat (bv) de druk te hoog wordt, reageert de regelaar alsof de druk te laag is.
Dat kun je oplossen door:
De LOGO echt te stoppen of de spanning eraf.
Of bij zoals jij bij een storing de PI regelaar uit te zetten. dus A/M Laag maken.

Over het algemeen kun je analoog op twee manieren verwerken:
Analoog met een P (PI) regelaar als je ook analoge uitgangen wilt gebruiken (kleppen analoog sturen 0-100% bv)
Digitaal (via bv Tresholt triggers etc) als je er mee wilt schakelen (klep open of dicht, storing aan of uit etc).

Daar waar een schakeling rookt, vloeit de meeste stroom (1e hoofdwet van Toeternietoe)
ritmeester

Golden Member

TER ZIJDE:

Ik weet wat LOGO doet en kan maar heb er nog nooit mee gewerkt.

Nu komt er een zeer uitgebreide vraag van een forum lid en als je dan ziet dat er meteen mensen die ook met LOGO werken, en er verstand van hebben, meteen reageren met mogelijke oplossingen is gewoon mooi ! :-)

Dit maakt het forum geweldig.

I love it when a plan comes together !

Het moet inderdaad wel zoiets zijn met de PI regelaars.

Ik ga dat eens proberen te maken zonder de regelaars en puur op inputsignaal schakelen met differential triggers.

Want met reset bedoelde ik ook echt spanning van LOGO eraf en dan er weer op. Maar dan nog blijft de LOGO raar doen. Net zolang tot ik het programma er opnieuw inschiet...

@ ritmeester, het forum is geweldig! Edit: Ik probeer mijn vragen zo uitgebreid mogelijk te maken zodat ik een zo goed mogelijk antwoord kan krijgen. Kleine moeite om even uit te leggen waarvoor het bedoeld is en het helpt misschien om er een beeld bij te vormen.

[Bericht gewijzigd door R-Tronic op 6 juli 2020 09:14:16 (23%)]

Welke LOGO gebruik je, de 0BA8 en dan FS.....
Gebruik je een TD scherm?
Gebruik je de LOGO in een netwerkomgeving?

Je hebt 1 analoge uitgang, waarvoor dient deze?

Nog wat programmeertips.
Als je op een ingang van een blok gaat staan met je muis, dan kun je met de RECHTER muisknop selecteren en kun je de desbetreffende ingang inverteren (omkeren) er komt dan een bolletje op de ingang te staan.
Dan kan (bij jou prog)Linksboven block High vervallen, B012 heb je dan ook niet nodig.
Je gebruikt 3x een analoog fiter op eenzelfde analoog signaal, en alle gelijk ingesteld. Je kunt ook 1 analoog filter gebruiken en het uitgangssignaal 3x gebruiken.

Je Trigger Hoog en Trigger Laag zou ik niet via een PI regelaar doen, vanwege het onvoorspelbare gedrag. Of je moet de PI regelaar afstellen op P (dus zonder I). Los het op met bijvoorbeeld (het kan ook anders) met een analoog tresholt trigger.

Ik zie inmiddels dat je dat ook gedaan hebt, het I deel staat uit.
Toch denk ik dat het beter werkt als je het met een Tresholt Trigger oplost.

Je signaalrichting is van Links naar Rechts, keurig, maar soms ontkom je er niet aan om van rechts naar links te gaan. Dan kun je beter de signaal"draad" doorknippen. Dat maakt het overzichtelijk. Dat kan door op de "draad" te gaan staan, rechtermuisknop en..... Zo kun je een doorgeknipte draad ook weer aan elkaar maken..

Daar waar een schakeling rookt, vloeit de meeste stroom (1e hoofdwet van Toeternietoe)

Goedemorgen,

Bedankt voor de tips, die van invert connector had je al eens eerder gegeven herinner ik me nu. Dat moet nog ff blijven hangen in de gewoonte denk ik.

LOGO is FS4 zo uit het hoofd. Hij hangt niet in een netwerk en er zit geen TDE scherm achter.

1 keer filteren is inderdaad beter dan 3 filters. De analoge uitgang zat daar omdat ik dacht dat alles naar een uitgang, flag of open connector moest lopen. Dat is hier dus niet het geval. Ik gebruik verder geen analoge uitgangssignalen.

Gisteren al gauw even tussendoor de PI regelaars er tussenuit gehaald en alleen met de analoge threshold trigger proberen te schakelen. Dit lukt voor hoge druk al wel, maar voor lage druk nog niet. Maar ik heb even niet veel tijd ivm installatie van een grote machine die voorrang heeft.

Met die teruglopende lijnen, die moest ik inderdaad nog ff knippen. Maar omdat ik dacht dat dit waarschijnlijk de laatste versie nog niet zou zijn heb ik even gewacht met opschonen van de layout. Als ik nog dingen moet aanpassen dan heb ik in zo'n klein programma liever dat alles nog aan elkaar zit. Op 1 of andere manier is dat nog overzichtelijker voor mij. In m'n vorige programma wat 10 keer zo groot is heb ik wel vele lijnen geknipt omdat dat wel een erg groot spinnenweb werd.:)

Ik zie nog wat raars in je programma
RS Blok B020 wordt wel geset (heeft iets met Alarm vultijd te maken) maar het blok wordt nooit gereset.
Dus terug naar je niet Alarmsituatie kan alleen door helemaal te stoppen met je LOGO, (Stop of spanning eraf, of programma opnieuw laden).

Als je een blok een naam geeft (max 12 posities) en je knipt een lijn van dat blok, dan komt de naam van het blok bij het knipje te staan.
Bv je hebt een blok Alarm LD dan komt de tekst erbij te staan.
Dat is vooral handig als je programma groot wordt, krijg je geen spaghetti van verbindingen en hoe het in elkaar zit kun je makkelijk volgen.
Werkt helaas niet bij Ingangen en uitgangen, die krijgen alleen de naam I1 of Q1 mee

Daar waar een schakeling rookt, vloeit de meeste stroom (1e hoofdwet van Toeternietoe)

Ja, dat klopt.

Wanneer er iets misgaat waardoor de pomp langer dan 40 seconden gaat vullen dan valt ie in "storing" met de melding dat je de pomp en/of het tankniveau moet controleren. Als het tankniveau te laag is, kun je dat niet zomaar bijvullen omdat het een water/glycol mengsel is. Dit moet handmatig gebeuren.

Als het vat leeg is, of de pomp werkt niet dan kan ik dat toch niet met de LOGO herstellen. Dus vandaar dat ie in storing blijft staan. Resetten moet dan ook door het afschakelen van de LOGO. Daarvoor heb ik een extra inbouwkastje geplaatst met een schakelaar en 2 drukknoppen voor handmatig bijvullen/aftappen. Iets netter was een resetknop geweest misschien, maar zo'n storing gebeurt niet dagelijks. Hooguit 1 keer per maand of soms maanden achter elkaar niet.

Ik heb nog 2 stuks niveausensoren die ik nog in de tank ga maken ook ter controle van tankniveau want bij een kleine lekkage zal de pomp alsnog uiteindelijk de tank leegpompen. Zo word een klein projectje toch steeds weer meer uitgebreid. Niet erg, want elke keer leer je weer wat bij:)

Het naam geven van de blokken is iets wat ik ook nog moet aanleren. In Solidworks vergeet ik dat ook telkens om de onderdelen een naam te geven. Wie weet of me dat ooit nog lukt:P

Het is gelukt!

Ik schakel nu alleen op de differential triggers en dat gaat prima. 3 analoge filters naar 1 filter en direct een veiligheid ingebouwd tegen leegpompen van het buffervat bij kleine lekkages.

Simpele counter die optelt bij bijvullen en gereset word door het aftappen. Als er nu 10 keer achtereen bijgevuld word, gaat de regeling uit. Hierdoor zal het vat nooit helemaal leegpompen. Als er tussentijds toch afgetapt word wegens te hoge druk = geen lekkage, dan reset de teller zich.

Hier en daar ook wat NOT poortjes weggehaald en de tip van Toeternietoe gebruikt met inverteren.

Als ik nu een keer weer tijd heb, ga ik de 2 niveausensoren in de tank plaatsen. Dat is toch iets beter dan de counter denk ik.

Bedankt voor de tips!