12V BLDC koelcompressor draait niet


Ik dacht maar aan die optie omdat ik van de veronderstelling uit ging dat je niet zeker weet of het probleem in de motor of de print zit. Ben je daar al uit?

Op 22 oktober 2020 11:37:12 schreef EricN:
Ik dacht maar aan die optie omdat ik van de veronderstelling uit ging dat je niet zeker weet of het probleem in de motor of de print zit. Ben je daar al uit?

De winding weerstanden zijn 0,2 ohm vr de driving coils en 3,7ohm vr de andere (op witte draad). Open circuit tov compressor body voor elk van pinnen. de gemeenschappelijke pin (bruine draad) is de +; De motor is geopend en het kleppendeksel verwijderd zodat die kan draaien zonder te comprimeren. Ik zie dus de piston een 1/2 slag of minder maken (op voorwaarde dat ik die eerst in een andere magnetisch stabiele stand breng dan die waarin de motor hem direct zet bij de eerste bekrachtiging van de spoelen via sluiten van termostaatcontacten). Ik denk dus dat de motor zelf OK is.

0,2 Ohm voor de hoofdwikkeling is wel heel erg laag!!.. Maargoed, een compressor opengeslepen?? Donder maar weg want die krijg je niet zonder vervuiling meer dicht..

Inderdaar wat lager dan de spec's (0,3) maar ik denk niet dat een DVM erg nauwkeurig is in dat bereik van 200ohm.
Qua dichten: zal wellicht met carbon fibre weefsel/epoxy gebeuren.

Inderdaar wat lager dan de spec's (0,3

Nee je zit met je meting iets boven de spec's. En inderdaad is een DMM niet zo heel goed in lage waardes. Belangrijkste is dat de gemeten waardes niet direct wijzen op een sluiting.
Als je wat nauwkeuriger wilt meten kan je met een voeding er bv precies 1A doorsturen en dan de spanning meten.
Mooie scope beelden maar zo totaal zinloos zonder onderschrift met wat elke trace precies moet voorstellen.

Mogen de Rg's losgekoppeld van de µP om te kijken of het signaal gegenereerd wordt (onbelast)?

Natuurlijk mag dat voor de uP maakt dat niet uit. Maar zonder exact de werking van de software te kennen kan je er geen harde conclusie uit trekken. Wellicht probeert hij alleen g2 aan te sturen en wacht op een response op een ingang om pas daarna g1 aan te sturen.

[Bericht gewijzigd door benleentje op 22 oktober 2020 20:29:00 (29%)]

Op 22 oktober 2020 19:12:49 schreef smd:
0,2 Ohm voor de hoofdwikkeling is wel heel erg laag!!.. Maargoed, een compressor opengeslepen?? Donder maar weg want die krijg je niet zonder vervuiling meer dicht..

kijk ook ns hier: https://www.youtube.com/channel/UCDxRSU3x4GCpRGfW4edfXIg
maar zoals gezegd, als die kan hersteld lamineer ik die dicht.

Een compressor dichtmaken met epoxy?? Gaat er zo langs lekken door de drukken van gas.. Zie dit als gevalletje hopeloos nu.Lassen gaat niet, je bakt er veel en veel te veel vuil in mee..

Hier al veel gehoord, maar dit treft alles!

Op 23 oktober 2020 18:51:28 schreef smd:
Een compressor dichtmaken met epoxy?? Gaat er zo langs lekken door de drukken van gas.. Zie dit als gevalletje hopeloos nu.Lassen gaat niet, je bakt er veel en veel te veel vuil in mee..

Ze zijn bij constructie toch ook dichtgelast. Zelfs vr reparatie (7 min. van https://www.youtube.com/watch?v=Q4IHJPJ9BsU) Misschien ook nagespoeld met R141. Of gelast met flow van Argon of stikstof.
En de permeabiliteit van epoxy is zeer laag.

Yep, een compressor is overlappend gelast in stikstof IDD. Lasspetters in je olie en ja, zuigt pompje op en ... klaar geen smering meer.

Op 24 oktober 2020 19:07:17 schreef smd:
Yep, een compressor is overlappend gelast in stikstof IDD. Lasspetters in je olie en ja, zuigt pompje op en ... klaar geen smering meer.

Dat is now net de reden waarom ik carbonfiber- of aramideweefsel met epoxyhars wou testen...
Maar terugkomend bij het startprobleem: weet iemand of die spoel van 3.5 ohm een sensor vormt of wordt gewerkt met BEFM?

Voor zover ik het kan beoordelen is de spoel van 3,5 ohm een soort hupwikkelingen en heb je daarnaast 2 hoofdwikkelingen. Het voordeel van twee hoofdwikkelingen is dat je met 2 fets elk wikkeling afzonderlijk kunnen aansturen met enkel een positieve spanning en je dus geen H-brug nodig hebt. Als er al BEFM gemeten word verwacht is die op de niet aangestuurde hoofdwikkeling.

Mn meting is 0,2 ohm ipv de spec 0,3: lager R dus.
Ik vulde de uitleg ivm de signalen aan bij de signaalbijlagen. (was verdwenen).

Dit is wat je in de startpost schrijft:

Echter zijn de normale R waarden van de 3 spoelen ongelijk; 2 hebben 0.3 ohm en de derde 3.5 ohm als normale waarden.

Waarbij ik uitgaat dat dit de door jouw gemeten waarden zijn want je bent daar absoluut niet duidelijk in.
In de datsheet die je in de startpost meestuurt staat wel 0,2 - 0,2 en 2,7.

Qua softw. Op welk signaal en op welke ingang zou die µP wachten en hoe te simuleren? BEFM? Amps? Hoe kan ik dit verder debuggen

Vaak zit de software dicht getimmerd en kan je niet bij. Echter je kan wel debuggen door zelf een test opstelling te maken die de print met de juiste signalen stuurt op response van de uitgangen maar dan kan je beter zorgen voor een werkende compressor en daar aan gaan meten.

Je gaf eerder aan dat 1 van gate vanuit de uP geen signaal geeft is dat ook zo nadat je wat los gesoldeerd hebt? IK zou toch ook kijken op de print hoe de feedback loopt. En daar eens aan meten.

[Bericht gewijzigd door benleentje op 24 oktober 2020 20:45:01 (60%)]

Omschrijving weerstand was idd vaag. sorry.
Eigenlijk vind ik geen mosfet of BJT die die hulpwikkeling zou aansturen en dus denk ik dat dit een sensor is. De 2 mosfets werken in op de 2 andere spoelen van 0,2-0,3 ohm.
Als ik de gateweerstanden los maak genereert de µP niks thv zn gate uitgangen. gezien de gates dan vlotten gaan de mosfets soms spontaan geleiden en warmen ze snel op en ik heb dit verder niet te lang laten aanliggen...
Een tweede BD25 of BD35 om de inputs daar te gaan bekijken, heb ik echter niet in bezit....
Morgen zet ik 1&ander op schema ivm de overige µP pins en hun benutting.

Eigenlijk vind ik geen mosfet of BJT die die hulpwikkeling zou aansturen

Ik zie toch 3 fets op de print zitten, helemaal recht is er ook een fet. De hulpwikkeling verbruikt max ca 4A en bij draaiende motor word dat minder. Maar geen idee wat de rechter fet aanstuurt.

Op 25 oktober 2020 01:14:39 schreef benleentje:
[...]Ik zie toch 3 fets op de print zitten, helemaal recht is er ook een fet. De hulpwikkeling verbruikt max ca 4A en bij draaiende motor word dat minder. Maar geen idee wat de rechter fet aanstuurt.

Die stuurt de Fan aan.

een schema met PCB

[Bericht gewijzigd door patpin op 25 oktober 2020 18:24:42 (71%)]

ik mat met scope op connector WT die naar de sensing coil gaat en meet daar als toestel aanligt (CT OFF) een sinus 150Khz 8.5V in 1/2 van de krukaspositie (180° aanwezig en 180° niet).
Verder checkte ik ook hetzelfde signaal bij startpoging.
foto1: startAttempt- yell microprocPin3-grn gate 2 -not turning
foto2: startAttempt- yell microprocPin3 detailed -not turning
foto3: startAttempt- grn gate 2
men ziet de krukas kleine bewegingen maken van een 5-tal graad tijdens de startpoging maar krukas draait niet.

Signaal van 3de plaatje klinkt aannemelijker dan de rest.. Alhoewel een bloksignaal is ook wel apart

Hoe zijn die elco's eigenlijk nog qua ESR?? Zijn tenslotte uit 93 en altijd warm geweest..

[Bericht gewijzigd door smd op 25 oktober 2020 21:12:28 (32%)]

Op 25 oktober 2020 21:10:26 schreef smd:
Signaal van 3de plaatje klinkt aannemelijker dan de rest.. Alhoewel een bloksignaal is ook wel apart

Hoe zijn die elco's eigenlijk nog qua ESR?? Zijn tenslotte uit 93 en altijd warm geweest..

Foto 2 en 3 zijn zelfde als foto 1 waar beide samen in zitten. Ik toonde ze elk afzonderlijk om ze beter te zien.
Ik mis duidelijk de actie van mosfet1 en vraag me af waarom die niet start.
(PS. compressor heeft weinig gedraaid, doch bekijk vandaag de ESR's).

[Bericht gewijzigd door patpin op 26 oktober 2020 08:46:58 (12%)]

Anders is het de leeftijd en kijk ook eens naar de kleine Ctjes, willen wel eens overgangsweerstand hebben.

Op 26 oktober 2020 19:43:52 schreef smd:
Anders is het de leeftijd en kijk ook eens naar de kleine Ctjes, willen wel eens overgangsweerstand hebben.

Voor elco's heb ik een ESR table gevonden maar niet voor ongepolariseerde of <1µF.

Volgens jouw schema zit de sense-wikkeling direct op uP zonder enige bescherming misschien dat de pin al dood is.

Op 26 oktober 2020 21:30:08 schreef benleentje:
Volgens jouw schema zit de sense-wikkeling direct op uP zonder enige bescherming misschien dat de pin al dood is.

De spanningen die erop terecht komen door de EMF en de activatie van een driving coil samen, zijn rond de 8.5Vpp.
d3 zal wel enigzins beschermen denk ik. Ik veronderstel dat de pin dood niet dood is gezien er een signaal van 156KHz op zit?

ik verwisselde de spoel/draindraden ZW en BL en de drainsignalen op de scoop bleven gelijk. compressor dus OK.

[Bericht gewijzigd door patpin op 27 oktober 2020 17:43:13 (58%)]