Picotest M3510A defect


Enkele metingen van vandaag. Ik kreeg ze helaas niet netjes als tekst gekopieerd, dan maar zo:
De gemeten waarden rondom U407 vind ik wel een beetje apart... Nu moet ik deze terug zien te vinden in het schema. Nu moet ik gedeeltes van het circuit zien te herkennen, aangezien het schema niet helemaal 1:1 is.

Ik verwacht dat ik ergens in dit gedeelte moet zoeken:

D207 opdruk 10Y (BZV49-C10) zou een 10V zener moeten zijn. In doorlaatrichting meet deze netjes 607mV, de breakdown voltage is gelijk aan de voedingsspanning als ik deze buiten de PCB om test (met een 1k weerstand in serie natuurlijk). Ik denk dat deze ook overleden is?

Helaas is er meer defect... Als ik dit component verwijder, blijft die berruchte 450mV onveranderd.
De kunst is nu om me niet blind te gaan staren op het probleem. Maar als het eenmaal op is gelost, heb ik gelukkig wel het een en ander bijgeleerd.

Ha Falco.P,

Goed bezig ik kijk nog voor het originele schema/service manual.
Maar ik dacht misschien heb je iets aan de schema's.... rustig aan is de juiste weg het zomaar uit en in solderen is inderdaad niet de manier.

Ik zal je tabel lezen kijken of ik een idee heb heb je alleen in de AC stand een fout ?

Groet,
Henk.

Everything should be as simple as possible, but not simpler.
RAAF12

Golden Member

Ik denk dat deze ook overleden is?

Dat is makkelijk te testen, laat 5mA door de zener lopen en meet de spanning over de zener. Dat moet 10V zijn.

Om precies te zijn gaat de 2 draads weerstandsmeting fout, 4-draads is wel OK.

DCV heeft een +455mV offset.
ACV is OK, geen offset te bekennen.

10A DCI doet helemaal niks, (ja de zekering is wel heel, en er loopt wel stroom doorheen.)
3A DCI is OK.
Wordt met 2 verschillende shunts teruggekoppeld.

Bij ons op het werk betekent desolderen meteen vervangen, dus ik ben ook niet zon fan van desolderen en dan terugplaatsen haha. Komt de betrouwbaarheid niet ten goede.

Op 31 oktober 2020 21:34:55 schreef electron920:
Ha Falco.P,

Goed bezig ik kijk nog voor het originele schema/service manual.
Maar ik dacht misschien heb je iets aan de schema's.... rustig aan is de juiste weg het zomaar uit en in solderen is inderdaad niet de manier.

Ik zal je tabel lezen kijken of ik een idee heb heb je alleen in de AC stand een fout ?

Groet,
Henk.

(PSU+)------[1k]----(DVM)---[ -|<- Zener ]---(DVM)----(PSU-)
Op een gegeven moment stond er 20V over de zener, (20/1000 = 10mA).
Lijkt wel alsof hij niet in breakdown komt. Want dan zou ik 10v over de zener moeten meten, en het restdeel van de voedingsspanning over de 1k weerstand.

Wel apart dat hij in doorlaatrichting wel netjes rond de 6-700mV zit.

Op 31 oktober 2020 21:38:45 schreef RAAF12:
[...]

Dat is makkelijk te testen, laat 5mA door de zener lopen en meet de spanning over de zener. Dat moet 10V zijn.

Ha Falco.P,
Heb je enig idee welke conditie de fout heeft veroorzaakt te grote elektrische stroom of een te grote elektrische spanning.
Bij een te grote lading is de diode open bij een te grote spanning is de diode kortgesloten.
Dit wordt metallisatie-burn-out genoemd en kan optreden bij zaken als EOS (Electrical Over Stress) er wordt als het ware stukjes metaal weg geblazen.

Ik moet het even op me laten inwerken, de fouten die je omschrijft m.b.t. de verschillende condities er is uiteraard een gemeenschappelijke oorzaak leuk wiskundig probleem :7

heb je een zener diode dan is die alvast vervangen overigens welk type is het want een temperatuur gecompenseerde zener diode kan je niet in de geleidingsrichting meten dus geen 0,7 V :o

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

De zener heeft de opdruk "10Y", als ik dan in me PDF bestandje kijk dan kom ik uit bij de "BZV49-C10"https://www.alldatasheet.com/datasheet-pdf/pdf/17593/PHILIPS/BZV49-C10…. Alleen komt de package niet overeen, die van mij lijkt meer op een DO-214AC package.

Nou euhm jaa eh, dit gaat misschien stom klinken. Maar ik was tussen de xenon ballast en dat blokje met de hoogspanningstrafo aan het meten. Er zat een condensator die rated was op 600V, dus ik nam aan dat de spanning daar onder zou zitten.. (en ja me collegas zeggen dat aannames doen gevaarlijk is.. Nu weet ik waarom.)

Op 1 november 2020 00:25:33 schreef electron920:
Ha Falco.P,
Heb je enig idee welke conditie de fout heeft veroorzaakt te grote elektrische stroom of een te grote elektrische spanning.
Bij een te grote lading is de diode open bij een te grote spanning is de diode kortgesloten.
Dit wordt metallisatie-burn-out genoemd en kan optreden bij zaken als EOS (Electrical Over Stress) er wordt als het ware stukjes metaal weg geblazen.

Ik moet het even op me laten inwerken, de fouten die omschrijft m.b.t. de verschillende condities er is uiteraard een gemeenschappelijke oorzaak leuk wiskundig probleem :7

heb je een zener diode dan is die alvast vervangen overigens welk type is het want een temperatuur gecompenseerde zener diode kan je niet in de geleidingsrichting meten dus geen 0,7 V :o

Groet,
Henk.

Ha Falco.P,

Dat is helder maar ik zit meer aan een TVS te denken kan je op een foto laten zien waar die ongeveer zit... wel rond de ingang :?

Hierbij de data van de diode,

byg10.pdf

Het is een snelle gelijkrichter 10Y maar kan uiteraard wel in een beveiliging circuit zitten !

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

Ha electron920,

Nu ben ik benieuwd hoe je bij de BYG10 uit bent gekomen :D , lijkt er inderdaad een stuk meer op.
Via de PDF die ik op de pc heb staan kwam ik bij een heel ander component uit met de verkeerde package. |:(

smd-codebook.pdf

Als het een 'gewone' diode betreft, meet deze wel goed en is er dus niks mee aan de hand. :9

De diode (rode omlijning) lijkt wel redelijk aan de ingang te zitten. (Boven het onderste relais) zie:

Op 1 november 2020 01:27:32 schreef electron920:
Ha Falco.P,

Dat is helder maar ik zit meer aan een TVS te denken kan je op een foto laten zien waar die ongeveer zit... wel rond de ingang :?

Hierbij de data van de diode,[bijlage]

Het is een snelle gelijkrichter 10Y maar kan uiteraard wel in een beveiliging circuit zitten !

Groet,
Henk.

Sine

Moderator

Op 31 oktober 2020 09:36:12 schreef flash2b:
Geloof je het zelf ?

Nee, ik kan inderdaad niet geloven keithley daar z'n naam op geplakt heeft.
Want het ver van wat ze normaal produceren.

Ha Sine,

Ik geloof ook dat het twee verschillende producten zijn maar waar dacht jij dat Keithely produceert als er achterop made in Taiwan staat :o :7

@TS,

ik ga zo even brainstormen en dank voor het antwoord dan weet ik een beetje waar ik in het schema kan kijken tot later.

Groet,
Henk.

[Bericht gewijzigd door electron920 op 1 november 2020 12:41:34 (27%)]

Everything should be as simple as possible, but not simpler.
RAAF12

Golden Member

RV102 kan ook nog platliggen als de input overbelast is geweest. Als er aan heftige dingen wordt gemeten gebruik ik mijn Fluke 867B die is bijna onopblaasbaar....

[Bericht gewijzigd door RAAF12 op 1 november 2020 14:18:10 (43%)]

@electron920 Super dankjewel alvast! Fijn dat mensen zo behulpzaam zijn :)

Op 1 november 2020 12:39:10 schreef electron920:
Ha Sine,

Ik geloof ook dat het twee verschillende producten zijn maar waar dacht jij dat Keithely produceert als er achterop made in Taiwan staat :o :7

@TS,

ik ga zo even brainstormen en dank voor het antwoord dan weet ik een beetje waar ik in het schema kan kijken tot later.

Groet,
Henk.

Als ik weer thuis ben zal ik zo snel mogelijk alle RV's doormeten. Goede tip trouwens! :9

Op 1 november 2020 14:14:23 schreef RAAF12:
RV102 kan ook nog platliggen als de input overbelast is geweest. Als er aan heftige dingen wordt gemeten gebruik ik mijn Fluke 867B die is bijna onopblaasbaar....

PE9SMS

Special Member

Op 1 november 2020 12:39:10 schreef electron920:
Ha Sine,

Ik geloof ook dat het twee verschillende producten zijn maar waar dacht jij dat Keithely produceert als er achterop made in Taiwan staat :o :7

@TS,

ik ga zo even brainstormen en dank voor het antwoord dan weet ik een beetje waar ik in het schema kan kijken tot later.

Groet,
Henk.

Als ik wat plaatjes google (Keithley 2110 pcb) dan zie ik gewoon precies hetzelfde board als in de startpost. Misschien dat er een andere referentie inzit, of wat firmware verschillen, maar verder hetzelfde ding.

This signature is intentionally left blank.

Ha Falco.P,

Even een vraag heb je de schakelfunctie al geprobeerd dus jou bevinding op 4 draad weerstand meting werkt de meter heb je dan de meter in 4 wire gezet ?
En in de stand 3 A werkt de meter maar als je de stand 10 A kiest werkt de stand 3 A dan inderdaad niet meer ?

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

Een foto zegt meer dan 100 woorden, 24 per seconde zijn nog duidelijker.
Denk ik zal even een filmpje maken:

Stroommeting:
https://www.youtube.com/watch?v=p6TdeBaxM90

2-draadsmeting:
https://www.youtube.com/watch?v=TMJuZCHG02g

4-draadsmeting:
https://www.youtube.com/watch?v=_1e8XH0WuyQ

Op 1 november 2020 19:30:29 schreef electron920:
Ha Falco.P,

Even een vraag heb je de schakelfunctie al geprobeerd dus jou bevinding op 4 draad weerstand meting werkt de meter heb je dan de meter in 4 wire gezet ?
En in de stand 3 A werkt de meter maar als je de stand 10 A kiest werkt de stand 3 A dan inderdaad niet meer ?

Groet,
Henk.

Heb ze net gelijk allemaal even gemeten:
Ook de polariteit van de meetprobes even verwisseld, om eventuele diodes e.d. uit te sluiten.

RV101 meet 1.99MΩ
RV102 meet 5,2Ω
RV103 meet ∞

Lijkt er inderdaad verdacht veel op dat RV102 plat ligt zoals je zei. _/-\o_
RV102 staat trouwens over de ~AC input van de brugcel. De spanningsval overde interne diodes van de brugcel is netjes 500mV. :9~

Hopen dat het zo simpel was, denk binnenkort even desolderen en dan meten. Dan weten we het helemaal zeker :D

Op 1 november 2020 14:14:23 schreef RAAF12:
RV102 kan ook nog platliggen als de input overbelast is geweest. Als er aan heftige dingen wordt gemeten gebruik ik mijn Fluke 867B die is bijna onopblaasbaar....

Ha Falco.P,

Ik heb de filmpjes bekeken maar wat ik bedoelde i.v.m. de fet schakelaars of die wel op jou commando hand bediening schakelde.
Maar goed je ben al weer een stukje verder die transzorb welke @RAAF12 aangeef is een goede kans........ zonder de sporen te kunnen volgen zou dat verklaren waarom twee draad meting niet werkt en vier draad wel |:(
Bij de twee draad meting is het meetpunt direct aan de stroom bron aangesloten en bij vier draad is deze meter virtueel naar buiten uitgevoerd op aparte bussen HI sens LO sens.

Omdat de transzorb parallel aan de ingang geschakeld is en dus ook parallel aan je te meten weerstand staat je zal je boven de 5,2 Ω geen aanwijzing te zien krijgen.
Als je eens probeer met een weerstand < 5,2 Ω zeg 1 Ω om te kijken of er verandering in de waarde te zien is.

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

Zojuist gedesoldeerd maar meet oneindig. Dus is het probleem niet blijkbaar.
R206 (tussen het relais en de witte vermogensweerstand) lijkt er parallel overheen te staan, en meet 5Ω.
Dit is een shunt voor het 10mA en 100mA bereik, daarboven wordt er overgeschakeld op de 0.1Ω ;(

Op 1 november 2020 14:14:23 schreef RAAF12:
RV102 kan ook nog platliggen als de input overbelast is geweest. Als er aan heftige dingen wordt gemeten gebruik ik mijn Fluke 867B die is bijna onopblaasbaar....

Ha Falco.P,

Kan je dat gedeelte optekenen ? ik zit toch meer aan de fets te denken die niet schakelen misschien een relais.
In dat kader is het misschien handig om een functie te kiezen ( voor het nalopen van dat circuit ) die niet veel omhanden heeft.
Bijvoorbeeld de 10 A stroom meting dat is denk ik te volgen die koperen beugel dat is de 10 A shunt daar heb je al op gemeten heb ik begrepen.
Die gaat naar een relais ? of een fet ?
Toen je de meting deed in welke stand stond je meter DC spanning auto of hand ?

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

Apart dat ik deze spanningen op de niet geinverteerde ingang meet van u202 (LM393). Deze zit op de basis van Q209 (F2G0A) BC850C??
Lijkt me dat de ingang nog aan meer punten vast hangt, ben benieuwd waar de spanning vandaan komt.

Deze spanningen zijn meetbaar op VDC (volledig bereik) ADC(10A) en het volledige weerstandsbereik.

Heb de print door proberen te lichten met een zaklamp, om zo wat sporen zichtbaar te krijgen. Tot nu toe alleen Q209.1 kunnen vinden.

Spanningen op U202:
V+ 7,99V
V- -7,99V

Out A -7,98V
+A 0V
-A 1,636V

Out B -7,98
+B 493mV
-B 1,637V

Tijd om eens me bed op te zoeken, :Z

Hee electron920,
het relais schakelt tussen het 10 en 100mA bereik (5Ω), en het 1&3A bereik (0.1Ω)

De 10A shunt zit aan de ene kant vast aan L205->Q203, en de andere zijde van de shunt aan Q209.
Zie mijn vorige post voor de foto.

Toen ik de "meting des doods ;(" deed stond de meter op Autorange :X

Op 2 november 2020 00:15:47 schreef electron920:
Ha Falco.P,

Kan je dat gedeelte optekenen ? ik zit toch meer aan de fets te denken die niet schakelen misschien een relais.
In dat kader is het misschien handig om een functie te kiezen ( voor het nalopen van dat circuit ) die niet veel omhanden heeft.
Bijvoorbeeld de 10 A stroom meting dat is denk ik te volgen die koperen beugel dat is de 10 A shunt daar heb je al op gemeten heb ik begrepen.
Die gaat naar een relais ? of een fet ?
Toen je de meting deed in welke stand stond je meter DC spanning auto of hand ?

Groet,
Henk.

Ha Falco.P,

Maar ik neem aan in de stand DC of...... oké de relais dienen voor de voorselectie het grove bereik.
Daar binnen schakel je met FETs alles goed maar je moet een sample nemen een meting die snel genoeg is om de schakelaars te bedienen.
Het is speculeren om welke reden de meter defect is geraakt en is dan ook niet zo zinvol !

Het volgen van de stroom meting is verreweg het minst complex.... doorgangstest van het circuit van ingangsbus naar 10 A shunt en naar de uitgang hier meet je de shunt 0,1 Ω die is er want je heb hem doorgelust naar de andere meter prima.

Nu moet je de spanningsval over de shunt meten dus zoals je omschrijf aan het begin van de shunt en aan het einde van de shunt hier zitten twee transistoren maar....... weet je zeker dat dit transistoren zijn of kunnen dit ook FETs als schakelaar zijn :?
Dat zal je eerst willen bekijken daarna verder !

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

Even een korte update:

Q209 bleek defect te zijn, deze meette 30Ω in beide richtingen.
Na het verwijderen van het component heb ik de zelftest uitgevoerd, deze was PASS.

Component is vervangen, hierna is error 602 weer aanwezig. Maar het goede nieuws is dat de offset spanning van ±450mV gezakt is naar 18,2mV :)

Ook gaat de 2draads weerstandsmeting weer de goede kant in.

10ADC geeft nog steeds een overload.

We gaan de goede kant in! :9~

(Q208), Q203, Q202 zijn ook verdacht.