Raspberry Pi Zero niet zichtbaar op netwerk

Op 20 november 2020 07:54:06 schreef mechatron:
Ik zat idd blind te proberen hem aan de praat te krijgen.

Eigenwijze drol! Wat is er nou tegen om even een monitor/keyboard/muis aan te sluiten en dan te kijken waar het mis gaat? Zo kan het nog jaren duren voordat je gevonden hebt dat je een stom typefoutje gemaakt hebt. Mag hoor, als het je hobby is. Zodra je netwerk connectie werkt kan ie weer headless natuurlijk want dan heb je SSH om er remote bij te kunnen.

PS, met zo'n W versie is het nog steeds lastig om het zonder monitor te doen. Ook die moet eerst juist connecten op je LAN en dat gaat niet vanzelf.

[Bericht gewijzigd door flipflop op 20 november 2020 17:41:49 (13%)]

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

Op 20 november 2020 17:40:23 schreef flipflop:
[...]
Eigenwijze drol! Wat is er nou tegen om even een monitor/keyboard/muis aan te sluiten en dan te kijken waar het mis gaat? Zo kan het nog jaren duren voordat je gevonden hebt dat je een stom typefoutje gemaakt hebt. Mag hoor, als het je hobby is. Zodra je netwerk connectie werkt kan ie weer headless natuurlijk want dan heb je SSH om er remote bij te kunnen.

PS, met zo'n W versie is het nog steeds lastig om het zonder monitor te doen. Ook die moet eerst juist connecten op je LAN en dat gaat niet vanzelf.

een zero heeft andere connectoren dan een gewone rpi. dus zonder verloop stukjes, kan je er geen scherm aan zetten.

ik hou van werken ..., ik kan er uren naar kijken
marcob

Golden Member

Het is allemaal helemaal niet moeilijk. Zorg voor goede SD kaartjes, dus geen Ali kaartjes.
Ik formateer de kaartje eerst met 'SD Card Formatter', gewoon uit zekerheid.
Daarna zet ik er een image op, met 'balenaEtcher' of 'Win32DiskImager', het voordeel van de eerste is dat deze nog een read check doet.
Dan kopieer ik via Total Commander de files 'wpa_supplicant.conf' en 'ssh' in de root map. De beide bestanden staan standaard op m'n pc.

Het bestand 'wpa_supplicant.conf' heb bewerkt met 'Notepad++' zorg dat bij de indeling van het bestand in 'Unix-formaat' staat. Als je bestanden bewerkt met gewone Windows kladblok of Wordpad dat het formaat niet juist is, en dan vind Linux niet leuk.

Doe het al tijden zo, nooit problemen gehand.

Een WOK is ook maar een vergiet zonder gaatjes

Even voor de goede orde: Ik heb het al regelmatig gedaan (pi opbrengen).

Zojuist een bestaande pi-configuratie op andere hardware overgezet (kon een oude pi zijn: er wordt niet veel van hem verwacht, kan ik de snellere voor wat anders gebruiken).

Eerst de monitor en ethernet aangesloten opgestart: Nope. Niet op het netwerk. Zucht. Toetsenbord gehaald ingelogd. Twee IP adressen. Blijk ik verkeerd gekeken te hebben. Dus toen DHCP server config veranderd dat ie /zijn/ ip adres krijgt en via SSH reboot aangevraagd. Toen bootte ie netjes naar z'n eigen IP adres. Prima. Dingetjes aangesloten, nog een reboot: Lijkt te werken. Dan naar z'n uiteindelijke locatie verhuisd en werkt ook goed. Halfuurtje. Klaar.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Nou, het feest is alweer over.

PiHole geïnstalleerd, na het spul in de meterkast bij de router te hebben gehangen.
Pi als DHCP server ingesteld (uitgezet in router en PiHole als DNS ingesteld)

NIETS, overal nog reclames tussendoor.

Ik kan ook geen uitleg vinden over het blacklisten van zaken etc. (blijkbaar weet iedereen precies hoe dat moet)
Blijkbaar installeert iedereen het en werkt het behalve hier???!!!!...
Er zijn block lists maar je moet er ook niet teveel tegelijk opzetten omdat je dan problemen kunt krijgen met zaken die er evt dubbel instaan (volgens youtuber)
Na het toevoegen van een block list en het updaten van de PiHole geen verschil in het aantal domains in bloclist.

Toen heb ik de moed opgegeven.

Nieuwe SD-kaartje ligt inmiddels en de kliko (met geen mogelijkheid te formateren en geeft catastrofale foutmelding), de oude zit weer in de printer.

(Toch 8 dagen van de straat geweest voor een paar euro.)

back to the drawing breadboard

Jouw probleem zit nu blijkbaar in de cofiguratie van PiHole. Anderen hebben het denk ik vooral over Raspbian lijkt het. Ik ook. De image die je van .org download moeten het gewoon doen. Heb je dat er al op had staan, gewoon even standaard?

[Bericht gewijzigd door flipflop op 21 november 2020 18:58:28 (17%)]

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein

ook op je pc de ip's en gateways veranderd? als daar alles nog naar je oude router wijst, dan mag je aanpassen aan de router wat je wil (dhcp), die pc's die een ip hadden blijven daar op gaan.
zijn de gateways wel allemaal correct gezet, en geen dubbel ip tussen router en je pi? want dan gaan de pc's alsnog over de router.

op internet staan veel handleidingen als jaren online, maar de linux variant op rpi veranderd continue, waardoor dan sommige dingen veranderd zijn. je kan dus niet zomaar alles in zo een handleiding volgen, tenzij je zeker bent dat het een recente is.

ik hou van werken ..., ik kan er uren naar kijken
marcob

Golden Member

Heb je gecontroleerd op je PC al de nieuwe DNS heeft overgenomen?
'ipconfig /all' laat de huidige DNS server zien.

Meestal nemen de devices pas de nieuwe instellen overnemen na een herstart.

En het klopt, piHole is geen wondermiddel, niet alle reclames worden geblokkeerd. Maar op een pagina zoals AD.nl zie ik geen reclames.

Een WOK is ook maar een vergiet zonder gaatjes

Wat ik niet begrijp als ik bij mijn ethernet adapters kijk dat ik het volgende zie:

Ethernet 2
Network cable unplugged
Sophos SSL VPN adapter

Ethernet
TP-LINK_..........
Realtek PCe ..........

En nog twee VMWare adapters (zie VMware niet bij de Apps dus krijg ik ook niet weg, Virtualbox kon ik zo wel verwijderen)

De TP link is een van de twee Access Points welke ik voor WiFi gebruik.
Waarom staat deze bij de ethernetadapters van mijn PC? In het verleden via WiFi verbinding met internet gehad maar dat is al een tijd niet meer zo.

Ik zou via 2 homepluggen en een switch een ethernetverbinding met mijn router (ExperiaBox V10) moeten hebben. (deze maand wordt dat er een van Ziggo).

Hoe de TP-LINK in de verbinding tussen mijn router en mijn PC staat begrijp ik niet. Als ik de TP-LINKadapter disable heb ik geen internet meer op de PC.

Ik had bij preferred DNS server het IP-adres van de Pi gezet (inmiddels weer teruggezet)

"geen dubbel ip tussen router in je pi" begrijp ik niet dus kans is er dat dat ja is (was).

EDIT: de pi wel een aantal keren herstart, de PC minder. Ik ga het volgende week zaterdag nog eens proberen, morgen eens proberen niet achter de PC te zitten.

En het klopt, piHole is geen wondermiddel, niet alle reclames worden geblokkeerd. Maar op een pagina zoals AD.nl zie ik geen reclames.

Voor mijn browsers gebruik ik ABP, ik hoop de reclameterreur te verminderen op het netwerk. Net in 1 filmpje op YT 3x reclame gehad toen ik op mijn telefoon zat te kijken. Heb gezien/gelezen dat in bijv. een smart TV de kans groot is dat het DNS adres daar hard in gebakken zit en dan helpt de PiHole ook niet.

[Bericht gewijzigd door mechatron op 21 november 2020 22:38:15 (16%)]

back to the drawing breadboard
bprosman

Golden Member

Heb gezien/gelezen dat in bijv. een smart TV de kans groot is dat het DNS adres daar hard in gebakken zit

Dat kan niet, je zou het wel statisch in kunnen stellen of dat het statisch ingesteld is.

Voor mijn browsers gebruik ik ABP, ik hoop de reclameterreur te verminderen op het netwerk. Net in 1 filmpje op YT 3x reclame gehad toen ik op mijn telefoon zat te kijken.

Dat heeft helemaal helemaal niets met je browser te maken maar met het (verdien)model van YouTube, die stoppen de reclames in de filmpjes net als een TV zender dat doet met films. Als je een abbonement neemt bij YouTube dan ben je reclame vrij.

Ik ben even de weg kwijt, hoe ben je nu met je PC verbonden met je netwerk ? (Niet via een draad want die staat "unplugged" en is dat de bedoeling ?)
Maak anders eens een tekening van hoe het zou moeten verbinden.

[Bericht gewijzigd door bprosman op 22 november 2020 09:56:39 (14%)]

De jongere generatie loopt veel te vaak zijn PIC achterna.

Hier het schema van mijn netwerk:

De internetverbinding van de PC die ik nu actief is is deze:

Ethernet
TP-LINK_..........
Realtek PCe ..........
(dit moet volgens mij niet eens kunnen?)

Ik mis een adapter over switch - homeplug2 - homeplug 1 - router
Mijn PC zou geen verbinding moeten kunnen hebben met een AP omdat er geen WiFi-antenne in zit.

(Met ABP krijg ik op mijn PC-browsers geen reclames meer, ik heb geen ABP op mijn telefoon.)

back to the drawing breadboard
bprosman

Golden Member

Mijn PC zou geen verbinding moeten kunnen hebben met een AP omdat er geen WiFi-antenne in zit.

Via de kabel wel.
DHCP staat uit in de AP's ?

Hoe zijn je IP ranges gedefinieerd ?

[Bericht gewijzigd door bprosman op 22 november 2020 10:47:57 (11%)]

De jongere generatie loopt veel te vaak zijn PIC achterna.

In beide AP's staat de DHCP disabled (default, had ik niet aan gedacht)
(de eerste twee nullen zijn andere getallen)
Start IP address: 0.0.2.100
End IP address: 0.0.2.199

In de router staat:
Address pool van 0.0.2.1 tot 0.0.2.200

Moet ik in de router bijv. 0.0.2.1 tot 0.0.2.99
en in de AP's bijv. 0.0.2.100 tot 0.0.2.149 en 0.0.2.150 tot 0.0.2.199
instellen?

In beide AP's had ik bij DNS ook niet het IP address van de Pi ingesteld. Maar ik dacht dat de PC sowieso buiten de AP's om met internet in verbinding staat.

Ik ga zometeen beide AP's uitschakelen en dan kijken naar de adapters van de PC.

EDIT: Met beide AP's uitgeschakeld blijf ik internetverbinding houden over:
Ethernet
TP-LINK etc
Realtek PCIe etc

Het lijkt er dus op dat de ethernetverbinding (PC - switch - homeplug2 - homeplug1 - router) foutief TP-LINK heet (dit krijg ik niet aanpgepast)

[Bericht gewijzigd door mechatron op 22 november 2020 13:20:05 (18%)]

back to the drawing breadboard

Ethernet
TP-LINK etc
Realtek PCIe etc

Het lijkt er dus op dat de ethernetverbinding (PC - switch - homeplug2 - homeplug1 - router) foutief TP-LINK heet (dit krijg ik niet aanpgepast)

windows 10 geeft de naam van de lan verbinding op basis van het mac adres van de gateway.
als een PC ooit wifi heeft gehad, zal hij de naam van het access point ook voor bedrade netwerken gebruiken, zolang het MAC adres hetzelfde is.

voor de pihole is het belangrijk dat deze zo dicht mogelijk bij je modem zit.

- zijn het routers of access points die je hebt?
- heb je deze aangesloten op de LAN of WAN poort?

mijn insziens moet je 1 router hebben (liefst je eigen, die van ziggo is ruk) en dan je modem in bridge zetten.
verder zet je alle WIFI in AP mode op de WAN poort.
dan zeg je in je eigen router de DNS op de PiHole en werkt het.

ik gebruik het zo en werkt vrij goed, de chromecast toont echt zelden reclame (1 a 2 keer gebeurd) en enkel de youtube APP. in de browser is het stukken minder.

(ik gebruik addblock plus, privacy badger en pihole en nog komt er spul doorheen)

GMT+1

Ok, dus als ik binnenkort de router van Ziggo heb en de PC voor het eerst hiermee bedraad verbind dan krijgt de adapter de juiste omschrijving? (En kan de huidige adapter het archief in)

Ik had de PiHole direct in de router gestoken met een ethernetkabel.

Het zijn Access Points (zoals plaaje hieronder) welke ik kan instellen als AP, Range Extender, Client of Multi-SSID. Ze staan beiden als AP ingesteld.
Enige externe aansluitingen zijn: power, 1x ethernet en antenne.

Keuze uit LAN of WAN heb ik niet onder Network in de Access Points, dat is denk ik alleen het geval bij een router?

Ik zie zo snel niet in de router hoe ik hierin de WiFi in AP mode op de WAN poort moet zetten (of geldt dit alleen voor de Access Points?)
Wat me wel opvalt is dat bijv. een telefoon (alleen WiFi) achter het icoon van de RJ plug staat maar dat komt misschien omdat deze via een AP toch via een ethernetkabeltje het modem inkomt??

(binnen mijn lokale netwerk heb ik eigenlijk toch niets met WAN te maken?)

Algemene vraag:
Moet ik de IP ranges van de router en de AP's verschillend maken om IP conflicten te voorkomen? (2 apparaten krijgen hetzelfde IP toegewezen)

back to the drawing breadboard
bprosman

Golden Member

Moet ik de IP ranges van de router en de AP's verschillend maken om IP conflicten te voorkomen? (2 apparaten krijgen hetzelfde IP toegewezen)

Ja.

De jongere generatie loopt veel te vaak zijn PIC achterna.

De keuze wan of lan is vaak een aparte plug op de router. Ik weet niet of jouw router meerdere rj45 heeft?

Als het goed is deelt maar 1 apparaat dhcp uit, en die moet je vertellen dat hij geen dns doet, maar de pihole. Dan pakt ieder apparaat het automatisch op.

GMT+1
bprosman

Golden Member

Op 23 november 2020 15:19:11 schreef Progger:
De keuze wan of lan is vaak een aparte plug op de router. Ik weet niet of jouw router meerdere rj45 heeft?

Als het goed is deelt maar 1 apparaat dhcp uit, en die moet je vertellen dat hij geen dns doet, maar de pihole. Dan pakt ieder apparaat het automatisch op.

De PiHole zelf kan eventueel ook DHCP doen

Overigens mogen er best meerdere DHCP servers actief zijn maar houd ze dan "binnen" het AP en zorg dat er geen overlap zit in de IP-ranges die ze uitdelen.

[Bericht gewijzigd door bprosman op 23 november 2020 15:41:09 (16%)]

De jongere generatie loopt veel te vaak zijn PIC achterna.

Op 23 november 2020 15:19:11 schreef Progger:
De keuze wan of lan is vaak een aparte plug op de router. Ik weet niet of jouw router meerdere rj45 heeft?

Mijn idee is dat het geen routers zijn omdat er slechts 1 stuks RJ45 aansluiting op zit, ik kan hem dus ook niet als bedrade switch gebruiken.

(maar misschien valt dit volgens de definitie wel onder de routers)

Voor zover ik kan zien heb ik alleen nog een aan/uit knop en een reset "gaatje" (verborgen knopje).

In onderstaand plaatje zie je alle if's met de buitenwereld die erop zitten.
Beide AP's zijn hetzelfde type met een paar jaar ertussen.

back to the drawing breadboard
Hensz

Golden Member

Op 23 november 2020 16:00:54 schreef mechatron:
Mijn idee is dat het geen routers zijn omdat er slechts 1 stuks RJ45 aansluiting op zit, ik kan hem dus ook niet als bedrade switch gebruiken.

(maar misschien valt dit volgens de definitie wel onder de routers)

Daarom is het eerder juist een router. Een router regelt verkeer tussen 2 (of meer) netwerken. Een hub/switch regelt het verkeer binnen één netwerk. De router van je provider doet dat tussen het netwerk dat via DSL oid tot je komt en de ethernetpoort die jij mag gebruiken. Eén is genoeg, maar het mogen er meer zijn. Dan is je router meteen al voorzien van een hub, idd erg handig! :D
Ik zie dat je router alleen wifi B/G doet, is het ding daarmee nog wel een beetje bijdetijd?

Don't Panic!
marcob

Golden Member

Een WOK is ook maar een vergiet zonder gaatjes

Zo zit het bij mij:

op de werkamer (zolder) staat nog een printer, werklaptop, desktop, 2e AP en losse kabel voor testen
de PiHole zit draait als docker container op een NAS.
overal hetzelfde subnet, de Asus geeft DHCP uit en de wifi op de ziggo staat uit (afstand is te groot naar meterkast).

code:


+------------------+     +--------------------------------+
|  Zolder          |     |           1e verdieping        |
|   +-----------+  |     |    +-------------------+       |
|   | Switch    |  |     |    |   AP              |       |
|   |           |  | +--------+                   |       |
|   +----+---+--+  | |   |    +-------------------+       |
|        |   |     | |   |                                |
| +------+-+ |     | |   |                                |
| | PiHole | |     | |   |                                |
| +--------+ |     | |   |                                |
|            |     | |   |                                |
+------------|-----+-|---+--------------------------------+
|            |       |   |                                |
|  +---------+-------+-+ |             Draadloos:         |
|  |  Switch           | |             Laptop             |
|  |                   | |             Chromebook         |
|  |                   | |             Chromecast         |
|  |                   | |             Google home speaker|
|  +-----------------+-+ |             Nest hub           |
|                    |   |                                |
|                    |   |                                |
|                    |   |                                |
|                    |   |                                |
|                    |   |                                |
|    +------------+  |   |  +-----------------------+     |
|    |            |  +------+  Asus RT-AC68u        |     |
|    |  Ziggo     +---------+                       |     |
|    |  (bridged) |      |  |                       |     |
|    +------------+      |  +-----------------------+     |
|                        |                                |
|                        |                                |
|                        |                                |
|    Meterkast           |     Woonkamer                  |
|                        |                                |
+------------------------+--------------------------------+

dit is alles wat ik in heb hoeven stellen. de NAS heeft een fixed IP adres buiten de reeks, de asus is gateway, de nas DNS.

GMT+1

De router/modem (KPN) heeft nu range 1 - 100
AP1 heeft range 101-150
AP2 heeft range 151-200
Octopi heeft 253
PiHole krijgt 252
(Voor het net moet ik de AP's zelf misschien ook een IP boven 200 geven, nu 2 en 4, scheelt weer 2 IP's die de router dan kan uitdelen maar praktisch zal dit niet nodig zijn.)

De switch zie ik niet op mijn netwerk dus die kan ik ook niets toewijzen, hoeft dan ook niet.
De homepluggen kom ik niet in dus die worden toegewezen door de router.

Maar eerst moet ik achter 2 goede SD kaartjes aan, scheelt dagen geklooi. Komend weekend ook eerst wat kasten op zolder verplaatsen om de indeling wat efficienter te maken.

back to the drawing breadboard
Hensz

Golden Member

Normaliter laat je de Internetmodem (het ding van Ziggo) de DNS uithangen. DNS heb je altijd nodig en die Internetmodem staat altijd aan. De Access points hoeven geen DNS te spelen, dit compliceert de boel alleen maar en je wint er niets mee. Ze hebben nu een eigen IP-adres, dat is makkelijk als je er toch nog een keer iets aan moet configureren. Idem voor de NAS met PiHole c.q. voor ev. andere dingen waar iets aan gesleuteld moet worden.

Don't Panic!

@mechatron, ik snap er niets van, je zegt dat DHCP uit staat, maar dat ieder apparaat zijn eigen range heeft.

staat DHCP nu aan of uit?

@Hensz, PiHole is een internet/reclame filter op basis van DNS, dus moet je deze juist DNS laten doen.

GMT+1