50 Hz brom, maar geen ground loop

Ik heb onlangs een (tweedehandse) actieve PA speaker gekocht (Skytec SP1200A) en dat ding heeft een enorme 50 Hz brom. Ook als hij op helemaal niets is aangesloten. Soms begint hij spontaan even te knetteren en dan opeens is de brom weg. Sowieso, één op de tien/twintig keer dat ik dat ding aan doe, heeft hij geen brom.

De aarde van de 220V ingang zit op de backplate aangesloten. Maar verder is er geen enkel chassisdeel (connectoren, pots) wat verbinding maakt met de backplate.

Als ik de ground doorverbind met de aarde, is de brom weg. Maar zou dan niet eigenlijk de aardlek schakelaar moeten doorslaan?

Iemand enig idee waar ik dit moet zoeken?

Soldeer alles eens goed door, kijk of interne connectoren goed vast zitten...

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Welk type?
Is dat zo een 400/800 watt ding met een max 60 watt autoradio ic erin als versterker. (wind in de rug en berg af). Zou zomaar rot kunnen zijn of los in het soldeer.

Skytec SP1200A. Vermogen 300W. Er zitten twee borden in: een versterker bord en audio bord (zie bijgaande foto's).

Ik had visueel de soldeerpunten al bekeken, maar zag geen kringen of oxidatie. Ik ga de soldeerpunten nog wel een keer langs met de soldeerbout.

pa3gws

Golden Member

Daar zit de een of andere TDA chip in die van zijn leven geen 300 Watt kan ophoesten. >:)
Rotte solderingen slechte elco's enz. alles is mogelijk met de Skypech producten.
Ik hoop dat je er niet teveel voor betaald hebt.
Anders is het een mooie

Ik ben gestopt met roken nu mijn schakelingen nog.

Ik moet zeggen, hij doet het verder prima, zit ook goed (hard) geluid in. Alleen die brom...

Als het volume wat harder staat, wordt de brom natuurlijk overstemd, maar het is een teken dat er iets niet goed zit. En voordat dat ding er mee kapt terwijl ik 'm in gebruik heb, zou ik het graag opgelost willen zien...

Heb je de connectoren al eens los van weer vast gezet?

Lijkt mij gewoon een slechte verbinding ergens, het zal iets heel kleins zijn maar niet zo via een forum op te lossen.

Nee, ik denk ook niet dat ik met een paar vragen het probleem vind. :)

Ik vroeg me meer af of het een acceptabele oplossing is om gewoon de massa aan de aarde te hangen (sinds daarmee de brom weg is).

de 2 dikke elco's maken ook kans.. de schroef in de print welke de lip aan aarde houd langs de stekker van de trafo maakt ook kans..

[Bericht gewijzigd door testman op 7 december 2020 20:44:59 (58%)

waar rook was, werkt nu iets niet meer

Op 7 december 2020 20:32:25 schreef Zippy1970:
Ik vroeg me meer af of het een acceptabele oplossing is om gewoon de massa aan de aarde te hangen (sinds daarmee de brom weg is).

Welke massa hang je aan aarde? Een gearde speaker moet je ook in een geaard stekkerblok steken.

Op 7 december 2020 22:27:26 schreef nijhuisr:
[...]

Welke massa hang je aan aarde? Een gearde speaker moet je ook in een geaard stekkerblok steken.

Ja hij zit gewoon in een geaard stopcontact. De twee borden delen hun massa dus het maakt niet uit waar ik de massa pak; zodra ik die met de aarde verbindt, is de brom weg.

waarschijnlijk is de interne massa onderbroken. Kan gewoon weggebrand zijn door potentiaalverschil tussen aarde/ massa bij een opstelling in het verleden. volgens dat ik kan zien op je eerste foto gaat massa naar chassis via een van de zwarte schroefjes, links onder op het printje. kijk daar eens rond. (en draai de schroef voor alle zekerheid eens aan)

[Bericht gewijzigd door kris van damme op 7 december 2020 23:29:44 (39%)

Op 7 december 2020 20:44:07 schreef testman:
de 2 dikke elco's maken ook kans.. de schroef in de print welke de lip aan aarde houd langs de stekker van de trafo maakt ook kans..

Schroef nagekeken en dat maakt goed contact met aarde massa.

Het gekke is, ik kan 'm 20x achter elkaar uit en weer aanzetten, en dan is opeens de brom verdwenen. En hoezeer ik ook aan de componenten wiebel, en hoe lang ik 'm ook aan hou, de brom komt niet terug. Maar zet ik 'm nogmaals uit en weer aan, dan is de brom er weer.

Ook knettert-ie af en toe heel erg, en heel soms na het knetteren is de brom ook weg. Het klinkt als een los soldeerpunt, maar dan zou het flexen van de printborden hoorbaar moeten zijn.

De 2 grote elco's zijn inderdaad verdacht (eigenlijk alle elco's), maar misschien ook de transistor op het versterker bord?

Ik ga nu even het bord los schroeven en toch alle soldeerpunten nalopen. Ik kijk ook meteen even of ik nog wat elco's heb liggen als vervanging voor die twee grote. En als ik toch bezig ben, vervang ik meteen die transistor.

Blijft nog steeds de vraag, is het acceptabel om gewoon de massa aan de aarde te hangen?

Edit:
Net alle soldeerpunten op het versterkerbord opnieuw gesoldeerd, geen verschil.

Het audio bord er ook uitgehaald en alle soldeerpunten opnieuw gesoldeerd. Alle (13) elco's ook vervangen. Ik heb het gevoel dat hij ietsje minder bromt, maar kan ook wishful thinking zijn... M.a.w, nog niet opgelost.

Zo maar even langs de elektronica winkel en twee grote elco's halen en een S9014 transistor.

Verder zag ik op beide printplaten geen onderbroken traces of zo...

Zit die bout rechts van de print nou tegen de print aan?

maartenbakker

Special Member

Die transistor zal net als de kleine elco's niet stuk zijn. Als je op de gok onderdelen vervangt dan is de kans, net als toen je begon, het grootst dat de grote elco's stuk zijn. Ook die kans is lang geen 100%, maar als je een hamer hebt moet je elk probleem behandelen als een spijker.

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Waarschijnlijk wordt de kast toch als massa gebruikt want zodra u die extra draad aansluit is de brom verdwenen. De geel/groene aarddraad is er voor bedoeld om aanrakingsgevaar bij metalen apparaten te voorkomen maar heeft geen invloed op de werking van het apparaat. Mijn advies, als met die extra massadraad de brom verdwenen is niets meer aan doen want want het apparaat is niet defect.

Op 7 december 2020 17:42:15 schreef Zippy1970:

Als ik de ground doorverbind met de aarde, is de brom weg. Maar zou dan niet eigenlijk de aardlek schakelaar moeten doorslaan?

Iemand enig idee waar ik dit moet zoeken?

Zippy,

er zit een ringkerntransformator in met gescheiden primaire en secundaire wikkeling. Er kan dus geen stroom (van de secundaire) terug vloeien via de aarde naar het sterpunt bij de stroomleverancier. Dus is het normaal dat je differentieel niet doorslaat.

Maak je ergens een verbinding tussen aarde en de primaire kant, dan zal de differentieel wel doorslaan.

mvg

Robbe

meet de brugcel ook even door, als die (half) defect is kun je ook dit soort gezeik krijgen....
dan krijg je namelijk dit:

ik heb dit soort defecten al heeeel veel gezien...

RTFM, dan pas vragen...

Op 8 december 2020 15:07:49 schreef maus0611:
Zit die bout rechts van de print nou tegen de print aan?

Nee, die zit er onder. Het lijkt zo omdat het hokje van de printplaat daar een beetje afgebroken is, waarschijnlijk omdat ze de bout met een dopsleutel vast hebben gezet.

Op 8 december 2020 15:08:41 schreef maartenbakker:
Die transistor zal net als de kleine elco's niet stuk zijn. Als je op de gok onderdelen vervangt dan is de kans, net als toen je begon, het grootst dat de grote elco's stuk zijn.

Hahaha ja, die grote zijn het meest verdacht, maar die had ik niet liggen en die kleine wel. En ik was toch bezig alle soldeerpunten opnieuw te solderen dus ik dacht, kom, als ik toch bezig ben... Ik ga morgen (vandaag geen tijd) langs de elektronica winkel. Neem ik ook meteen een nieuwe TDA 7294 mee. Kost toch maar een paar euro. De TDA 7294 levert 100W bij 100V. De trafo levert 28.5V (dus gelijkgericht ongeveer 32V) dan klopt die 300W continue vermogen toch wel redelijk?

Op 8 december 2020 15:37:01 schreef Robbe de Smet:
[...]

er zit een ringkerntransformator in met gescheiden primaire en secundaire wikkeling. Er kan dus geen stroom (van de secundaire) terug vloeien via de aarde naar het sterpunt bij de stroomleverancier. Dus is het normaal dat je differentieel niet doorslaat.

Ah ok. Dus het kan geen kwaad om de massa aan de aarde te leggen. Alleen gevaar voor de elektronica zelf in het geval er iets mis gaat.

Op 8 december 2020 16:19:17 schreef wielklem:
meet de brugcel ook even door, als die (half) defect is kun je ook dit soort gezeik krijgen....

Ook een goede. Ik zal 'm doormeten.

Brugcel doorgemeten en die is goed.

[...]

Ah ok. Dus het kan geen kwaad om de massa aan de aarde te leggen. Alleen gevaar voor de elektronica zelf in het geval er iets mis gaat.

[...]

Hier in dit geval kan het geen kwaad, toch ga ik je nog iets mee geven. Zie dit niet als een verwijt maar eerder als tip naar de toekomst toe.

Uit je opmerking meen ik te begrijpen dat je wat netspanning betreft niet al te goed begrijpt hoe één en ander werkt. Een punt zomaar verbinden met aarde uit een net gevoed apparaat kan ernstige gevolgen met zich mee brengen. Jij hebt geluk gehad dat je nietsvermoedend een punt uit de schakeling verbindt met de aarde die gevoed wordt uit een transformator. Niet alle apparaten hebben een transfo

Als je niet 100% weet waar je mee bezig bent niet meer doen! Nu is je probleem (deels) opgelost, maar dit kunnen we onder de noemer beginners geluk plaatsen.

Mvg

Robbe

Op 8 december 2020 19:05:37 schreef Robbe de Smet:
[...]

Jij hebt geluk gehad dat je nietsvermoedend een punt uit de schakeling verbindt met de aarde die gevoed wordt uit een transformator.

Je hebt gelijk dat ik niet (helemaal) wist hoe precies een aardlek schakeling werkte, maar inmiddels wel (heb me even ingelezen). Het aansluiten van de aarde op de massa ging eigenlijk per ongeluk. Toen ik de backplate verwijderd had, raakte hij per ongeluk de massa van de speaker en toen was opeens de brom weg. Vervolgens las ik (op dit forum nota bene) dat in België het vrij normaal is om de massa van een schakeling aan de aarde te leggen. En in dezelfde discussie dat het in Nederland niet is toegestaan (of iets in die strekking).

Mijn kennis van elektronica is beperkt, maar boven gemiddeld. Ik heb niet genoeg kennis om een schakeling te ontwerpen, maar wel om een schakeling te begrijpen als ik 'm bestudeer. Dus de meeste do's en don'ts weet ik wel. Maar inderdaad, zeker niet allemaal!

Op 8 december 2020 21:46:35 schreef Zippy1970: Vervolgens las ik (op dit forum nota bene) dat in België het vrij normaal is om de massa van een schakeling aan de aarde te leggen, En in dezelfde discussie dat het in Nederland niet is toegestaan (of iets in die strekking).

Ik denk dat je hier een paar dingen door elkaar haalt: massa met aarde verbinden is in princiepe niet verboden bij geaarde toestellen. Wat wel verboden is, dat is om metalen delen van dubbel geïsoleerde toestellen aan aarde te leggen (ik denk maar aan de behuizing). Of de massa aan de behuizing leggen bij dubbel geïsoleerde toestellen mag ook niet. Dubbel geïsoleerde toestellen hebben een aansluitsnoer zonder aarde, dus als je dat doet kan de behuizing onder spanning komen te staan. Maar in zo'n geval moet je al ferme toeren uithalen om dat te doen, gezien bij dubbel geïsoleerde toestellen de behuizing veelal volledig uit kunststof bestaan.

Dubbel geïsoleerde toestellen zijn te herkennen aan het symbooltje met een dubbel vierkant

Off-topic:

Overigens hebben randaarde en aardlekschakelaar heel weinig met elkaar te maken, een ALS werkt ook op ongeaarde groepen.