Soladin120 omvormer met afwijkend knipperpatroon


Lijkt me een hikkende voeding syndroom. Elco's niet bol? Dit patroon staat idd niet in de handleiding. Een defect wordt weergegeven met de rode led.
Je hebt de print open gehad. Heb je er goede foto's van?

Geen aardingsprobleem met het paneel? Verliesstroom, ook al is die galvanisch gescheiden.

Hallo Eric,

De elco's staan niet bol. Zie ook de 2 fotos.

Als ik de elco's in de schakeling meet komt de waarde overeen met de goed werkende Soladin.

Het zonnepaneel staat los en werkt goed met de andere soladin. Dus ik denk geen aardingsprobleem.

Shiptronic

Golden Member

Je hebt een goed werkende , dus kan je onderdelen uitmeten/ wisselen

Wie de vraag stelt, zal met het antwoord moeten leren leven.

Tja. Gezond is dat niet. Lijkt me dubbelzijdig dus soldeerschade is snel gemaakt.

@Nico. Is er een foto vd onderzijde? Ik mis 99% vd onderdelen.

Neen, onderdelen uitwisselen kon vroeger met die grote prints maar is met dit priegelwerk vragen om problemen. Dat ga ik dus niet doen.

Bijgevoegd de foto van de onderzijde.

Ziet er wel allemaal strak uit en niet china kwaliteit. Naast de groene connector zit precies een stabilisator? Voeding vd IC's? Verder lijkt het me te complex om zo advies te geven.
De datasheets vd IC's er bij halen en kijken of hun Vcc ok is mss...

Ik heb met mijn in circuit metingen toch een klein verschil gemeten tussen de goede en kapotte soladin. Zie bijgevoegde foto.

Het gaat om het blauwe onderdeel in de hoek van de 220 volt kant met de opdruk 87128 etc.
Het leek mij een condensator (wel met een voor mij onbekende opdruk) en daarom heb ik in-circuit de capaciteit gemeten met mijn UT139C meter.

In de goede soladin meet ik 242 nf. In de 'kapotte' soladin meet ik 149 nf.

Is dit inderdaad een condensator en zou dit de oorzaak kunnen zijn?

Dat is een 275vac mkt x2 220nF. Die blauwe zijn meestal van goede kwaliteit maar zo zie je maar dat ook deze sneuvelen. Ik dacht dat ze een ontstorende functie had maar je weet het pas zeker met een nieuwe. Ik zat me ook af te vragen wat het maximum vermogen is dat je ongevraagd via dit soort toepassing op het net mag sturen?

Edit. Volgens mij is het ook 07:28 ipv 87128

Bedankt Eric, dat geeft mij de zekerheid die ik zocht mbt dit onderdeel.

Je mag 600 watt via bestaande groepen op het net zetten. Als het meer is moet je aparte groepen maken.

Ik ga dit onderdeel uitwisselen en koppel het resultaat terug.

Heb net even getest met een goede condensator.

Helaas het zelfde beeld. Dat was dus niet de oorzaak.

Deze condensator zit over de 220 volt klemmen dus eigenlijk ook wel een beetje logisch.

Heeft iemand nog een goed idee om dit opgelost te krijgen?

EL83

Special Member

Op 6 maart 2021 20:54:30 schreef Nico120:
Je mag 600 watt via bestaande groepen op het net zetten. Als het meer is moet je aparte groepen maken.

Pas wel op, met de NEN1010 2015 is deze vrijstelling vervallen (was eerder 2,25A maximaal terugleveren op stekker)

Tegenwoordig heb je voor alles wat terug kan leveren, zelfs voor een 120w omvormer een aparte groep nodig (tenzij je het aannemelijk kan maken dat de situatie van voor 2015 bestaat :+.

Nog een puntje van aandacht wat betrekking heeft tot alle PV installaties in Nederland:

Bij vervangen van de omvormer of het aanpassen van het vermogen van de PV installatie moet deze installatie meteen aan de laatste normen voldoen.

@EL83. Bedankt voor de toelichting. Wel interessant dat het mag zonder veel papierwerk.

@Nico. Idd ontstoorachtige functie dus. Voeding nagekeken vd IC's? Die TO220 naast de groene stekker. De zon is op, het paneel levert terug...

De TO220 naast de groene stekker is een mosfet IPS0151 en die is nog goed.
Die zit overigens aan de zonnepaneel-kant en m.i. zit de storing aan de 220v kant.

Toch weer even doorgegaan met meten van de schakeling en waardes vergeleken met de goede soladin.
En wederom bingo.

Er zitten 2 diodes links in de hoek aan de 220 volt kant (zie de foto van de onderkant hierboven) waarvan er 1 geen 0,6 volt meer weergeeft bij de meting. Bij de goede soladin is dat wel ca 0,6 volt.

De opdruk is erg moeilijk leesbaar. Het lijkt op het volgende:
FT338 S1M. De S1M is wel duidelijk leesbaar.

Ik kon zo snel geen datasheet vinden op internet. Wellicht dat het net wat andere letters of cijfers zijn. Iemand een idee?

hobby-ist

Honourable Member

De heer Schrijver uit Drachten heeft er zijn levenswerk van gemaakt om deze Soladins in leven te houden. Dus zou het jou niet lukken, dan adviseer ik je kontakt op te nemen met hem.
Hij heeft in ieder geval zeker onderdelen.
Mogelijk koopt hij ook defecte of niet meer te maken Soladins in voor de onderdelen.
Succes met de reparatie. Hoop dat het lukt.

Er ist wieder da...

Allemaal bedankt voor het meedenken.

Ik had nog een 1N4007 liggen (is ook 1000v, 1A). Die heb ik over de kapotte SMD-diode gesoldeerd.

Ga morgenochtend testen als de zonnepanelen voldoende spanning hebben.
Ik heb goede hoop dat dit de oplossing is.

Peter112

Special Member

Op 7 maart 2021 20:46:12 schreef Nico120:
Allemaal bedankt voor het meedenken.

Ik had nog een 1N4007 liggen (is ook 1000v, 1A). Die heb ik over de kapotte SMD-diode gesoldeerd.

Ga morgenochtend testen als de zonnepanelen voldoende spanning hebben.
Ik heb goede hoop dat dit de oplossing is.

nou maar hopen dat die oude niet in sluiting gaat als er weer prik overheen komt te staan.

edit, zie volgende post.

[Bericht gewijzigd door wvogel57 op 7 maart 2021 23:04:21 (83%)]

Niet goed. Als de kapotte diode een kortsluiting is geworden, blijft de fout. Dus de kapotte diode lossolderen !
.

[Bericht gewijzigd door wvogel57 op 7 maart 2021 23:03:33 (11%)]

Even een reactie op de laatste opmerkingen en een update:

Bij het doormeten van de kapotte diode was de weerstand in de geleide richting oneindig. Daardoor kon ik er een diode overheen solderen. Dat wilde ik om niet ongewild printsporen kapot te maken.
Voorts had ik de omvormer al even in het stopcontact gedaan zonder zonnepanelen.

Helaas was dit niet de oplossing. Het rare knipperpatroon blijft.

Bij mijn verdere metingen leek het alsof een van de 2 mosfets in het ingangscircuit kapot was. Dit zijn 75545 mosfets.
Dat bleek een foute meting te zijn dus helemaal voor niets de mosfet uit de schakeling gesoldeerd met mijn desoldeerbout.

Wat mij bevreemde is dat zonder deze mosfet het rare knipperpatroon het zelfde bleef bij het testen met een zonnepaneel en de 220 volt aangesloten.

Ik kwam op internet een beschrijving tegen om mosfets met een multimeter te testen. Het is deze site: https://www.utm.edu/staff/leeb/mostest.htm#:~:text=1)%20Hold%20the%20M….

Ik heb deze methode op mijn los gesoldeerde mosfet losgelaten en dit leek wel te werken. Heeft iemand hier ervaring mee?

En kun je een mosfet ook makkelijk in-circuit testen?

En tot slot: heeft iemand nog een idee welke component de oorzaak zou kunnen zijn?

Die kapotte diode is waarschijnlijk een ultrafast diode en gaat een 1N4007 dus niet werken en zal zich als sluiting gedragen! Een UF4007 is wél een ultrafast diode.

Een N-channel mosfet kan getest worden door de multimeter op de diode-stand te zetten en vervolgens de plus op de source (rechterpoot) te zetten en de min op de drain (metalen achterkant), middelste poot. De meter moet dan ongeveer 500mV geven. Wanneer de MOSFET uit het circuit is, dan moet bij dezelfde test wanneer in plaats van de source de gate (linkerpoot) met de plus aangeraakt wordt de MOSFET in geleiding gaan. Hierdoor wordt de eerder genoemde spanningsval ongeveer 100mV i.p.v. 500mV. De gate kan weer ontladen worden door de meetpen tussen de gate en de drain te doen en deze vervolgens naar de drain te trekken. Nu moet de meter met de plus op de source en de min op de drain weer ongeveer 500mV aangeven.

Controleer ook de 4 MOSFETS van de H-brug (4 koperkleurige plaatjes achter elkaar). Deze moeten de hoge DC-busspanning omzetten naar een SPWM signaal die door het LC-filter omgezet wordt naar een zuivere en gesynchroniseerde sinus.
Ook de drivers voor de MOSFETS of de HF-trafo (geelkleurig groot blok) kunnen kapot zijn waardoor de microcontroller dit als een harde sluiting ziet.
Het zwakke punt in een omvormer zijn vooral de 2 MOSFETS aan de push-pull zijde, waar ook het zonnepaneel (of bij een off-grid inverter de accu) direct mee in verbinding staat. Deze gaan over het algemeen het vaakst kapot omdat deze een behoorlijke stroomsterkte moeten verwerken (en daarom ook altijd goed gekoeld moeten worden).

Verder raad ik aan om bij het testen een kachel of iets dergelijks in serie te zetten om verdere schade te voorkomen!

Bedankt HVinduction.

De kapotte diode was een S1M (zie enkele posts hierboven) en dat is echt een universele diode.

Alle mosfets in de schakeling gedragen zich zoals door jou genoemd (ca 500 mv).
Ook de 2 mosfets aan de push-pull zijde die vaak kapot gaan.

De mosfet die ik los gesoldeerd had (1 vd 2 van de push-pull kant) gedraagt zich ook zoals door jou beschreven buiten de schakeling.

De rest van de schakeling is zo klein dat ik me daar eigenlijk niet aan wil wagen.

Ik krijg binnenkort een simpele osciloscoop. Welke punten kan ik dan het best gaan bekijken om een kapot onderdeel te kunnen traceren.

Anders vrees ik dat mijn onderzoek hier gaat stoppen.

Shiptronic

Golden Member

Zorg voor een goede differentiaal probe voor dat je aan dat ding gaat meten, ander kans dat gelijk je scoop omzeep is ;)

Wie de vraag stelt, zal met het antwoord moeten leren leven.

Inmiddels heb ik contact gehad met de heer Schrijver uit Drachten met de vraag of mijn knipperpatroon hem bekend voorkwam.

Chapeau dat hij mij wilde antwoorden.

Dat patroon kwam hem inderdaad bekend voor en betekent in feite dat de sturing van de 2 push-pull mosfets aan de ingang kapot is.

Ofwel de UCC3806 ofwel (een poort van) de microprocessor.
Het omwisselen van dit soort ic's gaat mijn gereedschap echter te boven.

Ik staak deze reparatie derhalve en heb nu wat reserve onderdelen voor de goede Soladin 120.

Iedereen bedankt voor het meedenken en wat mij betreft kan dit topic gesloten worden.