Sony mainboard testen

Beste,

Ik heb een sony KD49x8309c met een defect mainboard. Deze blijft in de android bootloop hangen. Een probleem met de NAND/eMMC chip waarschijnlijk.

Nu kon ik eindelijk een mainboard overnemen van eenzelfde type tv, waarvan het scherm defect zou zijn. Foto's gezien, zelfde boardje dus zou moeten passen, dacht ik.. want na het wisselen van het mainboard, start te tv nog steeds niet op, lijkt het. Het beeld blijft zwart. Het led onder de tv blijft wit.

Nu is de vraag: kan het zijn dat ik het t-conboard ook moet vervangen?

Tussen mijn defecte mainboard, en dit nieuwe mainboard merk ik wel verschillen op. Mijn defecte mainboard start op, komt in een bootloop terecht. Dit mainboard, daarvan blijft het beeld zwart. De LED onder de tv blijft continue wit.

Haal ik de 2 LVDC-kabels los en start ik de tv opnieuw op, dan is bij mijn defecte mainboard gebeurd er niets. Bij het 'nieuwe' mainboard, licht het scherm op om vervolgens achtereenvolgens volledig rood, blauw of..nog een kleur op te lichten. Daar zit dus veel meer leven in, dan bij mijn mainboard in een bootloop.

Vraag is: hoe kan ik testen of mijn 'nieuwe mainboard' inderdaad werkend is? En, kan het zijn dat ik ook het t-con moet vervangen?

De verkoper heeft een maand over het verzenden gedaan en heeft na betaling niets meer laten horen. Op een andere advertentie reageerde ie dus wel.. dus ik heb mn twijfels over zijn eerlijkheid. Dacht eigenlijk opgelicht te zijn..

Bij Sony moet je 'aanmelden' cq legitiem dan wel legaal maken via een speciaal aanmeld en installatie proces. Ooit een keer bij de hand gehad toen ik van een 40 het defecte mainboard had vervangen uit een 32 sloper met defect scherm.

Waar het moederbord het meeste rookt, loopt ook de meeste stroom!

Geen idee, zou zomaar kunnen. Maar dacht eigenlijk dat deze gewoon 1 op 1 om te wisselen zouden zijn, omdat ze exact hetzelfde type zijn. Dat ´aanmelden', hoe doe ik dat?

Klopt het van de kleuren wel, dat deze achtereenvolgens weergegeven worden op het scherm als de 2 LVDS-kabels losgekoppeld zijn?

maartenbakker

Special Member

Die kleuren zijn een ingebouwde test van de TCON, dus dat klopt wel.

Aanmelden zou betekenen dat het mainboard kunstmatig gekoppeld is aan de TCON, iets anders kan niet echt. Ik had er nog nooit van gehoord, maar het zou kunnen.

www.deficientie.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Betekent dat dat ik dan ergens in de instellingen moet zoeken om 'm te koppelen? Of, heb ik het t-con uit de andere tv ook ervoor nodig?

Voor mij is dit allemaal nieuw namelijk.

maartenbakker

Special Member

Als ik er tegenaanliep en mij zou verteld worden dat er een aanmeld- en installatieproces is, dan zou ik het inderdaad met de bijbehorende TCON proberen.

Maar wacht eventueel nog even af of er een reparateur langskomt die bekend is met recente Sony's.

www.deficientie.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Op 11 juni 2021 22:36:06 schreef maartenbakker:
Die kleuren zijn een ingebouwde test van de TCON, dus dat klopt wel.

Aanmelden zou betekenen dat het mainboard kunstmatig gekoppeld is aan de TCON, iets anders kan niet echt. Ik had er nog nooit van gehoord, maar het zou kunnen.

Ik weet nog dat ik i.i.g. een firmware upgrade moest doen omdat de vervanger uit een 32" kwam. Die "aanmelding" bestond er uit dat na de upgrade er middels een bepaalde toetscombi op de AB de zaak "legaal" o.i.d. gemaakt moest worden. Voor die handeling had je wel beeld en geluid, maar niet langer dan ongeveer een minuut, dan ging ie standby en powerled knipperen en moest eerst de voeding er 5 minuten af.

Volgens Sony zelf kan en mag het mainboard zomaar vervangen niet. Was iets met dat je het oude board moest opsturen voor vernietiging voordat je een nieuwe kreeg. Iets met beschermde patenten en privacy gedoe omdat een smarttv persoonlijke data als abonnee aanmeld gegevens kan bevatten e.d.

Maar een originele nieuwe van Sony was sowieso geen optie omdat die 550.- ex btw koste. Die 32" sloper was 25.- euro. Was scherm van defect geraakt tijdens/na een voetbalwedstrijd o.i.d.

Waar het moederbord het meeste rookt, loopt ook de meeste stroom!

Als alleen de witte led brand en voor de rest doet het ding niets dan is er echt wel wat aan de hand. Als het mainboard uit eenzelfde toestel komt met eenzelfde t-con dan is het meestal meteen werken, dat zou ook de witte led verklaren. Als het namelijk uit een andere model zou komen en de t-con is niet "gekoppeld" dan knippert de led groen / amber om en om. Dat zou op te lossen zijn door de firmware opnieuw te laden wat in dit geval niet zo is. Mocht het mainboard afkomstig zijn uit een groter toestel waarbij een losse led driver is gebruikt wat eenvoudig te herkennen is aan een extra aansluiting boven de power connector dan gaat het ook niet werken.

Het mainboard zou uit dezelfde tv komen van hetzelfde merk/type.

Zal proberen of ik het tcon board er ook bij kan kopen. Dat heb ik in eerste instantie geweigerd, want daar wou de verkoper extra euro's voor.

De verkoper was nogal een 'aparte'. Na betaling een maand niet reaheren, maar wel pogen een identieke tv te kopen. En opeens een maand later een tracktracecode ontvangen.

William u wil dus zeggen dat u steeds t,con mee moet vervangen indien u het mainboard vervangt had er 2 vandeze modellen staan en 1 met kapot scherm na het vervangen van mainbord alleen knipperen van de led tv ,s daarna voor export weg gedaan maar nu weet ik dat voor in het vervolg bij sony

Ik zal de verkoper vragen om foto's van zijn t-con, zodat ik die in ieder geval kan vergelijken. Meneer wou het mainboard voor een tientje erbij verkopen.

Nu is een zwart beeld, eveneens een symptopn dat kan optreden bij een defect mainboard van dit type, dus daarom ben ik een tikje wantrouwend of ik die extra euro's er nog wel in moet stoppen. Zeker ook omdat de verkoper niet de betrouwbaarste bleek.

Ik heb de mainboards vergeleken en deze zijn identiek. Wel is een van de stekkers van de lvds kabel iets anders. De code onder het QR-vierkantje is identiek: y210b300c en ik heb vernomen dat dat met de software te maken heeft?

[Bericht gewijzigd door enweereentje op 17 juni 2021 23:07:02 (22%)]

Op 11 juni 2021 20:16:43 schreef enweereentje:
Beste,

Ik heb een sony KD49x8309c met een defect mainboard. Deze blijft in de android bootloop hangen. Een probleem met de NAND/eMMC chip waarschijnlijk.

De Philips TVs die je hier veel vindt zitten meestal ook in een bootloop.
Daar is het probleem dan meestal de fusion chip, type BGA.
Zou bij die Sony misschien ook het probleem kunnen zijn? (Veel kans op denk ik.)
Reballen kan een oplossing zijn.

Proberen waard, als je me een mailtje stuurt kunnen we mss wel iets afspreken.

Kan je fotos of een link plaatsen van de printen, liefst zonder koelplaten op de BGAs?

Op 17 juni 2021 22:39:46 schreef maxtv:
William u wil dus zeggen dat u steeds t,con mee moet vervangen indien u het mainboard vervangt had er 2 vandeze modellen staan en 1 met kapot scherm na het vervangen van mainbord alleen knipperen van de led tv ,s daarna voor export weg gedaan maar nu weet ik dat voor in het vervolg bij sony

Nee, je moet de firmware opnieuw installeren, dan wordt de t-con weer gekoppeld met het mainboard.

Op 18 juni 2021 10:57:27 schreef Deusjevoo:
[...]

De Philips TVs die je hier veel vindt zitten meestal ook in een bootloop.
Daar is het probleem dan meestal de fusion chip, type BGA.
Zou bij die Sony misschien ook het probleem kunnen zijn? (Veel kans op denk ik.)
Reballen kan een oplossing zijn.

Proberen waard, als je me een mailtje stuurt kunnen we mss wel iets afspreken.

Kan je fotos of een link plaatsen van de printen, liefst zonder koelplaten op de BGAs?

Bij deze Sony's is meestal de oorzaak de EMMC, dit is ook een BGA maar veel kleiner en die moet geprogrammeerd zijn. De processor zal in sommige gevallen ook wel eens defect/los kunnen zijn maar dat ben ik nog niet tegen gekomen.

En kan je die zelf flashen in dit geval William??

Ja, mits je de software hebt, alleen Netflix werkt niet en de CI module werkt niet maar dat laatste heb ik nooit kunnen testen.

Begrijp ik het goed dat ik dus de firmware opnieuw erop moet zetten?

Downloaden op een geheugenstick en dan inbde usb-poort en de tv inschakelen?

Op 18 juni 2021 20:19:43 schreef enweereentje:
Begrijp ik het goed dat ik dus de firmware opnieuw erop moet zetten?

Downloaden op een geheugenstick en dan inbde usb-poort en de tv inschakelen?

@william1967 :
bedankt voor de update. Ook eens gegoogled, vertelt hetzelfde. Met commentaar aan enweereentje wil ik je zeker niet tegenspreken. Gewoon benieuwd en zou 't eens willen testen. Wie weet...

@enweereentje :
Nee, als de eMMC stuk is moet je een nieuwe eMMC plaatsen welke je eerst moet programmeren met een programmer die ook eMMC kan programmeren.
Hiervoor heb je dan een originele of van een andere tv gedumpte firmware bin file voor nodig. Zoals william al zei, niet alle functies zullen nog werken.

eMMC is nog het meest te vergelijken met NAND geheugen in een SSD.
Ze hebben weliswaar een beperkt aantal schrijfcycli maar eer je daar aan geraakt...
Ze kunnne ook redelijk heet worden en gezien het BGA zijn falen ze soms ook al zijn ze zo klein ook wel door het lossen van soldeerverbindingen. Denk zelfs dat vaker voorkomt dan dat ze stuk gaan.

Best mogelijk een eMMC reball je probleem oplost.
Ok, alle chips kunnen stuk gaan, ook BGAs. Reballen is niet altijd een oplossing maar in dit geval misschien toch het proberen waard.

Wil het gerust testen, baat het niet...

Ik heb 2 mainboards: een in de android bootloop. Daar is de emmc chip de boosdoener.

En een tweede mainboard, die uit een werkende identieke tv zou komen. Echter, deze geeft geen enkel beeld in mijn tv, maar ledbalk onder de tv kleurt en blijft wel wit.. Koppel ik de lvds-kabels los dan verschijnen achtereenvolgens de diverse kleuren in beeld. Deze is wellicht gekoppeld aan een andere tcon.

Ik doelde met de vraag aan William dus op dat tweede mainboard.

Op 19 juni 2021 02:10:03 schreef enweereentje:
Ik heb 2 mainboards: een in de android bootloop. Daar is de emmc chip de boosdoener.
En een tweede mainboard, die uit een werkende identieke tv zou komen. Echter, deze geeft geen enkel beeld in mijn tv, maar ledbalk onder de tv kleurt en blijft wel wit.. Koppel ik de lvds-kabels los dan verschijnen achtereenvolgens de diverse kleuren in beeld. Deze is wellicht gekoppeld aan een andere tcon.

Ik doelde met de vraag aan William dus op dat tweede mainboard.

Het probleem is dat je het 2e mainboard zelf nooit werkend hebt gezien, een witte led kan duiden op een goede koppeling met de t-con maar dat is giswerk mijnerzijds. De EMMC zal op het einde van zijn leven zijn, dat is meestal de melding die mijn programmer aangeeft bij deze Hynix EMMC's. Opnieuw laden heeft geen zin, kost een berg tijd en het werkt niet, vervangen is de enige oplossing. Het probleem dat een deel niet werkt is voor Netflix eenvoudig op te lossen middels een mediaplayer van een paar tientjes en omdat de meeste via HDMI kijken is de CI ook meestal geen probleem. Ik heb er al enkele tientallen kunnen redden op deze manier.