Defecte Iso Tech PS 303 DD regelbare voeding

Beste CO' ers

Onlangs ben ik bljkbaar wat onvoorzichtig geweest en heb ik vermoedelijk door of verkeerd aansluiten of door overbelasting mijn regelbare voeding naar de Filistijnen geholpen.

Hij lijkt geen spanning meer af te geven (Display blijft op 0,0 staan), maar als ik de stroom opdraai, meet hij wel stroom.
Dus de stroomregeling lijkt wel te functioneren.

Het lijkt dus alsof er een tor gesneuveld is en er intern sluiting lijkt te zijn, gezien de stroomregeling wel functioneert.

Nu weet ik wel wat elektronica dingen, maar schema's en dergelijke uitpluizen is nooit echt mijn sterkste kant geweest.

Kan iemand tips aanreiken welke onderdelen verdacht kunnen zijn ?

Op internet heb ik het volgende schema gevonden:

https://www.eevblog.com/forum/repair/good-will-gps-3030-schematic/?act…

(gepikt van https://www.zendamateur.com/viewtopic.php?p=245224)

bij voorbaat dank voor de hulp!

Als het niet kan zoals het moet , dan moet het maar zoals het kan

Wekt het apparaat de indruk dat hij ook daadwerkelijk stroom levert, dus wordt het koellichaam warm na een tijdje op een flinke stroom, of geeft het wat bromgeluiden ?

Zo ja dan zou ik D117 over de uitgang verdenken, of C118 mocht dat een tantaaltje zijn. Die kan men allicht in sluiting blazen met een flinke inductieve last.

Zonder te meten kan ieder onderdeel verdacht zijn.
Meet eerst of je 24 volt hebt op de aangegeven punten,
Meet ook of je + en - 15 volt hebt op de ic's.

Dank voor de antwoorden, ik ga hem openschroeven en kijken of ik wat items kan controleren.
Intussen vond ik ook dit topic, en dat lijkt er verdacht veel op,
https://www.electronicspoint.com/forums/threads/wanting-help-fixing-be…

ik houd jullie op de hoogte

Als het niet kan zoals het moet , dan moet het maar zoals het kan
flash2b

Golden Member

Jouw Iso-Tech is de RS variant gemaakt door GW Instek, wat een tamelijk goed merk is. Die voeding in die blog is een chinese kloon, er zijn veel (slechte) klonen van deze GW Instek gemaakt, jouwe zo een stuk beter moeten zijn.

Allen bedankt, net als in het topic (te vinden in de eerder vermelde link) blijkt de Reverse Polarity Protection diode de geest gegeven te hebben, in mijn geval een 1N5402.

Diode losgesoldeerd en de voeding werkt weer.
Ik zal kijken of ik ergens nog een zelfde diode heb liggen of anders wat bestellen!

Als het niet kan zoals het moet , dan moet het maar zoals het kan

Pak maar een dikkere diode plus een zekering. Dan hoef je de volgende keer alleen maar de zekering te vervangen.

Bezoek mijn neefjes' site: www.tinuselectronics.nl
flash2b

Golden Member

Dan moet je de zekering wel tussen de + en de uitgang zetten direct na de clamping diode, want anders werkt het averechts.

Zoiets dus:

code:


          Zekering 3A
           ____    
>-----+---+____+-------<  + Voeding
      |
      |
     _|_
     /|\  30A Diode
      |
      |
>-----+----------------<  - Voeding

Een 30A diode kan waarschijnlijk wel de piekstroom aan die bij een verkeerd aangesloten accu kan gaan lopen. De zekering moet wel eerder sneuvelen dan de diode.

[Bericht gewijzigd door ohm pi op 17 oktober 2021 19:35:12 (28%)]

Bezoek mijn neefjes' site: www.tinuselectronics.nl