Kabel remeha calenta icm recom werkt niet


Op 24 januari 2022 07:46:46 schreef HenkR:
De kabel is waarschijnlijk bedoeld voor iets anders. Het zou nog kunnen dat de ftdi chip is ingesteld als reverse. Dan inverteerd hij alle signalen. Er is een gratis programma te downloaden via de ftdi site.

Is het bekend hoe deze ingesteld moet zijn? Ik ga vanavond weer even verder met dit project

Anoniem

Het programma is FT-prog en daar zie je bij alle in/uitgangen de mogelijk om te inverteren. deze moeten allemaal uit staan.

PE9SMS

Golden Member

Op 23 januari 2022 20:35:13 schreef A vd Linden:
De foutmelding wijst eigenlijk op een rechten probleem. Toegang geweigerd.
Probeer eens uitvoeren als administrator.

Mee eens, of er nu seriele communicatie is of niet (bijv verkeerde baudrate), je moet op z'n minst de comport kunnen openen zonder foutmeldingen zoals "toegang geweigerd".

This signature is intentionally left blank.

Ik krijg de melding dat er geen toestel is aangesloten terwijl dat wel het geval is. De eerdere melding die ik kreeg ( geen toegang) kreeg ik als ik gtwcom3 selecteerde maar dat dat klopt want ik gebruik immers geen gateway.

Ook in dat geval zou ik een "device not found" of een timeout verwachten. Access denied wijst naar een rechten, dus software probleem. Heb je de driver al eens opnieuw geinstalleerd? Wel eerst echt verwijderen.

RAAF12

Golden Member

Idd, mijn idee. Hij spreekt verschrikkelijk Engels maar op deze manier en met dat driverpack moet het gaan werken, let op volgorde van installeren.
https://www.youtube.com/watch?v=7IKsJzq3JCU

Ik heb hem geprobeerd uit te lezen via realterm. Als ik aan de kabel morrel bij de stekker van de ketel dan geeft die broek Error en soms rxd. Ik heb de stekker doorgemeten rj tot op de chip en die is op alle draden in orden. Vervolgens heb ik alles doorgemeten tot op de usb als de stekker in de ketel zat. Ook dat was in orde. Ik dacht mogelijk dat de aansluiting op de ketel was maar ook dat is niet het geval.

Als ik niet het stekkertje heen en weer bewoog gebeurde er helemaal niets

Op 24 januari 2022 14:47:44 schreef RAAF12:
Idd, mijn idee. Hij spreekt verschrikkelijk Engels maar op deze manier en met dat driverpack moet het gaan werken, let op volgorde van installeren.
https://www.youtube.com/watch?v=7IKsJzq3JCU

Gedaan, krijg dan de melding dat alles al correct is geïnstalleerd, en dat klopt ook

Heb je iets anders wat je aan de kabel kunt hangen om te kijken of dat wel werkt?
Heeft de eventlog nog iets te melden over de usb?

[Bericht gewijzigd door A vd Linden op 24 januari 2022 16:10:26 (24%)]

het licht gaat een beetje uit, ik heb verder niets wat ik er aan kan hangen.
eerder aangegeven om de om de tx en en de rx met elkaar te verbinden. dat heb ik gedaan maar dat geeft geen resultaat. mogelijk omdat ik ook nog iets met ground moet doen voordat het gaat werken, dat is mij niet helemaal duidelijk

PE9SMS

Golden Member

Dat is een goede test inderdaad, rx en tx met elkaar verbinden, ground hoef je niets mee te doen. Dan zou je in een terminalprogramma (Teraterm, Realterm, etc) de tekst moeten zien die je zelf intikt. En als je in het terminalprogramma de optie local echo aanzet dan moet je ieder karakter dubbel zien verschijnen.

This signature is intentionally left blank.

Op 24 januari 2022 16:37:51 schreef PE9SMS:
Dat is een goede test inderdaad, rx en tx met elkaar verbinden, ground hoef je niets mee te doen. Dan zou je in een terminalprogramma (Teraterm, Realterm, etc) de tekst moeten zien die je zelf intikt. En als je in het terminalprogramma de optie local echo aanzet dan moet je ieder karakter dubbel zien verschijnen.

Gedaan en dan zie ik de communicatie, dus dat lijkt goed te werken.
Het lijkt er dan dus op dat die aansluiting op mijn ketel niet goed functioneerd. Is dat iets wat ik nog kan controleren?

Op 24 januari 2022 10:05:06 schreef HenkR:
Het programma is FT-prog en daar zie je bij alle in/uitgangen de mogelijk om te inverteren. deze moeten allemaal uit staan.

enig idee welke ik dan moet hebben ?

PE9SMS

Golden Member

Op 24 januari 2022 16:46:14 schreef Knoem:
[...]

Gedaan en dan zie ik de communicatie, dus dat lijkt goed te werken.
Het lijkt er dan dus op dat die aansluiting op mijn ketel niet goed functioneerd. Is dat iets wat ik nog kan controleren?

Ook gechecked dat local echo aanzetten dubbele karakters geeft? (Want als local echo toevallig al aan stond heb je alsnog geen communicatie als je je eigen tekst in enkelvoud ziet.)

[Bericht gewijzigd door PE9SMS op 24 januari 2022 16:59:47 (14%)]

This signature is intentionally left blank.
Anoniem

Op 24 januari 2022 15:58:48 schreef Knoem:
Ik heb hem geprobeerd uit te lezen via realterm. Als ik aan de kabel morrel bij de stekker van de ketel dan geeft die broek Error en soms rxd. Ik heb de stekker doorgemeten rj tot op de chip en die is op alle draden in orden. Vervolgens heb ik alles doorgemeten tot op de usb als de stekker in de ketel zat. Ook dat was in orde. Ik dacht mogelijk dat de aansluiting op de ketel was maar ook dat is niet het geval.

Als ik niet het stekkertje heen en weer bewoog gebeurde er helemaal niets

Ik denk dat het rj11 stekkertje van de kabel niet goed is. Als je kunt zou ik die vervangen.

Op 24 januari 2022 16:55:08 schreef PE9SMS:
[...]Ook gechecked dat local echo aanzetten dubbele karakters geeft? (Want als local echo toevallig al aan stond heb je alsnog geen communicatie als je je eigen tekst in enkelvoud ziet.)

dit begrijp ik niet zo goed, ik zie enkel wat ik heb ingevoerd en zie dan de blokjes geel worden bij het typen RXD TXD

Op 24 januari 2022 17:01:15 schreef HenkR:
[...]

Ik denk dat het rj11 stekkertje van de kabel niet goed is. Als je kunt zou ik die vervangen.

zat ik ook al aan te denken, heb ik nu even niet voor handen. Maar ik heb hem doorgemeten en het lijkt goed.

Anoniem

Dat wil niet zeggen dat hij goed contact maakt met de ketel.

Op 24 januari 2022 17:23:25 schreef HenkR:
Dat wil niet zeggen dat hij goed contact maakt met de ketel.

Eens ik ga kijken wat ik vanavond kan regelen

Op 24 januari 2022 17:23:25 schreef HenkR:
Dat wil niet zeggen dat hij goed contact maakt met de ketel.

Morgen even stekkertjes kopen, maar is het ook mogelijk om met de multimeter te meten of er signaal uit de ketel komt?

Anoniem

Het is zeker niet aan te raden om met meetpennen in de RJ11 connector op de pcb te gaan meten. De kans is groot dat je de contactveren beschadigd en dan krijg je zeker geen verbinding meer. De signalen zijn haast niet te meten omdat de rx aansluiting van de ketel altijd 0V zal zijn. De tx zal pulsen geven maar het is de vraag wat een multimeter daarvan laat zien.

Nieuwe stekker er op gezet, resultaat is en blijft het zelfde. Wel een nieuwe krimptang rijker en 9 rj9 stekkertjes.

Kan het zijn dat de kabel te lang is?

Anoniem

Nee, de lengte komt niet zo nauw. De originele kabel is bijna 2 meter. In welke woonplaats woon je?

Op 25 januari 2022 16:12:18 schreef HenkR:
Nee, de lengte komt niet zo nauw. De originele kabel is bijna 2 meter. In welke woonplaats woon je?

Voorschoten,

Anoniem

Dat is hier niet dichtbij anders had je mijn kabel kunnen lenen. Misschien is er iemand bij jou in de buurt die een werkende kabel heeft, dan kun je kijken of het dan wel werkt.

Als de kabel aangesloten is op de USB poort van de computer zonder aangesloten ketel geeft Recon een melding dat er geen toestel is aangesloten. De foutmelding die jij laat zien is geen Recon foutmelding maar komt uit Windows. Probeer een andere computer als je die hebt of kunt lenen.