PWM IC in voedinkje met SDH8303 (Silan) wil niet.

vergeten

Golden Member

Ik heb een apparaat met daarin een voeding gebaseerd op het IC de Silan SDH8303.
De buffer elko's meten 320v DC
De uitgangsspanning is 12v DC.
Daarvan is D7 in sluiting geraakt door onbekende oorzaak.
De afbeelding komt uit de chinese datasheet maar in dit geval is D7 een SR3100 schottky diode (3A/100v).
Nu heb ik het vermoeden dat er meer is gesneuveld (niet zichtbaar)
want met een andere (test)shottky diode doet hij ook niks.

Enig idee hoe ik kan vaststellen of het IC defect is (hij heeft geen open dakje) :)

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Is de fusible resistor van 22 ohm niet kapot? (TL431 wil ook wel eens sneuvelen)

[Bericht gewijzigd door Arco op 2 oktober 2022 14:39:17 (28%)

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com
vergeten

Golden Member

In mijn geval is die 10 Ω en in orde, de diodes zijn ook in orde.
De meeste discrete componenten heb ik al gemeten en die zijn goed.
De condensator EC3 is in mijn geval 22µF 50v en die meet nog maar 18µF met een ESR van 1,6Ω.
Omdat ik net geen vervanger in huis heb kan ik die niet uitwisselen.

[Bericht gewijzigd door vergeten op 2 oktober 2022 14:45:41 (63%)

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Wat bedoel je met "de uitgangsspanning is 12v"?
1. De secundaire doet het wel? D7
2. zou 12v moeten zijn?
3. De secundaire aan de primaire zijde om het ic te voeden? D6

Wat meet je op FB en VDD. Doet de Drain uberhaupt wat? EC3 stuk?

Instruction manual? You mean the manufacturers opinion?

Op 2 oktober 2022 14:38:16 schreef Arco:
(TL431 wil ook wel eens sneuvelen)

Dan verwacht ik toch een beetje actie op FB of VDD

Ik zie op het schema de R3 niet aan de massa liggen. Vreemd.

Benieuwd of die dingen ergens te koop zijn buiten ali.

[Bericht gewijzigd door EricN op 2 oktober 2022 14:59:36 (11%)

Instruction manual? You mean the manufacturers opinion?
vergeten

Golden Member

Op 2 oktober 2022 14:42:43 schreef EricN:
Wat bedoel je met "de uitgangsspanning is 12v"?

Dat zou de de uitgangsspanning moeten zijn.
Met een externe 12v voeding bypass ik de defecte voeding en dan werkt het hele apparaat prima.

1. De secundaire doet het wel? D7

Nee, die lag in sluiting schreef ik in mijn startpost.

3. De secundaire aan de primaire zijde om het ic te voeden? D6

is OK

Wat meet je op FB en VDD. Doet de Drain uberhaupt wat? EC3 stuk?

De condensator EC3 is in mijn geval 22µF 50v en die meet nog maar 18µF met een ESR van 1,6Ω. (1kHz)

EDIT: (aanvulling vanaf kladblaadje)
op 10kHz 15,9µF/ESR 0,83Ω en
op 100kHz 20,8µF/ESR 0,73Ω.

FB en VDD moet ik nog ff meten binnenkort.    Apparaat staat niet bij mij.

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Op 2 oktober 2022 14:51:58 schreef vergeten:
[...]
is OK

Als je er bij vertelt wat je gemeten hebt, dan bereik je daarmee diverse dingen. Enerzijds, kan het zijn dat jij denkt dat 5V prima is maar dat het 12V had moeten zijn o.i.d.: Je controleert dan ook via ons of wat jij denkt dat goed is klopt.

Anderzijds maakt het duidelijk dat je het meten onder de knie hebt.

Mijn chinese LCR meter gaf "capaciteit is prima" (als in het dubbele wat ze hadden moeten zijn) op een stelletje condensatoren die lekken als een malle.

Iemand die dat grapje weet kan dan dus als je vertelt: "M'n condensator is goed: ik heb hem met m'n chinese LCR meter gemeten en daar kwam 150uF uit terwijl ie 100uF moet zijn: Ruim voldoende", dan kan iemand ingrijpen met: 50% te veel is verdacht, wacht hoe heb je dat gemeten???

Het "en hoe heb je dat gemeten" gaat een keer vervelen. Dus als jij niet vertelt hoe je gemeten hebt, dan wordt er maar op vertrouwd dat je het goed gemeten hebt. Met als gevolg dat je dit soort fouten niet vindt.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Enig idee hoe ik kan vaststellen of het IC defect is (hij heeft geen open dakje) :)

Niet eigenlijk. Het enige dat je kunt doen is met een scoop kijken of het ic
op pen 6,7 en 8 pulsen genereerd. Als er geen pulsen zijn is het ic defect of krijgt het geen voedingsspanning op pen 4. En dat laatste kun je met een voltmeter meten. Wel meten tussen pen 4 en 1. Ik soldeer daar gewoon een paar draden aan omdat met een meetpen alleen meten het risico op uitschieten en daardoor sluiting maken erg groot is. Ik soldeer tegenwoordig overigens veel draden op te testen printen als meetpennen. Is soms iets meer werk, maar veel minder dan zelf fouten erbij maken door stommiteiten. Draadjes van afgeknipte weerstandjes gebruik ik daarvoor.

Gebruik ook een scoop met geisoleerde kanalen en voldoende bereik op de verzwakkers. Je werkt onder netspanning en een aardfout kan veel doen sneuvelen.

[Bericht gewijzigd door Ex-fietser op 2 oktober 2022 19:31:01 (47%)

vergeten

Golden Member

Op 2 oktober 2022 15:13:23 schreef rew:
[...]Als je er bij vertelt wat je gemeten hebt, dan bereik je daarmee diverse dingen. Enerzijds, kan het zijn dat jij denkt dat 5V prima is maar dat het 12V had moeten zijn o.i.d.: Je controleert dan ook via ons of wat jij denkt dat goed is klopt.

Ik denk ik het goed inschat, de voeding levert aan de uitgang een spanning die via een ULN2003 drie relais (12v spoel) schakelt.
Er wordt ook nog een 7805 mee gevoed, die maakt de 5 volt voor een microcontroller.
Als alle 3 de relais zijn ingeschakeld krijgen ze elk 11,2v op de spoel, op dat moment is de voedingsspanning van de (bypass)testvoeding 12v. Er lijkt dus zo'n 0,8 volt over de ULN schakeltransistoren te staan.

Op het bovenstaande is de inschatting van wat de uitgangsspanning van de defecte PSU zou moeten zijn gebaseerd. Het zou ook 13v kunnen zijn. :)

Dus als jij niet vertelt hoe je gemeten hebt, dan wordt er maar op vertrouwd dat je het goed gemeten hebt. Met als gevolg dat je dit soort fouten niet vindt.

Gemeten met een LCR meter DE-5000. (ook een chinees) :)

@Ex-fietser:
Dat ga ik meten. Met het voedinkje achter een scheidingstrafo.

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Voor minder dan een tientje heb je een nieuwe 12v 2a adapter bij de ali. :P

Want het kan ook nog zijn dat ook het mini-smps-trafotje stuk is.

Waar het moederbord het meeste rookt, loopt ook de meeste stroom!
vergeten

Golden Member

Het is de uitdaging hé en origineel willen houden.
Dat is bijna altijd economisch onverantwoord, maar dat speelt hier niet. :)

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

O, ja, dat is zeer zeker ook leuk. I.i.g. was er bij m'n laatste SMPS voeding de trafo stuk. Die gaf ergens windingsluiting bij een klein beetje warm worden. Met een pets waarna brugcel, mosfets en driver ic voor de tweede keer stuk ging. En je kán zo'n trafo zelf opnieuw wikkelen, maar daar had/heb ik niet zoveel zin in om met 0,1 mm "engelhaar" aan de gang te gaan.

Mocht het nodig zijn dat jij dat wel wilt doen, noteer dan duidelijk bij het afwikkellen de richtingen, lagen en dikte en hoe deze aangesloten zijn op de pootjes.

Verder staan er op YT de nodige filmpjes daar over. Daar kan je ook uitvissen hoe je zo'n trafo het beste openmaakt e.d. :)

Waar het moederbord het meeste rookt, loopt ook de meeste stroom!

Vervang die diode en het zal vermoedelijk weer werken, ik heb laatstleden een fietslader hersteld met hetzelfde euvel, het driver-ic was een MIP2K4.
Waarschijnlijk gaan die dioden defect door een te hoge reverse spanning, maar dit is maar een gokje ;)

e:/ in mijn geval was het een SB160 diode en heb er toen een UF4007 ingesoldeerd (grotere Vf) bij gebrek aan en het werkt nu al enkele maanden zonder problemen.

[Bericht gewijzigd door MGP op 3 oktober 2022 10:02:55 (25%)

LDmicro user.
vergeten

Golden Member

Op 3 oktober 2022 09:26:55 schreef harry64:
O, ja, dat is zeer zeker ook leuk. I.i.g. was er bij m'n laatste SMPS voeding de trafo stuk. Die gaf ergens windingsluiting bij een klein beetje warm worden. Met een pets waarna brugcel, mosfets en driver ic voor de tweede keer stuk ging. En je kán zo'n trafo zelf opnieuw wikkelen, maar daar had/heb ik niet zoveel zin in om met 0,1 mm "engelhaar" aan de gang te gaan.

Trafo stuk is niet het geval en opnieuw wikkelen zie ik ook niet gebeuren, gaat me net ff te ver :)

Op 3 oktober 2022 09:50:21 schreef MGP:
Vervang die diode en het zal vermoedelijk weer werken, ik heb laatstleden een fietslader hersteld met hetzelfde euvel, het driver-ic was een MIP2K4.
Waarschijnlijk gaan die dioden defect door een te hoge reverse spanning, maar dit is maar een gokje ;)

e:/ in mijn geval was het een SB160 diode en heb er toen een UF4007 ingesoldeerd (grotere Vf) bij gebrek aan en het werkt nu al enkele maanden zonder problemen.

Die gaat het hier niet redden. Het IC oscilleert niet is dood zonder opengebarsten te zijn.
Toch een paar andere schottky's geprobeerd zonder resultaat.

Het wachten op een nieuw IC (SDH8303) bij Ali vandaan met de kans op een NEPPER heeft me doen besluiten een andere 12v 800mA adapter in te bouwen.
Zoals @harry64 dus ook al voorstelde, waarna het apparaat weer perfect werkt.

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.