blink led, 18F452

Alleen berichten met de trefwoorden “breadboard” worden getoond. Alle berichten tonen

Dit topic is gesloten


Dag Dodge,

Heb jij resultaten gehad met het dwarf board?
Zou jij eens willen kijken naar onderstaand probleem?
Sorry, ik had eea al in het engels getypt. Moet geen probleem zijn denk ik.

I have a Dwarf board DB016 (bought from VOTI) with a PIC 18F252.
When I want to program the board with the blinking led example then I get error messages from the programmer.

When I build the "blinking led circuit" on a breadboard then programming is no problem!

What am I doing wrong???????????????

When I program the Dwarf board with the jumper J1 placed on the Wisp 648 programmer I get the next error message:

******************************************************************************
XWisp 1.35, command line mode
hardware: Wisp628 1.27 (fast) (wisp648 firmware)

send='004fx' received='004F'

This error is likely caused by a power failure when the Wisp628-with-dongle / Wi
sp648 hardware shorts the power. This can for instance be caused by a hardware p
roblem in the dongle (use a larger the elco?) or Wisp648, or by an external 5V p
ower source that does not respond well to a brief short (maybe try a ~ 5 Ohm ser
ies resistor, or use an 7805-based power supply). If you do not need the power s
hort (depends on your PIC type) you might disable it (Wisp648: remove the jumper
or put it in the inactive position.
ERROR
press <enter> to continue
******************************************************************************
The red led on the Wisp648 and the red led on the Dwarf board are blinking a short time and then switch off!

When I program without the jumper then I get the next message:

******************************************************************************
XWisp 1.35, command line mode
hardware: Wisp628 1.27 (fast) (wisp648 firmware)

device word 3FFF or FFFF, can not identify this target: defect, unsupported, or
16x84
ERROR
press <enter> to continue
******************************************************************************

The red led on the Wisp648 and the red led on the Dwarf board are switching on and don't switch off!

I use Wisp648 with firmware v1.27

I have used a regulated power supply
I have used a regulated power supply with 5 ohm resistor
I have used a 12 v dc 1a wall wart
I don't see differences.

The breadboard has no problems with the power supply.
I feed the circuit through the Wisp 648

(When I place the programmed PIC from the breadboard into the Dwarf then the yellow led on the Dwarf board blinks well.)

Dit topic is gesloten