Wisp 648 pic komt niet op spanning

Ik heb een tijd geleden de PICbasic cursus en de Wisp-648 besteld.
Ik heb een probleem met de Wisp-648:
De pic op de wisp komt niet hoger dan 3,3V. Ook niet wanneer ik direct 5V op de print zet, ik meet op de ingang wel 5V.

hmmm dan moet je eens even de voeding op de wisp nameten.

wat bedoel je met???

Ook niet wanneer ik direct 5V op de print zet

voed je hem dan via de zwarte en rode draad (als je die kleuren hebt gebruikt voor de voedingsdraden die naar de te programeren schakeling gaan...)

buiten dat, de wisp zou het er wel om moeten doen want een pic werkt ook op 3 volt.

1zie je het ledje knipperen zodra je de spanning erop zet??

2 heb je een reserve wisp pic gemaakt / gekocht zodat als er wat is met de orginele dat je die er dan in kunt zetten??

De pic op de wisp komt niet hoger dan 3,3V

Led gebeurt niks mee, alleen wanneer ik hem direct voed(werkt dus wel).

Heb (nog) geen reserve programmeer-pic, de schakeling heeft nog helemaal niet gedraaid.

Ik kreeg time-out in bumblebee en las dat de spanning op de pic(pootjes op het IC) 5V moet zijn.
Dit is niet zo vandaar de vraag.

Op 8 november 2011 18:45:44 schreef roel999:

wat bedoel je met??? [...]

voed je hem dan via de zwarte en rode draad (als je die kleuren hebt gebruikt voor de voedingsdraden die naar de te programeren schakeling gaan...)

De wisp 648 kan je in circuit voeden vanaf het breadbord, maar je kan ook direct voeding op de print zetten(5V op de 'blauwe + en 0' connector.

[Bericht gewijzigd door Henry S. op 8 november 2011 21:35:26 (39%)]

ja dat weet ik, maar er zijn 3 manieren om het ding te voeden:
via de (bij mij blauwe) printkroonsteen, via de stekker ( zo'n zaklampen stekker) en via de draden die naar de print gaan.

de printkroonsteen die jij hebt gebruikt gaat ook via de 5 v regulator (7805) net als die zaklampen plug.

de regulator werkt niet als je er 5 volt op zet, dat moet minimaal 8 zijn en maximaal iets van 30 volt.

dus op de printkroonsteen met + en 0 moet minimaal 8 volt evenals die zaklamp plug.

maar op de draden die direct naar de schakeling aan mag niks anders dan 5 volt want de regulator zit er niet tussen.

[Bericht gewijzigd door roel999 op 8 november 2011 19:03:11 (11%)]

Op 8 november 2011 18:55:39 schreef roel999:
heb je het ding zelf in elkaar gesoldeerd of is wouter je voor geweest??

Zelf gesoldeerd, het maakt niet uit op ik hem voedt vanuit de blauwe connector of met de programmeerkabel vanaf een breadbord.
Zal even kijken of ik later op de avond een foto kan maken met duidelijke uitleg (foto zegt 10x meer dan een paar woorden).

[Bericht gewijzigd door Henry S. op 8 november 2011 21:36:22 (32%)]

maar je zei net nog dat het ding wel werkte via de directe programmeer draden :+

maar je kan ook direct voeding op de print zetten(5V op de 'blauwe + en 0' connector.

dit klopt dus niet dit moet minmaal 8 volt en maximaal 30 volt zijn want hier zit de 7805 tussen

Op 8 november 2011 19:05:18 schreef roel999:
maar je zei net nog dat het ding wel werkte via de directe programmeer draden :+

De Led werkt wel wanneer ik hem direct voedt, De schakeling heeft nog nooit gewerkt.

[...]

dit klopt dus niet dit moet minmaal 8 volt en maximaal 30 volt zijn want hier zit de 7805 tussen

Dus wanneer ik 12V op de blauwe aansluiting zet moet het werken?

jep

dit kun je heel gemakkelijk doen via zo'n transformator die je bij allerlei apparatuuur bij krijgt.
met een beetje geluk hoef je zelfs niet de stekker eraf te knippen als hij direct in de zwarte (zaklamp) bus past :)

en je hoeft ook niet bang te zijn dat je hem verkeerd om aansluit want daar zit een diode voor ingebouwd.

die heeft mij trouwens ook al vaak genoeg gered :9

[Bericht gewijzigd door roel999 op 8 november 2011 19:18:56 (27%)]

Het is eigenlijk heel simpel, gewoon een 12V adaptertje inpluggen, en het werkt.
Op elke vlooienmarkt staat wel ergens een kraam met een berg van die dingen.
Meestal gaan ze voor 1 euro van de hand.

edit: Let wel even op de polariteit.

Oude computervoeding?
Is ook een aardig stabiele 12V.

[Bericht gewijzigd door Henry S. op 8 november 2011 21:36:42 (74%)]

heb je echt niet zo'n klein ding ergens op zolder liggen ofzo, die computer voedingen staan namelijk bekend om het fenomeen dat ze nogal veel stroom kunnen leveren. en als er dan iets fout gaat gaat zo'n klein adaptertje plat en zo'n computer voeding genereerd in zo'n geval wisp rooksignalen.

edit: @ kareltje

daar heeft wouter al aan gedacht hij heeft een diode over de voedingslijnen gezet, vlak voor de 7805, dus als je hem verkeerd om aansluit gaat er nog niet direct wat kapot.

dat ding heeft mijn wisp ook al enkele keren gered :)

[Bericht gewijzigd door roel999 op 8 november 2011 19:47:06 (30%)]

Op 8 november 2011 19:20:36 schreef roel999:
heb je echt niet zo'n klein ding ergens op zolder liggen ofzo, die computer voedingen staan namelijk bekend om het fenomeen dat ze nogal veel stroom kunnen leveren. en als er dan iets fout gaat gaat zo'n klein adaptertje plat en zo'n computer voeding genereerd in zo'n geval wisp rooksignalen.

Je hebt gelijk, ga er 1 zoeken.
Bedankt voor alle tips en ophelderingen.

Word vervolgd....

Het werkt, de wisp krijgt spanning en de led knippert.
Die 8-15V voedingsspanning heb ik nog nergens gelezen en heb al behoorlijk wat fora's afgezocht.

Hij knippert 3x bij opstarten waarna hij naar mijn idee werkt.
Nu het programeren nog uitvinden en dan vlammen.

[Bericht gewijzigd door Henry S. op 8 november 2011 21:37:02 (22%)]

nou op http://www.voti.nl/wisp648/n_index.html heeft wouter van ooijen (de bouwer / bedenker van de wisp's het hele ding van A tot Z uitgelegd.

ik ben blij dat het werkt succ6

het programeren met bumblebee is een eitje.
instellen zoals in www.picbasic.nl en aan de slag :)

Programeren lijkt mij ook niet zo moeilijk, ik heb alleen vermoeden dat ik wat verkeerds doe bij het aansluiten.
Heb meerdere PLC's geprogrameerd op school en vandaar ook deze stap.

Na de 2e pic(16f628) in het eerste circuit(PICbasic deel 1) gehad te hebben is er nog steeds geen programma geprogrammeerd.
Bumblebee geeft de foutmelding:Target device not identified, (device code:FFFF: probably connection or power failure.
De led op de PIC blijft branden na programmeren.

Gemeten met de multimeter:
- alle verbindingen(ohms van de kabel en connector op de print)
- er staat 5V gelijkspanning op de PIC.
- complete breadbord op verbindingen gemeten (1 van de eerste keren dat ik zo'n klein breadbord gebruik).

Ik heb echt het idee dat ik iets simpels verkeerd doe, alleen dat is vaak het moeilijkste te vinden.

[Bericht gewijzigd door Henry S. op 8 november 2011 21:37:29 (20%)]

ha geinig plc's programeren moet ik NU leren op school (mbo 4)

ik vindt dat je met een pic VEEEl meer krijgt voor je geld (denk aan interupt controller, timers, en meer poorten. het enige nadeel is dat een pic geen 230V kan hebben of grote stromen aansturen.

bumblebee geeft wel vaker een foutcode, dan heb je de voeding vergeten aan te zetten, of er is een draadje los geschoten.

wat je nog even kunt doen is in bumblebee: programmer -> identify

De led op de PIC blijft branden na programmeren

dat is normaal tijdens een foutcode doet ie dat heeft verder niks te zeggen

zodat je zeker weet dat het probleem niet in de voeding of connectie met de pc zit en dan hoef je nog maar 7 draadjes te controleren.

Op 8 november 2011 21:04:05 schreef roel999:
ha geinig plc's programeren moet ik NU leren op school (mbo 4)

Heb met de Siemens 5 en 7 gewerkt (redelijk oud materiaal).
Programmeertaal is op heel veel vlakken hetzelfde.
Wij zijn er niet dieper op ingegaan dan een simpele waterinstallatie.

Bij programmer-> identify geeft hij "Wisp 648, version:1.29" weer, dit werkt dus.

[Bericht gewijzigd door Henry S. op 8 november 2011 21:37:52 (24%)]

Sonytech

Overleden

Bij de Wisp648 die ik laatst gehaald heb bij Voti zitten er 4 diodes als bruggelijkrichter achter de DC-input, dus dan maakt de polariteit van de adapter ook niet meer uit.

In de documentatie is dat echter (nog?) niet terug te vinden.

"Verbaas u niet, verwonder u slechts."

oke nog 7 draadjes te gaan dus :)

die tussen de programmer en target.

oftopic:
---------------------------------------------
ik dacht eerst leuk programmeren veel ervaring mee dus loopt wel los.

eerst vertellen ze over instruction list programmeren inc. voorbeeldje dat veel op basic lijkt.

toen we eenmaal begonnen met siemens logosoft was er niks aan, gewoon blokjes aan elkaar knopen op je beeldscherm :( beetje een teleurstelling voor mij geweest.

edit: @ sonytech

ja dat heeft mijn wisp ook :)]

1 foto zegt meer dan 100 woorden:
http://i1217.photobucket.com/albums/dd393/Flippo765/Pic/Pic.jpg

Dit is zoals het nu is aangesloten

Sonytech

Overleden

Inderdaad, daar zag ik het in één oogopslag.

Het zal waarschijnlijk een stuk beter programmeren als je de juiste pennen van de DB15-connector van je ICSP-kabel gebruikt.

Zoals 'ie nu op de foto staat moeten ze twee pennen omhoog.

"Verbaas u niet, verwonder u slechts."

Denk dat ik het ziet, de meeste breadboards verbinden de 2 voedingslijnen link en rechts niet, de pic is niet van de min voorzien.

EDIT: wat sonytech zegt klopt ook, nu heb je misschien wel op een pin 13V gezet...
EDIT2: als het goed is op rb2 (groene draad)

Op 8 november 2011 21:42:11 schreef Sonytech:
Inderdaad, daar zag ik het in één oogopslag.

Het zal waarschijnlijk een stuk beter programmeren als je de juiste pennen van de DB15-connector van je ICSP-kabel gebruikt.

Zoals 'ie nu op de foto staat moeten ze twee pennen omhoog.

Als ik ze 2 pennen omhoog doe komen de LVP en MCLR aan de buitenkant?

Of bedoel je dat het geheel verkeerdom zit?
Volgens mij zit het op deze manier aangesloten?
http://www.picbasic.nl/images/schema_wisp-pic.gif

Op 8 november 2011 21:43:23 schreef LEDfan:
Denk dat ik het ziet, de meeste breadboards verbinden de 2 voedingslijnen link en rechts niet, de pic is niet van de min voorzien.

Je bedoel dat de gele-oranje en C niet met de - van de PIC zijn verbonden? Heb dit gemeten en blijkt 0 ohm te zijn.

Misschien is het toch bij jouw breadboard door verbonden, maar krijg je spanning op je PIC? En wat is de spanning tussen de gele draad en de min?

Er zijn 2 gele draden, de korte is een doorverbinding naar de min-lijn en de lange is een programeerdraad (MCLR)

Op de Pic staat 5V en tussen de korte gele en min 0V.

Sonytech

Overleden

Vergelijk dan even hoe jij je stekker hebt aangesloten en hoe het op de foto staat in de Wisp648-manual.

Wouter heeft er ook nog bijgezet dat er nummers bij de pennetjes staan. Die staan er echt, maar je moet er misschien even een lampje en een vergrootglaasje bijpakken.

Maar: ook in dit geval zegt 1 foto meer etc...

[Bericht gewijzigd door Sonytech op 8 november 2011 23:13:01 (13%)]

"Verbaas u niet, verwonder u slechts."