555 probleem

Heb hier een schakeling gemaakt met een 555. Nu deze werkt met 2 weerstanden (200Ω en 1kΩ ) goed maar met de laagste (30Ω ) faalt ie op de test plank, in de sim gaat het dan weer wel goed.
http://img847.imageshack.us/img847/9322/555faalt.jpg

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar
Frederick E. Terman

Honourable Member

a) over welke weerstand heb je het hier?
b) zoek eens in het datablad op welke waarden aangeraden worden.

Keramisch, kalibratie, parasitair: woordenlijst.org

A: de laagste dus R4 (30Ω )
B: goed idee, is misschien te snel voor de 555.

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar
Frederick E. Terman

Honourable Member

Niet te snel, maar te laag. :)

Keramisch, kalibratie, parasitair: woordenlijst.org

Toch wel zielig voor het torretje achter die discharge pin. Reken eens uit wat voor stroom daar in totaal gaat lopen?

Het verbaast me dat het met 200 ohm nog goed gaat, in combinatie met nog een andere stroom die je zelf even mag zoeken.

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Ja eigenlijk moet dat torretje daar niet staan want ik mag blijkbaar tot 200mA door de 555 trekken, zien ik staan in de datasheet. Zelfs met 75E gaat het nog goed, maar dan zit ik nog steeds niet aan de pulsen trein dat ik moet hebben om straks te testen.

Deze (ongeveer) moet ik hebben: 13, 50, 117 pulsen per seconden.

Edit: ik heb hem Sparky, je bedoel het torretje in de 555. Eventjes de sim in werking gezet en zou iets van een 400mA pieken trekken door de discharge pin.

Edit2: als ik naar 10nF ga dan gaan de weerstanden met factor 10 omhoog behalve de 47Ω en zou de stroom af nemen naar max 100mA piek.

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar
Frederick E. Terman

Honourable Member

Ik snap helemaal niet hoe je aan zulke idioot lage waarden komt.
Kijk eens in de datasheet, daar staan formules en ook nog een grafiek hoe je de waarden kunt bepalen.
Met 10nF en 100Hz zou je in de Megaohms moeten zitten - wat trouwens weer wat hoog is; een grotere condensator zou dan geschikter zijn.

De sim kan niet goed de discharge current bepalen. Gebruik ook daarvoor liever de grafieken in de datasheet.

[Bericht gewijzigd door Frederick E. Terman op 13 november 2011 10:01:39 (15%)

Keramisch, kalibratie, parasitair: woordenlijst.org

mmmh raar. De ds nog eens open gedaan en volgens mij heb ik ergens een verkeerde formule gebruikt.

Juiste formule: f=1.44/[(Ra+2*Rb)*C]

Hiervan https://homepages.westminster.org.uk/electronics/555.htm , heb ik een programma gebruikt.

Straks nog een bekijken.

Edit: ik denk dat ik al weet waar ik de mist in gaan, de waarde van de condensator verkeerd omzetten.

[Bericht gewijzigd door Damic op 13 november 2011 11:28:32 (17%)

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar
Frederick E. Terman

Honourable Member

Dat bedoel ik. Gebruik nu eens die formule echt.

Ra= 30, Rb= 47, C= 100n. Dus f= 1.44/(124*100n)= ?

e: ↓ Dat lijkt me goed, dat zijn al beter hanteerbare waarden. :)

Het lijkt trouwens of er een rekenfout zit in dat programmaatje waarover je het hent.

[Bericht gewijzigd door Frederick E. Terman op 13 november 2011 12:24:48 (44%)

Keramisch, kalibratie, parasitair: woordenlijst.org

Heb dus wel de juiste formule gebruikt maar de condensator verkeerd omgezet, paar nullen te weinig.

Als ik nu 100nF gebruik kom ik uit op:
Ra=1.1MΩ,270kΩ en 100kΩ
Rb=10kΩ

f= 1.44/(124*100n)= 116kHz

Dank je fet en Sparky om met op het juiste pad te zetten.

[Bericht gewijzigd door Damic op 13 november 2011 11:37:16 (12%)

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar

Heb daarstraks de schakeling gebouwd en de transitor vervangen door een mosfet (IRFZ44N) met het gedacht dat zal wel werken en het werk maar niet goed.

Op de gate heb ik +5V en een blok signaal.
Als ik meet over de SD dan heb ik een paar mV (40mV) en een signaal. Nu ben ik de datasheet in gedoken en volgens mij heb ik niet genoeg spanning om open te sturen, klopt dit?

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar

Dat kan je wel zeggen ja. Zonder te zoeken ga ik uit van een normale FET: die gaan pas lekker geleiden bij een stuurspanning van minimaal 10 Volt op hun gate. 5 Volt is echt te weinig.

Voor de volgende keer: ook zonder formule is 30 ohm echt te weinig voor de weerstand die je eerst berekent had: volgens mij is het minimum 1k, maar dat doe ik uit m'n hoofd.

http://www.m-voorloop.nl --- Ik? Welnee! Ik zit nog lang niet achter de germaniums.

... en de transitor vervangen door een mosfet ...

Toch niet zoals Q1 in je schema geschakeld is, mag ik hopen?

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)
free_electron

Silicon Member

Op 13 november 2011 00:43:53 schreef Damic:
Heb hier een schakeling gemaakt met een 555. Nu deze werkt met 2 weerstanden (200Ω en 1kΩ ) goed maar met de laagste (30Ω ) faalt ie op de test plank, in de sim gaat het dan weer wel goed.

die sim in de vuilbak smijten... als die sim correct werkte dam moest er rook uit je computer gekomen zijn.. aangezien dat niet het geval is werkt die sim incorrect.

@weardguy ... bij powerfets doe je dat om ze echt hard aan te krijgen . voor de Ts zijn toepassing zal die fet al properkes aan zijn bij pakweg 4 volt...

@damic. fet met source aan grond knopen en de weerstand tussen drain en +12 zetten...

Professioneel ElectronenTemmer - siliconvalleygarage.com - De voltooid verleden tijd van 'halfgeleider' is 'zand' ... US 8,032,693 / US 7,714,746 / US 7,355,303 / US 7,098,557 / US 6,762,632 / EP 1804159 - Real programmers write Hex into ROM

@Pros: nee juist geschakeld, anders had ik wrs niets van signaal.

@F_e: Electronic Workbench Multisim 11.0.1 Portable, zegt genoeg zeker.

Die weerstand (1k) tussen de 555 en de fet mag die dan weg of verlagen en er staat geen weerstand tussen de Drain en de +12V, misschien is dat het probleem dat ik niets meet.

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar

Als je de PWM-frequentie niet te hoog maakt (enkele honderden Hz) hoeft er niet noodzakelijk een weerstand tussen 555 en gate. Bij hogere frequenties kan je er toch maar beter een kleine weerstand (10Ω ... 100Ω) tussen plaatsen.

En ja, als je de drain niet belast zal je daar ook geen nuttig signaal meten.

Hoe kom je overigens aan die 5V op de gate, als je de 555 met 12V voedt? Of meet je de gemiddelde spanning? In dat geval is het waarschijnlijk OK, en wisselt de werkelijke spanning op de gate tussen 0V en 12V.

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)
fred101

Golden Member

Probeer simetrix eens. Dat is een akelig goede sim.

Ik heb toevallig van de week een aantal MOSFETs op de curvetracer gehad ( uit een TL EVSA en ivm de dynamische load) de meeste waren bij een Vg van 3 tot 4 V al behoorlijk in geleiding. Maar het ligt volgens mij ook aan het schema. Bij een source weerstand , zoals jij nu volgens mij gebruikt, verandert de Vgs als er meer stroom gaat lopen. Als je bv een Rsource hebt van 10 ohm en een Vdrain van 10 V en de MOSFET heeft Vg= 0 V dan is hij gesperd en loopt er geen stroom. Als je dan Vg= 5 V ( even uit de lucht gegrepen waarde) maakt en de FET gaat vol open dan loopt er 1 A. Maar dan is Vs dus ook ongeveer 10 V. Dat betekent dan dat de gate -5V is tov de source en daarbij is hij totaal gesperd. Wil je hem in dat geval vol open gooien dan heb je dus iets van 15 V gate spanning nodig.

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur, ook oud en exotisch

Die 5V geeft de scoop aan, gate weerstand veranderd naar 100Ω, weerstand (1kΩ ) tussen drain en +12V gezet en nu zag ik een mooie volgende blokgolf.

Ook eventjes het spoel gemeten en daar zit ik op 1.5Ω dan maar eens geprobeerd met een 2.2Ω weerstandje en daar kwam rook uit (tja 5,45A door een klein weerstandje). Ook nog geprobeerd is een 2.7Ω 5W = rook (4.44A).

Dan test opstelling gemaakt waarvoor ik het gaan gebruiken en heb eventjes ontsteking gehoord maar dan niets meer, maar dat is voor de volgende keer.

[Bericht gewijzigd door Damic op 15 november 2011 20:10:04 (55%)

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar

Je hebt wel een emotionele relatie met kleine weerstandjes, hé? >:)

Enne... een spoel met een ohmse weerstand van 1.5Ω gedraagt zich bij PWM-sturing geheel anders dan een gewone weerstand.

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Ja rook :D vergeet meestal uit te rekenen hoeveel Watt ik gaan disiperen :D

Edit: ondertussen wat getest en het werkt nu wel. Schoon vonk vorming, moet alleen het rotor huis om draaien zien alleen een vonk overspringen maar niet alles.
Had eerst de probe verkeerd aangesloten over de spoel en dan krijg je natuurlijk dit:
http://i63.photobucket.com/albums/h148/fragme_dmc/electronics/dis/P1050869.jpg
Omgedraaid dit:
http://i63.photobucket.com/albums/h148/fragme_dmc/electronics/dis/P1050870.jpg

Bedankt aan allen ;)

[Bericht gewijzigd door Damic op 15 november 2011 22:17:39 (25%)

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar
fred101

Golden Member

Space invaders met alleen een 555 cool >:-)

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur, ook oud en exotisch

Lol fred :D

Edit: kan iemand me zeggen hoe ik het signaal van de 555 stabieler kan laten worden want volgens mij zitten hier nogal wat spikes in.

Ben Belg sowat :D :: plaatjes zijn meestal klikbaar