Actieve load voor voedingen te testen

Zoals ik al in het Show Your Projects topic heb laten zien ben ik bezig met het bouwen van een Actieve load voor voedingen te testen.

Ik heb hiervoor het schema van Pros gebruikt, dat ook al een keer door Technojunk is nagebouwd.
http://prosje.be/CO/Schemas/PowerStroomBron.png

Ik heb de uitgangstrap (het roze gedeelte) vier keer opgebouwd en daarvoor als T2 een TIP132 gebruikt. Verder heb ik hieraan niets wijzigd.

Verder heb ik zenerdiode D3 vervangen voor 3x 1N4148 diode in serie met 1x 1N4148 diode in sper over de serie schakeling, aangezien ik geen 2V zeners kon vinden. Dit werkt trouwens prima.

De regeling werkt prima, en ik heb al tot 5A door de uitgang laten lopen. Met P1 is dit prima te regelen. De totale regeling trekt iets van 6mA.

Maar nu komt het.....

Wanneer er geen voeding is aangesloten, of wanneer de voeding in begrensing komt, dan loopt er ineens 60mA door de regeling.

Dit wordt veroorzaak doordat de stroom van de emitter van T1 via R4 door de BE-overgang van T2 naar massa loopt. Terug regelen met P1 helpt hierbij niet, als de ingang van IC1 aan de ground hangt, dan blijft de uitgang hiervan rond de 6V. Omhoog draaien van P1 verhoogt deze spanning nog verder. Doordat T1 blijft geleiden, blijft er een relatief hoge stroom via R4 en de BE-overgang van T2 naar de massa lopen.

Als ik in deze toestand C3, met mijn vinger, ontlaad dan daalt deze spanning weer en komt de regeling weer in normale toestand.

C3 is volgens mij toegevoegd in het schema om de regeling rustiger te maken, maar gooit bij niet aangesloten voeding dus roet in het eten.

Weet iemand hoe dit te verbeteren is, zodat wanneer geen load aan de uitgang is aangesloten, de regelaar geen hoge spanning op de basis van de uitgang transistoren zet? Die darlingtons zijn namelijk zo kapot.

Als je P1 naar 0V draait, en de uitgang van de opamp wordt nog steeds hoog, kan je de offset-regeling van de opamp gebruiken om dat bij te stellen.

Wat T2 betreft: die kan hierdoor niet stuk gaan. R4 beperkt de basisstroom immers tot een waarde die heel wat lager is dan het maximum.

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Voor een off-set regeling heb ik een negatieve voeding nodig. Dat is niet handig.

Misschien een zenerdiode over pin 4 en 8 van de CA3140 (zie datasheet 'clamping').

Is er geen andere manier, het lijkt me toch onwenselijk dat als er geen voeding is aangesloten, de regelaar maximale stroom staat te leveren naar T2.

Bij mij zijn al 2 stuks TIP132 overleden. Éen in CE-sluiting en één CE-oneindig.

Edit:
off-set opmerking was onzin (dank aan Pros)

Het probleem wat jij nu ondervind had ik ook met mijn elektronische load. Ik heb alleen FET`s gebruikt ipv darlingtons maar het probleem komt doordat er geen ingangssignaal naar de opamp gaat en deze dus vol gaat uitsturen. Ik had als oplossig bedacht om via de voedingsspanning hoogomig een vaste spanning aan te bieden (bijvoorbeeld van de opamp voedingsspanning) getest heb ik dit nog niet, maar zou moeten werken aangezien de shunt laagomig is trekt die de spanning later wel omhoog.

Hang aan de emmitter van T1 een pnp (BC557) T3 naar de min. De basis van T3 hang je met een weerstand naar de min en een weerstand naar de collector van T2.

Staat er geen spanning op de collector van T2 dan trekt T3 de sturing weg van T1. Zodra de spanning op de collector van T2 >0.6V is spert T3 en werkt de regeling normaal.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Om de offset van een CA3140 bij te stellen heb je helemaal geen negatieve voedingsspanning nodig. Instelpotje van 10k tussen pinnen 1 en 5, loper aan GND, en draaien maar...

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Op 27 januari 2012 10:29:40 schreef Roland van Leusden:
Hang aan de emmitter van T1 een pnp (BC557) T3 naar de min. De basis van T3 hang je met een weerstand naar de min en een weerstand naar de collector van T2.

Ronald ik snap je niet helemaal.

Emitter T1 aan ?? van T3 --> ???
Basis T3 via weerstand naar GND en collector T2 --> OK
Collector T3 ??

@Pros
Je hebt gelijk, mijn fout. Offset regelingen voorbeelden die ik vond hadden een symetrische voeding.

Emitter T1 aan emitter van T3
Basis T3 via weerstand naar GND en collector T2 --> OK
Collector T3 naar massa

Het afregelen van de offset lost mi jullie probleem maar gedeeltelijk op. Als je de potmeter P1 niet op nul hebt staan en je sluit geen voeding aan om te testen dan zal de opamp gaan uitsturen.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Begrepen !

Weerstand collector T2 naar basis T3 iets van 10KΩ en vervolgens via 1KΩ naar de massa ?

Lijkt me een goed uitgangspunt. In de collector van T3 nog een weerstand van 100Ω opnemen bij nader inzien.

Misschien is het wel een beter idee om de emitter van T3 aan punt U1 te knopen, dan gaat de opamp helemaal niet uitsturen als er geen spanning op de collector van T2 staat.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Misschien is het wel een beter idee om de emitter van T3 aan punt U1 te knopen

Dat lijkt me ook. Anders is het afwachten wie van de twee (T1 of T3) het eerste stuk gaat.

Bij mij zijn al 2 stuks TIP132 overleden

Daar begrijp ik niets van. Als je de CA3140 met 10V voedt, komt zijn uitgang niet hoger dan 8V. Trek daar nog 1.2V af (twee PN-overgangen in T2), en deel het door 220. Dat resulteert in een basisstroom van maximaal 30mA - ver onder de 300mA die een TIP132 maximaal mag slikken.

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Uc-e is dan 0V, daar zit het mi in.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Ik heb hier over mijn soortgelijk probleem zitten zeuren: http://www.circuitsonline.net/forum/view/92757/1/current+sink

De opamp stuurt open als er geen bron is. Maar ander probleem van dit ontwerp (mijne dus) is dat hij redelijk traag reageerd: als je de load aansluit loopt er kortstondig een zeer grote stroom (mijne was op zon 8A berekend en dat liep er dan ook makkelijk). Dit was logisch, het duurt even voor de regeling door heeft dat er een stroom loopt. Na zon 4 mS was dat teruggereld tot de ingestelde stroom (van bv 20mA). Een idee wat ik toen had is om een comparator te gebruiken om de spanning van de load te detecteren (bv 0.5V). deze spanning heb je toch nodig en als hij er niet is trekt hij de basisstroom van de eerste tor naar gnd en er loopt geen stuurstroom de TIP's in. Als je dan een load aansluit start hij rustig op van 0->20mA.

E: ik zie dat dit al in het laatste schema stond. Echter, dit schema heeft een foutje: er loopt in bepaalde situaties enkele mA terug in de 7805. Dat kan natuurlijk niet. De oplossing hiervoor staat niet in dat schema. Los daarvan zal er nog wel e.e.a. mis zijn met dat schema want echt lekker heeft het nooit gewerkt, maar voor het idee misschien.
http://hal.redsam.nl/csink.sch.4.png

http://www.pa4tim.nl/?p=2773
Deze van mij is tot nu toe probleemloos en erg simpel. Hij zit met koelblok en al nu gewoon in een kastje want het wordt bij 5 A nog niet lauw. Ik gebruik wel FETs. Die leken mij ideaal hiervoor.
Er is een application note waarin Jim Williams ( nr 104) er ook twee beschrijft. Met en zonder Fets
http://cds.linear.com/docs/Application%20Note/an104f.pdf
Bij de tor gebruikt hij een extra FET voor de voeding onder test om te voorkomen wat volgens mij jou probleem is .

[Bericht gewijzigd door fred101 op 27 januari 2012 12:58:50 (21%)]

www.pa4tim.nl, Reparatie van meet- en calibratie apparatuur, ook oud en exotisch

Als je CA3140 gebruikt moet dat ook kunnen door de strobe pin te schakelen.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Dus als ik de stobe (pin 8) aansluit aan de emitter van een PNP (T3) transistor die zijn collector aan de GND heeft zitten, en de basis van deze transistor via een 10:1 spanningsdeler aansluit over de aansluingen van de te testen voeding, dan ben ik er !

In AN104 zie ik dat Williams dat doet met een VN2222 (Q2) fet aan de ShutDown (SD) van een LT1206. Maar ik zie die SD is laag-aktief.

Dat zou ik ook kunnen doen met een BS170BS250, dus de gate aan de V+ van de de testen voeding en 1MΩ naar GND, source aan de GND en drain aan de strobe (pin 8) van de CA3140.

Ik ga dit topic ook maar volgen, want ik was van plan om het ontwerp van Pros te bouwen, maar dan met een grote IGBT module (mooi-voor-thuis exemplaar, aangezien 1 van de 2 transistors stuk is). Volgens de datasheet mag het ding 2400W verstoken (bij Tj 25C, maar toch).

De aansturing lijkt me hetzelfde als de variant met MOSFETs. Het verbaast me eigenlijk dat de regeling stabiel is met alleen de gate capaciteit aan de opamp. C3 moet die opamp natuurlijk een beetje temmen, maar heb ik het gevoel dat het wel een goed idee kan zijn om de uitgang wat te belasten, en eventueel een RC netwerk tussen de opamp en IGBT gate, maar de faseverschuiving kan weer voor instabiliteit zorgen.

[Bericht gewijzigd door SparkyGSX op 27 januari 2012 14:37:31 (44%)]

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Dat zou ik ook kunnen doen met een BS250, dus de gate aan de V+ van de de testen voeding en 1M naar GND, source aan de GND en drain aan de strobe (pin 8) van de CA3140

Lijkt me idd de mooiste oplossing.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Ik heb me deze avond wat vermaakt door een BD681 te treiteren. Ook een darlington, maar twee maatjes kleiner dan een TIP32.

Om te beginnen heb ik het ding een emitterweerstand van 1Ω gegeven, en een basisweerstand van 47Ω. Op die laatste een spanning van 5V, met een basisstroom van 68mA tot gevolg.
Daarnaast werd een belasting met regelmatige tussenposen met de collector verbonden en terug afgekoppeld. Dat heb ik zo een uurtje laten draaien - de BD681 is nog steeds kerngezond.

Misschien zijn de torren van flash2b stuk gegaan, op het ogenblik dat de te testen voeding aangesloten werd? De torren geleiden dan volledig, en als het om een zware voeding zonder stroombegrenzing gaat, of een voeding met een geweldig grote uitgangselco, kunnen er flinke stromen vloeien.

Hoe dan ook, ingrijpen aan de STROBE-pin v/d CA3140, wanneer er geen spanning op de collectors van de eindtorren staat, lijkt me een goed idee. Als een andere opamp gebruikt wordt (zonder strobe), kan ook ingegrepen worden aan de uitgang v/d opamp - de doorsnee-opamp maakt geen bezwaar als zijn uitgang kortgesloten wordt naar GND.

Toch nog een bedenking: als de opamp "vrijgelaten" wordt, zodra je de te testen voeding aansluit, is de kans groot dat zijn uitgang met een sprong naar maximum gaat. Dan zit je nog steeds in het scenario, dat ik hierboven beschreef. Het "vrijlaten" van de opamp zou IMHO een langzaam proces moeten zijn, waardoor de opamp alle tijd krijgt om zich behoorlijk in te stellen.
Misschien toch maar die offset-regeling aanbrengen, en de discipline kweken om S1 te sluiten en P1 naar 0V te draaien, alvorens je aan een test begint?

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Dank je wel voor je antwoord Pros.

Mijn voeding is een V&A/Mastech HY030-5D welke max. 30V/5A kan afgeven. Ik ben echter nog niet boven de 15V geweest, maar wel 5A. De voeding heeft wel een stroom begrenzing, maar als ik aan het testen met de Active load bezig ben, moet ik die wel steeds hoger draaien, anders zitten ze 'elkaar in de weg' en slaat de voeding af.

De transistoren gingen zo maar kapot, de voeding was al ingeschakeld. Bovendien zijn het NOS torren, dus ik heb het verhaal van 'fakes' ook uitgesloten.

Met die stobe pin van de CA3140 ga ik morgen even proberen.

In de 2011 CO labvoeding wordt ook een soortgelijk ding gedaan:
http://www.uploadarchief.net/files/download/strobe%20release.png

Ik neem aan dat in dit schema Q3, D5 en R14 kan vervallen. En dat ik dan de collector van Q2 aan de ground kan hangen en de emitter van Q2 aan de strobe kan hangen. De VDD is dan de V+ van de voeding, niet de +10 van de op-amp.

Zoiets dus:
http://www.uploadarchief.net/files/download/strobe%20release2.png

Eventueel kan ik dan over R13 een kleine condensator zetten om het vrijlaten te vertragen.

Zit het dan goed met de verhouding R12/R13 ?

De transistoren gingen zo maar kapot, de voeding was al ingeschakeld

Nu begrijp ik er nog minder van...

Wat R12/R13/Q2 betreft: de STROBE-pin van de CA3140 is intern verbonden met een stroombron, die rechtstreeks voeding krijgt van Vcc. Als je de datasheet van de CA3140 erbij neemt, wordt het duidelijker.
En Q2 is in wezen een emittervolger tov. de STROBE-pin, zij het dan een PNP-variant.
Dus, als de spanning op de basis van Q2 2V bedraagt, zal Q2 nog steeds stroom uit de STROBE-pin trekken tot daar een spanning van 1.4V staat.
M.a.w. dit is geen simpele aan/uit regeling, maar een regeling die meegaat met de spanning op R12. Vandaar (denk ik) de aanwezigheid van R14, Q3 en D5 in het Elektuur-schema.

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Hmm, aantal componenten loopt wel snel op zo, kunnen we niet iets leuks doen met een dual opamp.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Ik had ook al een beetje mij twijfels over het opstartgedrag van die schakeling. De opamp dicht knijpen zolang er geen voeding aangesloten is, lijkt me al een goed begin. Een sort-start zou ook geen slecht plan zijn, lijkt me.

Als je de inverterende ingang van de opamp omhoog trekt, zal hij zijn uitgang laag maken. Op het moment dat je de ingang loslaat, zal de opamp zijn uitgang laat stijgen. Vanwege C3 zal dit niet met een grote stap gebeuren, en de eindtorren dus relatief rustig open gestuurd worden.

100nF lijkt me trouwens wel erg groot voor C3, ik heb het gevoel dat het ding daar wel erg traag van wordt.

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Nog even iets over de doodsoorzaak van die torren.
Als ze stukgingen op het ogenblik dat de voeding aangesloten was, kan die verhoogde basisstroom (die optreedt als er niets aangesloten is) moeilijk de oorzaak zijn.

Overbelasting, dan? De TS maakt melding van 15V en 5A, hetgeen betekent dat de torren en de emitterweerstanden gezamelijk 75W staan te verstoken - zowat 18W/tor. Afgaande op het Show-topic zou ik zeggen dat het koelblok volstaat voor deze belasting, temeer omdat een fan voor geforceerde koeling zorgt.
Dat kan nog iets verbeterd worden, door die isolatieplaatjes tussen torren en koelblok weg te halen - de collectors zijn toch met mekaar verbonden.

Hoe dan ook, ik blijf het een raar verhaal vinden...

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Kleine update.

Inmiddels de eerste schema (de bovenste in mijn laatste post) voor de Strobe aansturing (zelfde als in de 2011 CO Labvoeding) op het breadboard nagebouwd. Dit deel getest met een LED+weerstand naar +10V ipv. pin8 van de CA3140. Bij inschakeling is er een korte puls te zien, en bij terugregeling van de voedingsspanning gaat de LED branden bij ongeveer 6V. Verkleining van R13 naar 47KΩ, verlaagd de drempelspanning naar ongeveer 3V, maar resulteert ook in een korte puls als het geheel wordt ingeschakeld.

Mijns inziens is dit circuit (voor mijn toepassing) niet echt bruikbaar, aangezien er dan een dood moment in de regeling wordt geïntroduceerd tussen de 0 en 3V.

Ik denk dat ik nu iets met een BS170 en een BC557 ga proberen, om geen dood moment meer te hebben.

@Pros
De silicon isolaties plaatjes heb ik inmiddels na vervanging van twee torren verwijderd en heb ze nu allemaal met koelpasta direkt op de koelplaat zitten. Hierbij is er een merkbaar betere warmte geleiding. Dit zou de oorzaak trouwens kunnen zijn van mijn kapotte torren, aangezien de koelplaat nu veel beter warm wordt.

Mijn nieuwe 2 torren hebben echter een andere spanning val als de oude, de oude doen dus 'meer werk' want de stroom is niet gelijk in elke lus/trap. Dit ga ik nog verbeteren door die twee ook maar te vervangen.

O ja, ik heb inmiddels ook een off-set correctie over pin 1 en 5 aangesloten.