Meten aan schakelende voeding

Ik heb hier een defecte schakelende voeding liggen. Geeft geen uitgangsspanning en uitgangsled brandt ook niet.

Schema lijkt 90% op onderstaand.
http://www.uploadarchief.net/files/download/schak_voeding3.jpg

Na de gelijkrichter staat >+300 VDC.
Dus ik stap 2: Krijgt de THX203H wel zijn voeding? Er daar snap ik echt iets totaal niet..... pin 2 en 3 van de thx203h is respectievelijk + en -. Ik meet 25mV. Wat ik niet snap in het schema is waar de +Vcc vandaan komt voor de THX... Wie kan mij dat principe even uitleggen.....Ik voel me even zo dom.

Ik had wel D6 eruit gehaald omdat ik die verdacht vond. Maar na die losgesoldeerd te hebben en los gemeten te hebben doet die het nog perfect (in circuit valse waarde).

Ik heb hier ook een oscilloscoop staan. Maar hoe kan ik daarmee de voeding voor de thx meten? De aardlek vloog eruit zodra ik de probe massa aan - lag. Lekker dom. Gelukkig niks kapot gegaan....

Mag ik met de probe direct op de print meten? Ik wil weten of de optocoupler het nog doet (blokgolf). Hoe moet ik dan meten?

Michel

Alleen secundair kan je fatsoenlijk meten.

Wil je primair meten: een scheidingstrafo gebruiken, maar let heel goed op het blijft linke soep.

Verder: Vervang C5 eens door een nieuwe, die gaan vaak stuk in dit soort configuraties.

PS De voeding komt van zijn eigen schakelen via D6. R1 wordt gebruikt om het ding te starten. Vandaar dat die voedings booster vaak een oorzaak van de ellende is (C5 in dit geval?).

Als C5 het niet is zal het zeer waarschijnlijk de THX zijn.

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.

de r1 2,2m kan ook de voeding verzorgen, staat er wel spanning achter die weerstand?

waar rook was, werkt nu iets niet meer
EricP

mét CE

C5 is je eerste verdachte. Als IC1 hemelen is, dan ook C1 vervangen.
D6 vind ik trouwens ook wel spannend. Trage diode op dat plekje? Met welke frequentie schakelt dat ding??

Verder heb ik ook nog wel eens de neiging om bij dit soort voedingen gewoon met hagel te schieten: vervang alle electrolieten en (potentieel defecte) halfgeleiders, dan zal het wel weer werken. Weerstanden nameten (da's zo gebeurd). Commercieel gezien vaak beter te verantwoorden dan op componentbasis te gaan uitzoeken en vervangen (met het risico dat je wat mist en het spul weer dood gaat).

Eerst moet R1 de chip van een tijdelijke spanning verzien genoeg om te starten daarna moet de spanning op C5 het overnemen

Hoofdverdachte #1 in smps's is de schakelende Mosfet/Transistor, maar aangezien die hier geintregeerd zit in een chip,.. denk ik dat je chip kapot is. (afgezien van bolle/lekkende elko's)
-Via pen 7/8 wordt de main spoel geschakeld.
-Die 2,2M levert de startup current
-Puls via 7/8 op spoel
-2nd primaire spoel geeft inductie spanning >gelijkspanning voor IC
-Oscillator start op en het comparator-feest kan beginnen

Datasheet... maar die had je al gevonden
http://lib.chipdip.ru/030/DOC001030452.pdf

Re-integratiecoach uitgerangeerde en degoutante electronen
maartenbakker

Golden Member

Schakeltor gaat 9 van de 10 keer in sluiting als hij stuk is, dus dan heb je een kapotte zekering of zekeringweerstand en geen 300V.

Minstens zo verdacht als elco's, zijn hoogohmige weerstanden. Zeker als er een enkele weerstand gebruikt is, waarvan altijd maar de vraag is hoe goed hij tegen 300V kan. Mocht hij inderdaad nog hoogohmiger zijn dan hij hoort te zijn, dan kan het zeker geen kwaad om hem te vervangen door bijvoorbeeld 2 maal 680k en 1 maal 820k in serie te zetten.

Wat een prachtige datasheet overigens, op meerdere manieren.

Het is kennelijk van een Chinese fabrikant (zie de gebruikte haakjes), en de leukste kromme vertaling is dat ze de bipolaire uitgangstransistor (nota bene: geen FET) als tube betitelen en dat ze die shutten (alsof het een valve is).

Ander mooi punt is dat hij vrij uitgebreid is!

"The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Ik ben even bezig geweest. Heb R1 er even uitgehaald en gemeten en die geeft 2 MOhm, dus die is ok.
C5 vervangen. die was wel op. Ik heb een Capaciteit functie op mn multimeter en die gaf niks meer aan op de C.

Maar het is niet verholpen. Ik meet nog steeds 20mV op pin 2 en 3 van de thx. En het rare is..... achter R1 meet ik dat ook! Ik snap er niets van want als de THX geen stroom trekt moet ik de 320VDC ook achter de R1 meten maar dat meet ik niet.....

Michel

Je zou nog kunnen proberen met een losse adapter of zo iets tussen rond de 12V over C5 te zetten, en te kijken of hij dan nog wel opstart. Als hij het dan wel doet, is er alleen iets mis met het opstart circuit, of met de diode of transformator wikkeling waarmee hij zijn eigen voeding moet maken. Als er met een externe hulpvoeding nog geen leven is zit, is die THX waarschijnlijk overleden.

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Dan ben ik bang dat het THX chippie stuk is.

Als je naar het inwendige schema van het ding kijkt zou je op pin 1 ca 0.7 V of iets meer verwachten. Het lijkt dat er inwendig sluiting in zit.

Meet eens of er sluiting tussen pin 1 en 3 de GND zit?

@Sparky: Wel met een scheidingstrafo op deze (defecte) voeding anders is het levensgevaarlijk!
En je was met net voor met dat idee...

PS zet dan ook een gloeilamp in serie met de voeding, als er in een keer sluiting ontstaat, blaas je niet letterlijk alles van de print.

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.

Maar het is niet verholpen. Ik meet nog steeds 20mV op pin 2 en 3 van de thx. En het rare is..... achter R1 meet ik dat ook! Ik snap er niets van want als de THX geen stroom trekt moet ik de 320VDC ook achter de R1 meten maar dat meet ik niet.....

Dat hangt weer sterk af van het gebruikte meetinstrument. Een goede mosfet meter kan daarover uitsluitsel geven, de tegenwoordige populaire meters doen dat niet. Als de R I hoger is dan 20 meg is het te meten, anders niet. Er zal toch ook ergens op dat IC meer dan 300 volt aanwezig moeten zijn via de primaire wikkeling van de trafo, is de trafo onderbroken, wat vrijwel nooit voor komt, is die spanning zoek. Kan ook nog een haarscheur in de print zitten en die zitten dan meestal direct naast het soldeer eilandje aan de pen van de trafo. Met een goede sterke loep 10X of zo is dat wel te zien, maar ook te meten. Dan nog een tip, zet nooit een massa van de scoop aan de primaire kant zonder scheidingstrafo, dat gaat van KLABBABBER!
Mogelijk is er ook nog een meetfout gemaakt, er zijn 2 soorten gnd, de secundaire en de hete. Metingen aan de primaire kant worden altijd gemeten aan de hete ground en dat is die welke aan de negatieve pool van de elco zit. (aangeduid als een hark met 3 tanden)

Groetjes Hans.

[Bericht gewijzigd door Zoef de Haas. op 30 september 2014 14:14:35 (11%)]

Hoe het werkt is niet belangrijk, als het maar werkt!

Hallo daar zijn we weer :-)

Als ik R1 los haal dan meet ik na R1 iets van 200 VDC dus de THX schijnt wel wat mA te trekken als R1 eraan vast zit.

D6 nogmaals gecontroleerd en is ok.

Echter tussen pin 1 en 2 van de THX meet ik continue kan dat? Dat zou betekenen dat D6 doorgeslagen zou zijn en dat is het niet.....

Tussen pn 1 en 3 meet ik 138 Ohm..... dus ook tussen 2 en 3 vanwege de sluiting 1 en 2.

Ik ga eens over C5 9-12V zetten met mn labvoeding kijken of er wat gebeurt. edit: wat zou ik moeten zien dan, ik durf mijn oscilloscoop nergens aan te hangen zonder scheidingtrafo.

de 3 spoelen van de trafo zijn continue dus "ok".

Kan iemand mij in de tussentijd uitleggen wat r2-c2-d5 combi voor werk verricht?

12V over C5 dan trekt de schakeling 110mA

mijn Delta labvieding gaat tot 50VDC; Kan ik daarmee de gehele schakeling mee kunnen opstarten? Dus over C1 50V? edit: o natuurlijk niet, als hij het bij 320VDC niet doet dan zeker bij 50 ook niet duh

[Bericht gewijzigd door Henry S. op 1 oktober 2014 00:06:57 (15%)]

Michel
EricP

mét CE

Kan iemand mij in de tussentijd uitleggen wat r2-c2-d5 combi voor werk verricht?

Dat is het 'freewheel' stuk. Als je de stroom door die spoel onderbreekt, gaat de spanning sky-high. Dat wil je niet. Hierdoor kan de stroom blijven lopen en het veld zich richting secundair afbouwen zeg maar. Hier leggen ze daar wat over uit. Blijkbaar heeft men hier redenen om voor een C en een R te kiezen. Heeft vast iets met flanken ofzo te maken :).

Op 30 september 2014 20:33:25 schreef Hoihoi:
ik durf mijn oscilloscoop nergens aan te hangen zonder scheidingtrafo.

Je kan even met de spanningszoeker (neonlamp) kijken dat de nul en niet de fase op de buitenkant van de oscilloscope kast staat.
Anders de stekker van de schakeling omdraaien en insteken in de WDC.
En de scopekast niet aarden.

Als je met 1 hand meet de andere hand onder de tafel kan je wel meten aan zo'n schakeling. Deed ik ook veel voordat er een scheidingstrafo stond.
Ik wilde bromvrij meten aan kleine signaaltjes in KTV's (chroma. sandcastle puls, Teletekst lijnen ect) en dan is een geaarde scope veel beter.

Maar als je het niet aandurft doe je het toch gewoon niet, simpel zat.

maartenbakker

Golden Member

IK krijg uit de metingen sterk de indruk dat het IC stuk is.

"The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Ik zou gewoon de 230V aansluiten, en 12V over C5 zetten, en kijken of het ding dan nog op wil starten. Een gloeilamp in serie is wellicht geen slecht idee. Je kunt dan gewoon de multimeter aansluiten op de uitgang voordat je de spanning erop zet.

Speciaal voor dit soort werk heb ik een setje isolators bij de scope, maar een scheidingstransformator werkt natuurlijk ook.

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

sow dat durf ik niet. dan leg ik de 0 na de gelijkrichter (320vdc) aan de 0 van m'n labvoeding. Dat gaat toch fout?

[Bericht gewijzigd door Henry S. op 1 oktober 2014 00:06:17 (68%)]

Michel

In principe zou dat goed moeten gaan, zeker als je het ding voed via een scheidingstransformator, maar ik zei ook niet voor niets met een adapter, en niet met een labvoeding.

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Op 30 september 2014 21:39:30 schreef Hoihoi:
sow dat durf ik niet. dan leg ik de 0 na de gelijkrichter (320vdc) aan de 0 van m'n labvoeding. Dat gaat toch fout?

Niet doen dus, inderdaad die labvoeding kun je opblazen.

Ik heb zelf ook eens heel lang geleden een primair circuit zo op willen starten, de metalen kast van mijn voeding hangt aan aarde.
De hele voeding is geïsoleerd van de kast dus je zou zeggen: moet kunnen met de nodige voorzichtigheid.

Ware het niet dat de power transistor van de voedingsregeling met een mica plaatje op de kast zit. Die isolatie sloeg finaal door en de hele stuurprint van de voeding lag aan barrels. Toen moest ik twee dingen gaan repareren, vreselijk balen dus. (Dit verhaal kan ook zo in het domme fouten topic, zal het even crosslinken.)

Maar wat meet je precies tussen 1 en 2 van de THX sluiting of een diode overgang? 99% denk ik dat de THX wijlen is.

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.

Op 30 september 2014 23:06:41 schreef SparkyGSX:
In principe zou dat goed moeten gaan, zeker als je het ding voed via een scheidingstransformator, maar ik zei ook niet voor niets met een adapter, en niet met een labvoeding.

Een geschakelde ? :p

Je hebt tijd of je hebt geen tijd ! als je geen tijd hebt, waar is die dan gebleven ? http://www.ledverlichting-ledverlichting.nl

Een schakelende voeding zou ook goed moeten gaan, maar ik zat aan een ouderwets exemplaar met een ijzeren transformator te denken.

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken
subsonik

Golden Member

Op 30 september 2014 20:33:25 schreef Hoihoi:
(...)
12V over C5 dan trekt de schakeling 110mA

Dat is veel te veel. IC1 is kapot, daar hoef je niet verder voor te meten...

Die redenering kan ik even niet volgen! C5 in combinatie met de diode levert een voedingsspanning aan het IC en deze spanning komt pas als de schakeling werkt. Die hoog ohmige weerstand R1 is voor het startcircuit en als de schakeling oscilleert, dan neemt D6 de functie over en dan zal die 12 volt best eens kunnen kloppen.

Groetjes Hans.

Hoe het werkt is niet belangrijk, als het maar werkt!
subsonik

Golden Member

Zoef: ik snap zeer goed hoe het startcircuit werkt, maar 110mA is buitensporig veel voor het eigen verbruik van zo'n switcher-IC. Dat moet in de grootte-orde van maximaal enkele mA zijn.

Bij 12V en 110mA zou de THX203H maar liefst 1.3W staan stoken, en dat in een DIP8...

Voor de grap even in de datasheet gekeken, en idd: "static current: 2.8mA".

Als men de omschrijving duidelijk geeft met de mededeling dat er 110mA stroom loopt als extern 12 volt wordt aangeboden, dan is mij dat ook duidelijk, maar er staat 12 volt over de elco en dat kan alleen als de schakeling werkt. Zo is dus de verwarring ontstaan en kan ik beamen dat het IC defekt is, maar er is meer, die elco kan ook nog een groot DC lek hebben of de diode. Behalve het IC zou ik ook C5 vervangen en ook die weerstand van 2.2M, want behalve een startfunctie heeft hij ook een regelende functie. Hij bepaalt de pulsbreedte aan de hand van de aangeboden netspanning en is de waarde opgelopen, dan is de pulsbreedte te groot en gaat het IC er weer aan.

Groetjes Hans.

Hoe het werkt is niet belangrijk, als het maar werkt!