Defecte schakelende voeding

Hallo allen,
Allereerst mijn kennis van schakelende voeding is niet groot. Alleen ken ik het principe.
Vandaar een paar vragen.
Het betreft een schakelende voeding uit een Kenwood radio/cd speler.
De fabrikant zelf is niet thuis helaas.
Nu heb ik al een balangrijke C en de MOSFET ( type T70R380P ) vervangen, zonder resultaat.
Nu heb ik wat spanningen in het primaire gedeelte gemeten. Uiteraard met in achtneming van veiligheid. Een scheidingstrafo heb ik niet maar heb het opgelost door de sekundaire kant van een ringkerntrafo via een variac te voeden om zo de schakeling zonder galvanische verbinding met het net te voeden.

Na brugcel staat er 300 V over de elco.
Via een spanningsdeler komt di met 5 V op pootje 8 van het IC. Helaas zonder opschrift.
Op alle andere pootjes.....0 Volt.
Met de scoop vind ik nergens een ( hoogfrequente) wisselspanning.

Nu mijn vragen.

Het IC kan ik dat vervangen door een voor dit doel gebruikelijke equivalent. Want ik vermoed dat die defect is, maar....
Het apparaat wordt met een impuls schakelaar aangezet. Hoe dit werkt weet ik niet. Wat ik wel weet is dat die schakelaar verbonden is met de voedingsprint.
Moet ik dan de schakeling ergens triggeren om er achter te komen wat defect is?
Ik heb zo goed als het mij lukte een gedeelte van de schakeling uitgetekend. Ook heb ik een paar foto’s bijgevoegd. Hierop is duidelijk te zien dat het IC geen kenmerk heeft.

Graag reaktie, bij voorbaat dank

fatbeard

Honourable Member

Check alle hoogohmige weerstanden. Kans bestaat dat ze te ver verlopen zijn, het komt voor.

Een goed begin is geen excuus voor half werk; goed gereedschap trouwens ook niet. Niets is ooit onmogelijk voor hen die het niet hoeven te doen.
maartenbakker

Special Member

Wat is het type van het apparaat? Welk IC-equivalent wil je gebruiken?

www.deficientie.nl | www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Staat er spanning over de elko? Moet ongeveer325V zijn.
Meet je spanning tussen de source of de min en de drain?
Staan er op de gate van de Mosfet pulsjes?
Zijn alle weerstanden nog die waarde die ze moeten hebben?

"tijd is relatief"
jerome

Golden Member

Als bij de vervangen fet de gate in sluiting staat met één van de 2 andere pennen, is ook de driver overleden. Zonder mark gaat dit wel moeilijk worden om een vervanger te vinden als je geen schema krijgt. Zou dan liever uitkijken naar een vergelijkbare voeding. Welke spanningen heb je nodig? Het opgenomen vermogen vindt je vast op de stikker van het toestel of in de handleiding bij technische gegevens.

hartelijk dank allen.

* De voedingsprint komt uit de Kenwood Model No. M-918DAB
* Heb de weerstanden allen gemeten, de meeste waarden
kloppen, maar op sommige SMD-tjes kan ik het niet lezen.
* De volledige voedingsspanning staat via de trafo wikkeling
op de gate van de MOSFET.
* Op de Drain en de Source staat GEEN spanning.
* Zoals ik al meldde meet ik nergens een wisselspanning.
* Wat voor equivalent heb ik in gedachten...geen idee, hebben
jullie een voorstel? De beruchte elco tussen poot 4 en 6
heeft de waarde 22 micro Farad.
* Welke spanningen moet de voeding leveren:
Bij de 10-voudige connector die de voedingsprint verbind
met het mainboard staat het volgende:
+28V;+28V;AGND;AGND;BT-GND;BT-VCC;GND;+5V;-5V;on/off

Graag reactie

Wisselspanning vind je alleen voor de brugcel.
De frequentie waarop een switcher werkt is meestal iets tussen de 50kHz en 2MHz.

Een vervanger is niet zo simpel: er zijn vele honderden switchers waarvan sommigen *bijna* gelijk zijn...
Op de gate hoort in ieder geval geen continu spanning te staan, maar stuurpulsen uit het ic...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com
Anoniem

Heeft die Kenwood radio/cd speler ook een typenummer?

Op 9 september 2021 19:17:35 schreef elektrofix:
Heeft die Kenwood radio/cd speler ook een typenummer?

Is door TS al genoemd!

De voedingsprint komt uit de Kenwood Model No. M-918DAB

[Bericht gewijzigd door buzzy op 9 september 2021 20:00:20 (14%)]

Die switchers geven ook wisselspanning! ( zie mijn eerdere opmerkingen) Het IC doet het dus niet.
En ja op de gate hoort de blokgolf of wat het ook zijn mag uit het IC op de gate te staan. Ik vind het idd raar dat daar nu de voedingsspanning op staat. Zal de weerstand vanuit de trafo eens meten.
En het model nummer vd de Kenwood heb ik in mijn vorige post genoemd.

Die switchers geven ook wisselspanning!

Dat zijn normaal gesproken pwm signalen.
(wisselspanning denk je meestal aan 'onbehandelde' spanning met lage frequentie...)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Heb je al gekeken of de voeding naar het sturings ic in orde is?
Als daar iets misgaat dan start de ic niet op. Meestal zijn er weerstanden en of kleine condensators in de buurt die dat regelen en die durven regelmatig kapot te gaan. Het kan ook zijn dat de IC zijn voeding krijgt van een kleine wikkeling van de trafo.
Heb je al eens gekeken of je geen schema gevonden krijgt met de nummers van je voeding? Gooi die anders een google. Soms vind je een schema en dus nummer van de sturings ic. Maar wie weet vindt je een reparatie verslag of ander topic online met meer informatie. Zo vind ik wel eens meer informatie die handig is bij reparatie als ik geen schema vind. En met Google translate kom je al een heel eind als het in een taal is die je niet machtig bent.

Goede tip Brains! Ga die printplaat nummers in google stoppen.
Overigens krijgt het IC keurig 5 Volt vanaf de gelijkgerichte netspanning via een weerstands laddertje

Anoniem

Het www geeft niks prijs voor het typenummer of een nummer op de smps print.
Die 5 volt op p8 is waarschijnlijk de voedingsspanning van de controller voor de opstartfase en lijkt OK.
Dus als je de stekker in het stopcontact steekt zul je op de uitgang van de controller even pulsen moeten zien met de scope.
Zijn die er niet dan is je controller hoogst waarschijnlijk defect.
Zie je die wel dan kan het zijn dat je controller in veiligheid gaat en de voeding niet opstart.
Dit kan omdat er wat fout is met het circuit rond p4/p6 die de voedingsspanning levert voor de controller in bedrijf.
Of dat er wat mis is aan de coldside waar bv geen spanning wordt opgebouwd (bv dubbeldiode D3 defect?) en er via de optocoupler niks naar hotside wordt teruggekoppeld.
Je mist trouwens die opto in je schets die dus niet gaat kloppen.
Zeker een correct leesbaar schema optekenen van je smps

IDD geeft google geen resultaat op type nummer van het SMPS board
En ik heb niet zo'n netjes, incompleet schema gepost.
Rechts op de foto ziet jullie (vermoedelijk) de zener ZD2 die staat over de optocoppler, en meet in de twee verschillende richtingen 4 M Ohm en 7 M Ohm.
lijkt mij wel verdacht.

hennep

Golden Member

Het feit dat er geen signaal op de mosfet aankomt hoeft niet te betekenen dat het ic kapot is. Als de fototransistor in de opto kapot is en constant in geleiding dan zal het ic ook niets doen.
Het is wel een ontwerp met ingebouwde zelfdestructieklok. Als ik die bufferelko zie, die klem zit tussen twee vermogenscomponenten, daarvan zal de capaciteit flink zijn afgenomen. Al gemeten?

vergeten

Golden Member

Op 9 september 2021 12:34:38 schreef Genon:
Een scheidingstrafo heb ik niet maar heb het opgelost door de sekundaire kant van een ringkerntrafo via een variac te voeden om zo de schakeling zonder galvanische verbinding met het net te voeden.

Vertel eens met wat meer details hoe je dat hebt gedaan? Anders ben je een beetje bezig met schijnveligheid?
De meeste variacs zijn namelijk niet galvanisch gescheiden!

Als het goed is zet je de variac uitgang bijvoorbeeld op 24 volt, daarmee voed je een trafo van 230/24v die je omgekeerd gebruikt, dan is het wel veilig.

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Ik denk dat Genon bedoelt dat hij de secundaire kant aan een variac aangesloten heeft en de nominale spanning ingesteld heeft voor die secundaire, zodat er primair iest wat dicht in de buurt van netspanning komt, beschikbaar is.

@ hennep: mijn idee...

http://www.m-voorloop.nl --- Ik? Welnee! Ik zit nog lang niet achter de germaniums.
Anoniem

De volledige voedingsspanning staat via de trafo wikkeling op de gate van de MOSFET.

Kan niet met een max VGS van +-30V voor deze fet. Vergissing met je GDS aansluitingen dus

MMFT70R380P-1.pdf

meet in de twee verschillende richtingen 4 M Ohm en 7 M Ohm.
lijkt mij wel verdacht.

Zegt niks, in circuit meet je door meer dan de zener

Het feit dat er geen signaal op de mosfet aankomt hoeft niet te betekenen dat het ic kapot is.

Tuurlijk niet maar als je de stekker in steekt horen er op p5 van de controller ff pulsen te vertrekken naar de gate. Zoniet is de controller defect of schort er wat met het opstartcircuit aan p8.
Kan dus best zijn dat de controller daar minstens 6V nodig heeft om te kunnen opstarten.

Heb de weerstanden allen gemeten, de meeste waarden kloppen

Sommige dus niet?
Als dat die aan p8 zijn kun je dus het vlaggen hebben. Is een gekende fout voor een niet opstartende controller.
Pas als bij de opstartfase de voeding rond p4/p6 het niet overneemt of via de opto geen signaal of fout signaal van de coldside komt gaat ie in veiligheid.
Ik zie trouwens ook geen verbinding van de current sense weerstanden naar de controller!
En ja je bent hier rechtstreeks met netspanning bezig dus weet wat je doet is heel belangrijk

De werking van het smps ic kun je ook off line onderzoeken.
Als voeding gebruik je dan een regelbare laagspannings voeding.
Bij en fout fikt de boel dan niet weer meteen uit, zeker niet als je stroombrgrenzing gebruikt.
Ik heb nog niet gelezen wat het type smps ic is, dat is wel een handicap.

hennep

Golden Member

Het ic zou wel eens een IR2153 kunnen zijn. Dat zou verklaren waarom pin 7 (high side) niet is aangesloten. Pin 5 (low side) stuurt dan de gate aan. Er was al vastgesteld dat gate en drain verkeerd om in het schema staan. Ik ben benieuwd waar de opto ergens in het schema zou moeten komen, nu ontbreekt dat deel in het schema.

5v is veel te weinig voor zo'n IC. Bijna altijd zorgt een spanningsdeler vanaf de 325V in combinatie met een condensator en zener voor het opstarten, en vervolgens moet een aparte wikkeling (net als secundair tegengesteld aan primaire dus flyback) in serie met een diode het IC voeden, wat gewoonlijk 12-30V is.
Gebeurt dit niet, dan gaat de chip oscilleren door de UVLO en dat is te horen aan een herhalende tik. Al die chips zijn vrijwel identiek aan de UC3842, behalve natuurlijk de pinout.
Het hoeft niet alleen de condensator te zijn, maar het kan ook fijnsluiting in de trafo zijn waardoor de chip niet goed kan opstarten en dus weer uitvalt.

Dit is in ieder geval nooit een IR2153 aangezien er maar één transistor zit aan de primaire zijde en er geen spoelen zitten op de uitgang om de energie te bufferen. Bovendien is het lastig om met een IR2153 een optocoupler te gebruiken om de uitgangsspanning te regelen.

Op 9 september 2021 20:02:09 schreef Genon:
Die switchers geven ook wisselspanning! ( zie mijn eerdere opmerkingen) Het IC doet het dus niet.
En ja op de gate hoort de blokgolf of wat het ook zijn mag uit het IC op de gate te staan.

Meet je dat met een scoop ? Veel multimeters zijn niet geschikt om pwm signalen te meten qua bandbreedte en crest factor. Ze kunnen ook rare waarden geven bij meten aan een werkende smps als de afscherming niet goed is.

Zeners test je in situ bij een werkende voeding gewoon door de spanning er over te meten (als het ding er niet alleen voor protectie zit) En anders uitgesoldeerd met een weerstand in serie en labvoeding. Gebruik een paar mA. Niet in situ met een ohm meter, elke DMM heeft tegenwoordig wel een diode stand maar de hoogte van de meetspanning is, net als in de ohm stand, vaak te laag voor zeners (mijn meters variëren van 3 tot 10V en 2 hebben een instelbare stroom).

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur, ook oud en exotisch

Op 10 september 2021 13:20:14 schreef elektrofix:
[...]Kan niet met een max VGS van +-30V voor deze fet. Vergissing met je GDS aansluitingen dus
[bijlage]

En ja je bent hier rechtstreeks met netspanning bezig dus weet wat je doet is heel belangrijk

Foei foei, die oude pensionados zoals ik maken steeds meer fouten!
Inderdaad staat de MOSFET verkeerd in het schema.
De voedings spanning staat over DS.
De gate is via R's en een diode verbonden met pin 5 van het IC.( R10, R11 en D4).
En uiteraard meet ik volledig galvanisch gescheiden van het net via de boven beschreven methode: Variac dan sec van ringkern dan primair van ringkern naar SMPS