ESP8266+Servo Probleem: Uitgangsspanning 7805 zakt naar 2.5V bij 0.4A.

buckfast_beekeeper

Golden Member

Voed je ESP via een andere 5V en gebruik 2 optocouplers om je MOSFET en PWM signaal aan te sturen. Dan zit je ESP al veilig. Al zeker tijdens de test fase.

Hoe groot is de opstartstroom van je servo? Een sterk vermoeden dat de kleine regelaars die piek gewoon niet kunnen leveren en dat dit zelfs je switchers heeft gemold.

De LM2596 is ook een switcher. Heb je die gebruikt zoals aangegeven in de datasheet?

Uiteindelijk is het een en en verhaal. Te dunne draden naar de servo gaan de stroompiek wat verkleinen maar er ook voor zorgen dat de servo niet de stroom krijgt die hij verlangt om te starten.

Zit je niet op een dood spoor te zoeken omdat je koste wat kost wil bewijzen dat je idee moet werken?

Van Lambiek wordt goede geuze gemaakt.

Ik heb niet alles gelezen, maar.... Zo'n 9 gram servo kan makkelijk (kortstondig) 1A trekken als ie naar een nieuwe locatie moet. Maar dit is geen 9 grams servo, deze is zwaarder. Het zou me niets verbazen als ie gewoon makkelijk pieken van 2-4A trekt.

Als je je voeding daar niet op kan begroten, dan moet je gewoon de stuur-electronica uit via een andere 7805 voeden dan de servo. Die servo kan het hebben dat de voeding gewoon wegzakt. Dan gaat ie langzamer naar de gewenste stand.

Het: "de GND draden moeten bij de accu bij mekaar komen" verhaal is m.i. bij dit soort stromen nog niet noodzakelijk. Als je redelijke draden neemt mag best de servo stroom over de retourdraad van de stuur-elektronica naar de accu.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Hoe groot de daadwerkelijke opstartstroom is kan ik niet meten wegens het niet hebben van de apparatuur daarvoor. Wel heb ik gemeten (met een iets degelijkere LM2596 setup en bedrading) dat de servo continue 1,2A trekt wanneer ik hem blokkeer. Exact conform de specs (stall torque). Of de servo eerst een maar micro of milliseconden (de opstartstroom) 5, 10, 20 of 50A trekt, weet ik dus niet.

Overigens werkt de servo icm (nieuwe) wemos met de LM2596 nu perfect. Supersterk. En trekt 1.2A zonder noemenswaardige spanningsval bij de LM2596. Ook is er amper warmteontwikkeling voelbaar. Ook gaat de LM2596 wel redelijk passen in mijn behuizing als ik toch al een nieuw bordje moet solderen met een iets andere indeling. Dus wat dit project betreft is het probleem opgelost.

Maar, @buckfast, de reden dat ik hier zo lang mee aan het klooien ben is niet omdat ik perse vast wil houden aan mijn eerste ontwerp met de 7805. Maar omdat ik wil weten wat de exacte reden is dat dit niet werkt, zodat ik daar rekening mee kan houden bij toekomstige projecten als ik weer eens een 7805 wil gebruiken. Ik wil weten wanneer wel en wanneer niet. Vandaar mijn speurtocht. En daar ben ik nog steeds niet uit, tenzij het inderdaad een minderwaardige clone is en de hele serie minderwaardig is (heb er inmiddels 4 doorheen gejaagd uit dezelfde verpakking).

Concreet ben ik eenvoudigweg gewoon heel benieuwd naar waar ik een 7805 wel voor kan gebruiken, en waarvoor niet.

Een 7805 kun je gebruiken als je niet over de max. stroom en vermogen van de 7805 heen gaat.
Servomotor op dezelfde voeding als de CPU is ook vragen om problemen.
Hoge stroom van de motor trekt de 7805 onderuit, en daardoor loopt de CPU vast.

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Op 3 december 2021 16:25:02 schreef Arco:
Een 7805 kun je gebruiken als je niet over de max. stroom en vermogen van de 7805 heen gaat.

Dat lijkt me duidelijk. =p

Maar hoe bepaal je dat in de praktijk? Datasheet van 7805CV zegt max 1A bij 'voldoende koeling'. Daarmee wordt neem ik aan continue 1A bedoeld en voldoende koeling om het intern koeler dan 150C te houden.

Stel, de servo in kwestie had een stall current van 1A ipv 1,2A. En voor het gemak nemen we even aan dat het opstartkoppel ook niet hoger is dan 1A (wat het ongetwijfeld wel is). Had het dan wel gekund met een 7805 icm een flink koelblok? En als het wel continue zou moeten werken met groot koelblok, waarom werkt het dan niet heel eventjes met een klein koelblok? Of zonder koelblok?
Deze casus even zonder esp, om het simpeler te houden. Puur een 7805 + denkbeeldige 1A servo.

Op 3 december 2021 17:06:27 schreef perpetuum_mobile:
[...]

Dat lijkt me duidelijk. =p

Maar hoe bepaal je dat in de praktijk? Datasheet van 7805CV zegt max 1A bij 'voldoende koeling'. Daarmee wordt neem ik aan continue 1A bedoeld en voldoende koeling om het intern koeler dan 150C te houden.

Precies. Als je de handleiding van de 7805 goed leest, dan staat er ook dat er nog een current limit inzit. Die is dan afgesteld op "typical 1.3A" (*) of zoiets. En dat is dus de "kortstondig max". Als je daar overheen gaat dan zakt ie al in nog voordat ie heet gaat worden.

groot koelblok,

Meestal niet nodig. Als die stall current of opstartstroom maar "zo nu en dan" getrokken wordt, dan hoeft de 7805 dat dus maar even te leveren en heeft dan weer de tijd om af te koelen. Dus als je geen "stall-situatie" verwacht, en korte perioden van activiteit dan is een klein koelblok of zelfs geen ook mogelijk.

(*) dit om te garanderen dat je altijd minimaal 1A d'r uit kan trekken. Zouden ze hem op 1.05A mikken en zit dit exemplaar 10% lager... tja dan zit jij in de problemen als je 0.99A "zou moeten kunnen" nodig hebt.

[Bericht gewijzigd door rew op 4 december 2021 09:40:26 (10%)]

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
Lambiek

Special Member

Op 3 december 2021 17:06:27 schreef perpetuum_mobile:
Maar hoe bepaal je dat in de praktijk? Datasheet van 7805CV zegt max 1A bij 'voldoende koeling'.

Met een klein foefje kun je hoger dan 1A.

En een 78S05 levert standaard al iets meer dan 1A, zit geloof ik op 1.5 of max 2A.

En hier op de site staan ook voorbeelden hoe je zoiets kunt doen.

https://www.circuitsonline.net/schakelingen/33/voedingen/5-a-gestabili…

Als je haar maar goed zit, GROETEN LAMBIEK.

De 78xx heeft een thermal shutdown en een current limiter, en beide zijn in staat om de uitgangsspanning/stroom te onderbreken/beperken.
(en dat vindt een microcontroller meestal niet fijn...)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Volgens mij heb je spanningsregelaars van slechte kwaliteit.

Maar als uw motor staat te trillen is de aansturing niet goed of stabiel genoeg, mijn SG90 servootjes staan rotsvast als ik die test.
Dat wil ook zeggen dat de regelaar x-aantal piekstromen per seconde moet verwerken door die trillingen.

Misschien kun je eens proberen met een powerbank.

LDmicro user.
Sine

Moderator

Op 3 december 2021 09:34:09 schreef rew:
Ik heb niet alles gelezen, maar.... Zo'n 9 gram servo kan makkelijk (kortstondig) 1A trekken als ie naar een nieuwe locatie moet. Maar dit is geen 9 grams servo, deze is zwaarder. Het zou me niets verbazen als ie gewoon makkelijk pieken van 2-4A trekt.

Ik gok dat dat het probleem is ja, en niet die "Chinese" regelaars (die stiekem best goed zijn)

Lambiek

Special Member

@TS,

Maak dan zoiets, dan heb je 5A tot je beschikking.

Heb je al eens geprobeerd hoe het met een lab-voeding werkt?

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 4 december 2021 12:09:11 schreef MGP:
Volgens mij heb je spanningsregelaars van slechte kwaliteit.

Je hebt kennelijk te weinig gelezen. We zijn er ondertussen achter dat de 7805 conform z'n datasheet bij de gevraagde piekstromen wel zal inzakken tot onder wat de ESP lekker vind. En het doorzagen over de 7805 is ook niet zo productief: TS heeft ondertussen een DCDC converter ingebouwd en dat werkt bevredigend.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
KGE

Golden Member

Op 1 december 2021 19:06:54 schreef perpetuum_mobile:
Hierbij een HD video van de schakeling:
https://we.tl/t-OXHVaNmE4i

Een extra 7805 is wellicht een oplossing idd, maar ik ben inmiddels vooral benieuwd naar waarom dit niet werkt.

@Weirdguy: Ik heb ook nog getest van een 470uF condensator tussen 5V en GND, maar dat had geen effect.
De spanning zakt ook in zonder servo, maar met een 10Ohm weerstand tussen 5V en GND. En ook dan meet ik 0,4A en 2.5-3.5V ipv 5V.

Je hebt volgens mij gewoon nep 7805's gekregen...

Als je een 7805 die je mishandelt vreemd doet is dat nog geen reden om het 'nep' te noemen...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Ik denk dat de servo ook gewoon wack is, want het werkt nog steeds niet helemaal perfect. De nieuwe schakeling zit in de bijlage. De voeding gaat nu:
12V Accu > LM2596 module > 7805 > Wemos.
De servo hangt direct aan de LM2596 output (7.5V).

Het werkt wel goed genoeg voor mijn toepassing, maar:

Als ik de servo van 0 naar 180 stuur. En voordat hij is aangekomen bij 180 weer terug naar 0 stuur. Dan gaat ie alsnog hard trillen. Hij 'redt' zichzelf er wel weer uit nu. Het trillen duurt hooguit een paar seconden en daarna gaat ie alsnog naar zijn doel.

Als ik dus eerst de servo naar 180 stuur. En als hij daar is aangekomen pas weer terug naar 0. Dan doet ie het perfect. En dat kan ik achter elkaar blijven doen. Maar zodra ik hem van richting laat veranderen terwijl hij nog onderweg is de tegengestelde richting op, gaat het mis.

Dit komt ook wel overeen met de allerhoogste stroompiek die de servo maar kan trekken. Hij moet EN de boel afremmen naar stilstand EN de andere kant op accelereren.

De 5v blijft nu stabiel. Enkel de wemos gebruikt nu de 7805 en laatstgenoemde wordt (zonder koelvin) ook niet meer dan lauw.

De 7.5v output zie ik bij geblokkeerde servo amper inzakken @ 1.2A. Bij de servo zelf zakt het naar 7.2-7.3v wanneer geblokkeerd. Met de bedrading zit het dus denk ik wel goed.

Ik heb een nieuwe servo besteld. Een MG946R. Die is zelfs nog ietsje sterker dan de 995. Ben benieuwd hoe die zich zal gedragen. Want langzamerhand begin ik de fabrikant van deze servo te verdenken van een hele slechte PID afstelling in de firmware...

KGE

Golden Member

Op 4 december 2021 14:50:21 schreef Arco:
Als je een 7805 die je mishandelt vreemd doet is dat nog geen reden om het 'nep' te noemen...

Wanneer je een 7805 met een 10 ohm weerstand belast zou die gewoon netjes 5 Volt moeten leveren. Volgens TS komt er dan maar 2,5 tot 3,5 Volt uit.. Wanneer zijn ingangsspanning minstens twee Volt boven de uitgang ligt en dit het resultaat is dan zijn het nep 7805's

MarEle

Golden Member

Het lijkt me verstandig tot alles werk om de transistor weg te laten. Dan weet je zeker dat deze geen problemen geeft.

Ik zou toch ook eens een level-shifter proberen. Ik kan nergens vinden dat de aansturing op 3.3v mag. Door de transistor zit je hier zelfs nog een paar tiende volt onder.