opamps vervangen frm stereocoder

ik heb de opamps uit de frm(lm741) vervangen door TL071.
Nu krijg ik echter bijna geen geluid, alleen wat zacht vervormd gekraak. PLaats ik de 741 terug, is het weer prima
Iemand een idee?
Voor de rest een standaard FRM van toen

Waarschijnlijk moet je wat weerstandswaardes aanpassen i.v.m. de gewijzigde ingangsimpedantie... Voor duidelijkheid het schema:

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Ha sandoz,

Een goede hint gegeven door @Arco :D
De LM741 is een B.J.T. en de TL071 is een J-F.E.T. Op amp de bias generator zal zeker aangepast moeten worden.
Wat ik verwacht is dat je versterker nu vast loopt tegen de voeding rails kijk naar de 8,2 kΩ en 12 kΩ ,
plaats tijdelijk een pot-meter ( loper en een kant ) van 47 kΩ over de 12 kΩ !

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

Check de TL071's zeer goed! Er zijn veel fakes in omloop, heb ik zelf ervaren. Ze haalden de 3KHz niet eens om een blokgolf zonder vervorming te versterken! Controleer of er zich "iets" bevindt tussen pinnen 1/5 en pin 4, weerstand of diode. Niets? Wordt dan gesteld 100% zeker een fake te zijn.

het zijn aliexpress versies, dus zou kunnen

Ha sandoz,

Oei maak even een simpele x4 versterker los op een broodplank :P

Groet,
Henk.

Everything should be as simple as possible, but not simpler.

Opgepast: niet alle TL071 versies hebben een externe offset adjust. Bij de pennen in je schema voor de LM741 staat NOT CONNECTED in de datasheet.

Bias moet op 2 plaatsen worden aangepast:

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com
Sine

Moderator

Op 21 juni 2022 13:44:44 schreef Brightnoise:
Opgepast: niet alle TL071 versies hebben een externe offset adjust. Bij de pennen in je schema voor de LM741 staat NOT CONNECTED in de datasheet.

Juist alleen de enkele 071 opamps hebben deze adjust, de 072 en 074 hebben deze niet, alleen is die offset pot geen 10k maar 100k

Op 21 juni 2022 13:54:25 schreef Sine:
[...]

Juist alleen de enkele 071 opamps hebben deze adjust, de 072 en 074 hebben deze niet, alleen is die offset pot geen 10k maar 100k

Nee, het ligt toch ietsje anders. Maar not connected intern zou ook geen bonddraad betekenen (in de meeste gevallen) en dus niet een oorzaak van de fout mogen zijn. Het zal inderdaad wel iets anders zijn.

[Bericht gewijzigd door Brightnoise op 21 juni 2022 14:05:14 (24%)

De -H versie heeft geen offset aansluitingen om een simpele/praktische reden: hij is er ook in SOT23-5... (men kwam pootjes tekort... :) )

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com
Frederick E. Terman

Honourable Member

Ik geloof er niets van dat de voorspanning ('bias') het probleem is. Die komt uit een paar kΩ, terwijl de ingangen van de opamps vele MΩ (741) of GΩ (071) zijn.
En dan zál de gelijkspanning een paar mV verschuiven - dat maakt niets uit. De invloed van de voedingsspanning is duizenden malen groter.

Check de nieuwe opamps.
Mochten de 071's wél goed zijn, dan vraag ik me af of de boel niet staat te oscilleren.
Die 1,2 nF in de ingang van de audiotrapjes zit daar om de luie 741's nog even een schop te geven vanaf enkele kHz, door daar de tegenkoppeling te verminderen.
De TL071's worden hier alleen maar zenuwachtig van, en gaan enorm rinkelen, op bijna oscilleren af, zie plaatje: ingang 0,1 V blok; rood is mét 1,2 nF, groen zónder.
Een veel kleinere waarde zou daar goed zijn.

Keramisch, kalibratie, parasitair: woordenlijst.org

Even in wat simpelere taal: hoe check ik ze?

Ik heb besteld de 071cp, wellicht de verkeerde?

[Bericht gewijzigd door sandoz op 21 juni 2022 16:45:52 (37%)

Thevel

Golden Member

Waarom geen 741, daar werkt het toch mee?

Persoonlijk zou ik voor audio de 071 liever gebruiken dan de 741.
En die boost waar FET het over heeft is volgens mij een benadering van de 50 microseconden pre-emphase.

Testen: DC-gemiddeld moet de uitgang van iedere opamp gelijk zijn aan de referentiespanning (weerstands spanningsdeler). En zoals Arco al aangaf mag die verbeterd worden, maar dat hoeft niet echt.

ik sluit me aan bij FET. de 741 is een "tamme" opamp, daar kan je hoogohmige weerstanden etc gebruiken voor de feedback, en kan je aan veel regeltjes je voeten vegen. voor de snellere 071 gaat dat niet op, denk dat de kans groot is dat er extra oscillatoren ontstaan.

En als het Chinees zand is, tja.. een kleine schakeling bouwen waarmee je de opamp op zijn topsnelheid kan testen lijkt me makkelijk te doen.

Frederick E. Terman

Honourable Member

Op 21 juni 2022 17:32:31 schreef Brightnoise:
En die boost waar FET het over heeft is volgens mij een benadering van de 50 microseconden pre-emphase.

Nu je het zegt, dat zal inderdaad de bedoeling zijn1.
Het blijft wel zo dat de 071's wat 'harder' gaan in het hoog, dus toch voorzichtig ermee. :)

--
1Je wilt natuurlijk niet het complete MPX-signaal gaan pre-emphasizen. Zouden piraatjes eraan denken de preemphase uit hun zender te halen als ze er een stereocoder voor hangen?

Keramisch, kalibratie, parasitair: woordenlijst.org

Ik sluit me aan bij Thevel; IF IT AIN'T BROKEN, DON'T FIX IT!

A good housewife opens the fridge-door at zero cross point of AC cycle.

Meet de DC instellingen, en lees de datasheets. Ik ben bang dat de TL071's bij het opstarten in de hoek blijven hangen omdat de ingangen van teken wisselen als men aan de onderkant van het common mode bereik komt, wat bij opstarten het geval zal zijn.

Een niet optimale Dc instelling zal hooguit de headroom wat verminderen.

Sine

Moderator

Op 21 juni 2022 19:55:44 schreef CrossFireX:
Ik sluit me aan bij Thevel; IF IT AIN'T BROKEN, DON'T FIX IT!

Nouja, een 741 is voor audio natuurlijk broken by design.

Op 21 juni 2022 19:27:17 schreef Frederick E. Terman:
[...]Nu je het zegt, dat zal inderdaad de bedoeling zijn1.
Het blijft wel zo dat de 071's wat 'harder' gaan in het hoog, dus toch voorzichtig ermee. :)

--
1Je wilt natuurlijk niet het complete MPX-signaal gaan pre-emphasizen. Zouden piraatjes eraan denken de preemphase uit hun zender te halen als ze er een stereocoder voor hangen?

Dit piraatje wel. Ook omdat anders je RDS raar gaat doen.

Waar het moederbord het meeste rookt, loopt ook de meeste stroom!
blackdog

Honourable Member

Hi,

Ik heb er even naar gekeken en een deel op een breadboard geprikt.

Plaatje met annotatie in het schema.
https://www.bramcam.nl/Diversen/StereoCoder.png

Links midden in het rood geef ik aan dat ik van 15V voeding uit ga.
Ik heb een dual opamp gebruikt voor het testen en het si een LF412, zeg maar een soort TL072, maakt verder niet uit.
De eerste opamp is de voeding splitser, die deelt de voedingspanning op met de 8K2 weerstand en de 12K weerstand helemaal links in het schema.

De twee daarop volgende opamp’s hebben ieder ook de gedeelde voedingspanning op hun uitgang staan en dat is dus 8,9V
De offset potmeter die ik niet heb toegepast bij mijn testen zal de balans tussen de twee versterker opamp’s een beetje kunnen regelen, voor een TL071 moet die trimpot wel 100K zijn.

Ik weet niet helemaal goed wat het uitgangspunt is van de frequentie correcties die zijn toegepast in de twee versterker opamps.
Laten we met mijn inzicht beginnen bij de uitgang van de versterker opamps, de uitgangen hebben een 390Ω weerstand en een 10nF condensator naar massa.
Richting de multiplexer en dat is de CD4066 geeft dit een low pass filter van rond de 41KHz als -3dB punt.(Blauwe kader)
De tweede functie van de 10nF condensator, is dat de schakelpulsen uit de CD4066 gedempt worden richting de uA741.

OK, dan nu wat er gebeurd met het audio signaal, bij 400HZ en 100mV aan de ingang van een kanaal, versterkt de opamp dit signaal tot 840mV.
De combinatie van de 47K, 10K, 33K en de 470pF maakt een Low Pass filter van 8,5KHz.(Roze kader)
De combinatie van 560Ω 33k en de 560K weerstand zorgt voor een lift in de frequenties boven de 4KHz en +3dB punt van dit filter ligt dus op 4KHz.(Groene kader)
De mix van de filterwerking rond de opamp (mix van beide filters) gaf gemeten -3dB bij 15KHz, wat mij zinnig lijkt voor deze simpel opzet.

De mixertrap met de meest rechtse opamp heb ik niet getest, maar de 741 op dat punt heeft het echt moeilijk met de hoge frequenties.
Mijn mening is dat het vervangen van de opamp’s zinnig is.
Dit gemeten met een passief low pass filter van 50uSec.

Groet,
Bram

PS
Nog even een toegift betreffende het frequentie gedrag van de pre-emphase.
De gebruikte functie generator stond ingesteld met flanken van 20uSec, dit omdat anders de opamp over zijn nek ging van de stijle flanken.
Er komt dus weer een redelijke nettte 400Hz blok uit.
https://www.bramcam.nl/Diversen/StereoCoder-02.png

Existence, well, what does it matter? I exist on the best terms I can... Heart and soul, one will burn
fred101

Golden Member

Op 21 juni 2022 20:58:45 schreef Sine:
[...]

Nouja, een 741 is voor audio natuurlijk broken by design.

Als het goed werkt is het toch goed ? De TL071 is ondertussen ook antiek, ik zou voor een LTC1052 gaan >:-)

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur, ook oud en exotisch
blackdog

Honourable Member

Hi,

Het blijft een simpel ontwerp, maar ik zou ook de uA 741 vervangen door zoiets als een TL071.
Het wordt er niet een super ontwerp van, maar je vervorming gaat wel lekker naar beneden een verder zie ik behalve de 10/100K offsetpot geen problemen met de opamp wisseling.

Echte ontwerpen hebben een veel beter filter voor het audio en daarmee bedoel ik stijler gefilterd, maar voor hobby werk, waarom zou je moeilijk doen. :-)

Groet,
Bram

Fred, een chopper opamp! kan de chopper frequentie lekker mixen met de 38KHz chopper, toppy! *grin*

Existence, well, what does it matter? I exist on the best terms I can... Heart and soul, one will burn

Ha Blackdog,

Niet helemaal mee eens een LM741 is in de gebruikte situatie net zo goed / slecht als een TL071.
De multiplexer levert zoveel vervorming zoals hij belast wordt dat je bij T.H.D. meting de Op amp niet eens ziet |:(
Dus het is al eerder genoemd lekker laten zitten wel de impedantie (pool ) aanpassen dit kan je proberen door de bias generator aan te passen zodat de Op amp weer voldoende marge krijgt !
Maar ik had aan @TS gevraagd meet een Op amp kopieer het schema aan de rechterkant met twee weerstanden.
En als jje ook de rechter vervangt doe ze dan niet allemaal tegelijk maar links probleem oude terug dan rechts :D
Ik wacht wel af of dat lukt.

Groet,
Henk.

Everything should be as simple as possible, but not simpler.