Raspberry pi stopmotion

Hallo,
Ik wilde met de Raspberry Pi camera een stopmotion maken. Hiervoor gebruik ik de offciele Raspberry Pi turorial: https://projects.raspberrypi.org/en/projects/push-button-stop-motion/7

Ik loop vast bij stap "Generate the video". Zoals in de tutorial aangegeven krijg ik inderdaad de avconv: command not found ? error. De stappen die daaronder volgen heb ik nagelopen maar niks werkt. Ik heb online verder gekeken en ik heb ook apt-get install ffmpeg en apt-get install libav-tools commando geprobeerd.
Ondertussen heb ik ook de commando
sudo apt-get update en sudo apt-get upgrade gebruikt en mijn Pi reboot.

Ik weet niet welke opties ik verder nog heb. Ik hoor graag jullie advies.

Alvast bedankt!

edit: besef mij nu dat ik deze post waarschijnlijk niet op de juiste plek heb gepost :3 maar ik hoop dat jullie mij kunnen helpen

krijg je errors na die update/upgrade of sudo apt-get install libav-tools commands?

Op 23 maart 2020 15:44:55 schreef arduinonoob:
ik heb ook apt-get install ffmpeg en apt-get install libav-tools commando geprobeerd.

Dat lijkt me een zinnige actie. Als dat niet werkt, wat krijg je dan voor foutmeldingen?

Edit: Ik heb "apt install ffmpeg" ingetikt en dat zeurt bij mij dan over te weinig disk space en wilde 84 pakketten gaan installeren dat ging me even te ver. Dus ik heb het er maar even bij gelaten.

[Bericht gewijzigd door rew op 23 maart 2020 16:36:00 (27%)]

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Foutmeldingen inderdaad. En indien niet duidelijk of de installatie lukte of niet:

dpkg -l | egrep 'ffmpeg|libav-tools'

post daarvan desgewenst de output.

hoe beter de vraag geschreven, zoveel te meer kans op goed antwoord

Op 23 maart 2020 16:33:01 schreef rew:
[...]Dat lijkt me een zinnige actie. Als dat niet werkt, wat krijg je dan voor foutmeldingen?

Edit: Ik heb "apt install ffmpeg" ingetikt en dat zeurt bij mij dan over te weinig disk space en wilde 84 pakketten gaan installeren dat ging me even te ver. Dus ik heb het er maar even bij gelaten.

Ik krijg bij libav-tools: libav-tools has no installation candidate
en bij ffmpeg: invalid operation
Misschien mis ik nog een bestand?

Op 23 maart 2020 16:25:43 schreef Stijnos:
krijg je errors na die update/upgrade of sudo apt-get install libav-tools commands?

Ik krijg geen error bij update en upgrade.

Als ik sudo apt-get install libav-tools commands invoer dan geeft het aan: invalid operation

sudo apt-get install libav-tools commands

hier is het woord "commands" teveel

Maar de "libav-tools has no installation candidate" wijst erop dat dit package niet beschikbaar is in de thans geconfigureerde bronnen.

Mogelijke oplossing: uitzoeken (of ergens vragen, alhier bv.) uit welke bron dit kan komen, en deze dan toevoegen aan aptitude. Wel rekening houden met mogelijke stabiliteitsproblemen op langere termijn, externe bronnen durven al eens verdwijnen met de noorderzon.

hoe beter de vraag geschreven, zoveel te meer kans op goed antwoord

Het pakket "libav-tools" heet (tegenwoordig) gewoon anders dan in die howto staat.

Probeer het eerst eens met alleen die ffmpeg. Bij mij trekt dat een hele hoop andere pakketten mee, dus waarschinnlijk zit die benodigde libav spullen er al bij.

Anders doe je iets als: apt-cache search libav Bij mij geeft dat dan 77 pakketten waar d ie string in voorkomt. Dan dingen met dbgsym hoef je niet, -dev is voor als je programmas wilt ontwikkelen, ook dat heb je niet nodig. Kijk maar eens of je dan vind wat je moet hebben.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Op 23 maart 2020 19:08:10 schreef rew:
Het pakket "libav-tools" heet (tegenwoordig) gewoon anders dan in die howto staat.

Probeer het eerst eens met alleen die ffmpeg. Bij mij trekt dat een hele hoop andere pakketten mee, dus waarschinnlijk zit die benodigde libav spullen er al bij.

Anders doe je iets als: apt-cache search libav Bij mij geeft dat dan 77 pakketten waar d ie string in voorkomt. Dan dingen met dbgsym hoef je niet, -dev is voor als je programmas wilt ontwikkelen, ook dat heb je niet nodig. Kijk maar eens of je dan vind wat je moet hebben.

Bedankt voor je reactie! Ik heb apt-cache search libav geprobeerd en een aantal pakketten gedownload vanwaar ik dacht dat deze handig waren.

Ook heb ik gekeken naar apt-cache search mmpeg en daar een aantal bestanden gedownload. Helaas heeft dit voor mij nog niet geholpen..

avconv is oud en heel compatible met ffmpeg.

sudo ln -s /usr/bin/ffmpeg /usr/bin/avconv

Hiermee maak je een symbolic link (kopie zonder ruimte in te nemen, als een shortcut)

Het ffmpeg commando werkt wel toch?