Simpel vraagje over types TL071

Ik ben nieuw op dit forum, hallo!

Ik heb een vraagje over de TL071 opamp, dat jullie waarschijnlijk met twee vingers in de neus kunnen beantwoorden. Ik wil een buffer maken voor mijn basgitaar ( http://www.muzique.com/lab/buffers.htm , tweede of derde voorbeeld van onderen) of eventueel een heel simpele booster/buffer ( http://www.jer00n.nl/2010/07/28/clean-boost-for-guitar-or-bass/ ), beiden met een TL071.

Nou kan ik bij Conrad eigenlijk alleen allerlei varianten van de TL071 kopen, bijvoorbeeld TL071CP, TL071IP, TL071BCP, TL071ACP etc.

Welke moet ik nu nemen hiervoor?

Ik heb een beetje zitten zoeken hier op de zoekterm TL071 maar dan krijg ik zoveel resultaten (heb er een paar doorgenomen zonder resultaat), maar alles doorlezen kost me dagen...
Alvast hartelijk dank!

Edit PS: ik ben niet echt een deskundig, merken jullie misschien wel. Ik kan zo'n schakelingetje wel in elkaar solderen, maar mijn echte theoretische kennis is beperkt...

Hiertoe kijkt men in de datasheet. De betekenis van dit soort (voor en-) achtervoegsels hoeft niet hetzelfde te zijn bij verschillende fabrikanten.

Soms is het opletten ivm verschillende behuizingen / parameters / aansluitingen, vaak echter is het verschil in een toepassing ook niet belangrijk omdat het bijvoorbeeld het temperatuurbereik betreft, terwijl de schakeling altijd bij kamertemperatuur zal werken.

Datasheet van de TL071CP bij Conrad

Eerste pagina:

Plastic DIP (dat is de bekende zwarte baksteen met pootjes, niet SMD ) en 0-70 graden lijken mij hier prima. De schakeling is AC gekoppeld dus de offset is niet relevant.

blackdog

Golden Member

Hi Kwetal,

Probeer het maar op deze manier, dan heb je veel meer kans dat het stabiel werkt.

http://www.bramcam.nl/Diversen/Bas-Amp-01.png

Er staan meer componenten in het schema, maar deze zijn dus nodig om het beter te laten werken en dus stabiel te houden.

Groet,
Blackdog

Waarheden zijn "Illusies waarvan men vergeten is dat het illusies zijn"

@Aart: Bedankt! Ik had wel in de datasheet gekeken maar was de weg kwijt geraakt... Dit kan ik idd wel begrijpen ;-)

@blackdog: Bedankt, ik doorgrond het niet helemaal maar ik geloof je op je woord. Het verschil zit hem voornamelijk in die netwerkjes linksboven, zo te zien. Ik ga ermee aan de slag.

Fijn, die snelle reacties, top!

RAAF12

Golden Member

Omdat de input hoogohmig is de layout belangrijk
Verder een extra 0.1µ C direct aan pin7. Ga je voeden vanuit een 9V batterij blokje?

Overigens is een IC gebruiken helemaal niet noodzakelijk, met 1 transistor bereik je hetzelfde effect..

blackdog

Golden Member

Hi Kwetal,

De verandering zit in het hele schema :-)

C4 van 10uF ontkoppeld de voeding voor de opamp, deze condensator moet vlak bij de opamp komen.
C2 ontkoppeld ook de voeding, en dat is de spanning waarmee de opamp op ongeveer de helft van de aangeboden spanning wordt ingesteld.

De spanning op het knooppunt van R3, R4 en R3 moet heel schoon zijn daar de eventuele rommel op dit punt door de opamp 3x wordt versterkt.
Bij een batterij die al bijna leeg is, laten we zeggen een 9V batterij die 6V is geworden heeft krijgt een hoge inwendige weerstand.
Bij flinke uitsturing krijg je variatie van de batterij spanning en die zou dan weer op de +ingang van de opamp terrecht komen en dit geeft dan een motorboot effect.
Dus R1, R2 en C2 zorgen er voor dat dit niet gebeurd.

Dan hebben we nog R4 van 1K die beschermt de ingang een beetje en zorgt er ner alsR7 voor dat de opamp niet gaat genereren als hij wordt aangesloten via lange kabels.

R5 en R6 heb ik 10x kleiner gemaakt als in het schema dat jij liet zien, hierdoor pikt de schakeling minder storing op en heeft minder ruis.
Verder is er meestal ook geen condensator nodig van zeg 100pF over R6 bij de door mij gekozen waarden.

Ik hoop dat je het nu een beetje begrijpt.

Groet,
Blackdog

Waarheden zijn "Illusies waarvan men vergeten is dat het illusies zijn"

Op 14 december 2018 17:52:59 schreef RAAF12:
Omdat de input hoogohmig is de layout belangrijk
Verder een extra 0.1µ C direct aan pin7. Ga je voeden vanuit een 9V batterij blokje?
[bijlage]

Overigens is een IC gebruiken helemaal niet noodzakelijk, met 1 transistor bereik je hetzelfde effect..

[bijlage]

@Raaf: Ik ga idd voeden vanuit een 9V blokje.
Even een toelichting op mijn doel: de input krijgt te maken met de output van een passieve bas (dus direct de pickups), dat is in de orde van enkele 10-tallen KOhm. De versterker waarvoor ik dit nodig denk te hebben (Warwick LWA1000) schijnt een relatief vrij lage ingangsimpedantie te hebben (+/- 500KOhm) waardoor passieve bassen iets van hun levendigheid kunnen verliezen. Ik wil kijken of ik mijn bas op deze versterker wat meer crunch en tophoog kan geven. Vandaar dat ik een buffer wil, en als ik toch bezig ben, evt. ook nog wat extra gain.
Vraagje: een extra 0.1 micro C aan pin 7 zou in het schema van blackdog toch niet veel effect hebben? Die komt dan parallel met C4 en die is 10 mF?
Ik heb ook zitten denken aan een transistor, of een JFet, maar ik had begrepen dat een opamp de laagste uitgangsimpedantie geeft ("typically measured in tens of ohms instead of hundreds"), dus vandaar...

Op 14 december 2018 17:54:53 schreef blackdog:
Hi Kwetal,

De verandering zit in het hele schema :-)

C4 van 10uF ontkoppeld de voeding voor de opamp, deze condensator moet vlak bij de opamp komen.
C2 ontkoppeld ook de voeding, en dat is de spanning waarmee de opamp op ongeveer de helft van de aangeboden spanning wordt ingesteld.

De spanning op het knooppunt van R3, R4 en R3 moet heel schoon zijn daar de eventuele rommel op dit punt door de opamp 3x wordt versterkt.
Bij een batterij die al bijna leeg is, laten we zeggen een 9V batterij die 6V is geworden heeft krijgt een hoge inwendige weerstand.
Bij flinke uitsturing krijg je variatie van de batterij spanning en die zou dan weer op de +ingang van de opamp terrecht komen en dit geeft dan een motorboot effect.
Dus R1, R2 en C2 zorgen er voor dat dit niet gebeurd.

Dan hebben we nog R4 van 1K die beschermt de ingang een beetje en zorgt er ner alsR7 voor dat de opamp niet gaat genereren als hij wordt aangesloten via lange kabels.

R5 en R6 heb ik 10x kleiner gemaakt als in het schema dat jij liet zien, hierdoor pikt de schakeling minder storing op en heeft minder ruis.
Verder is er meestal ook geen condensator nodig van zeg 100pF over R6 bij de door mij gekozen waarden.

Ik hoop dat je het nu een beetje begrijpt.

Groet,
Blackdog

Ik denk dat ik het een beetje begrijp, Blackdog. C2 en C4 zorgen voor stabilisering van de voedingsspanning en de voorspanning, dempen storingen en voorkomen oscillaties als de voedingsspanning daalt. R4 is duidelijk en R7 zorgt er ook voor dat oscillaties geen kans krijgen. En ik kan me ook voorstellen dat lagere waarden in de spanningsdeler van de feedbackloop ruis kunnen verminderen. De kleine C over R6 ben ik in andere schema's ook tegen gekomen, maar die zat niet in de voorbeelden die ik in eerste instantie gaf. Bedoel je dat dat daar eigenlijk wel zou moeten?

Edit: overigens bedankt voor je uitleg! Ik ben aan het leren...

Thevel

Golden Member

Op 14 december 2018 18:59:32 schreef Kwetal:
Ik ga idd voeden vanuit een 9V blokje.

De schakeling trekt nog geen 2mA en kan dus dagen op een 9V blokje werken.
Goed te doen dus.

blackdog

Golden Member

Hi Kwetal,

Ik heb het schema nog een beetje aangepast.
C6 en C7 zijn er bij gekomen, C6 houd HF signalen tegen.
Ik weet alleen niet goed in hoeverre dit de bron die je aansluit op deze versterker daardoor beinvloed word.

Je kan C6 eventueel naar 100pF brengen als de bron te veel belast wordt door nF, daar je het over een muziek instrument hebt voor lage frequenties,
denk ik niet dat de 1nF problemen oplevert.

C7 zorgt er voor dat de paracitaire capacitijten aan de -ingang voldoende worden gecompenseert, 150 pF daar geeft ee n-3dB punt van rond de 50Khz.

Groet,
Blackdog

Waarheden zijn "Illusies waarvan men vergeten is dat het illusies zijn"

Ik heb 5 x TL071ACP besteld en ik ga volgende week eens een beetje experimenteren op een breadboard.
Ook maar weer eens die online elektronicacursus doornemen...

Bedankt voor alle input!

Ik heb om te beginnen, als vingeroefening, een buffer gemaakt op een breadboard:

volgens deze voorbeelden:
http://www.muzique.com/images/buff1.gif (voor de voorspanning)
en
http://www.muzique.com/images/buff7.gif
voor de buffer zelf. (van deze site: http://www.muzique.com/lab/buffers.htm )
Alles werkte gelijk in 1 keer (getest op een pieplein huiskamerversterkertje, vegelijkbaar met een bluetooth boxje), maar toen ik hem op mijn goeie bascombo testte hoorde ik een licht, onregelmatig hoog geknisper, alsof iemand met heel droog dun papier zit te knisperen. Zou dat nou te maken hebben met dat de voeding en voorspanning niet goed gestabiliseerd zijn, zoals in het schema van Blackdog wel gedaan is (maar voordat ik daaraan begin moet ik er eerst even inkomen met wat eenvoudige dingen)? Of moeten de componentjes (R's, C's) van de input en voorspanning misschien dichter bij het IC worden geplaatst (lukt me niet goed op het breadboard, dan moet ik gaan solderen)? Of zit het 'm in het ontwerp? Sorry dat ik jullie misschien met hele banale dingen lastig valt, maar het zijn mijn eerste stapjes...

RAAF12

Golden Member

Dat was idd de insteek toen ik de foto van de layout postte. Zoals gezegd is de input hoogohmig en dat betekent dat de verbinding kort moeten zijn. En lees ook de andere remarks die Texas Instruments hierboven in de datasheet zet. Ik verwachtte wel dat je hierop terug zou komen nadat je meldde dat het item op een broodplank zou worden gezet. Succes ermee.

Heb je de voeding van je TL071 ontkoppeld volgens schema van @blackdog? C4, 10µF. Dat moet.
Je kan de 1MΩ weerstand verlagen naar bijv 10kΩ. Dan eens kijken of het knisperen nog aanwezig is.

Bezoek mijn neefjes' site: www.tinuselectronics.nl

Ik heb alles (in ieder geval R3, maar verder voor de zekerheid ook maar alles in de linkerhelft van het schema, ook het draadje van de terugkoppeling) zo dicht mogelijk bij het IC geplaatst, alle pootjes getrimd etc. en het is nu idd wel iets minder.

Maar het is er nog steeds een beetje. Ik heb natuurlijk ook brom, dat zal met afscherming te maken hebben, maar verder nog steeds wat gespetter en een regelmatig getik, zoals voetstappen. Ik heb het even met mijn smartfoon opgenomen maar je hoort het wel:

Spetter.m4a

Ik moet wel zeggen dat het niet in verhouding staat tot wat er gebeurd als er een snaar wordt aangeslagen, dan springt de stuc van de muren, de versterker stond bijna op halve kracht... Dus misschien is het een non issue. ik had trouwens ook het idee dat het iets minder werd nadat ik de draadjes van de batterijklem wat degelijker in de stekker had geschroefd, dat zat een beetje gammel.

C4 voor ontkoppeling van de voeding leverde eigenlijk geen hoorbaar verschil op. EDIT: 10K voor R3 ben ik helemaal vergeten te proberen! Ga ik nog wel even doen als ik even tijd heb maar het probleem is dat dan volgens mij de ingangsimpedantie ook een eind naar beneden gaat en dan gooi ik het kind met met de badwater weg. Ik wou hem eigenlijk liever nog hoger hebben...

Anyway, ik ben gisteren begonnen om http://www.hobby-electronics.info/nl/course weer eens door te nemen, dat had ik een jaar of 13 geleden ook al eens gedaan maar daar is niet veel van blijven hangen. Daar zal ik nog wel even mee bezig zijn, maar ik wil het allemaal toch wel begrijpen, wat ik doe. Daarna ga ik weer door met proberen want ik merk dat ik er wel veel schik in heb! Je moet er alleen de tijd voor vinden...
Tot zover hartelijk dank voor de tips, ik hoop dat ik nog eens bij jullie te rade mag gaan als ik zo ver ben.
Wel erg fijn, zo'n forum met behulpzame mensen die een Noob als ik eens van een advies kunnen dienen!

RAAF12

Golden Member

Die voetstapgeluiden zijn idd erg boeiend, het lijkt mij dat er iets net boven de gehoorgrens staat te oscilleren. Kan je makkelijk zien met een scope. De signaalweg tussen gitaar en opamp moet wel met een 100% afgeschermde kabel zijn gemaakt. Dat eentransistorversterkertrapje (zie boven) is veel vergevingsgezinder ivm opbouw dan een opamp met fetinput en +/- 30 transistors inside.

blackdog

Golden Member

Hi Kwetal,

Dit is een versterker trapje met een hoog Ohmige ingang, dat is vragen om brom met zo'n opstelling. :-)

Haal die rode draad eens weg en verbind de condensator door met de massa, als het goed is, dan is de brom weg of bijna weg.
Bij dit soort breadboard opstellingen heb ik altijd een metatelen plaatje onder het breadboard liggen dat ik met massa van de breadboard schakeling verbind om brom en andere storingen te verminderen, een beetje afscherming dus.

En dan nog dit, de uitgang mag je niet zomaar met een lange draad verbinden, daar moet je een 47 of en 100 Ohm weerstand mee in serie setten vlak bij de opamp uitgang.

Als de schakeling met de condnesator naar massa dan stil is, dan is het OK

Groet,
Bram

Waarheden zijn "Illusies waarvan men vergeten is dat het illusies zijn"

Dat niet alle fabrikanten hetzelfde zijn weet ik nog wel...
We hebben een apprlicatie gehad waarin de LM324 van ST vaak weigerde, terwijl alle andere merken probleemloos werkten...

Zelfde met opto-vervangers van TI voor de TLP62x: zouden 100% compatible moeten zijn, maar waren dat niet...
(Bij heel langzaam van uit naar aan 'hing' de opto soms, iets wat we nooit echt hebben kunnen verklaren)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Heb van alles geprobeerd, R3 verlagen, andere gitaarsnoertjes, andere aansluitsnoertjes, voor de zekerheid voeding extra ontkoppelen, etc. (merkte en passant ook nog op dat ik op de ingang per ongeluk 10 nF had i.p.v. 100nF, blijkbaar is dat niet zo kritisch hoewel ik wel verschil hoor...) maar het geknisper en de voetstappen bleven. Daarna hetzelfde nog eens overgemaakt met een JFET (BF245) i.p.v. de opamp, volgens het schemaatje van die buffer site, werkte ook goed maar wederom dezelfde geluiden.

Tot ik op het idee kwam om mijn breadboard eens een eindje van mijn laptop neer te zetten. Daarna was hij muisstil. Op de valreep toch nog een serieuze gooi gedaan naar Debiel van het jaar...

Enfin, eind goed al goed, ik heb er schik in gekregen en ga lekker door met pielen! Allemaal hartelijk dank voor alle raad en tips en een prettige jaarwisseling!

blackdog

Golden Member

Yo! Kwetal, :-)

Ik heb je wat goede tips gegeven, daar lees ik niets van terug of je deze nu ook hebt uitgevoerd...

De storing door je laptop/power adapter is standaard, vooral bij hoge ingangs impedanties zoals jouw schema.
Ik gaf je ook al aan dat je een metalen plaatje onder je breadboard zou kunnen leggen voor een beetje afscherming.

Tip,
Als je met audio gaat werken in een test opstelling zorg voor wat afscherming.
Sluit de uitgang als het kan op batterij gevoede apparatuur aan,
zoals een batterij gevoede luidspreker die verder niet via een adapter aan het 230V net hangt.

Asl je met kleine signalen werkt, wat bij audio vaak zo is,
zal je bijna altijd een metalen behuizing moeten hebben om het brom en storings arm te maken.

En dan ben ik nog niet eens begonnen over de gevoeligheid voor HF straling. :-)

Blijf lekker prutsen in het komende jaar, het is een mooie hobby :-)

Groet,
Bram

Waarheden zijn "Illusies waarvan men vergeten is dat het illusies zijn"

Op 31 december 2018 14:42:08 schreef blackdog:
Yo! Kwetal, :-)

Ik heb je wat goede tips gegeven, daar lees ik niets van terug of je deze nu ook hebt uitgevoerd...

He Blackdog, nee die tips van jou had ik zeker in mijn oren geknoopt, zoals afscherming en een plaatje onder mijn breadboard e.d. Best Practice dingen die ik beslist ga doen, maar ik had dat alleen niet allemaal bij de hand en het probleem was eigenlijk niet de brom, dat heb je altijd met versterkte instrumenten en als dat allemaal netjes gesoldeerd in de afgeschermde holte direct in mijn bas zit zal dat wel veel minder zijn. Het was dat vreemde getik en gekraak maar wellicht was dat ook over geweest met goede afscherming. Ik ga zeker rekening houden met dat soort dingen in de toekomst.

Je tips over die rode draad heb ik ook gelezen, alleen begreep ik het niet helemaal. Die linker rode draad komt van mijn bas op de ingang en die rechter is de output, dus die kon ik toch niet weghalen? Ik ging er heel oneerbiedig van uit dat je op het verkeerde been was gezet door mijn klungelige breadboard layout...

Dat uitgebreidere schema van jou ga ik volgend jaar zeker ook bouwen. Maar ik wil me nu eerst even storten op de theorie als ik de tijd kan vinden, ik wil gewoon goed begrijpen hoe het allemaal werkt en niet zomaar wat formuletjes en ezelsbruggetjes leren.

Op 31 december 2018 14:42:08 schreef blackdog:
Blijf lekker prutsen in het komende jaar, het is een mooie hobby :-)

Groet,
Bram

Dat begin ik ook door te krijgen ;-) ! Bedankt en fijne avond straks!

Gelukkig nieuwjaar allemaal!
Edit: Rest verwijderd, voegde niks toe... ;-)

[Bericht gewijzigd door Kwetal op 5 januari 2019 13:56:12 (92%)]