Hardware of driver?

USB camera geeft soort geïnverteerd kleurenbeeld op één USB ingang. Of is het iets met witbalans?

USB2 microscoop camera op USB2 nummer 1 ingang (knop van toetsenbord laptop).

Zelfde microscoop op een USB3 ingang van dezelfde laptop (maar USB2 nummer 2 geeft ook goed beeld).

Ideeën?
Verlichtingsledjes die zijn ingebouwd doen het even goed in beide poorten. USB2 is toch gewoon twee voeding (doen het want camera doet iets en leds doen het prima) en twee data (doet ook wat want je ziet iets herkenbaars op het scherm).

[Bericht gewijzigd door r-p op vrijdag 2 oktober 2020 22:02:05 (27%)

Probeer eens een zin te schijven. Ik heb eea drie keer doorgelezen, maar snap nog steeds niet wat de situatie is.

Wat er staat is dat je twee verschillende cameras/microscopen hebt die verschillend beeld geven. Lijkt me logisch.

Als ik ga gokken heb je 1 ding die op verschillende poorten verschillend resultaat geeft.

De "camera driver" zal het verschil tussen ene en andere poort niet kunnen zien doordat de USB drivers in het systeem dat soort dingen verbergen. Dus de driver kan niet "fout zijn" denk ik.

Mogelijk is er iets met de spanningsvoorziening van de verschillende poorten. Ik zou gewoon de werkende poort gebruiken en er verder geen aandacht aan besteden.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Op 3 oktober 2020 12:47:17 schreef rew:
Als ik ga gokken heb je 1 ding die op verschillende poorten verschillend resultaat geeft.

Klopt.

Ik dacht tijdens het schrijven dat het een verschil was tussen de USB3 poorten enerzijds en de USB2 poorten anderzijds. Maar tijdens het schrijven wilde ik graag volledig zijn dus heb ik nog verder getest en bleek het verschil ook tussen de twee USB2 poorten onderling te bestaan. Dit is de duidelijkheid niet ten goede gekomen...

Ik zal de spanningsvoorziening onder belasting even nakijken. Probleem is dat ik snel vergeet en nu al voor de tweede keer dacht dat de camera stuk was ;) omdat ik vergeten was dat ik vorige keer ook al had uitgevonden dat wisselen van de USB-poort de oplossing is.

EDIT: Geen verschil in stroomverbruik met een USB-power meter (resolutie.

Logitech dongle werkt wel in deze vreemde USB poort, dus heb die er nu maar inzitten.