Samsung Microgolf (MG28H5125NK) start niet

Hallo,

Heb hier een microgolf van Samsung MG28H5125NK van 2017.
De start knop doet niets meer.
En, neen, het is niet het knopje.... ;-)
Je vind op internet wel terug dat dit meer voorkomt, maar geen oplossing, buiten print vervangen.

Als je bv 20x probeert, doet ie het misschien wel eens 1x, maar dan weer een tijdje niet??

Heb al veel soldeerlassen bijgesoldeerd, en ook de deurswitches getest tot op de print.
Toch vind ik geen oplossing.

iemand nog ideeen??

mvg,

Tom

Heb ondertussen een oplossing gevonden.

Blijkt dat het scannen van de knoppen samen gaat met het aansturen van de display (gemultiplexte matrix)
Voor het detecteren van de startknop ging de spanning net niet hoog genoeg.
Oorspronkelijk staat er een 2K (R311) als pull-Up.
Door hier bv een 10K parallel over te zetten, lijkt alles weer te reageren.
Waarschijnlijk zijn de levels in het design zeer kritsch ingesteld en zal na verloop van tijd door toleranties en temperatuurschommelingen dit net wel of niet meer werken.
Ik vond ook veel meldingen terug met exact hetzelfde probleem dat na 2-3j optreed.

Bij deze kan ie weer....

Zie foto voor betrefende weerstand.

Tom

Mooi hij het nu weer doet.
Hopelijk blijft het nu werken, een koude maaltijd is ook maar niks :P

Blijkbaar was de oplossing met extra weerstand van korte duur.
Na 2 dagen deed ie het al niet meer.

Na wat extra onderzoek, had ik de pin naar het display, die parallel hangt op de switch lijn losgemaakt.
Dan blijkt de Start switch wel door te komen.
Zou er na verloop van tijd mss wat degradatie onstaan in dat LED display??
Het wordt natuurlijk aan hoge frequentie gemultiplexed met het button PCB.

Ik had eerst geprobeerd met een schottky diode tussen uC en display, en dat lijkt ook al te werken, alleen zie je een klein intensiteits verschil op sommige segmenten van het display.
Door dit met een P-ch Mosfet te schakelen, wordt dit euvel grotendeels opgelost.

Ondertussen is deze oplossing al 2 weken geleden geinplementeerd, en werkt nog steeds.

Ik heb een kleine schets gemaakt van wat de oplossing kan bieden...

mel

Golden Member

Zou het niet gewoon de voeding zijn?Rotte elco of zo?
Het heeft tenslotte gewerkt...

[Bericht gewijzigd door mel op 4 juni 2021 10:26:17 (23%)]

u=ir betekent niet :U bent ingenieur..

Neen, perfect vlakke 5V en 12V.
Met scope bekeken.
En das meestal ook het eerste waar ik naar kijk.

T'is echt iets speciaals, komt meermaals voor en enige oplossing is een nieuwe PCB (100€)

Misschien lekkende schakelcontacten?

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Welke schakelcontacten bedoel je?
de Relais ?

Het board reageerd zelfs niet op de start knop wanneer het los van de rest van de microgolf getest wordt.
Alle andere knoppen doen het wel (beep) behalve de start....

Voor de deur, heb ik een draadbrugje op de pcb connector gesoldeerd tijdens het testen.

Ik heb 2 magnetrons met soortgelijke klachten. De ene is een MC28M6055CS waarbij vele knoopjes het niet doen, maar wel de startknop. De pushbuttons zelf zijn uiteraard prima. De printplaat lijkt overeen te komen met die van Rocky. Rocky, heb jij het schema? Ik vraag me namelijk of of jouw modificatie ook voor andere functies opgaat. Maar zonder schema begin ik niet veel. Iemand anders die mij kan helpen aan een schema is ook goed. De andere magnetron waar de startknop inderdaad weigert is de CE107MST, een schema daarvan is ook zeer gewenst.