Krijg max1744 niet aan de praat

Ik heb een schakeling gemaakt met een 5v buck convertor van maxim en die krijg ik niet aan de praat.
Het schema heb ik overgenomen van het fabrikant:max1744.

Ik heb er dit schema van gemaakt met bijbehorende pcb ontwerp en printje.

Het probleem is dat er ergens kortsluiting ontstaat. Bij 6v onbelast neemt de regelaar zo een 100mA op en word warm.

Na veel te lang zoeken wil ik graag gebruik maken van jullie kennis.

Het enige symptoom wat ik heb kunnen vinden is dat als ik de condensator oplaad aan de uitgang naar meer dan 5v er geen kortsluiting plaatsvindt totdat de uitgang naar 5v zakt, daarna ontstaat de kortsluiting. Dit verteld mij dat wellicht de aansturing van de P-MOSFET (dit niet is aangesloten, zie plaatje) er iets mee te maken heeft.

Het eerste printje had ik volledig opgebouwd met alle componenten en werkte niet, een ander printje heb ik alleen de condensator van de REF aansluiting gesoldeerd.

Je denkt toch niet serieus dat we uit dat schema iets wijzer kunnen worden he?

Q1 is een P-channel FET met een schottky diode in 1 behuizing of zo?

Als je de condensator aan de uitgang oplaadt tot meer dan 5V, zal die regelaar de FET dicht laten. Wordt de regelaar zelf warm, of Q1?

[Bericht gewijzigd door SparkyGSX op 9 juli 2009 20:28:12 (32%)]

Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken

Klopt inderdaad, dat is een FETKY. Combinatie van mosfet en schottky diode.

Schema lijkt zo op het eerste gezicht overeen te komen met je datasheet. Ben niet zo gelukkig met je layout, veel te veel aangerommeld.

Die FET die je gekozen hebt lijkt op het eerste gezicht ook niet al te beroerd. Geinig ding, met die diode erbij.

Heb je al eens met een scoop gemeten of het ding als een gek staat te klapperen? Zou niet zo moeten zijn, maar ja.
Zijn je input en output C low-ESR? Is je current-sense weerstand wellicht ook fors inductief?

Zorg dat je NOOIT, NOOIT, NOOIT wat met Versatel Tele2 te maken krijgt!

Ik heb gemeten met mijn scope en ik zie niets klapperen. Allemaal heel stabiel kort aan het sluiten, of de 40MHz rigol scope kan het niet bijhouden.

De input cap is een low-esr smd type en de output cap heb ik niet bij nagedacht bedenk ik me nu. Voor de current-sense weerstand heb ik er een gekozen speciaal voor stroom metingen.

Ik zou het erg op prijs stellen dat je mij verteld wat ik beter had kunnen doen wat betreft pcb layout. De kritische componenten volgens de datasheet heb ik dicht bij de max1744 geplaatst.

Kleine overwinning:

http://atoomnet.net/co/IMG_7209-crop-small.JPG

Schakeling overgezet op een breadboard en het werkt. (let niet op de boomstam onder de max1744) Ik zie de schakeling netjes switchen op de scope. Alle spanningen ook perfect in orde: REF, VH en VL.

Het probleem dat de schakeling niet werkt, moet dus in het printplaatje zitten.

In het kort: voor wat betreft die layout: ik ben nooit zo gecharmeerd van 'power tracks' die overal lopen. Houd die rommel bij elkaar en kort. Ik heb 'm zelf niet bekeken (dus misschien sla ik nu een flater...), maar in hoeverre lijkt you layout op de reference layout die ergens in die datasheet genoemd wordt?

Zorg dat je NOOIT, NOOIT, NOOIT wat met Versatel Tele2 te maken krijgt!

Ik heb nu de max1744 die op het breadboard zit met kabeltjes verbonden met de pcb en tot mijn verbazing werkt het.

Mijn vermoeden nu is dat in de pcb in de TS de max1744 niet goed is gesoldeerd.

http://atoomnet.net/co/IMG_7210-small.jpg

http://atoomnet.net/co/rimpel.png
Mooie rimpel op de 5V uitgang.

Er zit een 20W 12V halogeen lampje op de uitgang als test.
Gemeten ingang 15V 0,32A, uitgang 5V 0,87A. Naar mijn rekenkunsten is dat 90.6% efficiënt.

Vpp van 348mv, is dat niet een beetje veel? Heb je toch "ruis" van 0.35 V op de uitgang. Of zie ik dat nu verkeerd?

"If I would have listened to my customers, I would have invented a faster horse." - Henry Ford

Op 16 juli 2009 20:52:04 schreef Fire_IC:
Vpp van 348mv, is dat niet een beetje veel? Heb je toch "ruis" van 0.35 V op de uitgang. Of zie ik dat nu verkeerd?

Ja, mee eens. Wellicht is de door mij gekozen elco van 220µF niet in staat om dat lager te houden dan 0,35V bij 0,87A. Ik heb eigenlijk geen idee hoe ik zou kunnen uitrekenen wat de rimpel maximaal zou mogen zijn bij 300KHz.

Ik heb een nieuwe max1744 besteld en opnieuw geprobeerd te solderen op een nieuw printje. En het werkt! Dus conclusie is wellicht dat de eerste poging het solderen van de µMAX verpakking is mislukt.

http://atoomnet.net/co/IMG_7214.jpg

Van harte. Ben dan wel benieuwd wat er niet goed aan je soldeerwerk was (?). Zo spannend is het niet en je kunt het ook controleren.

Zorg dat je NOOIT, NOOIT, NOOIT wat met Versatel Tele2 te maken krijgt!

Mijn vermoeden is dat er een paar pootjes kortsluiting hebben gemaakt toen ik de spanning erop had gezet. Wellicht dat het ic er niet tegen kon en is toen kapot gegaan.
Heb het toen opnieuw gesoldeerd en ook met een hete lucht rework pistool.
Ik denk echter dat het bij een theorie blijft.