ESP-WROOM-02 UART communicatie

Hoi iedereen,

Ik ben bezig met een WIFI module ESP-WROOM-02 en heb het volgende probleem:

Wanneer ik de module aansluit op de seriele poort van de PC krijg ik wel de normale opstart tekst, met name een aantal vreemde karakters, gevolgd door het woord 'ready'.
Echter, als ik 'AT' doorstuur krijg ik ook 'AT' terug ipv 'OK'.
Als ik AT+GMR stuur, krijg ik niet de versie informatie terug. In de plaats krijg ik AT+GMR terug
MAW: ik krijg terug wat ik opstuur. (zie screendump in bijlage)

Wat kan hier het probleem zijn ?

Deze tekens krijg ik met de arduino als de baudrate verkeerd is....

Grote kans dat je een terminal programma gebruikt dat niet de vereiste \r\n meestuurt. de wroom weet niet dat je het commando beeindigt hebt. Wat je ziet is slechts echo.

in geval van putty als terminal programma:
https://www.esp8266.com/viewtopic.php?f=6&t=6565

(vinkje CR=LF in jouw programma misschien ?)

Die eerste riedel die voorbij komt is volgens mij een melding van de bootloader, op een andere baudrate of zo. Ik heb dat ook wel gezien bij mijn experimentje met een ESP-12E een tijd geleden (we hebben het toch over zo'n ESP-xx?). Op zich staat dat los van dat niet antwoorden.

[edit] Even opgezocht. Op deze site zie je die troep vooraan ook:
http://www.arduinesp.com/getting-started
Niet erg dus.

[Bericht gewijzigd door flipflop op 13 maart 2018 21:55:21 (19%)]

"We cannot solve our problems with the same thinking we used when we created them" - Albert Einstein
Shiptronic

Golden Member

heb je al eens geprobeerd de baudrate op 9600 te zetten?

Wie de vraag stelt, zal met het antwoord moeten leren leven.

Die bootloader zit op 74880 bps.
Maar is niet relevant. Hij krijgt "ready" te zien en dus is de gebruikers bps in orde. Ook krijgt hij echo, dat is niet vanuit het terminal programma maar vanuit de wroom. Dus seriële communicatie is op orde.

Nogmaals, lijneinde waarschijnlijk niet op orde.

Skysoft, het werkt met datgene wat je zei. Er moet een CR + LF achter elk commando.
Nu krijg ik wel degelijk antwoord van de ESP.
Bedankt voor de gouden tip ! :-)

Die esp modules moeten inderdaad beide hebben... ;)
Bij hTerm kun je instellen wat er bij een Enter verstuurd moet worden:

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Een expert is iemand die alle fouten al een keer gemaakt heeft, in dit geval een halve dag waard aan uren....

suc6 met je project.