CO RIAA preamp

Dag CO'ers,

Een paar jaar geleden heb ik de RIAA preamp van de website gebouwd. Toen had ik al het idee dat die een vrij groot uitgangssignaal had. Vandaag heb ik hem voor het eerst op mijn USB-geluidskaart aangesloten om zowel mijn PC als mijn platenspeler via de stereo te horen. Het viel mij na een tijdje op dat er een vreselijke ruis in het geluid zat.

Na wat opzoek werk over de klank van verschillende soorten vervormingen en ruis kreeg ik het vermoeden dat het signaal van de preamp te groot was en mijn geluidskaart dus begon te clippen. (ik vond op het internet volgende omschrijving voor oversturen: 'een zak gevuld met boze bijen' :P ) Om dit vermoeden te staven heb ik een snele meting gedaan.

Met een functiegenerator-app op mijn tablet heb ik een signaal gemaakt van 6à8mVp-p en 1kHz. (Spanning gemeten via m'n osciloscoop) Dit signaal heb ik dan aangesloten op de ingang van de preamp waarna ik het uitgangsignaal van de preamp heb gemeten op ca 4V (opnieuw via de osciloscoop). Dat betekent een versterking van ca 55dB.
Met m'n multimeter heb ik hetzelfde gedaan wat resulteerde in een versterking van ca 60dB
Deze cijfers lijken aan te geven dat deze versterker bedoelt is voor MC elementen.

Nu heb ik nog altijd geen vraag gesteld natuurlijk: Kan iemand deze conclusie bevestigen/tegenspreken? En aangezien ik (vermoed ik) een MM-element heb, wat is de beste manier om de preamp minder te laten versterken. Houdt dit in dat alle component waarden zullen veranderen? Ik heb nog gedacht aan een weerstand deler aan de uitgang, maar dat is dan weer nefast voor de uitgangsimpedantie. Daarnaast clipt de opamp ook vanaf signalen van ca 14mV en op het internet vind ik waarden van 35mV voor MM-elementen bij luide passages. Ook een spanningsdeler aan de ingang lijkt me niet ideaal i.v.m. ruis en ingangsimpedantie.

Groeten,
Shock6805

Als je maar genoeg geinteresseerd ben, verwondert heel de wereld.

Als je de RIAA versterker in de microfooningang steekt dan is het geluid uiteraard veel te hard (is bedoeld voor een line ingang)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Ruis en clipping zijn we 2 verschillende zaken. Als je een audiofragment opneemt dan kunnen we het misschien horen. Je zou ook de versterking iets kunnen aanpassen als test. Ik zou dan R1 en R10 iets groter nemen, dan wordt de versterking zwakker.

Als het ruis is kan dat aan meer zaken liggen. Misschien heb je nu ergens een gekke aardlus gemaakt tussen je PC en de platenspeler.

@Arco, waar haal je uit de tekst dat het om een microfoon ingang gaat?

Meeste standaard geluidskaarten hebben alleen een mic ingang, en geen line-in...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com
Sine

Moderator

Laptoptjes niet inderdaad, maar ik kan me de laatste 15 jaar geen pc heugen zonder line-in.
Zelfs de moederbordjes met audio onboard, add-in kaartjes hadden het eigenlijk altijd al.

Gezien de melding van veel te hard geluid heb ik het vermoeden dat hier de mic ingang wordt ge(mis)bruikt... ;)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com
Sine

Moderator

Dat is een beetje mijn punt, ik lees ruis en brom (bijen?)

Maar dat is niet typisch voor clipping.

Frederick E. Terman

Honourable Member

Op 4 november 2020 18:48:31 schreef Shock6805:
Met een functiegenerator-app op mijn tablet heb ik een signaal gemaakt van 6à8mVp-p en 1kHz.[...] waarna ik het uitgangsignaal van de preamp heb gemeten op ca 4V (opnieuw via de osciloscoop). Dat betekent een versterking van ca 55dB.
Met m'n multimeter heb ik hetzelfde gedaan wat resulteerde in een versterking van ca 60dB

Dat lijkt aan de hoge kant.
Deze schakeling heeft zijn maximale versterking bij ca. 20 Hz en daar is die bijna 60 dB.
Bij 1 kHz is de versterking nog ca. 41 dB, en bij 10 kHz ca. 30 dB.
Als jij een bijna tienmaal zo hoge versterking meet, lijkt het alsof je een fout in de schakeling hebt gemaakt. R1 bijvoorbeeld 47 Ω genomen, of zoiets.

Keramisch, kalibratie, parasitair: woordenlijst.org
RAAF12

Golden Member

Op 4 november 2020 18:48:31 schreef Shock6805:

Deze cijfers lijken aan te geven dat deze versterker bedoelt is voor MC elementen.

Voor MD elementen, die zitten globaal op 5mV uitgangspanning en de afsluitimpedantie is 47kΩ zoals in het schema vermeld.

Nu heb ik nog altijd geen vraag gesteld natuurlijk: Kan iemand deze conclusie bevestigen/tegenspreken?

Bij deze :-)

Misschien is het makkelijker te testen door de output van de MD pre-amp op een aux input van een conventionele versterker aan te sluiten. Aansluitingen maken met afgeschermde kabel en een bromvrije voeding gebruiken. Daar zou je prima vinyl mee kunnen afspelen.

wat is de beste manier om de preamp minder te laten versterken. Houdt dit in dat alle component waarden zullen veranderen? Ik heb nog gedacht aan een weerstand deler aan de uitgang, maar dat is dan weer nefast voor de uitgangsimpedantie.

Gewoon een serieweerstandje of om even te testen een potmeter in serie. De impedantie is toch een lastige zaak. Afhankelijke van de ingang en leeftijd van de versterker kan dat ergens variëren tussen 10 en 60K ofzo. Nu heb jij een computeringang en dat zal meestal wel redelijk overeenkomen mat die van alle andere computers. Maar heel belangrijk is dat niet. Je voorversterket mag je als goed is ook met een grote variatie aan weerstanden belasten zonder dat je frequentiedoorlaat merkbaar wordt aangetast. Gebruik wel een lijningang en geen microfoon ingang.

Een microfooningang op een computer is vaak geschikt voor een z.g. electret element. Die hebben een gelijk(voedings)spanning nodig (z.g. fantoomvoeding) Bij onjuist aansluiten van andere audiobronnen kan dit inderdaad ruis geven.

Dus gewoon niet te moeilijk doen maar even prutsen met een serieweerstand. En als je inderdaad een mic ingang gebruikt zou je nog iets kunnen doen met een seriecondensator. Wel een hele grote (paar honderd uF ofzo) om de frequentie karakteristiek niet te beïnvloeden.

Goeie morgen allen,

Wat betreft de microfoon ingang en het harde geluid:
De ingang waar ik het probleem ondervind, betreft de line-in van een Behringer UCA222. Die zou volgens de manual signalen tot 2dBV aan moeten kunnen. Volgens mij ruim voldoende om het signaal van een preamp te kunnen verwerken.
Het harde geluid slaat op het volume van de muziek als ik de preamp rechtstreeks op mijn versterker aansluit. Ter vergelijking: als ik muziek luister via mijn pc/smartphone/cd/tuner staat het volume op 10 van de 32 verdelingen. Als ik overschakel naar de preamp, moet het volume zakken tot 6/32 om ongeveer even luid te zijn.

Betreffende de ruis vs clipping:
Ik ben van clipping uitgegaan omdat het niet continu hoorbaar is. Dat zou wel moeten als het gewoon ruis is, lijkt mij. Zoals bij clipping te verwachten is, doet het zich vooral voor bij luide(re) passages.

Op 5 november 2020 00:18:51 schreef RAAF12:
[...]

Voor MD elementen, die zitten globaal op 5mV uitgangspanning en de afsluitimpedantie is 47kΩ zoals in het schema vermeld.

Die 5mV was ook wat ik gelezen had voor MD elementen. Daarom dat ik een signaal van 6à8mV heb gebruikt om te testen. En dan had ik mij verwacht aan een signaal van ongeveer 700mV bij een vaak gebruikt versterking van ca 40dB zoals F.E.T. ook vernoemt.

Op 5 november 2020 00:18:51 schreef RAAF12:
[...]
Misschien is het makkelijker te testen door de output van de MD pre-amp op een aux input van een conventionele versterker aan te sluiten. Aansluitingen maken met afgeschermde kabel en een bromvrije voeding gebruiken. Daar zou je prima vinyl mee kunnen afspelen.

Dan lijkt er dus geen probleem te zijn. Correctie, ik hoor net dat ik er dan ook last van heb, maar schijnbaar minder dan wanneer ik via de geluidskaart luister. Wellicht omdat de versterker iets grotere signalen kan verdragen dan de geluidskaart?

Ik zal ook alle componenten nog eens controleren om zeker te zijn dat ik geen verkeerde waarden heb gebruikt.

Wat ik nog niet weet, is het uitgangs-niveau van mijn platenspeler. Een zoek tocht naar een handleiding heeft tot nu toe nog niks opgeleverd. (Het is een kenwood P-44) Langs de andere kant, zou een te groot signaal aan de ingang van de preamp er voor moeten zorgen dat die continu staat te clippen wat ongacht wat er aan de uitgang hangt voor vervorming zou moeten zorgen.

Als je maar genoeg geinteresseerd ben, verwondert heel de wereld.

Weet je zeker dat het een MD element is?
Zo te zien is het een compact platenspelertje. Ik denk dat er inderdaad wel een MD element in zit, maar soms kom je toch nog platenspelers in die form factor tegen die nog keramische elementen hebben.

Meet eens met een digitale multimeter de weerstand tussen de massa en de signaaldraad. Je moet iets onder de 40k ohm meten. Meet je richting de 100k of oneindig, dan heb je een keramisch element met een hoger uitgangssignaal.

Geen analoge gebruiken, dan riskeer je dat je de mini magneetjes demagnetiseert.

Ledlover,

Ik ben niet zeker dat het een MD element is. Zoals ik al zei, ik heb nog geen manual gevonden en ik heb de platenspeler zonder handleiding van mijn grootvader gekregen. Ik meet vreemd genoeg ongeveer 190Ω tussen de massa en signaal van mijn tulp-stekker. Ik heb ook de platenspeler eens rechtstreeks aan mijn versterker gehangen, maar dan komt er amper geluid uit.

Als je maar genoeg geinteresseerd ben, verwondert heel de wereld.

190 ohm is normaal, dan is het inderdaad een MD element.
Weinig geluid rechtstreeks aan de versterker is ook normaal. Dat is in ieder geval 1 probleem uitgesloten.

Eenvoudigste oplossing is om gewoon een spanningsdeler aan de uitgang van de preamp te zetten. Potmeter :)

P42 (zelfde naald) man is wel te vinden. Heeft een 2.5mV MD element.

Ik neem aan dat je die Behringer geluidskaart via USB op de pc aansluit?
Controleer in Windows eens hoe die USB audio input gedefinieerd is en wat daar het ingangslevel van is?

ik heb ondertussen nog wat verder onderzoek gedaan. Zoals in onderstaande afbeelding te zien is, is enkel het linkerkanaal te hard versterkt. Ik heb ook alle componenten gecontroleerd. Die zijn aan beide kanten hetzelfde en komen overeen met het schema.

De twee *.mp3 files zijn een opname van de platen speler. Zowel via de geluidskaart als direct aan mijn versterker gekoppeld. Wat ik hoor komt volgens mij ook niet overeen met de fragmenten die Sine gepost heeft. Het lijkt mij dus absoluut geen ruis.

Als je maar genoeg geinteresseerd ben, verwondert heel de wereld.

Heb je dat met de platenspeler gecontroleerd? Dan even L-R omwisselen en kijken of probleem zich verplaatst of niet.

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com
Sine

Moderator

Dat is vreemd, als het twee identieke trapjes zijn zouden ze ook identiek moeten versterken.

Kijk eens goed naar R1 en R4 / R10 en R7, dat zijn de componenten verantwoordelijk voor de gain.

https://www.circuitsonline.net/files/imagecache/circuits-schematic/schakelingen/schematics/000124.GIF

[Bericht gewijzigd door Sine op 8 november 2020 14:27:38 (23%)]

Frederick E. Terman

Honourable Member

Dat de RIAA-versterker van @TS abusievelijk teveel versterkt had ik eerder al voorgerekend. Bij 1 kHz moet het ca. 41 dB zijn, @TS kwam op 60 dB.
Mijn suggestie was R1 (dan wel R10).

Nu zien we dat deze fout maar in één kanaal zit; het andere kanaal is normaal. Er MOET dus ergens een verschil zitten.
Je zult dus moeten meten.
Of anders kun je er met slimme verwisselingen van leidingen of onderdelen mogelijk achter komen.

Keramisch, kalibratie, parasitair: woordenlijst.org

Nog een paar extra opnames:

line-in platenspeler2.mp3

Dit is een opname met een andere platenspeler die ik me opeens herinnerde. De cartridge die daar op zit is een akai P-35. Volgens deze website zou die een signaal van 5mV moeten uitsturen. Het beeld in audacity lijkt dit ook te bevestigen.

line-in platenspeler3.mp3

Dat is de kenwood platenspeler met gewisselde kanalen.

Audacity laat zien dat de fout in het linkerkanaal blijft zitten. Daaruit blijkt, zoals FET al zei dat er iets fout moét zijn met het linkerkanaal van de preamp. Ik ga de componenten dus nog maar eens onderzoeken, blijkbaar heb ik iets gemist.

Als je maar genoeg geinteresseerd ben, verwondert heel de wereld.

Te weinig ruimte voor bijlages in de vorige post, dus ik ga hier maar verder.

In de wetenschap dat iéts verkeerd is, heb ik alle componenten (niet enkel de weerstanden) een keer gecontroleerd. En daar mee is de boosdoener volgens mij boven water gekomen.

De eerste foto is het linker kanaal, de tweede het rechter. Let op de condensator die vlak tegen het pcb zit. Die is in het linker kanaal 100 pF en in het rechter kanaal 1 nF zoals ook in het schema staat vermeldt. Dat is het enige verschil dat ik kan vinden, en moet dus de fout zijn.

[Edit]
Na de operatie ziet het er zo uit.

Nog steeds niet even groot, maar ik denk dat links en rechts ook niet hetzelfde proberen weer te geven. In het rechterkanaal ontbreken bijvoorbeeld de violen. (die zitten in het orkest overigens links voor de toeschouwer. Zou dat daar mee te maken kunnen hebben?

Allesinds bedankt allemaal voor het meedenken. :)
[\Edit]

[Bericht gewijzigd door Shock6805 op 8 november 2020 15:24:37 (25%)]

Als je maar genoeg geinteresseerd ben, verwondert heel de wereld.
RAAF12

Golden Member

Tja, je kan toch de twee kanalen met een regelbare sinus uitsturen? Een lege elco in de signaalweg laat bijv. geen lagere tonen door. Mocht je geen hardware hebben, toontjes staan ook op het net. Bijv. https://www.szynalski.com/tone-generator/
Ja, violen zitten links in een klassiek symfonie orkest. Bij een kamerorkest à la I Musici zitten ze meer verspreid in het stereobeeld!

Gewoon een mono signaal toevoeren?... ;)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com