IRAUD 550 Class D

Dacht een leuke compacte versterker case te bouwen met de IRAUD 550 module:

http://imagizer.imageshack.us/v2/800x600q90/922/iTkW0y.jpg
http://imagizer.imageshack.us/v2/800x600q90/924/zRYLY5.jpg

Na veel gedoe met digitale rotzooi eruit proberen te krijgen geven beide versterker op iets hoger volume een knetter geluid, niet bruikbaar dus.

Ik heb de modules aangesloten op een dual 40VAC ringkern trafo van 650VA. Ik heb de weerstanden voor de 5VDC voedingspanning al 2Kohm gemaakt geadviseerd volgens de verkopers van dit spul.

Maar dat helpt niet. Wie is er ook aan het stoeien met deze dingen en heeft oplossingen?

Ik hoor het graag.

Het schema klopt zo te zien in ieder geval niet. (op de print zitten 2 brugcellen die nergens te zien zijn op het schema)
Flinke lawaaibak met 700W (als 'ie tenminste werkt...)

Ik gebruik meestal de TPA3116D2. Geeft 100W, nooit meer nodig gehad. Heb er nog nooit problemen mee gehad of vreemde geluiden...
Niet erg kritisch, werkt altijd na opbouw. (op 1 keer na, toen had ik de voedingselco's omgedraaid. Goeie knal, en na vervangen elco's gewoon weer verder...)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Het schema wat getekend is klopt volgens mij, die gelijkrichters kan ik er wel bij denken. Het relais IC is er ook niet, maar dat geloof ik ook wel.

leuke compacte versterker case te bouwen

Heb ik ook gedaan, met hypex modules (UcD400HG), kost iets meer, werkt in een keer.

It's the rule that you live by and die for It's the one thing you can't deny Even though you don't know what the price is. It is justified.

Ik heb de scope er maar eens aan gehangen. Onder de 2.8Vpp geen knetter/tikkend geluid. Daarboven komt er een kleine vervorming alleen op de bovenste sinus helft:

https://imagizer.imageshack.com/v2/800x600q90/924/M2c5T8.jpg
https://imagizer.imageshack.com/v2/800x600q90/924/quRqtt.jpg
https://imagizer.imageshack.com/v2/800x600q90/922/SArTN2.jpg
https://imagizer.imageshack.com/v2/800x600q90/923/81lbTH.jpg
https://imagizer.imageshack.com/v2/800x600q90/922/DqulUX.jpg
https://imagizer.imageshack.com/v2/800x600q90/924/OOKkPb.jpg
https://imagizer.imageshack.com/v2/800x600q90/924/D8Kh6D.jpg

Als je de output spanning verhoogt dan verschuift de vervorming.

Ik heb 10 ohm weerstandjes tussen de gates gezet zoals in het datasheet schema zie hieronder, maar dit maakt niks uit. Wel wordt het drive IC niet meer zo heet.

https://imagizer.imageshack.com/v2/800x600q90/924/sVm88z.jpg

Beide versterker board geven hetzelfde probleem. Iemand?

komt de voorversterker spanning uit dezelfde voedingslijn als de voeding van de eindversterker? ook de fet eindtrap zonder weerstanden in de source en drive op de uitgang zijn wat raar als je vanuit een transistor eindtrap het geheel bekijkt.

waar rook was, werkt nu iets niet meer

Ja, voeding voor het IC komt van -B. Zit een 12VDC regulator circuitje voor zie schema in startpost.

Ik heb nog geen source weerstanden in classD versterkers gezien.
Het typical schema komt uit het datasheet van de IRS2092 drive IC.

In de open lus versterking zit de voedingsspanning als factor, mogelijk dat er iets vastloopt. Check de uitgang van je opamp en de signalen aan de ingang van de comparator schakeling.

This is the world we know best, the world of madness

Oscilleert de boel niet? Bestaat die sinus niet uit een veel hogere frequentie (met tijdbasis scoop wat uitvergroten)

Arco - "Simplicity is a prerequisite for reliability" - www.arcovox.com

Op 19 april 2018 11:55:29 schreef Arco:
Oscilleert de boel niet? Bestaat die sinus niet uit een veel hogere frequentie (met tijdbasis scoop wat uitvergroten)

De AC component die je op de scoop ziet is het residu van de hogere schakelfrequentie.

This is the world we know best, the world of madness

Zit die TL081 ook op de print of is die later toegevoegd ?
Ik zie daar namelijk geen HF ontkoppeling over de terugkoppelweerstand zitten in de vorm van een condensator, die TL zou dus ook raar kunnen gaan doen, zeker met zo'n heftige hoogfrequent bron erachter.

De voeding van die TL is ook maar + en - 5 Volt ? Die kan ook clippen dus.

[Bericht gewijzigd door KGE op 19 april 2018 18:41:56 (13%)]

Op 19 april 2018 11:55:29 schreef Arco:
Oscilleert de boel niet? Bestaat die sinus niet uit een veel hogere frequentie (met tijdbasis scoop wat uitvergroten)

Dat is idd een overblijfsel van de schakelfrequentie, 420KHz.

Op 19 april 2018 18:40:57 schreef KGE:
Zit die TL081 ook op de print of is die later toegevoegd ?
Ik zie daar namelijk geen HF ontkoppeling over de terugkoppelweerstand zitten in de vorm van een condensator, die TL zou dus ook raar kunnen gaan doen, zeker met zo'n heftige hoogfrequent bron erachter.

De voeding van die TL is ook maar + en - 5 Volt ? Die kan ook clippen dus.

Die zit ook op de print aan de onderkant in SMD vorm.

Input is gewoon line signaal, opamp is gewoon een buffer lijkt me met versterking factor 1.

Wat stel je voor voor de HF terugkoppeling? een paar nanofarad erover om de bandbreedte ze verkleinen?

Voor het mooie zou ik de schakelfrequentie van 1 board met 50Khz ofzo willen verhogen zodat ze elkaar niet bijten, dat wordt zo gedaan in de Synq class d versterkers.

Maar heb nu over elke voedingslijn een HF ontstoring ferrietkraal, ook over de input line signaal kabels.

[Bericht gewijzigd door nijhuisr op 19 april 2018 22:04:38 (17%)]

Trouwens de uitgang van de opamp moet je AC koppelen omdat de comparator zelf instellend is, dat is een mogelijke oorzaak van de vervorming.

This is the world we know best, the world of madness

Op 20 april 2018 02:32:20 schreef Blackfin:
Trouwens de uitgang van de opamp moet je AC koppelen omdat de comparator zelf instellend is, dat is een mogelijke oorzaak van de vervorming.

Ik heb op de plek van de 3K weerstand een 3K3 weerstandje in serie met een 4.7uF gezet maar het probleem blijft.

https://imagizer.imageshack.com/v2/800x600q90/924/mz1Oq2.jpg

Op 19 april 2018 18:40:57 schreef KGE:
Zit die TL081 ook op de print of is die later toegevoegd ?
Ik zie daar namelijk geen HF ontkoppeling over de terugkoppelweerstand zitten in de vorm van een condensator, die TL zou dus ook raar kunnen gaan doen, zeker met zo'n heftige hoogfrequent bron erachter.

Heb 22nF over de 20K gezet, filtert flink de hoge tonen weg maar probleem is hetzelfde.

Heb ook 100nF over de voeding van de opamp gezet dichtbij, niks

Vind die R11 tegenkoppeling wel raar, gaat van uit naar in, als de in en uit in fase is gaat het juist oscileren...

Transistors are Cool Tubes are Hot

Ik heb de scope er maar eens aan gehangen. Onder de 2.8Vpp geen knetter/tikkend geluid. Daarboven komt er een kleine vervorming alleen op de bovenste sinus helft:
Als je de output spanning verhoogt dan verschuift de vervorming.

Je verteld niet waar je hebt gemeten met de scoop plaatjes, is dit de op de uitgang?
Op de uitgang tussen de twee fets zou je een nette blokgolf moeten zien, probeer daar eens te meten.

Vind die R11 tegenkoppeling wel raar, gaat van uit naar in, als de in en uit in fase is gaat het juist oscileren...

De uitgang is in tegenfase met de ingang, de tegenkoppeling is aangesloten met de inverterende ingang van een opamp.

[Bericht gewijzigd door Martin V op 21 april 2018 20:50:49 (11%)]

"tijd is relatief"

Op 21 april 2018 20:42:32 schreef Martin V:

Je verteld niet waar je hebt gemeten met de scoop plaatjes, is dit de op de uitgang?
Op de uitgang tussen de twee fets zou je een nette blokgolf moeten zien, probeer daar eens te meten.

Dit is op de speaker uitgang. Mijn oude scoop is niet zo best meer merk ik. Ik zie wel een soort blokgolf maar is niet te triggeren helaas.

Ik kan dus alleen de symptomen zien aan de uitgang helaas.

Ik heb nog een andere trafo getest met maar 22VAC en dus 32VDC symm maar geen verschil.

Of ik kijk er finaal naast, of ik zie hier de eerste klasse D (power)versterker welke geen HF filtering en decoupling heeft tussen de eindtrap en speaker.
Het enige wat ik zie is een zobel netwerkje?

Wellicht is het ding simpelweg niet voorzien van filtering?

Als je ampje piept en kraakt, is DJohnny die hem maakt... Kom alleen niet om garantie, want dan is DJohnny met vakantie!

Klasse D is is in princiepe gewoon een H-brug. Die kan prima stromen sturen, mits de belasting inductief is. Dus spoeltje er achter en klaar...
Omdat een speaker toch al inductief is, wordt die spoel wel eens weggelaten. Het nadeel is dat je dan HF op je speakerdraden hebt, maar goed....

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

22uH en 0.47uF vormen een 12db/octaaf LP filter op ca. 50Khz.

De schakelfrequentie is 420KHz. Je houdt altijd een beetje van de frequentie over op de speaker, zie scoop beelden.

Voor de spoel staan een 110Vpp blokgolf.

Op 21 april 2018 10:03:44 schreef nijhuisr:
[...]

Heb 22nF over de 20K gezet, filtert flink de hoge tonen weg maar probleem is hetzelfde.

Heb ook 100nF over de voeding van de opamp gezet dichtbij, niks

C-tje kan dus wel kleiner, ergens tussen de 100p en 1 nF, schaadt zowiezo niet.

Kun je ook zien of het uitgangssignaal van de TL clipped bij die hogere volumes ?

Op 21 april 2018 20:42:32 schreef Martin V:
[...]
De uitgang is in tegenfase met de ingang, de tegenkoppeling is aangesloten met de inverterende ingang van een opamp.

Minnetje over het hoofd gezien, je heb gelijk..

Transistors are Cool Tubes are Hot