74LS189 worden warm en voltage drop

Op 31 juli 2017 19:44:48 schreef Thevel:
Zie nu op de foto dat je de LS versie gebruik, dus max. 40mA.

Soms zie ik het over het hoofd, maar dit keer wist ik het uit de titel van het topic... :-)

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
Thevel

Golden Member

In deze datasheet lees ik 40mA.

[Bericht gewijzigd door Thevel op 31 juli 2017 20:49:22 (15%)]

Bij TTL kun je de ingangen gewoon open laten (niet dat het echt netjes is) en heeft dat geen nadelige consequenties zoals bij CMOS.
('rew' heeft gelijk)

Dus alleen voeding op een chip zetten en meten wat er loopt: veel meer als 40mA -> defect dus. (of fake)

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.

Da's de 74LS189 zonder de 'A'... (die trekt max. 40mA, de -A versie 60mA, en de -B versie trekt zelfs 105mA)
De opdruk op de ic's lijkt erg nieuw; ik denk toch dat dit soort 64 bits geheugens al lang obsolete zijn...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Kijk eens goed naar het tweede IC van links geteld. Die is schuin afgeslepen zo lijkt het (rechterzijde dunner). Ook de "structuur" van de bovenzijde is niet mooi glad maar te ruw.

De opdruk van de jaar/week code ziet er vreemd uit. Vroeger stond er bijvoorbeeld gewoon 8432 of zo op (1984 week 32). En niet van de letter coderingen dacht ik.

Ik hou het ook op fake chips.

Kijk eens op de onderkant, vroeger stonden daar ook wat grotere stempeltjes op.

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.

Helaas ben ik een week niet thuis dus kan ik niets meer controleren of proberen.
Ik begin, vooral aan de hand van jullie reacties, inderdaad ook het vermoeden te krijgen dat de ICs nep zijn.
Eens proberen of ik echte kan vinden hier in de buurt en dan opnieuw proberen. Maar ik zal ook alle verbindingen opnieuw doen en een ander breadboard proberen.

De ICs hebben ook geen notch zoals de meeste hebben. Alleen een puntje bij pin 1.
Vreemde zaak dit.

Redeneer ik goed dat het prima mogelijk is dat ik een voltage drop meet wanneer er te veel van de voeding wordt getrokken?

Als je een of twee volt drop hebt in de voedingslijnen dan zit er iets niet goed, of het breadboard is gammel.
Drop zou niet noemenswaardig moeten zijn. (zelfs bij 1 ampere)

Bij oudere ic's verwacht je inderdaad meestal een 'notch' aan de pin 1 zijde. Opdruk en logo zien er ook wat nieuw uit.
(zou me niet verbazen als de bovenkant geverfd is. Kun je met een mesje dan zo eraf krabben)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Op 1 augustus 2017 11:13:18 schreef Arco:
Als je een of twee volt drop hebt in de voedingslijnen dan zit er iets niet goed, of het breadboard is gammel.

Als die chips 1 a 2 ampere trekken, dan is die voeding helemaal niet fout. Wel ongeveer wat je verwacht van een breadboard....

Op 1 augustus 2017 10:55:40 schreef tmdr:
Maar ik zal ook alle verbindingen opnieuw doen en een ander breadboard proberen.

Begin gewoon met 1 enkel stuk. En alleen met voeding-en-aarde. Zo kan je doordat je maar 2 draden aansluit zorgen dat je geen fouten maakt in alle andere draden.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Inmiddels ben ik weer thuis.
Zojuist op aanraden van jullie dus met een nieuw breadboard begonnen en alleen 5V en GND aangesloten (en maar één IC, dus niet twee zoals op de foto's). Dat ging prima, dus toen ook CS (active low) aangesloten. Ging ook nog prima.
Daarna een voor één aangesloten. Als ik RW naar GND prik zit ik nog steeds op 10mA.
Zodra ik die naar 5V zet gaat het verbruik al naar de 370mA.
Die dus maar snel weer terug gezet, want daar gaat iets niet goed.
Toen de vier address lines naar GND. Dan zit ik op 360mA.
Als ik dan vervolgens de data lines aansluit verandert daar niks in.
Al de tijd heb ik vier ledjes op de outputs gehad.
Zodra alle address en data lines naar GND gaan en ik RW HIGH zet, dik 1.15A.
Tevens nog een derde breadboard geprobeerd met zelfde resultaat.

Ik ga straks nieuwe halen, dit lijkt me gewoon troep.
Neem aan dat jullie dit beamen.

Stond er nog wat aan de onderzijde van de ic's? (en is de verf er heel makkelijk af te krabbelen aan de voorzijde?)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Op 7 augustus 2017 14:47:06 schreef Arco:
Stond er nog wat aan de onderzijde van de ic's? (en is de verf er heel makkelijk af te krabbelen aan de voorzijde?)

Sorry vergeten.
Op de onderkant staat in één van de twee cirkels die aanwezig zijn "japan 1".
Ze lijken niet geverfd. Zit direct in het plastic package te krassen. Komt geen verf van af.

Ja, ze worden ook wel gelaserd. Dan raggen ze dus met een laser het logo en typenummer in het plastic.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Heb twee nieuwe 74LS189 gehaald. Zien er een stuk anders uit en lijken prima te werken.
Echter nu het volgende probleem. Als ik een waarde in het geheugen lees en vervolgens RW LOW haal (active high), na een seconde of twee faden de ledjes weer terug naar allemaal HIGH. Ik had 1010 1010 er in gezet, maar dat gaat dus langzaam terug naar 1111 1111. Geen merkwaardige voltage verschillen oid. Overal zeker 4.8v en voeding zit zeer dicht bij de IC's ingeprikt.

/WE moet hoog zijn als je niet schrijft in het geheugen, en /CS laag...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Ok ik schaam me dood.
Dan werkt de boel.

Kennelijk een teken dat ik maar van het weer moet gaan genieten en niet binnen hiermee rotzooien.
Thnx voor jullie hulp heren. Helden!

Redeneer ik goed dat het prima mogelijk is dat ik een voltage drop meet wanneer er te veel van de voeding wordt getrokken?

Dat klopt helemaal als je teveel probeert eruit te halen kunnen er een paar dingen gebeuren.

  1. De voeding is krap bemeten en gaat snel kapot.
  2. De voeding heeft wat reserve maar zakt wel wat met de spanning.
  3. De voeding heeft een beveiliging en schakelt in protectie.
  4. De voeding heeft een beveiliging en gaat de spanning zelf actief terug regelen.

Adapters vallen meestal onder de eerste terwijl een zeer professionele voeding onder 4 valt.

Zojuist op aanraden van jullie dus met een nieuw breadboard begonnen en alleen 5V en GND aangesloten

Heel veel IC uit de 74, 54 en 40-serie met dezelfde pin aantal hebben de voeding op dezelfde plaats zitten. dus dat zal meestal nog wel goed gaan. Echter de in en uitgangen zitten op heel andere plaatsen. En als je bv een OF-poort hebt te pakken en je hebt 1 ingang hoog gemaakt dan word zijn uitgang ook hoog. Maar jij weet dat niet en je legt dat pootje aan GND omdat het in jouw schema zo moet. Dan gaat er dus heel wat stroom lopen.

mel

Golden Member

PAS OP! Er zijn typen met afwijkende pinning wat voeding betreft..staat in de datasheets wel aangegeven, maar toch..een foutje is zo gemaakt..

u=ir betekent niet :U bent ingenieur..
MNM(tm)

Golden Member

Je eerste setje '189 chips was duidelijk fake:
https://www.uploadarchief.net/files/download/2xsn74ls189an.png
Bij de rechter chip is duidelijk te zien dat de verdiepte circel abrupt stopt, terwijl deze bij de linker chip (nog) wel mooi rond doorloopt. De toplaag is er dus afgeschuurd en er is een nieuwe tekst in gelaserd.

Fan van Samsung (en repareer ook TV's). :)

Op 7 augustus 2017 18:12:44 schreef benleentje:
Maar jij weet dat niet en je legt dat pootje aan GND omdat het in jouw schema zo moet. Dan gaat er dus heel wat stroom lopen.

Daarom dus draadje voor draadje opzetten en steeds de boel testen en in de gaten houden.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Je eerste setje '189 chips was duidelijk fake

Ze zijn (slecht) overgestempeld. Hoeft niet te betekenen dat het geen echte 189's zijn. Gezien het uiterlijk was het geen TI.

Het model van het IC en de opdruk zien er te 'modern' uit voor zo'n gedateerd ic, de oudere TI logo's waren ook open, en niet dichtgeverfd...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com