Arduino Uno r3

ik heb dit in geplaatst en dat werkt ook heel goed daar is wel iets eigenaardig bij het uploaden gebeurt nu blijft het gele ledje dat normaal uit en aan gaat nu vast branden is dat normaal?

#include <LiquidCrystal.h>

// LCD display waarbij:
// rs aansluiten op pin 12
// rw aansluiten op pin 11
// enable aansluiten op pin 10
// d4, d5, d6, d7 aansluiten op pins 5, 4, 3, 2
LiquidCrystal lcd(12, 11, 10, 5, 4, 3, 2);

void setup()
{
// Print een bericht op de LCD.
lcd.print(" Hallo ROC-A12!");
lcd.setCursor(0, 1); //eerste positie op 1e regel
lcd.print("Elektrotechniek!");

}

void loop()
{
}

Op 30 maart 2018 17:24:23 schreef Rudim:
Meer info en sketch vind je op mijn Arduino blog onder "Arduinows!OBD2 deel 1 t/m 5".

Leuk om jouw blog te zien met allemaal projectjes rond de Arduino.

"tijd is relatief"

moet je geen initialize doen van je display?

hier vind je alles, aansluitingen, code...
ik mis de
LCD.begin(16,2); in jouw code. hier ga je het display initialiseren, de geheugenplaatsen in het display leegmaken (zodat je geen random karakters krijgt te zien) en bepalen hoe groot die is.
er zijn namelijk ook 20x4 displays die op dezelfde manier werken. dan zet je gewoon 20,4 tussen haakjes en kan je 4regels beschrijven

Op 30 maart 2018 17:24:23 schreef Rudim:
[...]

Meer info en sketch vind je op mijn Arduino blog onder "Arduinows!OBD2 deel 1 t/m 5".

heel leuk, ga zeker die code eens bekijken van die clock met pacman, tetris, pong... erin. ben met dergelijke ook bezig, maar dan de games schrijven ipv een simulatie in de klok. best ingewikkeld om zoiets te maken.

[Bericht gewijzigd door fcapri op 31 maart 2018 09:32:21 (35%)]

ik hou van werken ..., ik kan er uren naar kijken

ik heb initialize gedaan met display en geen fout ook met upload was alles in orde maar dan na de upload is het gele ledje niet meer uitgegaan , maar nu ga ik Lcd-begin(16,2); er eens bij zetten zien wat het dan geeft. en @ Rudim en heel goede blog daar kan ik men veel van leren heel interessant .

ik heb het gedaan maar het blijft het zelfde het gele ledje gaat niet uit eventjes bij het uploaden aan en uit en dan blift het branden