Topswitch SMPS probleem


Op 22 juni 2022 22:52:48 schreef Vegito:
Hallo Piet,

Ik zit met soort gelijk probleem zou je mij willen helpen hoe ik dit kan oplossen. ik heb een foto van mij huidige TOP227YN transistor het lijkt op eerste oog niet echt fris meer uit te zien

Ik zie niet direct een probleem. Wat heb je gemeten? Wat zijn de symptomen? Als het om hetzelfde apparaat met dezelfde symptomen gaat, heb je R3 al nagemeten? Dat was bij hem de oplossing.

[Bericht gewijzigd door maartenbakker op 23 juni 2022 02:44:41 (13%)]

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Nou de symptomen zijn hetzelfde apparaat gaat helemaal.niet meer aan geen enkel kick. En diverse fora heb ik gezien dat ze de top227yn vervangen. Echter de R3 kan ik niet op de board vinden alleen op de DSP board apart. Misschien multimeter erbij pakken en de weerstand en topswtich meten

Het kan ook alleen de TOP227 zijn die gesneuveld is. Ik heb al meerdere gehad waarvan het alleen aan de TOP lag. Een andere reden waardoor die niet meer opstart kan kortsluiting in de ventilator zijn, dan dus even fan loskoppelen en testen.
Ook heb ik eindelijk contact weten te krijgen met de fabrikant. De modificatie die de fabrikant heeft bedacht om het sneuvelen van de TOP227 te voorkomen is door er een kleine heatsink op te plakken.

Hi Piet super bedankt dat je wilt reageren en mij uit de brand wilt helpen.

Ik heb al de ventilator losgemaakt en geprobeerd aan te doen maar helaas is dat niet gelukt dus ik denk dat de TOP idd niet meer goed functioneerd. Hoe kan ik de TOP testen met de multimeter als diode te testen ?

Is de TOP die ik gevonden de juiste ? het gaat wel om de PLD 4.5 ik weet niet of jij ook die heb gerepareerd.

Met een multimeter kun je eigenlijk niet meten of de TOP nog goed is maar als de amp niet meer aan gaat en er staat wel spanning op de TOP dan is die waarschijnlijk defect. Ging bij mij inderdaad ook om de PLD 4.5 & 4.3

Hallo Piet, bedankt voor de info het los solderen is dat gemakkelijk of moet ik iets met spanning doen voor de chip te ontladen ? Laatste wat ik wil is een kapotte board ik heb wel soldeer skills en kan met flux werken. Omdat je zei dat dat er spanning erop staat.

super bedankt voor je info.

wat me wel opvalt is dat de plaatje waar bij jouw de chip op zit korter is dan die van mij daar zit nog een stukje board klopt dat ?

trouwens is deze de correcte type ?

https://www.reichelt.nl/nl/nl/ac-dc-offline-pwm-schakelaar-85-265-vac-…

of https://nl.farnell.com/power-integrations/top227yn/ac-dc-converter-40-…

Hi Piet,

We hebben de TOP227YN vervangen echter doet de versterker nog steeds niks dus ik ben nu beetje aan het twijfelen waar het aan kan liggen is er iets op de voeding mogelijk iets stuk ?. Wie oh wie kan mij hierbij helpen

Als er een TL431 bij die TOP zit: die is ook soms opgeblazen...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Bij mij was op de achterkant van de print ook R54 defect. Bijgevoegd het schema van het gedeelte rond de top voor de pld4.3 & 4.5.
Check met de multimeter eerst eens of alle waardes van de weerstanden kloppen, het kan best zijn dat er ergens een defect is geraakt.

Hallo Allen, ik ga vanavond weer even doormeten die weerstanden ik hou jullie op de hoogte wat de status is

Ik heb de R54 gemeten en als ik mijn multimeter mag geloven lees ik 15 ohm af terwijl er 10 ohm staat in de schema. Kan dat de oorzaak ? De overige in de buurt weerstanden die ik kon meten zijn 10 ohm.

Waarde van R54 luistert niet zo nauw. Kan goed dat men die aangepast heeft en anders is als het schema.
(kun je toch zien aan opdruk of kleurbanden?)

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

het is echt een hele kleine smd weerstand en de belettering niet te zien. Wel viel me op dat r51 geen meeting uitgaf

R51 zou 20 Ohm moeten zijn volgens schema. Deze fungeert ook als zekering, dus is waarschijnlijk overleden...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Ja, die geeft helemaal geen meting dus ik ga die denk ik bestellen en vervangen ook de IC octocoupler lijkt ok te zijn op diode stand als ik de plus van multimeter ronde stip plaats van de coupler en de zwarte op de naast liggende pootje van de ic krijg ik 330 waarde te zien.

Het zal een veiligheids (fusible) weerstand zijn, dus dat type moet je dan bestellen...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

Deze weerstand is ook via QSC te krijgen : https://parts.qsc.com/re-002005-00

Helaas kan je deze in Nederland niet rechtstreeks bestellen maar moet dit via een officiële dealer/importeur :(

Ja idd en dan ben je ook weken verder..

https://nl.farnell.com/ohmite/tww5j20re/wirewound-resistor-20-ohm-5w-5…

Deze zou dan moeten zijn.

Piet had je ook die kleine smd weerstand vervangen met 0402 ?

Op 16 juli 2022 22:01:36 schreef Vegito:
Ja idd en dan ben je ook weken verder..

https://nl.farnell.com/ohmite/tww5j20re/wirewound-resistor-20-ohm-5w-5…

Deze zou dan moeten zijn.

De versie zonder de E is lood versie en die is vervangen met ongeloodfdaarom E arachter

Piet had je ook die kleine smd weerstand vervangen met 0402 ?

de genoemde weerstand is erg moeilijk te krijgen via farnell wel alleen moet het speciaal besteld worden uit USA en dat kost je dan 25 euro verzending voor een weerstand die 90 cent kost. daarnaast moet je ook een bedrijf zijn om te kunnen bestellen.

Update:

Paar dagen nu verder omdat ik op aantal onderdelen ging wachten uit Amerika. Gisteren alles netjes binnen gekregen en ik heb het volgende besteld

2x Ohmite TWW5J20RE 5 Watt en 20 Ohm

4x Optocoupler LTV-357T

4x Nichicon CAP 47UF 10V

2x 0402 smd 1/16W 10 Ohm

Als eerste ben ik aan de slag gegaan met de keramisch weerstand TWW5J20RE te vervangen. Dat ging vrij makkelijk echter moest eerst witte RTV spul los gemaakt worden waarna ik de weerstand makkelijk eraf kon solderen.

De oude weerstand gemeten en 0 Ohm dus die was duidelijk niet meer goed terwijl andere 20 Ohm netjes aangaf.

Alles aangesloten apparaat aangezet en helemaal niks geen teken van leven.

Ik ben verder gaan zoeken stuit ik steeds tegen die optocoupler die vaak stuk gaat maar, ik kreeg netjes waarde doorheen waarde 330 continuïteit. Ik heb toen toch besloten om dan die optocoupler eraf te halen en dan te meten wat ik krijg. Zo gezegd en merkwaardig zal ik dezelfde meeting |:( . Omdat het toch al.eraf was heb ik hem wel vervangen echter merkte ik ook dat er een andere type erop zat LTV-356T ipv LTV-357T.

Na het vervangen met de hoop dat de unit aan zou gaan zag ik opeens QSC logo en hele schakeling begon te werken. Alles terug gebouwd en schoongemaakt is de resultaat dat de unit gefixed is !!!

Ik wil jullie ontzettend bedanken voor het meedenken en adviezen en zeker Piet die ook ons op de goede eind hielp met de schema's echt top.

Ben heel blij dat me AMP weer werkt en dat ie niet weken lang bij reparateur ligt.

Hieronder paar plaatjes voor diegene die mogelijk tegen hetzelfde aanlopen.

De opto zal niet kapot zijn, dat zijn ze zelden tot nooit...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com

ik heb enkel de TOP, TWW5J20RE, en de Optocoupler vervangen. Ik vermoed dat de Optocoupler in wendig niet meer goed is en de schakeling tussen de ene input naar de andere kant niet meer goed werkte of schakelde. Mogelijk is dit ook een beveiliging samen met de weerstand die ik ook vervangen hebt.

Het feit is wel dat de AMP nu weer aangaat en werkt. in een andere forum had iemand ook deze probleem en had QSC zelf ook de optocoupler vervangen.

ik heb gelukkig nu wat voorraad en zal zeker een heatsink op de TOP plaatsen voor wat koeling.

De opto zal echt nog wel heel zijn... (zelfs bij zware sluitingen waar alles zwart is, is de opto nog heel... ;) )
Koelprofiel is niet nodig/heeft geen zin, want warm worden doet de TOP niet. Ze overlijden meestal door transients bij in of uitschakelen...

Arco - "Simplicity is a prerequisite for reliability" - hard en software ontwikkeling: www.arcovox.com