Reparatie Philips PM5171 Amplifier / Log Converter

flash2b

Special Member

Op de radio beurs in Rosmalen kocht ik deze Philips PM5171 Amplifier / Log Converter.

Blackdog heeft deze al geshowed in Philip PM5171 Meetversterker waar ook het schema te vinden is. Mijne is een nieuwer type (met rode streep op front), maar echter wel defect.

Er zit een sluiting in de voeding, welke de thermische zekering van de trafo heeft getriggerd. Deze heeft goed zijn werk gedaan, want hij is verbroken.

Op de PCB zitten 4 soldeer bruggen die kunnen worden verwijderd zodat de voeding los van de rest kan worden getest. Deze bruggen heb ik voor mijn test dus verwijderd. In de voeding zit echter een sluiting, vooral de negatieve kant komt niet op niveau.

https://www.uploadarchief.net:443/files/download/pm5171%20power%20supply.jpg

Deze voeding is opgebouwd rond een SG4501N (in de mijne zit een SG3401J SG4501J). Alle transistoren zijn getest en meten goed. Bij mij is R774 niet gemonteerd. Ook de weerstanden meten nog goed.

Ik heb de thermische zekering overbrugt, die kan volgens mij niet uit de trafo worden gehaald en de diode brug tijdelijk verwijderd. De trafo meet dan netjes 2x 27.5V AC en wordt niet warm.

De verwijderde Semikron brug (vs BY164 in het schema)
https://www.uploadarchief.net:443/files/download/20170312_214321_cleaned.jpg

Hierna heb ik met mijn Rigol DP832A een +/- 27,5V DC aangebracht op condensatoren C564/C566.
https://www.uploadarchief.net:443/files/download/20170312_214004_cleaned.jpg

Met een stroombegrenzing van 200mA zakt de spanning flink. Op onderstaande foto is dit te zien, kanaal 1 (geel) is de negatieve kant en kanaal 2 (blauw) is de positieve kant. Mijn voeding staat in tracking én on/off dual channel.

https://www.uploadarchief.net:443/files/download/20170312_214113_cleaned.jpg

Kan ik er nu vanuit gaan dat de SG4501J defect is? Als ik die wil vervangen, dan is dat niet zo makkelijk want hij is obsolete.

Alternatieven

  • LM325, heb ik beschikbaar maar heeft een andere pinout
  • SG1468T, wordt verkocht door EOO en datasheet lijkt soortgelijk echter de T versie is de metal-can en heeft een andere pinout
  • LM317AHVT en LM337SP, deze versies zijn nodig door de hoge ingang spanning. De 317AHVT heb ik beschikbaar, de 337SP wordt verkocht door farnell. Kan met 2x 2 stuks een +/- 15V en +/- 25V bouwen de die in de PM5171 integreren.

Hieronder nog een overzicht foto van de patiënt op de operatie tafel
https://www.uploadarchief.net:443/files/download/20170312_214205_cleaned.jpg

Mijn vragen

  • Kan ik er nu vanuit gaan dat de SG4501J defect is?
  • Misschien heeft iemand nog een SG4501N of SG4501J beschikbaar of wil iemand die LM337SP (2 stuks) voor mij bestellen.
  • Kan die thermische zekering uit de trafo worden getrokken ?
  • In mijn PM5171 zat een Semikron gelijkrichter en niet een BY164, waarom?
  • Hebben jullie nog andere tips ?

Alvast bedankt voor jullie hulp en suggesties, het zou jammer zijn om deze PM5171 als sloop machine/onderdelen bak te gebruiken maar het moet wel financieel haalbaar blijven.

Misschien lees ik er overheen, maar zijn de elco's goed (een droge kan sluiting geven)?
In mijn PM5171 zit gewoon een BY164. Ik denk dat er al eerder een reparatiepoging in jouw voedingsdeel is gedaan.
Lijkt me overigens niet waarschijnlijk dat de SG4501 het symptoom veroorzaakt dat je beschrijft.

Ha flash2b,

Er is er nog een te koop bij ELEC. €4.57 .maar ik ben he met @markce eens dat als het IC de oorzaak is waarschijnlijk het dak er af was gegaan ;)

Groet Henk.

Everything should be as simple as possible, but not simpler.
miedema

Golden Member

Ha Flash2b,

De oplossing "sloopmachine" in geen geval!
Daarvoor is het een veel te leuk en handig versterkertje. Een voedinsprobleem moet toch op te lossen zijn :-)

Het is goed mogelijk dat iemand eerder een poging gewaagd heeft, en er niet uitgekomen is, of zelf fouten gemaakt heeft. Dat zijn dus de (denk)fouten die je moet zoeken. Zo vindt ik voor je SG3401J vooralsnog alleen een datatasheet voor een high frequency video amplifier......
Ook natuurlijk soldeer tussen printeilandjes etc.

Verder zou ik vooral goed kijken naar de passieve componenten rond het regel IC. Lekke elco's, opgelopen stroomshunt 768, de spanningstotempaal 769-773 etc.

Controleer of er geen verkeerde componenten waarden ingezet zijn. Laatst had ik een LCR meter waar dat af fabriek (Philips...) al het geval was.

Als je verder gaat met je boven beschreven meting, dan kun je uitzoeken waar die 200mA blijft.
Die linkjes om de voeding te ontkoppelen van de rest van de schakeling kan ik niet terugvinden op de printlayout in het servicedoc. Weet je zeker dat de voeding echt helemaal los is?

En mocht je er er helemaal niet uitkomen, dan is een klein hulpprintje met vervangend stukje elektronica de oplossing. Als je dat met die LM337's wilt doen, is het geen enkel probleem om ze met m'n volgende Farnell bestelling mee te laten komen.

succes & groet, Gertjan.

flash2b

Special Member

Dank voor alle reacties.

@markce
Ik heb de kleine elco's vluchtig gechecked, maar ik zal ze na jou opmerking allemaal even los solderen en grondig checken. Ik had me geconcentreerd op de halfgeleiders en weerstanden, en die meten goed. Leuk dat je ook een PM5171 hebt idd er hoort gewoon een BY164 in.

@electron920
Dank je wel voor die hint. In mijn PM5171 zit een SG4501J, de J suffix is voor Ceramic Dip, het 'dak' zal er dus niet snel af gaan. Stuur me even een link waar voor de ELEC winkel.

@miedema
Het was een typfout, het is een SG4501J (dus niet SG3401J) ik zal het aanpassen in de startpost. Ik zal alle elcos nalopen. De voeding is echt helemaal los, daar zijn die soldeer bruggen voor gemaakt, heb het gechecked. Dank je wel dat je eventueel LM337SP voor me wilt bestellen, mocht ik ze nodig hebben dan laat ik het weten.

Het lijkt inderdaad dat er al eerder aan deze PM5171 is gewerkt, vooral die Semikron gelijkrichter hint daar op. Vroeger propte Philips overal BY164's in, van die groene!

Die thermische zekering in de trafo, vind ik een rare oplossing want eenmaal gesprongen kan ie volgens mijn niet worden verwijderd. Op de overzicht foto is hij te zien bij de rode draadjes. Je kunt hem dus extern makkelijk benaderen het is een een klein plastic stukje waarbij hij in serie met de primaire kant is geschakeld.

Ik hou jullie op de hoogte van mijn vorderingen, ik hoop dat ik met mijn startpost een goede start heb gemaakt.

Alle nuttige reacties zijn welkom.

miedema

Golden Member

Ha flash2b,

Als je versterker verder weer goed werkt zou ik die thermische zekering gewoon overbruggen. Er zijn tenslotte plenty trafo's die het zonder moeten doen. Soms gaan die thermische beveiligingen ook gewoon open omdat ze te vaak warm geweest zijn.

De voeding is echt helemaal los, daar zijn die soldeer bruggen voor gemaakt, heb het gechecked

M'n opmerking daarover was juist bedoeld om je daar nog eens extra over na te laten denken. Vaak blijkt achteraf dat je veel exta zoektijd nodig had omdat je aanvankelijk iets te snel hebt geconcludeerd/aangenomen....

Er nog eens over nadenkend denk ik dat ik dat ik eerst zou uitzoeken waar die -200mA blijft. De stroombegenzing van het IC staat op -60mA (768). Blijft eigenlijk via transistor 342 over.... Tenzij er nog een andere verbinding is, zoals een sluiting bij de uitgesoldeerde brugcel (eerder gerepareerd...) etc.
Spanningsval over printsporen meten?

groet, Gertjan.

Ha flash2b,

Dan zit dat dak wel goed vast hierbij de link van Telec electronics http://www.telec.nl/ of via Ebay http://www.ebay.de/itm/1-PC-SG4501N-Dual-Voltage-Regulator-CS-DIL-14-/…

Als je de j nodig heb €7.95 bij Budge Tronics http://www.budgetronics.eu/index.php?action=article&aid=20619&lang=EN

Zo'n thermische zekering is langzaam en is primair bedoeld voor de trafo en ik denk voor 220V bij Philips is 230V krap op een oude trafo maar goed je heb een stroom op de negatieve rail ik ga er van uit dat je de condensator ook heb gemeten dan blijft waarschijnlijk alleen het IC over maar je heb nu de stroom bron op 200mA ingesteld kan je voorzichtig iets hoger.

Groet Henk.

Everything should be as simple as possible, but not simpler.

Zeker ook C564 en C569 checken.

Het zou zomaar kunnen dat eerst de BY164 door een (bijna) sluiting defect is geraakt, en na verbanging door een zwaardere brugcel (Seikron) de themische zekering het begeven heeft. Daarna haakte de eigenaar af.

flash2b

Special Member

Vanavond kan ik er pas weer verder mee.

@electron920
Dank voor de links. Bij TELEC had ik al eerder obsolete uA709 besteld in in DIP14 behuizing. Er is dus hoop voor een vervangend exemplaar.

Maar jullie opmerkingen en nu dat ik zie dat in die van Blackdog een ook een BY164 zit denk ik dat de elcos het probleem kunnen zijn. Die zouden een optater hebben kunnen gekregen toe eerder de gelijkrichter kapot is gegaan.

Als ik T342 (die wel goed meet) eruit haal, dan zou de -15V op moeten kunnen komen.

Volgens mij waren T341 en T342 er al een keertje uit geweest, aan de flux te zien.

Edit @markce
Mijn redenering ook maar je was sneller met typen.

blackdog

Golden Member

Hi,

Wat de brugcel betreft, wat mij betreft kunnen beide typen er in.
Als je een BY164 nodig hebt zeg je het maar, voldoende hier op voorraad.

De thermische zekering van de trafo zou ik mij niet druk om maken, jammer genoeg heb ik die niet meer op voorraad.
Doorverbinden zou ik zeggen en een goede zekering toepassen!

Ik heb de regelaar even bekeken, de negatieve regelaar in de SG4501 is de hoofdregelaar zover ik het kan zien.
De positieve wordt hiervan afgeleid, dus als de negatieve regelaar niet goed opkomt kan de positieve regelaar nooit goed werken.
Maar je weet nooit in hoeverre de chip defect is met alle vreemde eigenschappen van dien.
Deze chip heeft ook een echte "0" aansluiting, hierdoor kan hij heel goed een voedingspanning kortsluiten.

Groet,
Blackdog

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
flash2b

Special Member

@blackdog
Kon je die thermische zekering verwijderen dan? Ik heb er geen ervaring mee, hij steekt uit de trafo en zit met rode draadje in serie met de primaire kant.

Ik had al een mooie BY164 gevonden. Een zwarte uit 1980. De PM5171 is uit 1984. De Semikron in uit 1988. Heb nog een hele zwik groene beschikbaar.

De "0" aansluiting zit op pin 1. Dit is anders als een LM317 of uA78xx. Hoe kom jij tot de conclusie dat de negatieve kant van de SG4501 de ref is voor positieve kant? Uit de datasheet kan ik dit niet opmaken.

Ha flash2b,

Hetgeen @blackdog aangeef is te doen gebruikelijk met een tracking ook zonder IC is vaak een voedingsspanning de referentie.
Hierbij de datasheet

SG4501-Silicon

Groet Henk.

Everything should be as simple as possible, but not simpler.
flash2b

Special Member

Kijk Henk, dat wist ik niet dat dat gebruikelijk was. Bedankt !

(die data sheet had ik in mijn startpost al gelinked)

Ha flash2b,

Het is nu ook weer geen wet van mede en perzen ;) maar het geeft wat voordelen.
De datasheet heb ik overeen gekeken :+ ik begrijp dat je vanavond verder kan.
Laat het IC even alleen op de spanning draaien dan weet je genoeg.

Groet Henk.

Everything should be as simple as possible, but not simpler.
flash2b

Special Member

Even een snelle update:

C566 was 0µF ipv 2200µF
C571 en C572 hadden een verhoogde ESR

C566 en C564 los gesoldeerd en C571 en C572 vervangen voor 100µF/35V Nippon Chemicon. Toen op de punten van C564/566 de labvoeding aangesloten.

Resultaat:
https://www.uploadarchief.net:443/files/download/20170313_184534_cleaned.jpg

De -15 rail was -15.2V:
https://www.uploadarchief.net:443/files/download/20170313_184512_cleaned.jpg

Overige waarden:
+25V was +24,8V
-25V was -24,8V
+15V was +15,2V
-15V was -15,2V

Dat is allemaal binnen specs, dus de voeding doet het weer !

Ik lees op CO dat veel mensen kunnen zien of een elco kapot is door er alleen naar te kijken. Nou de helderzienden mogen het zeggen welke elco van 2200µF kapot is en welke nog 100% OK ?
https://www.uploadarchief.net:443/files/download/20170313_184702_cleaned.jpg

Helaas heb ik geen 2200µF/40V op voorraad en zeker geen axiale (kleinere 100µF zijn vervangen door radiale exemplaren). Aangezien de spanning tegen de 38,5V is, wil ik graag minimaal 50V versies gebruiken en ik had alleen radiale 35V versies.

Voor alles weer terug te bouwen ga ik eerst nog controleren of de rest van de PM5171 nog in orde is.

Mooi resultaat voor een uurtje werk, net voor het eten.

miedema

Golden Member

Ha flash2b,

Goed om te horen!
Dus het probleem zat toch in passieve componenten i.p.v. een obsolete IC :-)

groet, Gertjan.

Flash2b,
Goed om te zien dat mijn inschatting wb. de elco's gisteren avond goed was. Ben benieuwd of de schakeling verder goed werkt.

flash2b

Special Member

Heb bij EOO gezien dat ze nog axiale elco's verkopen, anders even bij Farnell kijken en lief om een meelift vragen.....

Voordat ik de 4 soldeer bruggen weer terug plaats, zal ik de rest ook eerst grondig controleren. Ik blijf voorlopig mijn labvoeding gebruiken, een stuk veiliger en geeft ook meer inzicht in stroom/spanning.

Axiaal koop ik meestal bij Conrad (Vishay-BC), tenzij het iets speciaals moet zijn (low ESR, 105C).

[Bericht gewijzigd door markce op maandag 13 maart 2017 23:01:38 (45%)

flash2b

Special Member

@markce and @Dominic
Bedankt voor deze info. Van Conrad wist ik dat niet, en Okaphone heeft de 2200µF in de aanbieding zie ik.

Ik ben nog steeds verbaast over die thermische zekering in de trafo waar ik nog wat van wil weten. Is het enige nu van deze zekering dat de behuizing niet in de brand vliegt want nu, omdat hij niet verwijderen is, zou eigenlijk de hele trafo moeten worden vervangen (normaal gesproken). Dus wat heeft die zekering nou beveiligd, niet de trafo dus.

Ik heb op AliExpress losse thermische zekeringen gevonden van verschillende temperatuur waarden, een paar voorbeeldjes:
https://nl.aliexpress.com/item/10-Pcs-Per-Lot-TAMURA-TAM-H3X-Thermal-F…
https://nl.aliexpress.com/item/5Pcs-lot-70C-Degree-Celsius-NC-Normal-C…

Geen idee wat de originele temperatuur was, en omdat die ook nog ín de trafo zat zal een uitwendige zekering een andere waarde hebben.

Misschien moet ik de 12C van de trafo even in Maarten Bakker's topic posten en krijg ik daar extra info.

blackdog

Golden Member

Hi flash2b,

Heb je misschien een goed plaatje van de trafo waar je de beveiliging goed kan zien?

Is de beveiliging gemaakt van transparant plastic?
De gene die ik ken, kon je er uit trekken om te vervangen...

Groet,
Bram

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
flash2b

Special Member

Kan vanavond misschien een betere foto maken, maar dit is een cut-out van mijn telefoon foto:
https://www.uploadarchief.net:443/files/download/2017-03-14%2009.48.44.jpg

Het ding is gemonteerd op een zwart plaatje, wat in de trafo zit. Er lopen rode draadjes naar de PCB. Het Rode lusje is door mij aangebracht.

12NC = 4012 100 70211

De thermische zekering voorkomt dat de isolatie in de trafo doorbrand en daarmee de netscheiding doorslaat.
Vrij nuttig dus en in jouw geval is de trafo nu nog bruikbaar (behalve de thermische zekering).

[Bericht gewijzigd door markce op dinsdag 14 maart 2017 11:40:54 (31%)

flash2b

Special Member

Dat snap ik, maar de goedkope zekering zorgt er wel voor dat de dure trafo moet worden vervangen. Dat ik dat niet ga doen, is natuurlijk niet zoals dit bedacht is omdat dan er geen werkende zekering meer in zit.

Dus de zekering is meer als een (eenmalige) verzekering.