Kostal Piko inverter defect

hennep

Golden Member

Gisteren heb ik een bericht gepost in "Blunders in datasheets".
Om dat topic niet te vervuilen met details maak ik even een nieuwe aan, naar aanleiding van een vraag van heer Henri de 62e

Op 17 november 2020 22:49:42 schreef henri62:
Als ik het vragen mag: Welk merk was dat?

Het gaat om een Kostal Piko 10.1 DCS (3 fasen 10kW)

Na een aantal jaren gebruik gaat er in dat merk inverter een eeprom kapot. Waarschijnlijk wordt er te frequent geschreven naar de eeprom maar ook de 3.6V VCC die in de (preliminary) datasheet staat kan de oorzaak zijn. De microcontroller werkt op 5V. Er gaat zodra de eeprom stuk is een rood ledje knipperen binnen in het apparaat er vanaf dat moment wordt er geen vermogen meer geleverd. De eeprom vervangen door een nieuwe zonder inhoud lost het probleem niet op. Waarschijnlijk moet het ding initieel gevuld zijn, of er is een kloppende checksum vereist.

Als je even zoekt op internet dan zul je zien dat dit probleem op meerdere fora bekend is. Niet alleen voor de 10.1 maar voor:
Kostal Piko 10.1 DCS
Kostal Piko 8.3 DCS
Kostal Piko 5.5 DCS
Solar Fabrik Convert 10T

Heb je zo'n inverter in gebruik, dan raad ik aan om zo snel mogelijk een backup van de inhoud te maken. Ik wil daarvoor een arduino programma maken. Bij belangstelling, laat het even weten.
Als iemand zo'n backup heeft, dan wil ik daarvan graag een kopietje. Op het moment ligt er zo'n inverter ongebruikt op een nieuwe eeprom te wachten. Niet bij mij, ik plaats dit voor iemand anders.

EDIT:
https://www.mikrocontroller.net/topic/507125#6481229
https://www.photovoltaikforum.com/thread/121493-kostal-piko-8-3-mit-fe…

Typisch gevalletje software probleem dus. Ik heb het eens meer gezien (heel andere devices).

Heb je al contact opgenomen met de leverancier om het defect te claimen/voor te leggen?

Zit er missschien een factory reset in waarme je een nieuwe kunt initializeren?

[Bericht gewijzigd door henri62 op 19 november 2020 00:14:10 (18%)]

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.
hennep

Golden Member

Gisteravond ben ik in Emmerich an Rhein geweest bij de eigenaar van de inverter. De oude eeprom waarvan wij dachten dat het een -R type was, is dat blijkbaar niet. Hierbij een foto

Wat wij zonder vergroting voor een R aanzagen is blijkbaar een logo, Het lijkt wel een beetje op een Q maar is dat ook net niet.

Het IC is blijkbaar een type dat niet op 3.3V V werkt. Bij de vorige poging om het ding uit te lezen deden we dat met een Arduino Nano op 3.3V
Gisteren heb ik heb nog een keer geprobeerd met een Arduino Pro Micro op 5V. Toen kregen we wel data te zien.
We gaan wel de code in een andere chip zetten, in een -W type maar we hebben weinig hoop dat het de oorzaak van het probleem is.

Ik denk ook dat het een software probleem is. Als de inverter 's morgens start dan gaat hij een aantal tests uitvoeren. Soms komt het programma door die fase heen en start de inverter gewoon op maar zo nu en dan gaat er een rood ledje op de print knipperen en wordt er niet geleverd tot de volgende zonsopgang. Langzamerhand neemt het aantal keren dat de inverter niet start toe, tot het moment dat hij er helemaal mee op houdt. Het zou nog kunnen dat een van de tests niet succesvol is maar het feit dat heel veel inverters datzelfde probleem hebben duidt volgens mij op een verdienmodelletje van de fabrikant. De eigenaar heeft een aantal tests gecontroleerd en die pakten allemaal positief uit. Zoals bijvoorbeeld de isolatieweerstand meten. Dit gebeurt met het circuit rond L2, daarmee wordt een hoge spanning gemaakt voor die meting. Nu de "defecte" eeprom als oorzaak (mogelijk) af valt is het niet duidelijk waardoor dit probleem wordt veroorzaakt.

Er is contact geweest met de leverancier maar de reparatie is zodanig duur dat je beter een andere inverter kunt kopen.

Het schema komt van een Poolse site en is dmv. reverse engineering samengesteld.

Hieronder, voor de puzzelaars, nog twee foto's van de print.

maartenbakker

Special Member

Zo schrijft ST inderdaad een Q.

"The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Geeft de inverter een foutcode of melding waar je iets zinnigs mee kunt? (Was zeker electrotanya waar dat schema op stond)

Maar die print is alleen maar een deel van de inverter toch? Ik mis de IGBT's en meer van dat spul. Wel een erg kleine print voor 11kW.

Het kan natuurlijk ook een simpel elco'tje in de voeding zijn wat rot is en de inverter niet laat opstarten. (C5,C6,C7 oid)

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.
hennep

Golden Member

Nee geen foutcodes. Er zat een led, D9 op de print, in de oudere modellen. Bij de laatste modellen is die led weggelaten. In het schema, is het D81. Zitten direct naast de controller.
Het was idsl.pl het schema is daar niet meer te vinden. Is elektrotanya niet Russisch?
Het controleren of de elco's nog allemaal de juiste waarde hebben is inderdaad de moeite waard.
Het vermogensbord heb ik niet gezien maar als dat afwisselend een aantal dagen goed werkt en dan weer niet, dan zoek ik het probleem toch in het processordeel.

hennep

Golden Member

Het probleem is gevonden. Een van de IGBT's was kapot, continue geleidend. Dit werd tijdens de tests in de opstart opgemerkt en daardoor start de inverter niet.

Aan de verkleuring van de koelpasta te zien is het blok IGBT's ook flink warm geweest. De inverter test alleen bij inschakelen. De fout zal dus in bedrijf opgetreden zijn, niet tijdens in of uitschakelen.

Het is een inverter voor 3 strings. Ondertussen werkt hij weer op 2 strings door een paar onderbrekingen te maken.

Op 19 november 2020 12:38:38 schreef maartenbakker:
Zo schrijft ST inderdaad een Q.

Ben je serieus?
Ik vind namelijk geen datasheet van een -Q versie :-)

Die Q zal wel een productie code zijn.

Die IGBT is waarschijnlijk unobtainium of achterlijk duur zeker? (infineon?)

En ook al kun je er aan komen, dan is het nog een grote uitdaging om de oude van de print af te krijgen zonder de print te slopen.

Dat schema is zeker niet van de inverter ik zie nergen een aansluiting van de IGBT's staan oid. Of zit het IGBT board op X2/X3?

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.
hennep

Golden Member

IGBT's zijn van Danfoss (DP60Y1200T111631) en waarschijnlijk speciaal gemaakt voor de klant. Er is geen datasheet te vinden maar de inverter doet het prima op 2 strings en de eigenaar is daar tevreden mee.

Ik denk dat X3 voor het programmeren van de NEC controller is. Aan de soldeerzijde van de print staat daar FlashPro bij. Ik denk dat dit bord alleen tests uitvoert en de strings met 3 relais kan inschakelen. X5 is een seriele verbinding en ik verwacht dat er nog ergens een controller zit die het echte werk doet. Ik ben woensdag weer in Duitsland en dan zal ik eens kijken waarmee X5 is verbonden.

Het schema is verre van compleet en de site waar dit schema is gevonden is verdwenen.
Dit schema stond als http://v.idsl.pl/images/we.png op het internet.
Ik heb nog eens geprobeerd om via archive.org de bestanden terug te halen maar helaas is van de site alleen de tekst terug te halen. Alle afbeeldingen zijn weg.

In ieder geval mooi dat je het stuk schema in ieder geval geborgd hebt.
Maak eens een foto van de text opdruk op de zijkant van IGBT?
Ze kunnen ook van Vincotech zijn (volgens mij ook origineel Siemens geweest?), de kleur en het lettertype komt me wel bekend voor.

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.
hennep

Golden Member

Ik dacht dat ik een foto had geplaatst waarvan de tekst zichtbaar was, was blijkbaar een andere.

De package is zo te zien geen standaard pinout (Zoals die PIM varianten). Waarschijnlijk inderdaad door Danfoss custom made (of Vacon).

Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.
hennep

Golden Member

Ik denk niet dat ik nog foto's hoef te maken, foto's en schemas staan nog op het internet. De poolse site is verhuisd. Ik heb hem teruggevonden: http://stan.wex.pl/

Of liever leesbaar:
https://translate.google.com/translate?sl=pl&tl=nl&u=http://st…