elektuur nixie thermo hygro werkend ?

Ik heb de elektuur nixie thermo hygro meter uit 2012 gemaakt (110321).
De source code is hiervoor nog steeds beschikbaar.
De PIC 16F867 uit dit ontwerp heb ik met MPlab geprogrammeerd zonder foutmeldingen. De analoge electronica op de print heb ik volledig getest.
Toch werkt het geheel niet, ook na diverse pogingen de PIC opnieuw of anders te programmeren. Mogelijk is de source code toch niet correct, ik ziue wat rare dingen in de code. Google geeft geen oplossingen. Is er iemand die dit project succesvol werkend heeft en mij wil helpen ?

Heb hem er even bijgepakt. Het ziet er onschuldig uit, hoewel twee diodes om de SHT21 voeding te laten zaken wat spannend lijkt.

Maar de PIC moet een PIC876-04/SP zijn. Is -867 een tikfout?
Er is dus hoogspanning?

Klopt, is een typefout, moet PIC 16F876-04, ik heb het exacte type volgens het schema.Er is hoogspanning (decimale punt werkt). De SN74141's werken allemaal correct (handmatig getest). Dus als ik deze handmatig aanstuur lichten de correcte cijfers op. Wat ik bijvoorbeeld al in de code zie is dat deze verwijst naar de PIC 16F876A, terwijl het hele artikel gaat over de 16F876 (zonder A).

[Bericht gewijzigd door johnking op 22 januari 2023 15:11:44 (12%)

De 876 is anders als de 876a, zie verschillen: https://ww1.microchip.com/downloads/en/DeviceDoc/39591a.pdf
Al geprobeerd te compileren voor de 876a i.p.v. de 876?

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Ja, ook al voor de 876A gecompileerd. Maar dan load je 876A code up in een 876; dat kan ook nooit de bedoeling zijn.
Het is zo vreemd dat het hele artikel gaat over de PIC876, maar de de bijbehorende code lijkt voor een PIC876A met bovendien programma regels die verwijzen naar een RS232 verbinding die er niet is. Maar tegelijkertijd klopt de titel in de code wel.

Het is een raar artikel vol tegenstrijdige gegevens...

In het schema staat een pic16f876-04 met een 6MHz kristal eraan? (wat zeker niet klopt. "kan* werken maar helemaal niet zeker...)
In de rest van de tekst en onderdelenlijst staat een pic16f876-20, wat wel kan kloppen.

In de firmwarwe staat weer een pic16f876A?

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Ja, dat is dus ook wat ik achteraf zie.
Toch zijn er wel filmpjes van werkende units, maar dat is dan met de geprogrammeerde PIC die je destijds kon bestellen. Ik heb het idee dat de gepubliceerde code niet de juiste is, vandaar mijn vraag of iemand wel succesvol was.

Ik zou het eens met een goede combinatie proberen (876-04 met een 4MHz kristal, of een 6MHz kristal met een 876-20)

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Op 23 januari 2023 14:13:21 schreef johnking:
Ja, dat is dus ook wat ik achteraf zie.
Toch zijn er wel filmpjes van werkende units, maar dat is dan met de geprogrammeerde PIC die je destijds kon bestellen. Ik heb het idee dat de gepubliceerde code niet de juiste is, vandaar mijn vraag of iemand wel succesvol was.

Was de HEX file niet te downloaden? in de Engelse versie van Elektor staat er van wel maar ik kan aan geen van beide (code+hex) zien.

LDmicro user.
Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Die link doet het niet, had die al geprobeerd, ben dan ook geen member.

LDmicro user.
Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Op 23 januari 2023 14:17:36 schreef Arco:
Ik zou het eens met een goede combinatie proberen (876-04 met een 4MHz kristal, of een 6MHz kristal met een 876-20)

Of dan toch met een 16F876A omdat dat die als linkerfile ook in de C code staat. Maar wat voor 16F876 dan ?

Op 23 januari 2023 14:46:46 schreef Arco:
Vreemd, vanaf deze pagina is 'ie wel gewoon te downloaden...
https://www.elektormagazine.nl/magazine/elektor-201206/16563

Inderdaad, ik zie het nu ook. Dat is dezelfde code. In sommige bestanden wordt verwezen naar de 16F876, in andere naar de 16F876A.

Ik heb deze een poosje terug gemaakt, met de .hex file van de website. Thermometer werkt prima.

Wel is er een buisje al deels defect binnen een jaar. Ik heb daar verder nog niet naar gekeken.

-

Op 23 januari 2023 16:57:31 schreef Ganzz:
Ik heb deze een poosje terug gemaakt, met de .hex file van de website. Thermometer werkt prima.

Wel is er een buisje al deels defect binnen een jaar. Ik heb daar verder nog niet naar gekeken.

Aha, dat is goed nieuws. En heb je dan een 16F876-04 of 16F876-20 of 16F876A gebruikt ? Heb je die geprogrammeerd met MPlab versie 8.92 (want dat heb ik geprobeerd)? Of heb je de hex file in MPlab ge-importeerd ? Kun je me iets meer vertellen ?

Ik zou de bijgeleverde hexfile eerst proberen , die zal in ieder geval moeten werken...
Anders eerst een ledje laten knipperen met 1sec om te zien of de processor 'leeft' en op de juiste frequentie draait...

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Op 23 januari 2023 20:14:47 schreef Arco:
Ik zou de bijgeleverde hexfile eerst proberen , die zal in ieder geval moeten werken...
Anders eerst een ledje laten knipperen met 1sec om te zien of de processor 'leeft' en op de juiste frequentie draait...

vanavond meteen die hex file geimporteerd. Maar geen succes. De PIC is live met een blinking led programma. Alle configuration bits staan goed en voor de zekerheid heb ik deze gevarieerd. Ik meet geen klok signaal op de OSC2 uitgang. Maar dat zie ik ook niet bij een werkend blinking led code. Heb wel eens begrepen data dat ook niet altijd kan.

Zou Ganzz een PIC voor mij kunnen programmeren ?

Allicht een voor de oscillator ongeschikt kristal?
Dat is apart te testen door een led te laten knipperen met het kristal als klok.

De onderdelenlijst zegt enkel "6 MHz", maar kristallen zijn (eigenlijk) vrij complexe componenten. Het kan zeker mis gaan. Van PIC geen verstand, allicht zegt de datasheet meer.

Probeer het eens met een uitgeschakelde i2c bus (als bijv. de SHT21 los zit of een pull-up, dan hangt de boel ook meestal...)

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com
Sine

Moderator

[open deur modus]

Zit het probleem echt in de pic? Of scheelt er wat aan je schakeling?

Wat doet het ding als de sensor niet werkt bijvoorbeeld?

Een 4MHz pic met een 6MHz kristal wil je sowieso niet...

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com

Met onderstaande hex-file kun je eens uw controller testen.

Met dit programma zou uw V3-nixie per seconde moeten tellen van 0 tot 9 en herhalen.

De telling kun je ook met een led controleren op RA0 pin 2, 500mS aan en 500mS uit.

De RC1 (pin12) output staat op 0 zodat uw hoogspanning werkt

Je mag uw controller gewoon in de schakeling zetten, de sensor mag blijven zitten, alsook de rest van de nixies.

De hexfile is voor een 16F876a op 6MHz en het configword staat ook op 3F32 zoals in het originele programma.

Ik heb het niet op een prikbord getest maar wel gesimuleerd en ben 99.9% zeker dat het werkt.
Moest dat niet zo zijn dan wil ik het morgen wel nog eens uitproberen.

edit: typfoutje rechtgezet, bij de ledcontrole pin2

LDmicro user.

Er zit nu een 16f876-04 in, die moet dan wel vervangen worden...

Arco - "Simplicity is a prerequisite for reliability" - hard-, firm-, en software ontwikkeling: www.arcovox.com