Nog heel veel meer ontwerptips en domme fouten

Shiptronic

Golden Member

Klassiek geval van alle kranen staan dicht ?
Wie de vraag stelt, zal met het antwoord moeten leren leven.
Jochem

Golden Member

Helaas, die instinker was ook al uitgesloten :P
Heb geduld: alle dingen zijn moeilijk voordat ze gemakkelijk worden.
Tidak Ada

Golden Member

Loopt de pomp echt? Die wil nog wel eens vast komeen te zitten na het zomerseizoen. Mijn pomp heeft een schroefdop op de as en een gleuf in de as. Daar ka je dan de as weer mee gangbaar maken van de kalkaanslag(?). Vergeet die dop niet ns afloop, er kan water uit lekken.
Rommelige werkplek? In de natuur is wanorde de meest stabiele toestand; de entropie is dan maximaal. Het handhaven van "orde" kost daarom altijd energie. ----------------------> TUBECOLLECTORSASSOCIATION@yahoogroups.com
MAH

Golden Member

Vandaag een productiefout gevonden. Dit is de powerconnector van de verwarming van een waterbed. Dit deel ligt normaal dus onder/achter het bed, bij de meeste mensen in het stof. De klacht was dat hij het niet meer deed na het stofzuigen...

Bij het openen van de connector kwam het snoer er meteen al uit, het heeft nooit vast gezeten in de pinnen. Ik heb de pinnen even uit het plastic gehaald, en te zien is dat ze wel zijn geperst. De aders hebben er nooit in gezeten en alleen er tegenaan gelegen. Het blijft oppassen! Aangezien het bedrijf nog bestaat zal ik het bij hun ook melden.

Edit: ook de tweede maar even open gemaakt: blijkt hetzelfde in elkaar te zitten. Het moet dus wel haast een seriefout zijn.
PCB architect en stylist te huur.
Wow, linke soep!

Ik kreeg laatst een hogedrukreiniger onder handen, waar fabrieks-af al een kroonsteen in zat (dat weet je al hoe laat het is), waarvan een van de aders te ver in de kroonsteen was gedrukt, en het schroefje dus op de isolatie was gedraait.

Tot mijn verbazing waren er geen sporen van vlambogen te bekennen, net als bij de connector van MAH.
Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken
Jochem

Golden Member

Bij een hogedruk is het ook niet goed natuurlijk, maar daar ben je nog wakker bij (en buiten) als je hem gebruikt.
Die van het waterbed is ronduit griezelig. Een consumentenbond*/kassa/radar melding waard.

*ik haat die toko, maar vooruit...
Heb geduld: alle dingen zijn moeilijk voordat ze gemakkelijk worden.
Op 2 oktober 2015 14:20:33 schreef MAH:
Aangezien het bedrijf nog bestaat zal ik het bij hun ook melden.

Geachte heer of mevrouw MAH,

Dank voor uw bericht. We willen u erop wijzen dat het zelf prutsen aan elektrische apparatuur erg gevaarlijk kan zijn en dat reparaties alleen door gekwalificeerd personeel mogen worden uitgevoerd. U kunt een elektrische schok krijgen en door kortsluiting kan brand ontstaan.

Wij hopen dat u begrijp dat door uw onkundige modificaties de garantie komt te vervallen.

Groetjes,
"De klantenservice"
>:)

(Just kidding. Maar ik ben wel benieuwd hoe het bedrijf reageert, ik kan me zo voorstellen dat de gemiddelde klantenservicemedewerker het niet gaat snappen. Zo bont als hierboven* zullen ze het hopelijk niet maken, eerder richting een "ik heb uw vraag doorgezet naar onze technische afdeling, inhoudelijke reactie volgt".)

*)Moeten ze moeite voor doen willen ze zo'n bizar slechte reactie geven. Ik heb het ook extra dik aangezet, inclusief de clichématige misvatting over kortsluiting. En meen er uiteraard geen barst van, het is juist heel netjes dat je dit meld en ik hoop dat ze er wat zinnigs mee doen.
Blog // Backwards Lightspeed Bus: i*i=-1, so iic=-c.
Nu weer eens een blunder van iemand anders wat ik tegen kwam. Gisteren even bezig geweest met een flow meter waar zo'n vlotter in zit. Daar achter zit een meetsensor op gemonteerd (met M12 plug) die op de magneet werkt van de vlotter. Output 4-20mA.

Er kwam dus netjes 4mA uit (nul flow dus) in rust. Maar dat was het ook, nada uitslag als ik handmatig de vlotter omhoog schoof. Hum dat is gek?
Andere sersor erop, nieuw uit het plastic. Precies hetzelfde.
Typenummer van de meetkelk erbij, ja klopt is een magneet vlotter.

Toch even een schroevendraaier er langs houden -> niet dus. Is gewoon van ijzer. De leverancier een heeft dus een ernstig maandag morgen momentje gehad. Dit moet ik dus nog reclameren volgende week.
Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.
FYI, Een motor zitten PWM-en. Zonder diode. De 25V mosfet gaat bij 27V zeneren (Of mag ik dat van FE zo niet noemen?). Iedere PWM-periode duurt dit zo'n 120 microseconde. We hebben de inductie van de motor dan uitgerekend op zo'n 15 mH. (maar we hebben de stroom niet zo nauwkeurig gemeten, dus we kunnen er zomaar een factor twee naast zitten). Maar goed. De fet vind dit dus niet zo'n probleem en blijft het gewoon doen. Wel was de PWM frequentie dus maar 100 Hz.

Later een diode toegevoegd. Die blijkt (ook de UF4004!) zo langzaam dat er zo'n 250ns aan "zener-periode" overblijft. Een 1N1408 vertoonde hetzelfde effect. De energie die in de mosfet gedumpt wordt is 500x minder, maar het is er nog steeds. Dit alles kan aan de "snelle opstelling" met krokodille-kabeltjes en andere lange draden te maken hebben.
Lessen: Dat zeneren is niet direct fataal, mijn motor heeft ongeveer 15mH aan inductie en een diode lost het niet 100% op.
four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
Lambiek

Special Member

Heb je al eens een RDC filter geprobeerd over de motor te zetten, en een zener over de drain source overgang. Het zelfde dus zoals we het in het artikel "Werken met mosfet's" beschreven hebben.
Als je haar maar goed zit, GROETEN LAMBIEK.
Dat heet natuurlijk Avalanche Breakdown, en dat mag, mits de energie per puls beperkt is (zie datasheet), en de junctie temperatuur binnen de toelaatbare grenzen blijft.

Dat dit met een dergelijke opstelling optreedt, is natuurlijk niet verwonderlijk; de beide MOSFETs van een halve brug, of in dit geval, de MOSFET en vrijloopdiode, moeten met een minimale parasitaire inductie aan elkaar zitten (dus de inductie die niet gedeeld wordt door beide paden), en er moet een fatsoenlijk buffer met lage inductie over de voeding zitten (MKP of zo, geen elco), met minimale inductie naar de halfgeleiders. Het is niet voor niets dat je op een IGBT module gewoonlijk een grote MKP condensator direct op de voedingsaansluitingen zet.

De inductie in de motorkabels zelf is natuurlijk niet relevant; die valt weg tegenover de inductie van de motor zelf, maar het verschil is dat beide stroompaden (MOSFET en diode) in dezelfde richting door dezelfde kabel lopen, waardoor de inductie bij het schakelen niet meer uitmaakt.
Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken
Het was een kort experiment. Ik verwachtte niet dat het kapot zou gaan en dat bleek terecht. Nu we de PWM frequentie een factor 1000 op hebben geschroefd, durf ik het niet meer aan zonder diode. Maar we zijn nu met andere dingen bezig, dus niet meer die motor.

Als de "condensator op de voeding" het probleem zou zijn, dan hadden we 27V-0.6V - 12V pieken op de voeding moeten zien. Ik denk niet dat die er zaten. Hmm. Een hint dat dit het geval was, is natuurlijk dat er erg weinig verschil te zien was tussen de verschillende diodes.... Ik zal het de volgende keer eens dubbelchecken.

Die zener zit al in de mosfet ingebouwd. IRF heeft ooit aangegeven voortaan te proberen de "max energie per breakdown event" in de datasheets te zetten, maar ik kan hem voor de IRFML8244 niet vinden. Ik kom op 75µJ uit voor ons experiment. Voor "dikke" torren zie ik specs als 75mJ tot 800 mJ (irfs7434).
four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
In het kader van "Wat had je dan verwacht".....

Vandaag een product met LCD display op -40C getest. Koude start enzo. (Product is eigenlijk ontworpen voor >0C, maar later is een toepassing voor de PCB bedacht zonder LCD, op een lagere temp)

Bij -40C komt er geen beeld op de LCD (duh...). Na langzaam opwarmen echter wel. Zonder overnieuw naar het display te schrijven. De controller doet het blijkbaar prima bij -40, alleen de liquid crystals waren niet meer zo liquide...
Volgende keer even in de glycol laten weken ;-)
Kun je er niet gewoon een weerstandje achter zetten om het ding warm te stoken, of moet het ook zuinig en zo?
Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken
Shiptronic

Golden Member

Wie de vraag stelt, zal met het antwoord moeten leren leven.
Normaal gebruikt men een temperatuur compensatie voor de constrast spanning als deze een ruim temperatuur bereik moet kunnen halen. Het zou zomaar kunnen dat met een andere 'Vee' het display wel beeld geeft. (Zie sommige application notes)
Wordt wel heel traag.
Henri's Law 1: De wet van behoud van ellende. Law 2: Ellende komt nooit alleen.
Bedankt voor alle welgemeende tips....maar: De LCD hoeft alleen maar in het 0C product. De -40C versie zal zonder LCD zijn.

Probleem opgelost :)
http://prive.bitwizard.nl/dsc06135_crop.jpg
De andere twee microUSB connectors uit hetzelfde stripje hebben wel vijf pootjes....
four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
High met Henk

Golden Member

Okee, dit is dan meteen de meest wacko situatie die ik hier gezien heb...

Tenminste dat je er 2 verschillemde in 1 stripje hebt
to all newbies: RTFM/D of google eens (p.s. RTFM/D = Read the f*cking manual/datasheet).
Wow, er zijn vast wat woorden gevallen die niet geschikt zijn voor publicatie toen je daar achter kwam.

Vandaag even flink boos geworden op een collega, die "het is toch maar voor even" een 400V verlengkabel met aan beide kanten een male stekker had gemaakt (verkeerde chassisdeel besteld), en vervolgens ook nog dat ding in de werkplaats op de grond laat liggen, terwijl de andere kant nog in het stopcontact zit. Hij zag er zelf echt geen gevaar in.
Een manager is iemand die denkt dat negen vrouwen in één maand een kind kunnen maken
Dok

Honourable Member

Als het maar vaak genoeg gebeurt, dan zal het personeels'verloop' wel veel worden ;-)
Wie niet horen wil moet TV kijken.
four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
Het zit je de laatste tijd niet mee he rew?
Toch niet een hele reel?
Komt er desondanks licht uit? De lens zit te ver opzij maar als de rest wel op z'n plek zit (led chip en bondwires) zou 'ie 't misschien gewoon kunnen doen.

Nieuwe leverancier ofzo?

(EDIT: Eigenlijk, voor de hobby, zijn zulke dingen wel grappig. Niet als er net een project door stilstaat, en commercieel is het natuurlijk nog vervelender. Maar om 's te zien is het leuk, en als die LED zou werken zou ik 'm hobbymatig gewoon op een printje zetten. Postzegelverzamelers hechten ook altijd de meeste waarde aan de misdrukken, muntenverzamelaars aan dubbel geslagen munten, etc.)

[Bericht gewijzigd door Lucky Luke op 16 november 2015 11:39:42 (52%)]

Blog // Backwards Lightspeed Bus: i*i=-1, so iic=-c.