Circuits Online Voeding 2016 Deel 2

Dit topic is gesloten

Kruimel

Golden Member

MAH stuurt die printjes supersnel op, ik had ook gereageerd op die advertentie (omdat ik de originele inkoopactie had gemist) en ik had de print binnen 2 dagen!

Groet,
Kruimel

Goeie avond,

Mijn voeding heeft iets vreemds. Als deze op CC staat, bijv 1A en ik geef een paar tikken op de het kastje wil hij zomaar verspringen naar 0.5A. Ook loopt de stroom continu heen en weer. Waar kan dit inzitten?

PE2BAS
bprosman

Golden Member

De jongere generatie loopt veel te vaak zijn PIC achterna.

Nou ik heb de pot zojuist vervangen, en daarna was het probleem nog steeds niet verholpen. Ik zat te denken dat die 2x de stroom geen toeval kan zijn dus ik met een multimeter op de 2 emmitoren van de transistoren gemeten, en nu is het probleem ineens verdwenen. Ook nu ik de meter los koppel werkt hij goed.

Ik kom er ook achter dat mijn spanning/stroom metertje helemaal niet kan werken zoals ik het in gedachte had. (Wel vaag dat het dan toch heeft gewerkt.)

[Bericht gewijzigd door hardbass op dinsdag 31 mei 2016 20:26:13 (20%)

PE2BAS

Dat wordt R7, R8, R9 en R10 em emittors oversolderen. Ik weet niet welke combinatie rot is. R7/R9 of R8/R10

https://dl.dropboxusercontent.com/u/2442535/2016-05-31%2021.00.33.jpg

Er zit bij de rechtse tor een draadje, dit zou het wellicht kunnen zijn.

PE2BAS

Ik gok op slechte soldeerverbinding bij R10. Dat dunne draadje loopt nergens naar toe en de soldeerverbinding ziet er goed uit. De soldeerverbindingen van R8 en R10 kan ik niet zien. Als één weerstand uitvalt (wordt oneindig ohm) dan grijpt de stroombegrenzing in op halve stroomsterkte.

[Bericht gewijzigd door ohm pi op dinsdag 31 mei 2016 22:45:30 (22%)

Goed gezien maar,

Alle componenten zijn vanaf onder gesoldeerd vandaar dat de bovenkant er bij die weerstand wat rommelig uitziet. Desalniettemin heb ik hem toch nog eventjes aangestipt met de bout. Omdat het probleem eerder al magisch wat verdwenen weet ik nu niet of dat de oorzaak was. Ik zal hem eens een poosje aanzetten met een dummyload. Misschien dat het probleem terug keert, maar misschien is het nu toch verholpen.

Ik heb ook het meet paneeltje even los gehaald. Ik heb nog even verder gekeken, maar hij zou toch wel moeten functioneren zoals ik hem heb aangesloten, maar het was niet ideaal.

PE2BAS

Nogmaals stroommeting
Ik heb de voeding voor 5 Ampère en 35 Volt gebouwd.
De stroommeting met een shunt in de afgaande + leiding heb ik al lang opgegeven, weerstanden van 0,09 Ohm en 0,01 Ohm maken en dan omschakelen om de bereiken van 1,999 en 19,99 Ampère uit te lezen op mijn DVM (200mV) is niet te doen.

Dan de meetversterker maar, waar ik niets van ken. Een deurbel aansluiten zonder schema lukt nog vrij aardig, maar Opamps ?

Omdat ik er niets van ken heb ik voor de meetversterker blindweg de schakeling van flash2b nagebouwd, zonder kennis of berekening. Eén en ander werkt wel zonder rooksignalen.

Wat ik zou willen is het uitgangsignaal van de meetversterker door twee spanningsdelers omvormen zodat mijn 200mV meter, de bereiken van 1,999 en 19,99 Ampère kan uitlezen. De berekening van de spanningsdelers gaat nog wel lukken.

Hoe pas ik het schema van "flash2b" aan ? Wie helpt me eruit ?
De waardes die ik nu bereik:
bij een uitgangsstroom van: meet ik aan de uitgang van de meetversterker:

0,5 mA - 0,03 V
2 mA - 0,039 V
10 mA - 0,086 V
20 mA - 0,141 V
400 mA - 1,35 V
1 A - 2,99 V
1,5 A - 4,00 V
2 A - 4,00 V

En ik wil meten tot 5 Ampère !

Alle hulp wordt zeer erg gewaardeerd

DW
flash2b

Special Member

Op 17 mei 2016 22:29:57 schreef flash2b:

Bij mij zijn de waarden:

CO Labvoeding 2016:
R7=120Ω (standaard), R8=120Ω (standaard), R9=0,33Ω (standaard), R10=0,33Ω (standaard)

Blackdog stroom adapter:
R3=1K8, R4=1K98 1% (2K parallel aan 200K), R5=10K2 1%, A=OP07 (ipv OP177)

De formule voor spanning versterking van de niet inverterende versterker is: A= 1 + R5/R4. De gewenste spanning versterking 165mV @ 1A wat neer komt op A = 6,06. Met de door mij gekozen waarden van R4 en R5 en een instelpotmeter van 100Ω komt dat neer op een variabele versterking tussen 5,90 en 6,15, prima dus.

Quote uit bericht: http://www.circuitsonline.net/forum/view/message/1825045#1825045

Heb je de bovenstaande waarden gebruikt? (ze zijn anders dan in het door Blackdog gemaakte schema !)

Met R9 en R10 in het originele CO Voeding 2016 schema heb je 165mV @ 1A. Om 1A weer te geven moest ik dus 6,06x versterken.

Aangezien Blackdog in de CO Voeding 2016 ipv 0,33Ω voor R9 en R10, 0,1Ω gebruikt heeft hij maar 50mV @ 1A. Hierdoor heeft hij gekozen voor een versterking van 20x

Wat zijn jouw waarden van R9 en R10 ?

Als er bij 2A, 4V uit komt dan heb je iig niet de waarden die ik heb opgegeven gebruikt.

Kort gezegt komt het erop neer dat de spanningval over R9 (of R10) bij 1A moet uitrekenen. Deze waarde moet je dan een X keer versterken om een waarde van 1V op de meter te zetten. Met de formule die hierboven in mijn quote staat kun je dan R4 en R5 aanpassen. Met de waarden zoals ze op het Blackdog schema staan is voor 20x en de waarden in mijn quote zijn voor 6,06x.

Alleszins al bedankt voor de snelle reactie

Ik heb voor R9 en R10: 0,12 Ohm
Op klem 2 van de Opamp heb ik 1.100 Ohm + potmeter 200 Ohm (bij mijn meting ingesteld op 0 Ohm)

Tussen 2 en uitgang 6 zit 22.050 Ohm

Ik gebruik geen 0p177 maar voorlopig een LM 741CN

DW
flash2b

Special Member

Bij 0,12Ω voor R9 en R10 heb je 60mV spanning val. Je hebt een versterking van 16,67x nodig !!!!

A= 1 + R5/R4

Als je R4=1.100 Ohm + potmeter 200 Ohm behoudt, moet je R5 verlagen naar 18804Ω = 18K8

Een uA741 heeft een offset, dus je kunt beter een OP177 (€1,50) of zoals ik een OP07 (€0,40) gebruiken.

@ flash2b

Bij 0,12Ω voor R9 en R10 heb je 60mV spanning val. Je hebt een versterking van 16,67x nodig !!!!

Ik ben een tijdje uit circulatie geweest.
Maar hoe kom je aan de berekening van 60mV ?
Ik wil toch tot 5 ampère meten en de gegenereerde spanning middels een spanningsdeler toevoegen aan een DVM van 200 mV
Bij 0.12 Ohm en 5 Ampère is de spanningsval toch 600 mV ?

Ik mis hier ergens iets, maar weet niet wat.

DW
flash2b

Special Member

Voor het bepalen van de versterking moet 1A worden weergegeven als 1V op de meter. Aangezien R9 en R10 parallel staan wordt dat dus 60mV. Met een versterking van 16.67 wordt 1A dus 1V en 5A dus 5V.

Als jou meter maar 200mV kan weergeven, wat niet echt een gemakkelijke waarde is, zou je dus 1A is 10mV en 5A is 50mV kunnen gebruiken. Je hebt dan helaas niet veel digits doordat de meter maar tot 200 kan tellen. Jou meter is meer geschikt voor 1A is 100mV en 2A is 200mV dan heb je nog wat resolutie.

Ik zou dus op zoek gaan naar een meter die 500 count of meer is. Op ebay zijn die wel te vinden voor rond 6 EUR.

In jou voorbeeld zag ik 2A is 4V staan maar later zeg je dat je meter maar 200mV is. Ook dan ben je weer een digit kwijt.

Tidak Ada

Golden Member

Ik denk dat D.W. een 4 digit meter moet aanschaffen. De meeste goedkope metertjes gaan idd tot 1999 (drie digits plus overflow).

Een andere mogelijkheid is automatische breikomschakeling, maar dat wordt een project apart.

Ik zit zelf ook met een degelijk probleem: die mooie meters, die Bram gebruikt gaan maar toto 30V, maar mijn trafo laat een uitgangssppanning van 37V toe....

Rommelige werkplek? In de natuur is wanorde de meest stabiele toestand; de entropie is dan maximaal. Het handhaven van "orde" kost daarom altijd energie. ----> TUBE COLLECTORS ASSOCIATION - †
blackdog

Honourable Member

Hi Tidak Ada,

Nou moet je niet gaan liegen... ;-)
Het metertje haalt net geen 36V DC, zie plaatje hieronder.
http://www.bramcam.nl/Diversen/Ebay-5Digit.png

Gegroet,
Bram

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
Tidak Ada

Golden Member

Er stond mij bij, dat hij volgens de specs niet verder dan 30 V ging.
Ik zal het niet meer uit mijn hoofd doen ;)

Rommelige werkplek? In de natuur is wanorde de meest stabiele toestand; de entropie is dan maximaal. Het handhaven van "orde" kost daarom altijd energie. ----> TUBE COLLECTORS ASSOCIATION - †

@ Flash2b

Ik lees te veel tekst en kijk niet genoeg naar het schema.
R9 en R10 staan parallel, vandaar en dat er bij de berekening van de versterking wordt uitgegaan van 1 A, was ook al niet in me opgekomen.
Bedankt

DW

@ FLASH2B en mogelijks anderen

Ampèremeting

Ik hoop dat je de moed niet verliest, want ik kom er nog steeds niet uit.
Ik heb voor de voeding tot 5 A, voor R9 en R10 telkens 0,12 Ohm.
Verder heb ik Uw meetversterker gebouwd met de OP07, en de waardes aangepast zoals U voor mij hebt berekend in functie van een 200mV DVM.
R4 = 1kOhm
R5 = (12k +6,8k=)18,8kOhm.

Het werkt niet.
Mijn DVM geeft bij 199 mV een display van 1999

1. de uitgelezen waardes in volt bij een bepaalde belasting zijn niet lineair. Slechts vanaf ong 50 mA tot 500 mA schijnt het lineair met ongeveer 0.123 V per ampère.

Bij diverse metingen tussen 1 mA en 50 mA heb ik 0.010 V tot 0.081 V per ampère
Boven 500 mA heb ik 0,160 tot 0,220 V per ampère.

2. Verder wil ik de stroom meten tot 5 Ampère. Het blijkt echter dat de uitgangsspanning vanaf ongeveer 1 A, niet meer stijgt en blijft hangen op 4.38 V.

Het is duidelijk dat ik wat mis doe, maar wat ?

DW
flash2b

Special Member

Vreemd.... bij mij was de lineariteit prima. Maar ik verlies de moed niet hoor, ik blijf je helpen !

Wat heb je voor R3 in dat schema gebruikt ? (die moet nl. '<=' R4 zijn).

Bij 1A zou er 60mV over de shunt moeten staan wat x 16,67 resulteert in 1V op de uitgang.

Bij 100mA is dit 6mV, dus 0,1V op de uitgang. Bij jouw is dit 0,081V wat dus afwijkt, maar dat zou je met je potmeter (die in serie met R4 staat) op 0,1V moeten kunnen draaien.

A = 1 + R5/R4 = 1 + 18K8/(1K + Rpotmeter) = 18,09x dus de waarde van R5 die ik gegeven heb is fout (sorry !!). R5 moet 17K2 zijn.

Dat het max blijft hangen op 4,38V komt volgens mij omdat de voeding spanning voor de OP07 op 5V is en dus dicht bij de maximale waarde.

Maar als er bij 1A 4.38V wordt gemeten is de versterking 73x !! Er is dus wat mis....

Ligt J2+ (ja de positieve pool) van de CO Voeding wel aan de GND van de meet versterker ??

blackdog

Honourable Member

Hi,

Ik begrijp het niet helemaal...
Er zijn als ik het goed begrepen heb twee emittor weerstanden van 0,12 Ohm.
Bij 5 Ampere doet iedere transistor ongeveer 2,5 Ampere en dat geeft dus 300mV die bij 5Ampere beschikbaar is aan spanningsval die je hebt om je paneel meter aan te sturen.
Je hebt dus een verzwakker nodig om deze stroom zichtbaar te maken op deze paneel meter!
Er wordt aangegeven dat de paneelmeter volle schaal 200mV is en als deze spanning (min 1 digit) wordt aangegeven verschijnt er 1999 op het display.

Er moet dus geschaald worden en dat houd in voor het 5 Ampere meetbereik, dat deze 300mV moet worden verzwakt naar een waarde die het metertje aan kan en overeenkomt met de geleverde stroom.
Dus 300mV over de emittor weerstanden moeten naar 50mV worden geschaald om dan 5.00 Ampere aan te gaan geven.
Hier is dus geen versterker voor nodig en de resolutie is dan 10mA/digit.
Tot 1,999 Ampere kan je met een andere spanningsdeler en een versterker trapje uitvoeren.

De spanning die van de emittors afkomt is 60mV per Ampere, bij 2 Ampere kom je dan aan 120mV en dan kom je 80 mV te kort voor en goede weergave.
De 120mV moet dus worden versterkt naar 200mV an dat is 200/120 = 1,66666 maal.

Wat betreft de opamp schakeling, deze moet uit de -5V en de +5V gevoed worden.
Het een en ander is ook nog afhankelijk van de ingangs impedantie van de paneel meter.
De meeste paneel meters met 200mV ingangsgevoeligheid zijn erg hoog Ohmig.
Maar is deze 1 of 10 Meg Ohm, dan moet hiermee rekening worden gehouden met het berekenen van de spannings deler.

De opamp schakeling MOET netjes worden opgebouwd en goed ontkoppeld.
Als de + ingang van de opamp op het opampprintje aan de massa daar wordt gelegt (als test) en de paneel meter is aangesloten,
dan mag de paneelmeter maar een paar digits aan waarde aangeven.
Wat dan wordt aangegeven is de versterkte offsetwaarde van de gebruikte opamp.
Deze kan worden weggeregeld als er een offset trimmer potmeter geplaatst word zodat in de teststand
de uitlezing op "0" kan worden geregeld.

Ik heb op het ogenblik geen tijd om het uit te tekenen en hoop dat dit praatje voldoende is voor wat meer inzicht :-)

Als ik het niet goed begrepen heb hoe de voeding is opgebouwd, dan hoor ik het graag.

Gegroet,
Blackdog

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.

@ flash2b en Blackdog

Mijn ampèremeting is nog steeds niet in orde.
Ik heb de schakeling opnieuw opgebouwd zoals al aangegeven werd met:
R3:820 Ohm
R4: 1 K
R5: 17,1 k

Mijn voeding kan 5 A leveren. De bedoeling is dat ik met een DVM van 200mV, mijn Ampèrewaarde kan aflezen in 2 bereiken 1.999 Ampère en 19.99 Ampère. (De eerste digit is geen overflow indicatie, maar een meetwaarde)
Ik zou een spanningdeler gebruiken voor het instellen van deze 2 bereiken.

Dit kan echter maar op voorwaarde dat ik een voloende uitgangssignaal uit de meetversterker krijg. Alle onderstaande waardes worden tot nu toe gemeten met een Fluke en een Dynatec, aan de spanningsdeler ben ik nog niet aan toe.

Wat blijkt nu:
1. De uitgelezen waardes (uitgangsspanning in volt bij een belasting in milli ampère) zijn lineair met 0.0014 V per mA en blijven gelijk tot ong 3A.

2. Bij een minimale belasting krijg ik echter onvoldoende nauwkeurigheid:
1 mA geeft 0.157 V aan de uitgang van de meetversterker.
2 mA geeft 0.158 V
3 mA geeft 0.160 V
5 mA geeft 0.162 V (meetfout ?)
10 mA geeft 0.170 V
20 mA geeft 0.184 V
enz...
Slechts vanaf 5 mA verkrijg ik de 0.0014 V per mA.

3. Deze 0.0014 V per mA blijven constant tot 3 Ampère, bij:
3 A = 4.34 V.
3.5A = 4.41 V.
Hier zit ik dus tegen de 5 V voedingsspanning aan. maar ik wil tot 5 A kunnen meten.
Langs de éne kant is mijn beginschaal niet gevoelig genoeg, langs de andere kant is mijn meetbereik te klein.

Hoe los ik dit op ? Voor zover het nog nuttig is te vermelden : "ik ken NIETS van Opamps"

DW

Op 28 juni 2016 00:11:04 schreef Tidak Ada:
Er stond mij bij, dat hij volgens de specs niet verder dan 30 V ging.
Ik zal het niet meer uit mijn hoofd doen ;)

Er staat mij bij dat je gelijk hebt. Dit soort metertjes heeft vaak: Tot 30V mag ie uit de meetspanning gevoed worden. Daarboven: Apart voeden met 4-30V. Als ie geen mogelijheid tot apart voeden heeft, dan verwacht ik een officiele bovengrens van 30V. Maar inherent an ie hoger, maar zal de spanningsregelaar die er in zit aan de warme kant worden.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/

Ha D.W. ,

Ik heb je post doorgelezen maar kom niet helemaal uit de tekst :+

Onder punt 1 vermeld je dat je relatie van 1.4mV/mA tot 3A in orde is maar onder punt 2 is de gevoeligheid laag niet voldoende ??? en voor hoog loop je tegen de voeding van je opamp dat kan ik volgen.

Nu heb ik het gehele topic niet in detail gevolgd maar voed je de opamp met 10V dus + en - 5V ? dit is wat blackdog voorstelde.

1- Hoe controleer je de belasting dus je meet over de shunt maar hoe weet je wat de belasting aan de uitgang is.

2- Wat is de resolutie en nauwkeurigheid van de meter welke je gebruik Fluke of Dynatec.

3- Welke belasting gebruik je is de Ohms ik vindt het in stapjes van 1mA te regelen knap :D daar zou ik knap moeite mee hebben.

Ik weet niet welk metertje je gebruikt maar ga er maar van uit dat je niet nauwkeuriger kan meten als 10mA dus uitlezen tot op 1mA is je zelf voor de gek houden als je op 1mA wil uitlezen moet je een 5.5digit meter gebruiken.
Voor de bovenkant heeft blackdog al een voorstel gedaan je schaalt in twee bereiken dan moet het lukken.

Maar belangrijk is het controleren van de stroom naar de belasting tov de spanning over de shunt dit hoeft niet lineair te zijn.

Groet Henk.

Everything should be as simple as possible, but not simpler.

@ electron920

Bij nader inzien het is niet de "gevoeligheid" maar eerder onnauwkeurigheid Ik moet de metingen in het lage bereik nauwkeuriger doen.

De +5 en -5 V haal ik uit de voedingsprint.

1. Ik meet met een Dynatec in serie met een ong. 7 Ohmse weerstand de stroom en met een Fluke de gegenereerde spanning van de meetversterker.

2. De resolutie en nauwkeurigheid van de meters zal wel in orde zijn, alleen moet ik in het lage bereik toch beter gaan meten.

3. Het is inderdaad een gepriegel om de uitgangsstroom van de voeding per mA juist te krijgen, kleine afrondingsfouten moet je me maar vergeven.

4. De meter die ik uiteindelijk, mits toepassing van een spanningsdeler ga gebruiken is een 200 millivolt meter, en geeft bij een input van 0,1950 V dan 1950 op het display. Hij meet dus tot op 1/10 mV. Het kommapunt is instelbaar.

Ik voeg 1 (slechte) foto's toe van de meters die ik nu in mijn oude voeding heb. En die ik ook hier ga gebruiken. Hieruit blijkt dat ik in de stand Ampère meet tot het mA niveau. (Foto 2: dscf2000.jpg krijg ik niet op het scherm)

Het probleem blijft echter dat ik vastloop bij ong 3 A, ik zit tegen de voedingsspanning van 5 V aan. Ik besluit hieruit dat de versterkingsfactor van de Opamp veel te groot is. Het heeft te maken met de waarde van R4 (1k ohm) op ingang 2 en R5 (517,1 kOhm) tussen ingang 3 en uitgang 6.

Ivm Opamps ben ik overvraagd, alle mogelijke hulp is welkom.

http://www.uploadarchief.net/files/download/dscf1372.jpg
http://www.uploadarchief.net/files/download/dscf2000.jpg

[Bericht gewijzigd door Sine op dinsdag 12 juli 2016 18:06:46 (0%)

DW

Dit topic is gesloten