Circuits Online Voeding 2016 Deel 2

Dit topic is gesloten

@ Paul Welther en Electron920

1. met de spanningsregel poti op 0, en de stroombegrenzings poti ook op 0, heb ik op de uitgangsklemmen 7,5 mV.
met de spanningsregel poti op 0 en de stroombegrenzings poti op max, heb ik 7,9mV.

2. Oscilleren ?
Foto 1377 (tijdsinstlling fototoestel is slecht, 1 sinus is nog te zien)
Belasting: 1mA
Frquentie: 50 Hz
V Piek/Piek: 1mV
http://www.uploadarchief.net/files/download/dscf1377.jpg

Foto 1391
Belasting: 100 mA
Frequentie: 666 kHz
V piek/piek: 6mV
http://www.uploadarchief.net/files/download/dscf1391.jpg

DW
RAAF12

Golden Member

Heb je wel de uitgangselco op de losse PCB aangesloten? Zijn de draden naar de endtorren erg lang? Ik zou wel een scherpe foto van de opbouw willen zien.

Grensovergang Spanje-Algarve (9-6-2024) https://www.youtube.com/watch?v=sserlsJy0wI&t=210s

@ D.W.

Dat is duidelijk wanneer je geen spanning heb en de stroom kring is gesloten meet je 50Hz ik denk dat het een brom is die je oppikt dit kan je controleren door het draadje direct aan de tip te verbinden en op de zelfde plaats te houden waar je aansluit klemmen zitten.
Maar je 2e meting laat duidelijk zien dat je een oscillator heb gebouwd :o ik zal het schema uitprinten dan kan ik gemakkelijk mee kijken.
Kijk eens op het draadje van @blackdog hier schrijft hij een en ander over de valkuilen van het nabouwen van een voeding bedrading sensleiding enz.
Er zullen vast veel meer draadjes uit het verleden zijn zoek eens op de site.
Als ik het schema gelezen heb kom ik er op terug.

PS, Dank RAAF12 ;)

Groet Henk.

Everything should be as simple as possible, but not simpler.

@ RAAF12

Hierbij mijn foto's.

Dat mijn voeding een oscillator blijkt te zijn is raar.
Maar verliezen we niet uit het oog dat er vooral een probleem is, dat ik voor mijn ampèremeting op de externe shunt van 0,1 Ohm NEGATIEF meet tot een verbruik van 10mA.
Ik weet in de verste verte niet of dat wat met generen te maken heeft.

Ik wil alleszins mijn ampèremeting in orde krijgen en weet verder ook niet wat voor effect dit genereren betekent bij het gebruik als voeding.

Alleszins bedankt voor het meedenken.
DW

http://www.uploadarchief.net/files/download/dscf1395.jpg
http://www.uploadarchief.net/files/download/resized/dscf1396.jpg
http://www.uploadarchief.net/files/download/resized/dscf1399.jpg
http://www.uploadarchief.net/files/download/resized/dscf1398.jpg
http://www.uploadarchief.net/files/download/resized/dscf1397.jpg

DW

Zijn die draad gewonden weerstanden je externe shunt en belasting?
Zoja, dan heb je het uitgangsprintje niet aangesloten met de +.
Dat geeft veel problemen.
Dan de zwevende lange draden aan de uitgang vind ik not done bij die lage waarden die je wilt scoren.
De tips van Blackdog niet konsekwent uitgevoerd.
Zit de extra koelplaat op de min 5v regelaar (heb de print niet zo voorhanden) zou toch op de plus 5 v moeten.
Is je aansluiting naar de potmeters met tweemaal afgeschermd ?
Ik zie een extra draadje aan een potmeter, waarvoor ?

@ Benl2C

Ik blijk nu 2 problemen te hebben. De schakeling genereert (belangrijk ?) EN ik krijg bij het meten over de shunt, negatieve waardes onder een belasting van 10mA.

1. De draadgewonden weerstanden (rechts op de 1ste foto) zijn de externe shunt waarover ik de spanning meet voor mijn Ampère meting. Het is een proefopstelling de waarde nu is 0.09 Ohm ipv 0,1 Ohm, en de draden zijn lang.
Kan dit een oorzaak zijn van genereren ? Maar het kan toch mijn negatieve spanning niet verklaren.

Als dit zou werken, (het werkt nu niet want ik meet negatief) is het de bedoeling dat ik een nieuwe shunt maak en deze voorzie van een extra laagohmige potentiometer, parallel over de shunt. Hierdoor zou ik hem nauwkeurig kunnen afstellen op 0.1 Ohm.

Deze shunt komt dan op een print die kan ingeschoven wordt in de 2 vertikale geleiders. En bevind zich dan in de onmiddellijke buurt van de voedingsprint. (Zie foto 5)

2. In volgorde is geschakeld: uitgang van print, shunt in de + leiding, uitgangsprintje, uitgangsklemmen.

3. De extra koelplaat zit op U3 = + 5V.

4. De aansluiting naar beide poti's is met afgeschermde draad (2 draads) de massa van de poti's gaat rechtstreeks naar de + uitgangsklem van het uitgangsprintje. Op deze uitgangsklem zit bovendien nog de spanningsmeter.

Bedankt voor het meedenken, maar ik ben er duidelijk nog niet uit.

DW

Met die problemen zou ik eerst het volgende in orde maken:
De bedrading naar de uitgangsbussen ala tips van Blackdog (getwist en voldoende dik) installeren.
De potmeters idem volgens de tips.
Geen aftakking bij de potmeters !!!
De draden voor de meetinstrumenten zo kort mogelijk houden en daar aansluiten waar je ook meten wilt. De uitgangsspanning meet je dus aan de uitgangsbussen zowel de "min" als ook de "plus"!
Maak ook gebruik van de "sense" mogelijkheid ( weer ala Blackdog)!

Voor het meten en testen met de externe shunt moet je aansluiten aan de uitgangsbussen.
Probeer eerst de problemen op te lossen voordat je gaat afregelen met de exacte waarden van shunt etc.

@ D.W.

Ik heb op dit moment even weinig tijd maar diverse CO leden hebben de draad op gepakt dus geef de moet niet op doen wij ook niet :)
Het feit dat er iets staat te oscilleren kan betekenen dat de voeding niet goed regelt waardoor er een negative spanning op de uitgang kan komen te staan waardoor je een negative stroom door de shunt meet.

Ik denk dat het advies van BenI2C zeer gegrond is en positief bedoeld :P dus probeer eerst je draden op te knappen.
Je kunt je voeding helemaal afmaken als je er voor kiest om de shunt na de voeding dus in de uitgang op te nemen.

Nu lees ik in je laatste post dat er +5V ik denk een 7805 op je koel profiel op de achterkant zit geen punt maar heb je hier heel kort de condensatoren bij gemonteerd ? dit is van groot belang om oscilleren van het beestje te voorkomen :( ik denk dat BenI2C wel ereid is om met je mee te kijken.

Groet Henk.

Everything should be as simple as possible, but not simpler.

@ Elctron920

Inderdaad de afvlakelco staat bijna tegen het koelprofiel van de 7805 (+5v).

Ivm oscilleren:
Ik las "ergens" dat Blackdog op een bepaald ogenblik sprak over een 10pF condensator over pin 13 en 14 van de LM324. Heeft het hier wat mee te maken ?

Verder ZOU oscilleren tegengegaan orden door ferrit kralen rond... waar ?

Ook nog het monteren van een lage ESR condensator op de collectoren van de uitgangstransistoren... waarde ?

Ivm de ampèragemeting.
Zou mijn probleem niet opgelost zijn als ik ofwel:
1. R9 en R10 van de uitgangstransistoren die nu 0,12 Ohm zijn naar 0,2 Ohm breng ?

2. De externe shunt waarover ik nu meet (theoretisch 0,1 Ohm) zou verhogen .
Maar of de negatieve meting elimineert zou ik niet weten.

@ Benl2C

Als ik het goed begrijp zouden ook de + en - leiding naar de uitgangsklemmen best getwist worden. (gelijkspanning!?).

De potentiometers zijn 2-draads afgeschermd, aangesloten op de print. De massa aansluiting EN de afscherming zitten verbonden aan + uitgangsklem. Er is geen aftakking aan de potentiometers.

Ik maak geen gebruik van de sense draden.

Voor het meten van mijn ampèrage meet ik nu met de externe shunt die zich bevindt tussen de print en het uitgangsfilter met zijn aansluitbussen. Dit is toch niet fout, of mogelijks wel ?

Nogmaals dank voor de respons

DW
Jinny

Golden Member

Probeer dat eens -na- de aansluitbussen?
Ik ben overigens nog niet aan meten toe gekomen....

Hoe doen vrouwen op TV dat toch? Wakker worden met prachtig glanzend haar en mooi gestifte lippen..... Wanneer ik wakker word heb ik een coupe 'Leeg geroofd vogelnest' en een incidenteel straaltje kwijl.. Gaat ook door voor 'Wilt wief' naar horen zeggen

@D.W: Ik kan het niet goed zien maar het lijkt dat je de uitgangsprint niet hebt aangesloten. Dit is wel erg belangrijk voor de regeling! Eerder heeft iemand daar ook al oscillatieproblemen mee gehad.

Every machine is a smoke machine if you operate it wrong enough

@ Jinny

Voor het meten van mijn ampèrage meet ik nu met de externe shunt die zich bevindt tussen de print en het uitgangsfilter met zijn aansluitbussen. Dit is toch niet fout, of mogelijks wel ?

Probeer dat eens -na- de aansluitbussen?

Zou ik dat echt moeten proberen ?
Langs de éne kant zegt men dat het uitgangsfilter onmiddellijk op de aansluitbussen moet komen en nu zou ik het filter van de bussen weghalen, vanaf de print ergens halfweg komt dan het filter, dan mijn meetshunt en dan mijn aansluitbussen ?
Volgens mij kan DAT niets uitmaken.

Wat is jouw idee over het vergroten van R9 en R10, nu 0,12 Ohm, tot 0,2 Ohm.
Heb je een idee over hoeveel uitgangsvermogen ik verlies, nu haal ik ong. 4,5 Ampère ?

Ik zit met 2 problemen (negatieve meting over de meetshunt en oscilleren) en weet in de verste verte niet of die wat met elkaar te maken hebben.
Ik heb er ook geen idee van wat het betekent en of het belang heeft, dat ik bij een belasting van 100 mA, oscilleer met 666 kHz en met 6 mV piek/piek

Verder blijft elke suggestie welkom, want ikzelf geraak er niet uit.

DW
Jinny

Golden Member

Even voor de duidelijkheid, je hebt een shunt.
Deze plaats je tussen de regelelectronica en het uitgangsprintje.
Je meet negatieve spanning.

Ik zeg, verplaats die shunt eens naar -na- de aansluitbussen en meet dan weer.
Voordeel, je weet zeker dat als je -nu- weer negatieve spanning meet, je je meters weg kunt mikken.

Meet je nu alleen positieve spanning, dan heb je dus een probleem.
Oplossing, punt voor punt de tips en trucs van Bram (Blackdog) nalopen.
Niet gaan winkelen, gewoon consequent zijn...
Je lijkt al te weten dat je een occilatieprobleem hebt, dat moet je oplossen.
Dat beinvloed de meting.

Vergroten van de emittorweerstanden naar .2 Ω geeft volgens de wet van Ohm (bij 5 Apm doelstelling) 2.5 * 0.2 = 0.5V verlies aan uitgangsspanning, dit wordt gecompenseerd door de elektronica.

Echter, wat is je trafo, hoeveel mag die leveren?
Ik heb een ringkern die 6 Amp kan leveren en daar trek ik 1.5 Amp van...
Een trafo die 5 Amp zou moeten kunnen leveren moet je niet gaan belasten tot 5 Amp....

Hoe doen vrouwen op TV dat toch? Wakker worden met prachtig glanzend haar en mooi gestifte lippen..... Wanneer ik wakker word heb ik een coupe 'Leeg geroofd vogelnest' en een incidenteel straaltje kwijl.. Gaat ook door voor 'Wilt wief' naar horen zeggen

@ Jinny en Benl2C

Mijn trafo is 160VA en kan dus 6.6 A leveren, praktisch dus à rato van 65% moet ik 4,29 A kunnen trekken.

Even voor de duidelijkheid, je hebt een shunt.
Deze plaats je tussen de regelelectronica en het uitgangsprintje.
Je meet negatieve spanning.

Ik zeg, verplaats die shunt eens naar -na- de aansluitbussen en meet dan weer.

Als iemand het volgende kan uitleggen, graag.
Met de meetshunt tussen de print en het uitgangsfilter meet ik negatief over de shunt tot 10mA. Boven de 10mA, normaal positief.

Zoals Jinny voorstelde heb ik de shunt buiten de kast geplaatst, dus na de uitgangsbussen, ik meet nu GEEN NEGATIEVE spanning meer,ONBEGRIJPELIJK ?

Meet je nu alleen positieve spanning, dan heb je dus een probleem.

Deze quote begrijp ik niet. Deze opstelling lost blijkbaar het meetprobleem op.
Ik zou dus het uitgangsfilter loskoppelen van de uitgangsbussen en de shunt plaatsen NA het uitgangsfilter. Daarbij zondig ik wel tegen de regel van Blackdog die zegt dat het filter op de uitgangsbussen hoort.

De oscillatie is nog steeds aanwezig, ik hoop dat dit niet te veel invloed heeft op het meten over de shunt. Het oscilleren moet later maar opgelost worden. Verder heb ik, denk ik toch, zowat alle constructieve raadgevingen van Blackdog opgevolgd. Ik zou niet weten waar nog te kijken.

Benl2C zegde dat ook de uitgangsdraden (gelijkspanning) uit de print, (voldoende dik) EN getwist moeten worden, Ik zal het maar doen maar weet niet waarom.

DW

Omdat je met hele kleine EN grote stromen wilt werken.
En daarom ook de sense draden gaan gebruiken.
Die negatieve spanning komt dat niet door de uitgangsdiode op de uitgangs print bij de eerste opstelling ?

Ha D.W.

Ik lees dat je resultaat boekt ik heb even een laptop er bij gepakt kan niet bij de andere spullen :(
Maar je heb nog steeds het probleem van je oscillator dat is niet goed zo hoort een fatsoenlijke voeding niet te werken ik kan mij voorstellen dat de eigenschappen waar Bram blackdog mee bezig is iets te ver gaan voor jouw toepassing maar een voeding als oscillator dat kan niet 8)7

Volgens mij hebben Jinny en BenI2C genoeg aanwijzingen gegeven om een en ander te verbeteren.
Met name de bedrading en het uitgangsfilter dit ivm de terugkoppeling van de regellus een voeding lijkt misschien wel simpel maar alles is direct coupled en dat maakt sommige eigenschappen complex met betrekking tot die regellus zul je de dempingsfactor van je uitgang goed moeten construeren.
Hier voor is het belangrijk dat simpel gezegd er niet veel ongewenste effecten roet in het eten gooien.

Dus bedrading altijd twisten symmetrisch opbouw van de bedrading is over het algemeen kleine capaciteit denk aan telecom kabel hoe fijner geslagen deste kleiner de capaciteit hoe groter de bandbreedte en dientengevolge een sneller systeem.
Ontkoppel condensatoren dicht bij je componenten als je dit niet doet ontstaat er zomaar 10mV spanning over een stukje koper en dan heb je ineens een stroom die zogenaamd de ander kant op loopt let op over je shunt meet je symmetrisch het is dus maar net waar de kraan zit ;) hoger potentiaal.

Ik had in mijn laatste post al gevraagd om naar de 7805 te kijken je ontkoppel condensatoren zitten veel te ver van het component deze staat te oscilleren.
Zo'n 7805 heeft maar 3 aansluitingen maar binnen in is ie best complex :D en ook hier is intern een redelijk versterking aanwezig en ook een terugkoppeling naar een verschil versterker als je dit maar met een klein spoeltje koppelt dan zit je zo rond de 1 a 1.5MHz met een niveau van 132dBm aan de uitgang tankkring er achter en je kan er de wereld mee rond :P dus hier even naar kijken.
In je voorlaatste post schrijf je dat je de emitter weerstanden wil veranderen naar 0.2 Ω als je dat doet dan heb je uiteraard geen externe shunt meer nodig dan heb je 0.1Ω totaal en is je schaal factor precies goed het is maar een hint ;)

Groet Henk.

Everything should be as simple as possible, but not simpler.
Jinny

Golden Member

D.W., het feit dat het buiten de voeding wel goed werkt, dat geeft dus aan dat je ergens een probleem hebt, er loopt (bij lage stroomsterktes) stroom de verkeerde kant op.
Waarschijnlijk uit de condensator, maar dat zou moeten ophouden op gegeven moment.
Het ocilleren kan daar zeker van de oorzaak zijn...

Als je een losse shunt wilt gebruiken, probeer het eens -na- de afvlakcondensator en -voor- de regeltorren.
Maar als Henk zegt, met de nieuwe weerstanden, dat kan ook, had ik even niet aan gedacht.

Hoe doen vrouwen op TV dat toch? Wakker worden met prachtig glanzend haar en mooi gestifte lippen..... Wanneer ik wakker word heb ik een coupe 'Leeg geroofd vogelnest' en een incidenteel straaltje kwijl.. Gaat ook door voor 'Wilt wief' naar horen zeggen

Zo... eindelijk tijd gevonden om de voeding af te maken :-). Ik kan niet anders zeggen dan dat het beestje zeer goed presteert met weinig, of eigenlijk helemaal geen rommel aan de uitgang. Daarbij issie sic. 'getuunt' met een heule échte carbonvezel sticker aan 't front. Jawel. De meeste onderdelen heb ik meteen in Rosmalen gevonden, behalve de condensatorbank, metertjes en de multiturn (10x) potmeters. Die komen via eBay. Allicht een aanrader, die China Bochen multiturn potmeters zijn helemaal niet slecht zoals iemand hier in dit topic al aangaf. 't Is geen Alps kwaliteit, maar voor 3 euro per 2 mag je dat ook niet verwachten. Dank Guido en Martijn voor het beschikbaar stellen van de PCB! Om het beestje aan de tand te voelen zou een electronic DC load eigenlijk wel nice zijn. PCB ideetje voor Rosmalen volgend jaar? ;-).

Hierbij wat fotootjes:

En hier nog een paar:

https://www.flickr.com/photos/66955762@N00/albums/72157634054799409

Michael / PA4MW

@ Koekoeksklok,

Mooi gebouwd strak design van het front paneel.
Zit er behalve de temp. uitlezing ook een actieve temperatuur beveiliging in.

Groet Henk.

Everything should be as simple as possible, but not simpler.

Thanks Henk :-)! Nog niet, maar ik ben dat wel van plan. Ik moet nog ergens Cliksons hebben die bij 85 graden schakelen. Maar waar die gebleven zijn...

Michael / PA4MW

Heel mooi opgebouwd! Complimenten!

En bedankt voor het showen!

[Bericht gewijzigd door MAH op dinsdag 26 juli 2016 14:50:27 (31%)

Every machine is a smoke machine if you operate it wrong enough
Jinny

Golden Member

Stuk mooier dan de mijne...

Hoe doen vrouwen op TV dat toch? Wakker worden met prachtig glanzend haar en mooi gestifte lippen..... Wanneer ik wakker word heb ik een coupe 'Leeg geroofd vogelnest' en een incidenteel straaltje kwijl.. Gaat ook door voor 'Wilt wief' naar horen zeggen

@ Jinny, Electron920, Benl2c, en vele anderen, mijn dank.

Mijn oscillatie probleem is opgelost sinds ik alle voorlopige opstellingen, met vliegende draden, heb opgedoekt en alles binnen de kast heb gebracht, ook heb ik de + en - uitgangsdraden naar het filterprintje getwist, of het nu dat is weet ik niet. In elk geval er is geen oscillatie meer te bespeuren.

Nu nog een allerlaatste (?) vraag:
Ik heb gekozen voor de 5 A voeding met 35 V uitgangsspanning

In verband met mijn ampèremeting zou ik R9 en R10, die nu 0,12 Ohm zijn vervangen door 0,22 Ohm.

Ik verlies hier ongeveer 0,55 V aan uitgangsspanning, dit is niet belangrijk. Maar moet ik best nog iets anders aanpassen ?

Een laatste inspanning van alle leden, en dan zijn we er.

Nogmaals allen bedankt

DW

@ D.W.

Goed te lezen dat een en ander de goede kant opgaat :) let op de 7805 daar moet je echt de tantaal dicht bij zetten anders is de kans heel groot dat als je de deksel op je kast schroef het weer terug is.
Soldeer desnoods de tantaal direct op de pootjes van de 7805.

Als je de twee emitter weerstanden naar 0.22Ω veranderd hoef je verder niets te doen de shunt komt dan goed uit met de gevoeligheid van je meter wordt totaal 0.11Ω dus bij 1A 110mV je kunt in dit geval twee spanning delers gebruiken een voor de 1A stand en een voor de 10A stand.
Als je deze regelbaar maakt kan je precies afregelen zodat 1A 100mV aangeef en 10A of in jou situatie 5A x 0.11Ω = 550mV.
Voor het meten van de spanning deze sluit je aan zo dicht mogelijk bij je uitgang en compenseert de spanningsval over de shunt.

Groet Henk.

Everything should be as simple as possible, but not simpler.
blackdog

Golden Member

Hi,

Om het programmeren een beetje te leren, wil ik een projectje starten voor mijzelf om de CO-2016 voeding die ik aan het bouwen ben een beetje op te leuken. :-)

Mijn vraag is nu, zijn er mensen die er ook in geintresseert zijn, zoja als dit er voldoende zijn besteed ik er wat meer tijd aan om het als projectje op CO te plaatsen.
Is er te weinig intresse, dan scheeld mij dit tijd voor andere zaken die ik hier ook doe :-)

OK waar gaat het om...
Processor de Arduino Nano
2x 18B20 temp sensor
Een Nokia 5110 display en deze gaat voorlopig dit aangeven.

1e
Temperatuur van de Trafo

2e
Temperatuur van de power transitor (koelblok) Deze sensor stuurd ook de ventilator aan en mute de voeding in extreme omstandigheden.

3e
Spanning op de buffer condensator (bij een dubbele trafo is dit ook een zekering OK indicator)

4e
De spanning over de regeltransistor "Dropout" ook dit kan een alarm geven als deze te laag wordt (netspanning lager dan verwacht)
De ingestelde stroom waarde, er is maar een 10 bit AD aanwezig dus geen preciese weergave van de ingestelde stroom.

5e
Weergave van de 2 a drie standen van de ventilator snelheid.

Misschien een reset toetsje.

Vooralnog wil ik geen menu's, alles op één scherm en verder geen instellingen behalve de 1x configuratie in de code.

Ik wil er GEEN waarde van de actuele spanning of stroom op hebben, daar is dit "Util" display niet voor bedoeld.
De bedoeling is dat het eventueel ook in andere voedingen is toe te passen.
Er zijn nog wat moeilijkheden die ik moet over winnen.
Deze is in het analoge domain het sensen van de buffer elco spanning en de uitgansspanning,
dit is wat moeilijker daar de "0" van het referentiedeel aan de + van de voeding hangt.
Dit maakt dat ik niet via een spannings deler direct de spanningen kan meten met de Arduino.
Alleen de stroomlimit is simpel te meten op de loper van de potmeter hiervoor.
Eventueel kan dit ook bij de U potmeter, maar dan blijft alsnog de buffer elco spanning over,
we zullen zien hoe ik dit ga oplossen :-)

De software kant problemen
Om de dropout goed te kunnen meten zal ik iets langer dan 0,5 periode van de netfrequentie moeten meten om de minimale spanning er uit te kunen filteren en daar de uitgansspanning vanaf te kunnen trekken.
Geen idee hoe je zoiets aanpakt :-)

Voorbeeldje display
http://www.bramcam.nl/Arduino/CO-Util-Display/CO-Util-Display-01.png

Dus, is hier intresse in of zal ik het alleen voor mijzelf opzetten, en input is natuurlijk altijd welkom!

Gegroet,
Blackdog

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.

Dit topic is gesloten