Welje elco's siemens logo 230rc dood

Ik heb hier een LOGO 230RC ingebouwd in een wikkelmachine.
Na een spanningsonderbreking van het lichtnet doet de logo niets meer.

Op het forum heb ik gelezen dat het mogelijk aan de elko's van de voeding ligt.

De dikste is 4,7 uf 400v
De twee anderen begrijp ik niet. 

47
CHA
3N1

en

3BK
47
50V

Zijn er nog meer die ik moet vervangen?

Kent iemand deze of heeft iemand hier ervaring mee. 

Bedankt

Piet

Hoeben

Golden Member

Die ene is 47u en 50V, die is duidelijk.

Die andere 47u en wat minder spanning omdat hij kleiner is. Neem anders een 47u van dezelfde maat en dan die met de hoogste spanning, dan heb je het minste risico.

Het kan best kloppen dat het apparaat niet opstart door slechte elcos.

fred101

Golden Member

Elcos zijn altijd de schuldige, behalve als ze het niet zijn ;-) Die dingen krijgen overal de schuld van.

Geen idee mbt een Logo maar ik repareer alles behalve consumenten apparatuur en ik kom zelden rotte elcos tegen. (in dingen als TVs zijn het meestal wel de onderbemeten wazige C-merk elco's)

Die 400V elcos gaan zelfs in consumenten shit zelden kapot.
Ben voorzichtig met die 2 SMD elcos, desolderen daarvan is meestal lastig, zeker als je er slecht bij kunt. Daar kun je de hele print mee mollen. Er zijn mensen die ze er af draaien maar dat heb ik nooit gedurfd. Als ik er een moet vervangen dan gebruik ik twee bouten. Je trekt heel makkelijk de traces los,

Een grotere behuizing krijg je waarschijnlijk niet op de pads

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur, ook oud en exotisch

De C opde kleinere elco: 16V .

De schakelchip kan er ook aan zijn. de TOP232 das geen onbekende.

het zijn geen hele oude smd elco's. als ze goed koel kunnen werken blijven die goed. als het daar héél warm wordt gaan ze achteruit.

Dat 8 pins ic dat een pootje mist is het schakel ic.
Het voorziet je schakeling van een spanning van 24V.
Die gaan in veel huishoudapparaten met bosjes stuk en je hoeft er niet altijd iets aan te zien.

A good housewife opens the fridge-door at zero cross point of AC cycle.

Ik neem aan dat deze rechtstreeks op de 230V aangesloten is, met de TOP232 als schakelende regelaar, maar waar is dan de trafo?

GJ_

Moderator

Op 11 mei 2020 14:13:14 schreef MJN:...maar waar is dan de trafo?

Ik kan me de 230V versie niet eens meer herinneren, ik gebruik ze vrijwel nooit, maar een heel dikke trafo zal het nooit zijn. Als ie er al in zit. Op de foto ontbreekt de bovenste print, die zit op de headers rechts gestoken.

fred101

Golden Member

Er is al in gespit. Die grote rechthoekige condensator met K er op heeft een paar mooie soldeerbout afdrukken.

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur, ook oud en exotisch
Hoeben

Golden Member

Op 11 mei 2020 15:02:13 schreef fred101:
Er is al in gespit. Die grote rechthoekige condensator met K er op heeft een paar mooie soldeerbout afdrukken.

Nou zie ik het ook. En al helemaal door het plastic heen tot aan de condensator zelf gegaan. Ik vraag me wel af waar ze aan hebben zitten solderen, dat zie ik niet. Moet wel die grote through-hole elco zijn.

Die elco's vervangen zou ik inderdaad ook met 2 bouten doen. Maar boven een hotplate gaat het dan nog beter.

bprosman

Golden Member

Er is al in gespit. Die grote rechthoekige condensator met K er op heeft een paar mooie soldeerbout afdrukken.

Als het voor een wikkelmachine is voor industrieel gebruik en niet voor de hobby zou ik m afschrijven en voor 129,- Euro ex. BTW een nieuwe bestellen.

De jongere generatie loopt veel te vaak zijn PIC achterna.

Afschrijven best wel jammer i.v.m. milieu/de afvalberg. Terwijl er grote kans is dat er maar een paar componenten stuk zijn (die TOP232 en misschien nog wat er omheen).

Probleem hier is natuurlijk ook "het programma".

Ik heb een nieuwe LOGO gekocht en ga daar lekker mee aan de slag.
Bedankt iedereen voor de reacties.

Lijkt wel of er een transformator-loze voeding in zit, net als: https://www.circuitsonline.net/forum/view/149727/1
Als je uit freubelt waar de dc spanning zou moeten komen, kun je hier twee
draadjes aan solderen en met een labvoeding proberen of er leven in komt.
Mocht dat zo zijn kun je het programma eruit halen...

bprosman

Golden Member

Misschien heeft TS de “sourcecode” wel gewoon.

De jongere generatie loopt veel te vaak zijn PIC achterna.

Het is gelukt om er draadjes aan te solderen. En het is gelukt om er weer leven in te brengen. En nog beter, de code kwam ook in beeld.
Daar heb ik een klein probleempje mee.
Sommige icoontjes zijn iets anders dan een nieuwe. Als het een groot probleem wordt kom ik wel weer.

Vervang ik deze met de'Asynchronous pulse generator'?
En dan de Th en Tl dezelfde waarden geven.

Toeternietoe

Dubbelge´soleerd

Op 7 juni 2020 22:28:32 schreef pcb_nl:
[bijlage]
Vervang ik deze met de'Asynchronous pulse generator'?
En dan de Th en Tl dezelfde waarden geven.

Yep

Daar waar een schakeling rookt, vloeit de meeste stroom (1e hoofdwet van Toeternietoe)
EL83

Special Member

Ik weet de complexiteit van de code niet maar als dit vrij veel zou zijn, heb je niet de Logo! software?
Nieuwe logo heeft toch de netwerkpoort voor te programmeren.

Dan zit je natuurlijk met het uitlezen van de oude logo.
Deze kan je op een scheidingstransformator aansluiten ik zie dat je met een externe voeding bezig bent :+ en dan een simpele USB-TTL adapter met 3 draadjes solderen aan de programmeer connector (destijds met een Arduino uno gedaan, Atmega eruit en RX-TX-GND op de logo aangesloten).

Grappig verhaal hoe ik ooit aan de software ben gekomen. Bij de afbraak van een deel van een productie lijn heb ik in de schakelkast een cd gevonden met een heel oude versie van Logo! Soft.
Deze liet zich installeren zonder naar een code oid te vragen en kon ik zonder problemen upgraden naar de laatste versie.

Na dat project had ik een 12/24RC 0ba3 logo! En software maar geen kabel.
Na wat onderzoek heb ik zelf de aansluiting uitgevogeld (ondertussen wel een kabel aangeschaft :D )

Op 11 mei 2020 14:13:14 schreef MJN:
met de TOP232 als schakelende regelaar, maar waar is dan de trafo?

Ik denk dat de wittige ding met 105 d'r op een 100uH spoel is. Dan is het een schakelende voeding die niet galvanisch gescheiden is.

four NANDS do make a NOR . Kijk ook eens in onze shop: http://www.bitwizard.nl/shop/
Sine

Moderator

Correct, die dingen hebben een niet netgescheiden voeding. Dat is ook niet nodig want de hele IO is toch aan de voeding gerefereerd.

bprosman

Golden Member

Grappig verhaal hoe ik ooit aan de software ben gekomen. Bij de afbraak van een deel van een productie lijn heb ik in de schakelkast een cd gevonden met een heel oude versie van Logo! Soft.
Deze liet zich installeren zonder naar een code oid te vragen en kon ik zonder problemen upgraden naar de laatste versie.

Ooit heb ik een officiele versie gekocht, die omgezet naar een .ISO file en als ik die mount kun je inderdaad upgraden naar de laatste versie.

De jongere generatie loopt veel te vaak zijn PIC achterna.

Op 5 juni 2020 10:03:05 schreef pcb_nl:
Het is gelukt om er draadjes aan te solderen. En het is gelukt om er weer leven in te brengen. En nog beter, de code kwam ook in beeld.
Daar heb ik een klein probleempje mee.
Sommige icoontjes zijn iets anders dan een nieuwe. Als het een groot probleem wordt kom ik wel weer.

Ik zit inmiddels met hetzelfde probleem, weet je toevallig nog waar je 24v op hebt gezet? Dan kan ik het bij mij ook proberen :)

Lamg geleden.
Ik meen dat ik de 5 volt lijn heb opgezocht en daar spanning op heb gezet. Toen kon ik de code eraf halen.

Het 24 volt gedeelte was kapot.

Als het niet lukt beter een nieuwe topic beginnen.

Slotje